Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Skype+webcam]LD_PRELOAD failed sur ~amd64 (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Wed May 19, 2010 7:23 pm    Post subject: [Skype+webcam]LD_PRELOAD failed sur ~amd64 (résolu) Reply with quote

Bonsoir à tous,

J'essaie désespérément de faire marcher ma webcam avec skype sur ma nouvelle install de gentoo, en ~amd64. En ~x86, je devais lancer ce code pour que ça marche :

Code:
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype


Skype étant une application 32 bits, j'ai adapté en

Code:
LD_PRELOAD=/usr/lib64/libv4l/v4l2convert.so skype


Mais j'obtiens l'erreur suivante :

Code:
ERROR: ld.so: object '/usr/lib32/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded: ignored.


Pourtant, le fichier existe :

Code:
kevin@KevinPC ~ $ ls /usr/lib32/libv4l/
v4l1compat.so  v4l2convert.so


J'ai fait des recherches un peu partout mais elles ne m'aident pas. J'ai trouvé d'anciens rapports de bugs avec des paquets alternatifs pour libv4l, et à la fin un commentaire disant que c'est intégré à emul-linux-x86-medialibs. Ce paquet est installé, mais ça ne change rien. Bien sûr, j'ai aussi installé libv4l. Je suis un peu désespéré, j'ai essayé avec les lib32 et les lib64, avec libv4l1convert.so et libv4l2convert.so, mais à chaque fois c'est la même chose. Ma webcam est bien installée puisqu'elle fonctionne sur aMSN, le problème vient uniquement de cette lib. Je ne sais plus où chercher, j'espère que vous aurez une solution, ou au moins un début de solution.

Merci d'avance,

Kevin57
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français


Last edited by Kevin57 on Sun May 23, 2010 1:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Fri May 21, 2010 7:05 pm    Post subject: Reply with quote

Salut,

essaie de le lancer comme ça:

Code:
#!/bin/sh
cd "/opt/skype"
if [ -n "/opt/skype" ]; then
    if [ "${LD_LIBRARY_PATH+set}" = "set" ]; then
        export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:/opt/skype"
     else
        export LD_LIBRARY_PATH="/opt/skype"
    fi
fi
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so exec /opt/skype/skype "$@"


à adapter si tu ne l'as pas installé dans /opt etc...
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sat May 22, 2010 1:25 am    Post subject: Reply with quote

Skype étant installé dans /usr/bin chez moi, j'ai adapté comme ça :

Code:
#!/bin/sh
cd "/usr/bin/"
if [ -n "/usr/bin/skype" ]; then
    if [ "${LD_LIBRARY_PATH+set}" = "set" ]; then
        export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:/usr/bin/skype"
     else
        export LD_LIBRARY_PATH="/usr/bin/skype"
    fi
fi
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so exec /usr/bin/skype "$@"


Mais ça ne change rien, toujours cette erreur :

Code:
ERROR: ld.so: object '/usr/lib32/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded: ignored

_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 340
Location: France

PostPosted: Sat May 22, 2010 6:45 am    Post subject: Reply with quote

J'ai le même message d'erreur et à priori ma webcam fonctionne. :lol:
_________________
My desktop : http://www.sysprofile.de/id11219
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Sat May 22, 2010 10:05 am    Post subject: Reply with quote

Tom_ wrote:
J'ai le même message d'erreur et à priori ma webcam fonctionne. :lol:


Chez moi passer le PRELOAD dans le script skype avant l'exec a supprimé ce message d'erreur, et depuis la webcam fonctionne.

@Kevin57
tu as modifié le lanceur de skype ou refais un script?
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sat May 22, 2010 12:35 pm    Post subject: Reply with quote

J'ai refait un script. Mais je viens de voir que j'ai aussi un dossier /opt/skype donc je réessaierai avec ton script au cas où. Mais pour l'instant j'ai des soucis plus urgents avec mon disque dur, donc je te tiens au courant quand j'aurai essayé! :wink:
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sun May 23, 2010 1:24 pm    Post subject: Reply with quote

Je viens de tester ta solution en la mettant directement dans le lanceur de skype (/usr/bin/skype), et ça marche. J'avais ensuite l'erreur suivante :
Code:
X Error, request 132, minor 18, error code 8 BadMatch (invalid parameter attributes)

Qui se solutionne avec un :
Code:
export XLIB_SKIP_ARGB_VISUALS=1


Donc j'ai adapté le lanceur skype ainsi :

Code:
#!/bin/sh
cd "/opt/skype"
if [ -n "/opt/skype" ]; then
    if [ "${LD_LIBRARY_PATH+set}" = "set" ]; then
        export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:/opt/skype"
     else
        export LD_LIBRARY_PATH="/opt/skype"
    fi
fi
export XLIB_SKIP_ARGB_VISUALS=1
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so exec /opt/skype/skype "$@"


Et ça marche encore mieux qu'avant : j'arrive à faire marcher la vidéo et le micro en même temps, alors que c'était impossible sur mon ancienne install. Allez savoir pourquoi! En tout cas, merci beaucoup!
_________________
Gentoo ~amd64 avec Openbox, AMD Phenom II X4 965 BE, Radeon HD 4250, 4GB RAM.
Traducteur indépendant allemand-français et anglais-français
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum