Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The Gentoo Framebuffer, Bootsplash & Grubsplash How-To
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 13, 14, 15 ... 25, 26, 27  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Assgier
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2003
Posts: 127
Location: Europe -> Netherlands -> Utrecht -> Amersfoort

PostPosted: Sat May 08, 2004 2:03 am    Post subject: Reply with quote

it's working now... once i understood what initrd images where and why i had to add the theme's to the kernel as well as Gentoo itself, i figured that the patch might've just not worked on 2.6.6-rc3 and come to think about that i remember having one little error during the patching process, wich obviously is the cause of it not working. That's why bootsplash wouldn't startup together with the kernel, but only few secs before X.

I have downgraded my kernel to 2.6.5 again (the one from kernel.org) and patched that one; it worked fine :)
After that it just worked the way i wanted it to! :)

So hereby i second that the 2.6.5 patch won't work with 2.6.6-rc3 :(

And here is another screenshot, Gentoo looking like SuSE 8O
_________________
8)
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1337
Location: Mississippi USA

PostPosted: Mon May 10, 2004 3:42 pm    Post subject: Reply with quote

OK I screwed up something. The GUI, or X, works fine but when I switch to a console, ctrl alt F1, the screen is screwed up bad. It looks like it is torn.

Somebody tell me what I did wrong. I rechecked my steps but no luck yet.

Need info, let me know. I'm using a 2.6 kernel. It is the one that is stable for me at least.

Edit: Hold that thought. Now the kernel won't boot. Hangs up after replaying journal. Still scratching head on that one. It did work once though, except for the problem above.

:? :? :? :?
_________________
My rig: Gigabyte GA-970A-UD3P mobo, AMD FX-8350 Eight-Core CPU, ZALMAN CNPS10X Performa CPU cooler,
G.SKILL 32GB DDR3 PC3 12800 Memory Nvidia GTX-650 video card LG W2253 Monitor
9TBs of hard drive space using LVM
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
Assgier
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2003
Posts: 127
Location: Europe -> Netherlands -> Utrecht -> Amersfoort

PostPosted: Tue May 11, 2004 1:15 am    Post subject: Reply with quote

dalek wrote:
OK I screwed up something. The GUI, or X, works fine but when I switch to a console, ctrl alt F1, the screen is screwed up bad. It looks like it is torn.

Somebody tell me what I did wrong. I rechecked my steps but no luck yet.

Need info, let me know. I'm using a 2.6 kernel. It is the one that is stable for me at least.

Edit: Hold that thought. Now the kernel won't boot. Hangs up after replaying journal. Still scratching head on that one. It did work once though, except for the problem above.

:? :? :? :?

if i where you i'd compile a new one (same settings, assuming that you have a settings file saved somewhere) :)

i'm going to see if i can patch the recently (like yesterday or something) new stable kernel 2.6.6 with the 2.6.5 one :)

[edit]
Quote:

linux-2.6.6 # patch -p1 <bootsplash-3.1.3-2.6.5 --dry-run
patching file drivers/char/keyboard.c
patching file drivers/char/n_tty.c
patching file drivers/char/vt.c
Hunk #1 succeeded at 3159 (offset 15 lines).

it's the only error i get when trying to patch 2.6.6, but it's enough to prevent bootsplash from working... maybe the topicstarter can do something with this information to make a patch for 2.6.6? :)
_________________
8)
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1337
Location: Mississippi USA

PostPosted: Tue May 11, 2004 3:35 am    Post subject: Reply with quote

Assgier wrote:
if i where you i'd compile a new one (same settings, assuming that you have a settings file saved somewhere) :)

i'm going to see if i can patch the recently (like yesterday or something) new stable kernel 2.6.6 with the 2.6.5 one :)



I did that several times, same crap. What is funny is, the only change is the changes for the bootsplash. Wonder if it was crapped during download or something.

I'll go practice rm -rf /usr/portage/distfiles/bootsplash something or other and start over from scratch. Maybe I upchuked something else too. <shruggs shoulders again>

Later

:? :? :? :D :D :D
_________________
My rig: Gigabyte GA-970A-UD3P mobo, AMD FX-8350 Eight-Core CPU, ZALMAN CNPS10X Performa CPU cooler,
G.SKILL 32GB DDR3 PC3 12800 Memory Nvidia GTX-650 video card LG W2253 Monitor
9TBs of hard drive space using LVM
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
Matrix7
n00b
n00b


Joined: 21 Feb 2004
Posts: 54
Location: Sussex

PostPosted: Thu May 13, 2004 1:20 pm    Post subject: Reply with quote

I've been having trouble getting my 2.6.6 kernel to boot as well. After exhaustive investigation I found that the MDA support in

Device Drivers >
Graphics Support >
Console Display Driver Support >
MDA Text Console <*>

was the cause of the problem. Unchecked that option and now my 2.6.6 kernel boots fine with bootsplash.
Back to top
View user's profile Send private message
sleggh
n00b
n00b


Joined: 13 May 2004
Posts: 3
Location: Iggesund, sweden

PostPosted: Thu May 13, 2004 8:57 pm    Post subject: Reply with quote

i just can't get this to work :/ im running ck-sources 2.6.4, tried about everything but it doesn't work. No errors at boot but when i run cat /proc/splash it tells me that splash is OFF. It worked once though, but it seemed like the picture were too small for the resolution i used, but it was not. My grub conf looks like this:

Code:
title=Gentoo Linux splash and fb     
root (hd0,2)
kernel /kernel-2.6.4-ck root=/dev/hda6 video=vesafb:ywrap,mtrr vga=0x31A
initrd=/boot/initrd-1280x1024


And i don't have an /etc/conf.d/bootsplash.conf , just a bootsplash file.
Back to top
View user's profile Send private message
woody77
n00b
n00b


Joined: 06 Feb 2004
Posts: 69
Location: SC Mtns, CA, USA

PostPosted: Thu May 13, 2004 11:17 pm    Post subject: Reply with quote

I'm running mm-sources-2.6.6-rc3. The 2.6.5 patch doesn't correctly apply to fbcon.c. But I *think* I was able to manually apply the patch. kernel's rebuilding now, and we'll find out soon enough.

**YES**

Ok, now I've finally got /proc/splash, but other issues, since I can't display anything, but the kernel patch seems to have worked. Here's the correct diff.

If someone would like to host this (topic-starter?) then pm me, and I'll e-mail it to you.

Only three "hunks" needed to be fixed-up from the 2.6.5 patch.

766-772 -> 813-824
1828-1846 -> 1924-1949
2279-2285 -> 2382-2390

Code:

*** /usr/src/linux/drivers/video/console/fbcon.c.orig   Thu May 13 14:55:09 2004
--- /usr/src/linux/drivers/video/console/fbcon.c        Thu May 13 15:55:19 2004
***************
*** 93,98 ****
--- 93,101 ----
  #endif

  #include "fbcon.h"
+ #ifdef CONFIG_BOOTSPLASH
+ #include "../bootsplash/bootsplash.h"
+ #endif

  #ifdef FBCONDEBUG
  #  define DPRINTK(fmt, args...) printk(KERN_DEBUG "%s: " fmt, __FUNCTION__ , ## args)
***************
*** 198,205 ****
        if (!info || info->state != FBINFO_STATE_RUNNING ||
            info->cursor.rop == ROP_COPY)
                return;
-       acquire_console_sem();
        info->cursor.enable ^= 1;
        info->fbops->fb_cursor(info, &info->cursor);
        release_console_sem();
  }
--- 201,214 ----
        if (!info || info->state != FBINFO_STATE_RUNNING ||
            info->cursor.rop == ROP_COPY)
                return;
        info->cursor.enable ^= 1;
+ #ifdef CONFIG_BOOTSPLASH
+       if (info->splash_data) {
+               splash_cursor(info->splash_data, info, &info->cursor);
+               return;
+       }
+ #endif
+       acquire_console_sem();
        info->fbops->fb_cursor(info, &info->cursor);
        release_console_sem();
  }
***************
*** 315,320 ****
--- 324,337 ----
  {
        struct fb_copyarea area;

+ #ifdef CONFIG_BOOTSPLASH
+       if (info->splash_data) {
+               splash_bmove(info->splash_data, vc, info,
+                               sy, sx, dy, dx, height, width);
+               return;
+       }
+ #endif
+
        area.sx = sx * vc->vc_font.width;
        area.sy = sy * vc->vc_font.height;
        area.dx = dx * vc->vc_font.width;
***************
*** 331,336 ****
--- 348,360 ----
        int bgshift = (vc->vc_hi_font_mask) ? 13 : 12;
        struct fb_fillrect region;

+ #ifdef CONFIG_BOOTSPLASH
+       if (info->splash_data) {
+               splash_clear(info->splash_data, vc, info,
+                                        sy, sx, height, width);
+               return;
+       }
+ #endif
        region.color = attr_bgcol_ec(bgshift, vc);
        region.dx = sx * vc->vc_font.width;
        region.dy = sy * vc->vc_font.height;
***************
*** 359,364 ****
--- 383,397 ----
        u16 c = scr_readw(s);
        u8 *src, *dst, *dst0;

+       #ifdef CONFIG_BOOTSPLASH
+       if (info->splash_data) {
+               splash_putcs(info->splash_data, vc, info, s, count, yy, xx);
+       return;
+       }
+       #endif

+       
+       
        image.fg_color = attr_fgcol(fgshift, c);
        image.bg_color = attr_bgcol(bgshift, c);
        image.dx = xx * vc->vc_font.width;
***************
*** 415,420 ****
--- 448,460 ----
        unsigned int bs = info->var.yres - bh;
        struct fb_fillrect region;

+       #ifdef CONFIG_BOOTSPLASH
+       if (info->splash_data) {
+               splash_clear_margins(info->splash_data, vc, info, bottom_only);
+       return;
+       }
+        #endif
+       
        region.color = attr_bgcol_ec(bgshift, vc);
        region.rop = ROP_COPY;

***************
*** 691,697 ****

        nr_cols = info->var.xres / vc->vc_font.width;
        nr_rows = info->var.yres / vc->vc_font.height;
!
        if (logo) {
                /* Need to make room for the logo */
                int cnt;
--- 731,744 ----

        nr_cols = info->var.xres / vc->vc_font.width;
        nr_rows = info->var.yres / vc->vc_font.height;
!  #ifdef CONFIG_BOOTSPLASH
!       if (vc->vc_splash_data && vc->vc_splash_data->splash_state) {
!               nr_cols = vc->vc_splash_data->splash_text_wi / vc->vc_font.width;
!               nr_rows = vc->vc_splash_data->splash_text_he / vc->vc_font.height;
!               logo = 0;
!       }
!  #endif

        if (logo) {
                /* Need to make room for the logo */
                int cnt;
***************
*** 757,764 ****
                vc->vc_hi_font_mask = 0x100;
                if (vc->vc_can_do_color)
                        vc->vc_complement_mask <<= 1;
!       }
!
        if (logo) {
                if (vc->vc_cols != nr_cols || vc->vc_rows != nr_rows)
                        vc_resize(vc->vc_num, nr_cols, nr_rows);
--- 804,817 ----
                vc->vc_hi_font_mask = 0x100;
                if (vc->vc_can_do_color)
                        vc->vc_complement_mask <<= 1;
!           }
!       
!       #ifdef CONFIG_BOOTSPLASH
!            if(vc->vc_splash_data && vc->vc_splash_data->splash_state) {
!                    con_remap_def_color(vc->vc_num, vc->vc_splash_data->splash_color << 4 | vc->vc_splash_data->splash_fg_color);
!            }
!       #endif
!       
        if (logo) {
                if (vc->vc_cols != nr_cols || vc->vc_rows != nr_rows)
                        vc_resize(vc->vc_num, nr_cols, nr_rows);
***************
*** 883,888 ****
--- 936,947 ----
        if (vt_cons[vc->vc_num]->vc_mode != KD_TEXT)
                return;

+ #ifdef CONFIG_BOOTSPLASH
+       if (info->splash_data) {
+               splash_putc(info->splash_data, vc, info, c, ypos, xpos);
+               return;
+       }
+ #endif
        image.dx = xpos * vc->vc_font.width;
        image.dy = real_y(p, ypos) * vc->vc_font.height;
        image.width = vc->vc_font.width;
***************
*** 957,962 ****
--- 1016,1027 ----
                if (info->cursor.rop == ROP_XOR) {
                        info->cursor.enable = 0;
                        info->cursor.rop = ROP_COPY;
+ #ifdef CONFIG_BOOTSPLASH
+                       if (info->splash_data) {
+                               splash_cursor(info->splash_data, info, &cursor);
+                               break;
+                       }
+ #endif
                        info->fbops->fb_cursor(info, &cursor);
                }
                break;
***************
*** 1032,1037 ****
--- 1097,1109 ----
                                mask[i++] = 0xff;
                }
                info->cursor.rop = ROP_XOR;
+ #ifdef CONFIG_BOOTSPLASH
+               if (info->splash_data) {
+                       splash_cursor(info->splash_data, info, &cursor);
+                       vbl_cursor_cnt = CURSOR_DRAW_DELAY;
+                       break;
+               }
+ #endif
                info->fbops->fb_cursor(info, &cursor);
                vbl_cursor_cnt = CURSOR_DRAW_DELAY;
                break;
***************
*** 1335,1340 ****
--- 1407,1416 ----
                        fbcon_softback_note(vc, t, count);
                if (logo_shown >= 0)
                        goto redraw_up;
+ #ifdef CONFIG_BOOTSPLASH
+               if (info->splash_data)
+                       goto redraw_up;
+ #endif
                switch (p->scrollmode & __SCROLL_YMASK) {
                case __SCROLL_YMOVE:
                        accel_bmove(vc, info, t + count, 0, t, 0,
***************
*** 1402,1407 ****
--- 1478,1487 ----
        case SM_DOWN:
                if (count > vc->vc_rows)        /* Maximum realistic size */
                        count = vc->vc_rows;
+ #ifdef CONFIG_BOOTSPLASH
+               if (info->splash_data)
+                       goto redraw_down;
+ #endif
                switch (p->scrollmode & __SCROLL_YMASK) {
                case __SCROLL_YMOVE:
                        accel_bmove(vc, info, t, 0, t + count, 0,
***************
*** 1527,1532 ****
--- 1607,1619 ----
                }
                return;
        }
+ #ifdef CONFIG_BOOTSPLASH
+       if (info->splash_data && sy == dy && height == 1) {
+               /* must use slower redraw bmove to keep background pic intact */
+               splash_bmove_redraw(info->splash_data, vc, info, sy, sx, dx, width);
+               return;
+       }
+ #endif
        accel_bmove(vc, info, real_y(p, sy), sx, real_y(p, dy), dx,
                        height, width);
  }
***************
*** 1569,1574 ****
--- 1656,1665 ----
        struct fb_info *info = registered_fb[(int) con2fb_map[vc->vc_num]];
        struct display *p = &fb_display[vc->vc_num];

+ #ifdef CONFIG_BOOTSPLASH
+       splash_prepare(vc, info);
+ #endif
+
        if (softback_top) {
                int l = fbcon_softback_size / vc->vc_size_row;
                if (softback_lines)
***************
*** 1652,1657 ****
--- 1743,1754 ----
        fbcon_cursor(vc, blank ? CM_ERASE : CM_DRAW);

        if (!info->fbops->fb_blank) {
+ #ifdef CONFIG_BOOTSPLASH
+               if (info->splash_data) {
+                       splash_blank(info->splash_data, vc, info, blank);
+                       return 0;
+               }
+ #endif
                if (blank) {
                        unsigned short oldc;
                        u_int height;
***************
*** 1828,1837 ****
        }

        if (resize) {
                /* reset wrap/pan */
                info->var.xoffset = info->var.yoffset = p->yscroll = 0;
                updatescrollmode(p, vc);
!               vc_resize(vc->vc_num, info->var.xres / w, info->var.yres / h);
                if (CON_IS_VISIBLE(vc) && softback_buf) {
                        int l = fbcon_softback_size / vc->vc_size_row;
                        if (l > 5)
--- 1925,1944 ----
        }

        if (resize) {
+               u32 xres = info->var.xres, yres = info->var.yres;
                /* reset wrap/pan */
                info->var.xoffset = info->var.yoffset = p->yscroll = 0;
+               p->vrows = info->var.yres_virtual / h;
+
+ #ifdef CONFIG_BOOTSPLASH
+               if (info->splash_data) {
+                       xres = info->splash_data->splash_text_wi;
+                       yres = info->splash_data->splash_text_he;
+               }
+ #endif
                updatescrollmode(p, vc);
!               vc_resize(vc->vc_num, xres / w, yres / h);
!                               
                if (CON_IS_VISIBLE(vc) && softback_buf) {
                        int l = fbcon_softback_size / vc->vc_size_row;
                        if (l > 5)
***************
*** 2274,2279 ****
--- 2381,2390 ----
        if (!num_registered_fb)
                return -ENODEV;

+ #ifdef CONFIG_BOOTSPLASH
+       splash_init();
+ #endif
+
        err = take_over_console(&fb_con, first_fb_vc, last_fb_vc,
                                fbcon_is_default);
        if (err)

Back to top
View user's profile Send private message
woody77
n00b
n00b


Joined: 06 Feb 2004
Posts: 69
Location: SC Mtns, CA, USA

PostPosted: Thu May 13, 2004 11:57 pm    Post subject: Reply with quote

Way cool! (works now). Just need to get my theme for 1400x1050 sorted out.
Back to top
View user's profile Send private message
Assgier
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2003
Posts: 127
Location: Europe -> Netherlands -> Utrecht -> Amersfoort

PostPosted: Fri May 14, 2004 4:50 am    Post subject: Reply with quote

is there any reason why the people from bootsplash.org don't release any patches for more recent kernels themselves :?:
_________________
8)
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1337
Location: Mississippi USA

PostPosted: Fri May 14, 2004 8:12 am    Post subject: Reply with quote

Assgier wrote:
is there any reason why the people from bootsplash.org don't release any patches for more recent kernels themselves :?:


Me too or me two. I'm can't get the 2.6.5 one to boot. I copied the config over from a good bootable kernel and it still won't do right. I got 2.6.6 and it boots but no bootsplash yet.

Waiting.

8O 8O :D :D :D :D
_________________
My rig: Gigabyte GA-970A-UD3P mobo, AMD FX-8350 Eight-Core CPU, ZALMAN CNPS10X Performa CPU cooler,
G.SKILL 32GB DDR3 PC3 12800 Memory Nvidia GTX-650 video card LG W2253 Monitor
9TBs of hard drive space using LVM
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
sleggh
n00b
n00b


Joined: 13 May 2004
Posts: 3
Location: Iggesund, sweden

PostPosted: Fri May 14, 2004 9:18 am    Post subject: Reply with quote

yeah! it's working now :) and i don't know why. My personal theme isn't working though, but that's another question.
Back to top
View user's profile Send private message
woody77
n00b
n00b


Joined: 06 Feb 2004
Posts: 69
Location: SC Mtns, CA, USA

PostPosted: Fri May 14, 2004 4:46 pm    Post subject: Reply with quote

Well, not quite perfect.. Gettings an "oops" during init, but after that, I can restart the service and it changes just fine. Not sure if this is a bootsplash problem, or one I introduced with my patch. Will look into it, since it IS in the code I had to manually merge.

Code:

bootsplash 3.1.3-2003/11/14: looking for picture.... found (1400x1050, 160727 bytes, v3).
bootsplash: status on console 0 changed to on
Unable to handle kernel paging request at virtual address e147b032
 printing eip:
c02f96ea
*pde = 1ddac067
*pte = 00000000
Oops: 0000 [#1]
PREEMPT
CPU:    0
EIP:    0060:[<c02f96ea>]    Not tainted VLI
EFLAGS: 00010202   (2.6.6-rc3-mm1)
EIP is at splash_renderc+0xe6/0x19e
eax: 00000001   ebx: e147b032   ecx: e0ae5e32   edx: 00000000
esi: 00000000   edi: 00000000   ebp: 0000ad55   esp: dfa3fd80
ds: 007b   es: 007b   ss: 0068
Process splash.bin (pid: 6103, threadinfo=dfa3e000 task=dfc6acb0)
Stack: 00000b00 00000010 00000000 ad550000 00000007 00000000 00000001 00000010
       df996220 c1511a94 c1511800 c02f9d9b e0ecc000 c1511800 00000007 00000000
       c1511a8c 00000419 00000019 00000010 00000008 00000010 00000008 e0ecc000
Call Trace:
 [<c02f9d9b>] splash_cursor+0x134/0x1e4
 [<c02f2ba2>] fbcon_cursor+0x3b9/0x3fe
 [<c0123193>] __group_send_sig_info+0x4d/0xcf
 [<c0294201>] invert_screen+0x190/0x1bf
 [<c0291c0e>] clear_selection+0x18/0x5d
 [<c0294774>] hide_cursor+0x2b/0x42
 [<c0294a84>] redraw_screen+0x1ad/0x1f5
 [<c01233f1>] kill_pg_info+0x32/0x54
 [<c029524c>] vc_resize+0x3f6/0x505
 [<c02f71ae>] splash_status+0xfd/0x171
 [<c02f746b>] splash_write_proc+0x171/0x445
 [<c0320803>] stall_callback+0x0/0x19b
 [<c017be81>] proc_file_write+0x0/0x42
 [<c017beb8>] proc_file_write+0x37/0x42
 [<c014d569>] vfs_write+0xb0/0x119
 [<c014d677>] sys_write+0x42/0x63
 [<c0105f13>] syscall_call+0x7/0xb

Code: 08 f7 c6 07 00 00 00 75 0e 8b 54 24 40 0f b6 3a 83 c2 01 89 54 24 40 89 f8 89 ea 84 c0 78 0f 8b 44 24 18 8b 54 24 14 85 c0 74 03 <0f> b7 13 83 c3 02 f7 c7 40 00 00 00 74 5b 0b 54 24 0c 89 11 83
 <6>bootsplash 3.1.3-2003/11/14: looking for picture.... found (1400x1050, 160727 bytes, v3).
bootsplash: status on console 1 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (1400x1050, 160727 bytes, v3).
bootsplash: status on console 2 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (1400x1050, 160727 bytes, v3).
bootsplash: status on console 3 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (1400x1050, 160727 bytes, v3).
bootsplash: status on console 4 changed to on
bootsplash 3.1.3-2003/11/14: looking for picture.... found (1400x1050, 160727 bytes, v3).
bootsplash: status on console 5 changed to on


however, after that first problem on the first attempt at setting up vt0, it works fine, on vt0-5. Very impressive. Not a clean transition between X.org and an fb'd vt, a bit of "snow" in the x windows and text window as it transitions, but it all cleans up quickly.

Now to just get my themes sorted out so that I've got the same background continuously.
Back to top
View user's profile Send private message
sleggh
n00b
n00b


Joined: 13 May 2004
Posts: 3
Location: Iggesund, sweden

PostPosted: Sun May 16, 2004 1:48 pm    Post subject: Reply with quote

hmm got a slight problem here.

http://upl.silentwhisper.net/uplfolders/upload5/console.png

i want the box to cover the whole text in the bottom of the picture, but i have no idea were in the config i'l change that.
Back to top
View user's profile Send private message
Assgier
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2003
Posts: 127
Location: Europe -> Netherlands -> Utrecht -> Amersfoort

PostPosted: Mon May 17, 2004 7:44 am    Post subject: Reply with quote

sleggh wrote:
hmm got a slight problem here.

http://upl.silentwhisper.net/uplfolders/upload5/console.png

i want the box to cover the whole text in the bottom of the picture, but i have no idea were in the config i'l change that.

you need to change that in the specific .cfg file of your theme :)
_________________
8)
Back to top
View user's profile Send private message
DCatcher
n00b
n00b


Joined: 18 Mar 2004
Posts: 12
Location: FRG

PostPosted: Mon May 17, 2004 9:42 am    Post subject: Reply with quote

Here's my first bootsplash.
Just with v2 config.

http://www.tribal-board.de/uploads/bootsplash.png
Back to top
View user's profile Send private message
Narada
Guru
Guru


Joined: 12 Dec 2002
Posts: 300
Location: London, UK

PostPosted: Tue May 18, 2004 12:12 am    Post subject: 2.6.6 patch available Reply with quote

There's now a 2.6.6 patch available on the original topic post. I've tried it and bootsplash works fine. However, I had to use the testing tree nvidia-kernel and nvidia-glx to start X with 2.6.6. Leave 8k stack sizes in kernel options rather than choosing 4k.
_________________
http://dhruba.name/


Last edited by Narada on Tue May 18, 2004 1:22 am; edited 1 time in total
Back to top
View user's profile Send private message
Larcen
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 174

PostPosted: Tue May 18, 2004 1:01 am    Post subject: Reply with quote

Maybe I overlooked something important, I most likely did..but here it is.

I have a working bootsplash, and using genkernel, so there was a initrd-gentoo-r1 automatically made and placed in ./boot. So when I copied over the configs, replaced the symlink and edited the config, I copied over the initrd using the same file name. Luckly when I rebooted, or before I did all this, I made a backup of my genkernel initrd in my root directory, because It failed and I had to mount everything using livecd and replace the initrd. :(
Back to top
View user's profile Send private message
teedog
Apprentice
Apprentice


Joined: 09 Mar 2004
Posts: 211

PostPosted: Tue May 18, 2004 2:58 am    Post subject: Re: instructions to list all video modes Reply with quote

chris.pickett wrote:
hope this helps everyone. if the lfb.exe or 622c.zip files go down, let me know, i'll keep copies.


622c.zip's link is dead. Could you put it up somewhere again? I have a Dell Inspiron 600m with a Radeon 9000, and while 0x342 allows me to boot, I don't get a bootsplash image (says signature not found). Bootsplash works if I use 0x31A (1280x1024). That's why I want to use your trick to find the correct vga= value for me to run 1400x1050.

Thanks.
Back to top
View user's profile Send private message
woody77
n00b
n00b


Joined: 06 Feb 2004
Posts: 69
Location: SC Mtns, CA, USA

PostPosted: Tue May 18, 2004 3:56 am    Post subject: Reply with quote

1400x1050 (kernel 2.6)
Code:

video=vesafb:ywrap,mtrr vga=0x342
Back to top
View user's profile Send private message
teedog
Apprentice
Apprentice


Joined: 09 Mar 2004
Posts: 211

PostPosted: Tue May 18, 2004 5:11 am    Post subject: Reply with quote

woody77 wrote:
1400x1050 (kernel 2.6)
Code:

video=vesafb:ywrap,mtrr vga=0x342


I did exactly that but no bootsplash image was loaded (kernel booted fine, just no image). Works fine with vga=0x31A.
Back to top
View user's profile Send private message
chris.pickett
n00b
n00b


Joined: 05 Apr 2004
Posts: 72
Location: Montreal

PostPosted: Tue May 18, 2004 2:03 pm    Post subject: Reply with quote

Go here for the bootdisk:

http://www.bootdisk.com/bootdisk.htm

and you want the one from the DOS-based image files.

I guess the guy just provides links to them.
Back to top
View user's profile Send private message
Larcen
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 174

PostPosted: Tue May 18, 2004 4:49 pm    Post subject: Reply with quote

DCatcher wrote:
Here's my first bootsplash.
Just with v2 config.

http://www.tribal-board.de/uploads/bootsplash.png


*Groans* I'm envious! *Kicks his initrd made by genkernel.*
Back to top
View user's profile Send private message
teedog
Apprentice
Apprentice


Joined: 09 Mar 2004
Posts: 211

PostPosted: Tue May 18, 2004 7:52 pm    Post subject: Reply with quote

teedog wrote:
woody77 wrote:
1400x1050 (kernel 2.6)
Code:

video=vesafb:ywrap,mtrr vga=0x342


I did exactly that but no bootsplash image was loaded (kernel booted fine, just no image). Works fine with vga=0x31A.


I'm so stupid. I forgot tor resize the image to 1400x1050. All is well now. :oops:
Back to top
View user's profile Send private message
infamousmrsatan
Apprentice
Apprentice


Joined: 08 Jan 2004
Posts: 201
Location: California

PostPosted: Wed May 19, 2004 1:38 am    Post subject: Reply with quote

Hi, several people have reported the problem that the initrd image fails to load when they create a custom image -- but that the original default bootsplash works great.

That is the boat that I'm in.

Here's my grub.conf:
Code:
# which listing to boot as default. 0 is the first, 1 is the second, etc.
default 0
#How many seconds to wait before the default listing is booted.
timeout 10
#Nice, fat splash-image to spice things up :)
splashimage=(hd0,0)/grub/splash.xpm.gz

### the following three configurations are the post fb kernels

## Kernel version updated form -fb-splash to -fb-splash2

# Yes Framebuffer, Yes Bootsplash, Gentoo Default Image
title=Gentoo Linux (Kernel 2.6.5) (+fb +splash)
root=(hd0,0)
kernel=(hd0,0)/kernel-2.6.5-fb-splash4 root=/dev/hda3 video=vesafb:ywrap,mtrr vga=0x317 splash=verbose
initrd=/boot/oldinitrd-1024x768

# Yes Framebuffer, Yes Bootsplash, Custom Image
title=Gentoo Linux (Kernel 2.6.5) (+fb +splash) (custom)
root=(hd0,0)
kernel=(hd0,0)/kernel-2.6.5-fb-splash4 root=/dev/hda3 video=vesafb:ywrap,mtrr vga=0x317 splash=verbose
initrd=/boot/initrd-1024x768

# Yes Framebuffer, No Bootsplash
title=Gentoo Linux (Kernel 2.6.5) (+fb -splash)
root=(hd0,0)
kernel=(hd0,0)/kernel-2.6.5-fb-splash4 root=/dev/hda3 video=vesafb:ywrap,mtrr vga=0x317

#  No Framebuffer, No Bootsplash
title=Gentoo Linux (Kernel 2.6.5) (-fb -splash)
root=(hd0,0)
kernel=(hd0,0)/kernel-2.6.5-fb-splash4 root=/dev/hda3


I'm pretty sure that I've followed all the intstructions right, and as I said, it works great with the default image. It is only when I try to use my own custom image that it fails (and fails silently, with no errors reported :/ ).

Thanks in advanced

Justin
_________________
Registered Linux User 344425
Join the adopt an unanswered post initiative today!
Por favor, corrija mi espanol!
Back to top
View user's profile Send private message
woody77
n00b
n00b


Joined: 06 Feb 2004
Posts: 69
Location: SC Mtns, CA, USA

PostPosted: Wed May 19, 2004 2:02 am    Post subject: Reply with quote

No errors are reported in dmesg? I never saw that happening, I always had *something*.

Usually that there was no suitable image found.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 13, 14, 15 ... 25, 26, 27  Next
Page 14 of 27

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum