Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to set up ISDN on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
orgon
n00b
n00b


Joined: 22 Dec 2003
Posts: 8

PostPosted: Mon Apr 05, 2004 12:52 pm    Post subject: Reply with quote

> Thanks,
> but thats not a solution because the Machine is a router and I
> don't want to login evertime to change the configs.

How do you switch between the ISP's now?

> Isn't there a file which is called evertime when the connetion is
> termianted?

Usually /etc/ppp/ip-down. I don't know why this isn't working for you. Check out, if this script is executed at all (e.g. add a line "touch /tmp/ip-down-test" and after end of connection look if this file exists).

cu

orgon
Back to top
View user's profile Send private message
mathes.s
Apprentice
Apprentice


Joined: 18 Apr 2003
Posts: 279
Location: Brunswick, Germany

PostPosted: Mon Apr 05, 2004 2:59 pm    Post subject: Reply with quote

Quote:
How do you switch between the ISP's now?


I use the two ipppX interfaces. When I do an "isdnctrl dail ippp0" it connects to the first ISP and when I do it with ippp1 it dials another number.


Quote:
Usually /etc/ppp/ip-down. I don't know why this isn't working for you. Check out, if this script is executed at all (e.g. add a line "touch /tmp/ip-down-test" and after end of connection look if this file exists)


I tested it and the file exists. But I have found an workaround for it. From Monday to Saturday I use only one ISP Number and only on Sundays I use the other number (because on Sundays I can connect at no cost to the ISP but I have do use another number). So I but everthing in Cron. He delets the unnecassery routes and automatically dials in on Sunday morning.

Thanks
_________________
Erst wenn der letzte Programmierer eingesperrt, das letzte Programm verwirklicht und die letzte Idee patentiert ist, werdet Ihr merken, dass Anwälte nicht programmieren können.
Back to top
View user's profile Send private message
orgon
n00b
n00b


Joined: 22 Dec 2003
Posts: 8

PostPosted: Mon Apr 05, 2004 4:09 pm    Post subject: Reply with quote

Quote:
Zitat:
How do you switch between the ISP's now?


I use the two ipppX interfaces. When I do an "isdnctrl dail ippp0" it connects to the first ISP and when I do it with ippp1 it dials another number.


Sorry, my question was not exact. What I meant was, do you change the ISP's automaticly, or do you open a remote-connection to the server and call isdnctrl manually?
But I think it doesn't matter any longer, since you have found your solution.

Best regards,

lukas
Back to top
View user's profile Send private message
ghandalf
n00b
n00b


Joined: 28 Apr 2004
Posts: 24
Location: Palermo - Sicily

PostPosted: Wed Apr 28, 2004 2:50 pm    Post subject: Reply with quote

Great guide.. :D

I didn't use the isdn-initialise method or the /etc/conf.d/net one.

I just used this isdn-setup:

Quote:

#!/bin/bash


REMNAME=
MYMSN=
REMMSN=
MYUSER=
MYIP=10.0.0.1

/sbin/isdnctrl verbose 3
/sbin/isdnctrl system on
/sbin/isdnctrl addif ippp0
/sbin/isdnctrl eaz ippp0 $MYMSN
/sbin/isdnctrl l2_prot ippp0 hdlc
/sbin/isdnctrl l3_prot ippp0 trans
/sbin/isdnctrl encap ippp0 syncppp
/sbin/isdnctrl dialmode ippp0 manual
/sbin/isdnctrl addphone ippp0 out $REMMSN
/sbin/isdnctrl huptimeout ippp0 120
/sbin/isdnctrl dialmax ippp0 20
/sbin/ipppd user $MYUSER remotename $REMNAME \
defaultroute \
name $MYUSER \
debug \
-detach \
mru 1524 \
mtu 1500 \
lcp-restart 1 \
/dev/ippp0 &

/sbin/ifconfig ippp0 $MYIP pointopoint
/sbin/ifconfig ippp0 -arp -broadcast
/sbin/route add $MYIP ippp0
/sbin/route add default netmask 0 ippp0



the only problem i've encountered has been the resolv.conf file:

There's one in /etc/, but anothere one is mandatory to make ISDN work properly:

/etc/ppp/resolv.conf

hope this help.

Gentoo with kernel 2.6.5
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Thu Apr 29, 2004 5:17 am    Post subject: Reply with quote

Hei Ghandalf

You give me hope... yesterday I gave up trying to get isdn to work on Gentoo, it was making me so mad I just had to give it a rest.

isdn works so easily using Knoppix's old 'isdn-config' - fill out half a dozen items, eaz, etc, and in one minute you are on the air - why on earth doesn't something so simple exist for Gentoo?

With your straightforward input I'll give it yet another try!

Cross fingers, and thanks
Back to top
View user's profile Send private message
ghandalf
n00b
n00b


Joined: 28 Apr 2004
Posts: 24
Location: Palermo - Sicily

PostPosted: Thu Apr 29, 2004 8:43 am    Post subject: Reply with quote

This what I've done to make it works:

1. Compiled everything about the ISDN as builded-in, nope as a module.
- my ISDN adapter is the ASUSCOM.

2. Verified after booting the situation giving:

# dmesg | grep HiSax

HiSax: Linux Driver for passive ISDN cards
HiSax: Version 3.5 (kernel)
HiSax: Layer1 Revision 2.46.2.5
HiSax: Layer2 Revision 2.30.2.4
HiSax: TeiMgr Revision 2.20.2.3
HiSax: Layer3 Revision 2.22.2.3
HiSax: LinkLayer Revision 2.59.2.4
HiSax: Total 1 card defined
HiSax: Card 1 Protocol EDSS1 Id=HiSax (0)
HiSax: HFC-PCI driver Rev. 1.48.2.4
HiSax: HFC-PCI card manufacturer: Asuscom/Askey card name: 675
HiSax: DSS1 Rev. 2.32.2.3
HiSax: 2 channels added
HiSax: MAX_WAITING_CALLS added

3. Emerged isdn4k-utils

3.1. # rc-update add isdn4linux default

4. created che chap-secrets file

5. created the isdn-setup file as in my previous post, and made it executable

6. checked /etc/resolv.conf and created /etc/ppp/resolv.conf

7. thats all, connected:

open a console, run isdn-setup, and isdnctrl dial ippp0, eventually run imon...:)

hope this help, post for any problem..;)
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Thu Apr 29, 2004 1:20 pm    Post subject: Reply with quote

Hei again

To be sure ref point 1, do you mean that you have built nothing to do with isdn as modules? ie you answered <*> to everything?

I had everything loading nicely the other day, but then I did something and it all went to hell, so now I'm trying to get back to hisax loading fully as you show above, by trying various combinations of <*> versus <M>, have re-compiled 4 times so far today.. luckily its a fast machine .-)

If you could copy/email me your configure file I would have a better chance of success I think..?

regards
Back to top
View user's profile Send private message
ghandalf
n00b
n00b


Joined: 28 Apr 2004
Posts: 24
Location: Palermo - Sicily

PostPosted: Thu Apr 29, 2004 2:00 pm    Post subject: Reply with quote

Quote:

To be sure ref point 1, do you mean that you have built nothing to do with isdn as modules? ie you answered <*> to everything?


not to everything...have a look below

Quote:

If you could copy/email me your configure file I would have a better chance of success I think..?


here we are--:)

Quote:

<*> ISDN support

Old ISDN4Linux --->
<*> Old ISDN4Linux (obsolete)
[*] Support synchronous PPP
[*] Use VJ-compression with synchronous PPP

Passive cards --->
<*> HiSax SiemensChipSet driver support
[*] HiSax Support for EURO/DSS1
[*] HFC PCI-Bus cards


thats all, nothing more..;)
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Thu Apr 29, 2004 4:50 pm    Post subject: Reply with quote

I have come a stage further:
bash-2.05b# dmesg | grep HiSax
HiSax: Linux Driver for passive ISDN cards
HiSax: Version 3.5 (kernel)
HiSax: Layer1 Revision 1.1.4.1
HiSax: Layer2 Revision 1.1.4.1
HiSax: TeiMgr Revision 1.1.4.1
HiSax: Layer3 Revision 1.1.4.1
HiSax: LinkLayer Revision 1.1.4.1
HiSax: Approval certification failed because of
HiSax: unauthorized source code changes
HiSax: Total 1 card defined
HiSax: Card 1 Protocol EDSS1 Id=HiSax (0)
HiSax: HFC-PCI driver Rev. 1.1.4.1
HiSax: HFC-PCI card manufacturer: CCD/Billion/Asuscom card name: 2BD0
HiSax: DSS1 Rev. 1.1.4.1
HiSax: 2 channels added
HiSax: MAX_WAITING_CALLS added

But I see that my revisions are older than yours. I also have kernel 2.4.24.

when I run bash-2.05b# /etc/ppp/isdn-setup I get..
Verbose-level set to 3.
addif: Invalid argument
ippp0: Invalid argument
ippp0: Invalid argument
ippp0: Invalid argument
ippp0: Invalid argument
ippp0: Invalid argument
ippp0: Invalid argument
ippp0: Invalid argument
ippp0: Invalid argument
SIOCSIFADDR: No such device
ippp0: unknown interface: No such device
ippp0: unknown interface: No such device
ippp0: unknown interface: No such device
ippp0: unknown interface: No such device
SIOCADDRT: No such device
SIOCADDRT: No such device
bash-2.05b# Sorry - this system lacks PPP kernel support.

Check whether you configured at least the ippp0 device!

-----------------------

So I'm back where I was a few days ago, but then I could modprobe hisax and be sure of type=35 and protocol=2.

Any idea what may be causing the above?

My set-up is I'll swear like yours..

#!/bin/bash

MYUSER=xxx #username at ISP - none for Start
REMNAME=online #ISP name
REMMSN=153381007007 #ISP's number
MYIP=10.0.0.1 #ipppd will overwrite this
MYMSN=3128xxxx #my isdn phone number

/sbin/isdnctrl verbose 3 #verbose messages
/sbin/isdnctrl system on #start isdn system
/sbin/isdnctrl addif ippp0 #add the interface
/sbin/isdnctrl eaz ippp0 $MYMSN #
/sbin/isdnctrl l2_prot ippp0 hdlc
/sbin/isdnctrl l3_prot ippp0 trans
/sbin/isdnctrl encap ippp0 syncppp #using syncppp
/sbin/isdnctrl dialmode ippp0 manual #not auto ref dial on demand
/sbin/isdnctrl addphone ippp0 out $REMMSN #ISP's number
/sbin/isdnctrl huptimeout ippp0 500 #time out 10 seconds - is that right
/sbin/isdnctrl dialmax ippp0 20 #redial count 20
/sbin/ipppd user $MYUSER remotename $REMNAME \
defaultroute \
name $MYUSER \
debug \
-detach \
mru 1524 \
mtu 1500 \
lcp-restart 1 \
/dev/ippp0 &

/sbin/ifconfig ippp0 $MYIP pointopoint #is the latter's spelling correct?
/sbin/ifconfig ippp0 -arp -broadcast #don't allow these
/sbin/route add $MYIP ippp0
/sbin/route add default netmask 0 ippp0 #all non-local traffic goes to ippp0

still hopeful

btw my card is an HFC-PCI card and I have seen elsewhere that pnp cards should be set as modules, not built in to the kernel..?
Back to top
View user's profile Send private message
ghandalf
n00b
n00b


Joined: 28 Apr 2004
Posts: 24
Location: Palermo - Sicily

PostPosted: Thu Apr 29, 2004 5:48 pm    Post subject: Reply with quote

Two things:

Try:

# rm /dev/isdninfo
# rm /dev/isdnctrl
# rm /dev/ippp0
# rm /dev/ippp1
# mknod /dev/isdninfo c 45 255
# mknod /dev/isdnctrl c 45 64
# mknod /dev/ippp0 c 45 128
# mknod /dev/ippp1 c 45 129


You have to:

# /etc/init.d/isdn4linux start
# /etc/ppp/isdn-setup
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Thu Apr 29, 2004 6:45 pm    Post subject: Reply with quote

Hei again ghandalf

I followed your last instructions but I'm afraid that running
bash-2.05b# /etc/ppp/isdn-setup gave the same result as above..

I'm calling it a day now, and will have another look tomorrow.

I'm wondering whether to upgrade my kernel to 2.4.26, but I'm not sure if I'll still be able to use the Pentium 4 Package CD, that goes with the x86-universal-2004.0 LiveCD?

Anyway, I'll be upgrading to 2004.1 as soon as I find out whether or not there is a new Packages CD to go with it. Couldn't see it in the mirrors.

Thanks for all your help
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Sat May 01, 2004 3:52 pm    Post subject: Reply with quote

Hei Ghandalf

Believe it or not but I am actually communicating over ISDN! :-)

Somehow or other in my many re-compiles, PPP dropped out...

So, now I simply used your script and isdnctrl dial ippp0 and away it went.

You can imagine how happy I am to be on line with Gentoo.

Thanks for your kind help.
Back to top
View user's profile Send private message
hugelmopf
n00b
n00b


Joined: 02 May 2004
Posts: 28
Location: Dresden (Germany)

PostPosted: Wed May 12, 2004 4:18 pm    Post subject: Reply with quote

Hey there,

Gandalfs guide seemed less complicated to me, so that's what I followed. But my dmesg-Output is a bit different from yours, especially that there is 0 cards defined:

Code:

# dmesg | grep HiSax

HiSax: Linux Driver for passive ISDN cards
HiSax: Version 3.5 (kernel)
HiSax: Layer1 Revision 1.1.4.1
HiSax: Layer2 Revision 1.1.4.1
HiSax: TeiMgr Revision 1.1.4.1
HiSax: Layer3 Revision 1.1.4.1
HiSax: LinkLayer Revision 1.1.4.1
HiSax: Approval certification failed because of
HiSax: unauthorized source code changes
HiSax: Total 0 card defined
HiSax: Card 1 Protocol EDSS1 Id=fcpcipnp0 (0)
HiSax: DSS1 Rev. 1.1.4.1
HiSax: 2 channels added
HiSax: MAX_WAITING_CALLS added


I have recompiled my kernel (2.4.25) to support my AVM Fritz! PCI v2.0 (checked the first of the three drivers in ghandalfs guide).

Can anybody help here? I'll keep trying myself, but maybe somebody is looking at it and saying: "Doh... how can he be so noobish. That's easy!" ;-)
Thanks, Frank
Back to top
View user's profile Send private message
Ben2040
Guru
Guru


Joined: 07 May 2003
Posts: 445
Location: UK

PostPosted: Sun Jun 20, 2004 3:33 pm    Post subject: Reply with quote

Hi

My BT Highway Box also says the above, but with different drivers etc..

Have there been any more anvancements on this scene? I have been futilly looking at the configs and kernel setyup of my SuSE router/proxy/file server to see how it manages to connect via ISDN (same card), but I really have no idea what I'm looking for :(


Ben
Back to top
View user's profile Send private message
Ben2040
Guru
Guru


Joined: 07 May 2003
Posts: 445
Location: UK

PostPosted: Thu Jun 24, 2004 8:33 am    Post subject: Reply with quote

:: BUMP ::

Anybody got any ideas?

Ben
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Thu Jun 24, 2004 1:49 pm    Post subject: Reply with quote

Ben2040 wrote:
:: BUMP ::

Anybody got any ideas?

Ben


Hei

Did you follow Ghandalf's april 29th advice:

Code:

# rm /dev/isdninfo
# rm /dev/isdnctrl
# rm /dev/ippp0
# rm /dev/ippp1
# mknod /dev/isdninfo c 45 255
# mknod /dev/isdnctrl c 45 64
# mknod /dev/ippp0 c 45 128
# mknod /dev/ippp1 c 45 129

You have to:

# /etc/init.d/isdn4linux start
# /etc/ppp/isdn-setup


Doing this enabled isdn to work ok on my HFC-PCI card using one of the 'difficult' 2.6.x kernels.. after weeks of almost giving up!

ISDN seemed to work much more easily on 2.4.x kernels..

best of luck
btw the Billion HFC-PCI card works a treat..
http://www.billion.com/support/faq/faq-isdn0.htm
Back to top
View user's profile Send private message
Ben2040
Guru
Guru


Joined: 07 May 2003
Posts: 445
Location: UK

PostPosted: Fri Jun 25, 2004 12:18 pm    Post subject: Reply with quote

Hi

Yep, tried deleting the dev files, but to no avail, same error -

On 2.4 - No such device (or similar)
On 2.6 - No such file or directory (or similar)

Ben
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Fri Jun 25, 2004 4:59 pm    Post subject: Reply with quote

Couple of things..

have you done

Code:

#rc-update add isdn4linux default


My .config file in 2.6.7 looks like this:
Code:

#
# ISDN subsystem
#
CONFIG_ISDN=m

#
# Old ISDN4Linux
#
CONFIG_ISDN_I4L=m
CONFIG_ISDN_PPP=y
CONFIG_ISDN_PPP_VJ=y
CONFIG_ISDN_MPP=y
CONFIG_IPPP_FILTER=y
CONFIG_ISDN_PPP_BSDCOMP=m
CONFIG_ISDN_AUDIO=y
CONFIG_ISDN_TTY_FAX=y

#
# ISDN feature submodules
#
CONFIG_ISDN_DRV_LOOP=m

#
# ISDN4Linux hardware drivers
#

#
# Passive cards
#
CONFIG_ISDN_DRV_HISAX=m

#
# D-channel protocol features
#
CONFIG_HISAX_EURO=y
CONFIG_DE_AOC=y
# CONFIG_HISAX_NO_SENDCOMPLETE is not set
# CONFIG_HISAX_NO_LLC is not set
# CONFIG_HISAX_NO_KEYPAD is not set
CONFIG_HISAX_1TR6=y
CONFIG_HISAX_NI1=y
CONFIG_HISAX_MAX_CARDS=8

#
# HiSax supported cards
#
# CONFIG_HISAX_16_0 is not set
# CONFIG_HISAX_16_3 is not set
CONFIG_HISAX_TELESPCI=y
# CONFIG_HISAX_S0BOX is not set
# CONFIG_HISAX_AVM_A1 is not set
# CONFIG_HISAX_FRITZPCI is not set
# CONFIG_HISAX_AVM_A1_PCMCIA is not set
# CONFIG_HISAX_ELSA is not set
# CONFIG_HISAX_IX1MICROR2 is not set
# CONFIG_HISAX_DIEHLDIVA is not set
# CONFIG_HISAX_ASUSCOM is not set
# CONFIG_HISAX_TELEINT is not set
CONFIG_HISAX_HFCS=y
# CONFIG_HISAX_SEDLBAUER is not set
# CONFIG_HISAX_SPORTSTER is not set
# CONFIG_HISAX_MIC is not set
# CONFIG_HISAX_NETJET is not set
# CONFIG_HISAX_NETJET_U is not set
# CONFIG_HISAX_NICCY is not set
# CONFIG_HISAX_ISURF is not set
# CONFIG_HISAX_HSTSAPHIR is not set
# CONFIG_HISAX_BKM_A4T is not set
# CONFIG_HISAX_SCT_QUADRO is not set
# CONFIG_HISAX_GAZEL is not set
CONFIG_HISAX_HFC_PCI=y
# CONFIG_HISAX_W6692 is not set
# CONFIG_HISAX_HFC_SX is not set
# CONFIG_HISAX_ENTERNOW_PCI is not set
CONFIG_HISAX_DEBUG=y


As you see I'm using more <m> than Ghandalf did in order that the HFC-PCI module could be set up correctly in /etc/modules.autoload.d/kernel-2.6, where I have
Code:

hisax id=hisax type=35 protocol=2
nvidia


and the last few lines of my lsmod contain:

Code:

hisax                 236740  2
isdn                  131008  3 hisax
slhc                    6400  1 isdn


btw Have you tried the Knoppix LiveCD? That uses <m> for almost anything that moves, and is very easy to set up in isdn-config.

As a sanity check :-)
regards
Back to top
View user's profile Send private message
Ben2040
Guru
Guru


Joined: 07 May 2003
Posts: 445
Location: UK

PostPosted: Sat Jun 26, 2004 1:33 pm    Post subject: Reply with quote

Hi

Yep, I tried Knoppix but that doesn't have the USB box in the list, bu like I said, it works plug n play in SuSE (All versions but don't know about the live CD).

I'll have a look at the modules after upgrading to 2.6.7.

Thanks

Ben
Back to top
View user's profile Send private message
drdebian
n00b
n00b


Joined: 07 Apr 2004
Posts: 49

PostPosted: Thu Sep 23, 2004 4:09 pm    Post subject: Reply with quote

This guide was great! I finally managed to get my ISDN card going in Gentoo. 8)

Now I'd like to try something more advanced: Only dial out when my T1 goes down... 8O

How can that be done? I read somewhere that I'd have to change route metrics, but couldn't find out how to achieve that using the Gentoo init-file (/etc/conf.d/net). Others say to use diald, but that seems rather old and unmaintained. :cry:

So, any ideas? :idea:
Back to top
View user's profile Send private message
sinanqapudan
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 208
Location: Milan

PostPosted: Thu Oct 28, 2004 8:47 am    Post subject: Reply with quote

Hi

at first I tried to set up my isdn connection using Backseat's guide, but I got the dreaded message:

Code:
bash-2.05b# Sorry - this system lacks PPP kernel support.
Check whether you configured at least the ippp0 device!


so I used ghandalf's method of using only /etc/ppp/isdn-setup and got my card working at last!

Still I'm not able to connect to the internet because the connection is terminated after some seconds. Using imon I can see that the systems starts calling, gets connected for a while (from 1 to 30 seconds) and then hangs up.

I tried then wille's solution for AlexKahl setting the value of lcp-restart to 20, but it didn't work.

Here are my configuration files:

/etc/ppp/isdn-setup:
Code:
#! /bin/bash

REMNAME=tele2internet
MYMSN=226xxxxx   # my number, without 0, with area code
REMMSN=7020221022   # number of ISP
MYUSER=tele2internet
MYIP=10.0.0.1

/sbin/isdnctrl verbose 3      # verbose messages
/sbin/isdnctrl system on      # ensure ISDN system is turned on
/sbin/isdnctrl addif ippp0      # add the interface
/sbin/isdnctrl eaz ippp0 $MYMSN   
/sbin/isdnctrl l2_prot ippp0 hdlc
/sbin/isdnctrl l3_prot ippp0 trans
/sbin/isdnctrl encap ippp0 syncppp   # we will use syncPPP
/sbin/isdnctrl dialmode ippp0 manual   # dial on demand
/sbin/isdnctrl addphone ippp0 out $REMMSN   # ISP's number
/sbin/isdnctrl huptimeout ippp0 120   # set timeout to 10 seconds
/sbin/isdnctrl dialmax ippp0 20      # set redial count to 20
/sbin/ipppd user $MYUSER remotename $REMNAME \
defaultroute \
name $MYUSER \
debug \
-detach   \
mru 1524 \
mtu 1500 \
lcp-restart 1 \
/dev/ippp0 &

/sbin/ifconfig ippp0 $MYIP pointopoint
/sbin/ifconfig ippp0 -arp -broadcast
/sbin/route add $MYIP ippp0
/sbin/route add default netmask 0 ippp0


/etc/ppp/options.ippp0:
Code:
# Example config for a personal ISP dialin
# see "man ipppd" for explanation of all possible options

# for the defaultroute setting, look in /etc/conf.d/net

/dev/ippp0

# you have to put login and password into /etc/ppp/pap-secrets too

#name "insert ppp login here"

lock
ipcp-accept-local
ipcp-accept-remote
noipdefault
usepeerdns
deldefaultroute
defaultroute
user "tele2internet"

# You might want to try these if you have problems:
#-vj
#-vjccomp
#-ac
#-pc
#-bsdcomp
#mru 1524
#mtu 1500
#noccp


If anyone could help me to solve this problem, it would be really really really really appreciated (and one more time really!!)!!

Also, how can I set the connection to use the ISP's DNS??

Thanks in advance.
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Thu Oct 28, 2004 9:51 am    Post subject: Reply with quote

Hei just noticed an isdn topic..

its a while since I went over to adsl now but I spent a lot of time with isdn as you can see above, so isdn still catches my eye ;-)

ref ghandalf april 29th, did you:

4. create the (pap- &) chap-secrets file

6. check /etc/resolv.conf and create /etc/ppp/resolv.conf

regards

ps what does your lsmod look like?
_________________
"I am not bound to please thee with my answers" W.S.
Back to top
View user's profile Send private message
sinanqapudan
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 208
Location: Milan

PostPosted: Thu Oct 28, 2004 10:04 am    Post subject: Reply with quote

Thanks a lot for your prompt reply!

Yes, I have made the chaps-secrets as shown by backseat

/etc/ppp/chap-secrets:
Code:
# Secrets for authentication using CHAP
# client    server  secret      IP addresses
USERNAME    *       PASSWORD


I also have copied the original /etc/resolv.conf into /etc/ppp/resolv.conf, so they both look like this:
Code:
domain homenetwork


This is the only istruction contained in the files.

Thanks again
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Thu Oct 28, 2004 10:40 am    Post subject: Reply with quote

Hei again

I'm on XP at the moment, about to backup my Gentoo disk, so I don't have access to resolv.conf. However I'm pretty sure mine also contained the isp's primary and secondary server addresses.. I'll check in a half hour or so.

regards

my info was entered by rp-pppoe not isdn, but I would think they required the same info..

# cat /etc/ppp/resolv.conf
# MADE-BY-RP-PPPOE
nameserver 148.122.208.99
nameserver 148.122.161.3
_________________
"I am not bound to please thee with my answers" W.S.
Back to top
View user's profile Send private message
sinanqapudan
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 208
Location: Milan

PostPosted: Thu Oct 28, 2004 7:46 pm    Post subject: YES! YES! YES! YES! YES! YES YES YES!!!! Reply with quote

Hi! I managed to connect to the internet!! Great satisfaction!!

Some details:

somehow (ask no questions, you will be told no lies) I found out that my ISP requires PAP authentication instead of CHAP. I duly copied /etc/chap-secrets over /etc/pap-secrets and afterwards I've been able to connect without the connection being terminated after some seconds, but still I couldn't receive any answer from ping.

I tried then to put the ISP's DNS addresses in the /etc/resolv.conf and /etc/ppp/resolv.conf files that now look like this:
Code:
#domain homenetwork
nameserver 130.244.127.161
nameserver 130.244.127.169

done the usual
Code:
bash-2.05b# isdnctrl dial ippp0

and tried to ping
Code:
bash-2.05b# ping 130.244.127.161

and got no answer!!
I tried to connect to www.gentoo.org and :o bingo!! :lol: The system was up!!
Evidently the wankers refuse ping!!

Thanks to everybody in this guide, very helpful!!
Special thanks to cintra, tak skal du ha!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 3 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum