Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
My "Blue & White G3" Installation + Yaboot tro
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Invisible Philosopher

Joined: 21 Jul 2005
Posts: 1
Location: my imagination and my computer

PostPosted: Sat Jul 23, 2005 5:19 pm    Post subject: My "Blue & White G3" Installation + Yaboot tro Reply with quote

Installing Gentoo on a Blue and White G3, without prior personal experience with GNU/Linux (though luckily my parents had some experience with it and helped at times). (It took several days due to my problems.) I attempted to follow the Gentoo PPC installation instructions, working from the 2005.0 minimal PPC LiveCD, doing a stage3 install. I found answers to a number of my problems by searching the forum, and I wanted to both help anyone else doing this without them having to do so much searching, and get my own installation finalized correctly. (I've bolded the questions that I still have to make them easier to find.)

My first problem: The disks in my computer were not found (I have a 60GB disk, which was empty before starting the installation, as well as the 6GB disk that my OSX is on and came with the machine). Not knowing much about Gentoo installation yet, I had used Mac OS X's Disk Utility to divide the 60GB disk into 3 equal partitions. But the problem, as I discovered, was a missing ability of the kernel running from the LiveCD. As some posts I found said, I needed to do `insmod path/to/cmd64x.ko' where cmd64x.ko is found in bug 87665. However now my problem was, how to reach that file while running from the CD? Clearly it was useless to put it on the very disks I couldn't reach. The LiveCD couldn't exactly download it directly because the CD is not modifiable. First I tried a simple attempt to put cmd64x.ko into the LiveCD contents onto another CD-R, but I guess there is more to it than that, which I didn't realize then when it simply wouldn't boot. The next thing I tried was to try connecting to another computer on the local network, but we couldn't figure out how to do that without the connection being refused. In any case as I found out trying the next thing, the LiveCD couldn't understand HFS+ filesystems without help, so that wouldn't have worked anyway. Finally I tried a portable(movable) USB disk. The LiveCD recognized it, but the best it could do was to mount it as HFS (and it was formatted as HFS+), so we had to repartition it to have a small plain HFS partition (after copying the backups residing on it to another computer temporarily). Then, on that other computer (though we realized afterwards it could just as well have been done on my OSX), cmd64x.ko was put onto that HFS partition (which was the first(mountable?) partition to make sure it was easy to mount that one). I discovered where it appeared in /dev by doing `ls /dev' before turning it on in one console (e.g. option-F1), the same thing after turning it on connected to my computer in option-F2, and then switching back and forth between the two displays until I saw the difference: it appeared as /dev/sda for me. So I did `mount -t hfs /dev/sda /home' (/home because it seemed like a safe thing to replace, and being a read-only filesystem (presumably), I couldn't make a new directory to attach it to), and then `insmod /home/cmd64x.ko'. Hooray, my disks appeared and I could continue with the installation instructions (though I had to mount and insmod every time I booted from the CD, which was quite a lot due to later problems).

I also discovered later, after deleting one OSX-created partition and filling in the space with Bootstrap, Swap and root partitions: I was having another problem, and something I found indicated that Bootstrap had to be partition #2, so I moved it to there with mac-fdisk and then used mkofboot, but it didn't solve the problem I was having at the time so I don't know what problems, if any, are caused by not putting that partition there.

Then I got mixed up about the date: it looked right, but I didn't notice the GMT after it, so when I set the time-zone it was a much more obviously wrong time; I didn't notice it then, so I will say more about that later....

The next major problem I faced was a kernel compile error (having manually configured the kernel by `make menuconfig'). I found out (through more forum searches) that I had to enable (I don't remember their exact names) `Device Drivers -> ATA/ATAPI/MFM/RLL support -> PCI IDE chipset support' and maybe `... -> PCI IDE chipset support -> Generic PCI bus-master DMA support' to get the kernel to compile. Later I enabled `... -> Generic PCI bus-master DMA support -> CMD64{3|6|8|9} chipset support' (and remade and copied the kernel) because I was having another problem and that seemed to be what the cmd64x.ko module I needed was about. It didn't solve the problem I was currently having at that time, so it's another thing that I don't know for sure whether it was needed.

Then I had a problem after it told me to `reboot'. From this point onward (until further notice in the story) I could only successfully boot by holding down command-option-o-f (all at the same time) upon startup, and entering at the prompt:
shut-down  #to shut down
boot hd:,\\:tbxi  #to boot OSX
boot cd:,\\yaboot  #to boot from the CD.
Upon booting my computer with no keys held down, it eventually came to a screen where the last line was `returning 0x01400000 from prom_init' and after a long delay rebooted again automatically (of course the same thing happened after that). The kernel option I turned on that allowed it to work was `Device Drivers -> Graphics Support -> Console display driver support -> Framebuffer Console support' option. That was only after finding something suggesting that on the forum, though: that option had no help available.

So next I got a kernel panic upon trying to boot the installed Gentoo. Great. Here are the last few lines it displayed:
VFS: Cannot open root device "hdd11" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)
 <0>Rebooting in 180 seconds.._
My searches were not so much help, but looking further up in the kernel output gave me enough of a hint. It appeared that:
  • the LiveCD considered my disks /dev/hdc(6GB, came with machine) and /dev/hdd(60GB added disk) (and itself /dev/hda)
  • booting from the Gentoo kernel I had compiled onto what appeared from the CD to be /dev/hdd, : the 6GB disk was called /dev/hda, the 60GB disk /dev/hdb, and the CD-ROM drive /dev/hde!
I tried to put OpenFirmware paths in /etc/yaboot.conf (`hd:' for the 6GB and `ultra1:' for the 60GB), but at least for boot= and root= they had to be ordinary paths: boot= had to be the path in the filesystem from which mkofboot/ybin is run, and root= be the path in the filesystem as seen by the kernel whose booting is being configured by yaboot! This is disturbing. For one thing, /etc/yaboot.conf cannot be correct both for booting from LiveCD and on-disk kernel, although it can be fixed at need since it is only accessed when running mkofboot or ybin (that is, I set root=/dev/hdb11 and, since I was on the LiveCD at the time, boot=/dev/hdd2). Also, I have no idea how the paths are determined so I don't know whether my solution, which seems enough like a hack already, might break at some unknown time. Could someone please help me find out whether there is a better solution, and (at least if not), whether/when my fears of it breaking might come to pass?

Also, although an ordinary boot goes to Gentoo now, having this in /etc/yaboot.conf:
(running ybin after changes, of course) does not seem to be having any effect; holding down Option at startup is ignored, and I still have to manually use OpenFirmware to boot OSX or a CD. Any ideas how to make this work better? Here is my complete yaboot.conf (though it says it was generated, I have modified it some -- and I have run "man yaboot.conf" for details (obviously? I hope so).):
## yaboot.conf generated by yabootconfig 1.0.8
## run: "man yaboot.conf" for details. Do not make changes until you have!!
## For a dual-boot menu, add one or more of:
## bsd=/dev/hdaX, macos=/dev/hdaY, macosx=/dev/hdaZ

# ofboot=ultra1:2
# ultra1? hdd? ??




BTW, thank you "ext2fsx", which allowed me to access that file (which is on an ext3 "Linux partition") from my working OSX system and copy its contents to here.

Now back to the date. I had gotten all the way in the installation instructions up to just before making a user for everyday use, but before I did anything more I wanted to fix the date, especially since, apparently, the system might do something wrong if the date is incorrect. I managed to set the hardware clock to UTC and get the GNU/Linux side of things working (rebooted and the time still appeared correctly), until I booted back into OSX, which I believe set the clock back to something based on a time retrieved from the Internet. Upon booting back into Gentoo, the time was back to the old problem time, a temporal distance off from the correct time equal to my offset from GMT. I figured maybe OSX really does store the time as local time (at least on my setup of OS X (which is 10.3.7)), despite what another post on the forum said, but I couldn't even get the time to stay correct across a reboot of Gentoo when I tried to use local time for the hardware clock. I didn't know if I was doing something wrong with /etc/adjtime; I tried what the post I referred to suggested in terms of resetting it. The question I was going to ask was: "How can I get the time to work correctly when running both OS's at various times (and what thing might an incorrect time cause to malfunction?)". But then I looked at the installation instructions again, looking for something else, and it looks like I missed (or have forgotten doing) a step involving /etc/conf.d/clock! Setting clock="local" in that file, and resetting /etc/adjtime to "0.0 0 0.0" made the time correct, in both systems!

Thank you for your attention -- I'm afraid I can be rather wordy when I get into telling a story.

Edit: Related to the forum, I don't like using "Invisible Philosopher" as my name here (I want to use my real name) -- is there a way for me to change it? Editing my profile, modifying it didn't seem to last. If so, how; if not, would I have to make another account, or is there a way I'm not thinking of?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum