Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unable to boot os x (solved)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message

Joined: 23 Sep 2004
Posts: 6

PostPosted: Tue Jul 26, 2005 3:26 pm    Post subject: unable to boot os x (solved) Reply with quote


i can't get os x to boot from yaboot. i have added the location of the partition into my /etc/yaboot.conf file, updated the bootstrap partition but still no luck

my yaboot.conf file is as follows:




i have quite a weird setup, split over 2 drives. i wanted gentoo on my external usb drive and os x on the internal ibook hard drive.

my bootstrap partition is /dev/hda2
my /boot partition is on /dev/hda3 (i know its not reccommended to have a seperate boot partition but i need one to load the kernel from)
my os x partition is /dev/hda4

i have swap on /dev/sda1 and my / partition is /dev/sda2

os x doesnt show up as an option to boot in yaboot. linux doesnt boot properly because of a missing init option but i can fix that later.

any advice?

Last edited by pyr0phr34k on Tue Jul 26, 2005 6:37 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 25 Nov 2004
Posts: 196
Location: Germany

PostPosted: Tue Jul 26, 2005 5:15 pm    Post subject: Reply with quote

here is my yaboot.conf:

## Change `unconfigured' to your bootstrap partition eg: /dev/hda2

## device is the OpenFirmware device path to the disk containing
## kernel images. if your disk is /dev/hda you can find the
## OpenFirmware path by running the command: ofpath /dev/hda DO NOT
## specify a partition number for this! On IBM hardware you can
## generally comment this out.


## partition is the partition number where the kernel images are
## located. The kernel images should be on your root filesystem, so
## this is usually the same partition number as your root filesystem.
## so if root = /dev/hda3 (the 3rd partition) then you should have
## partition=3 This *MUST* be set correct or yaboot won't boot! This
## option can be either set globally as shown here, or per image in
## the image= sections


## delay is the amount of time in seconds the dual boot menu (if one
## is configured, by the presense of macos, macosx, etc options here)
## will wait before choosing the default OS (GNU/Linux or the value of
## defaultos=). If you omit this then the value of timeout=
## (converted to seconds) will be used.

## timeout is the amount of time in tenths of a second that yaboot
## will wait before booting the default kernel image (the first image=
## section in this config file or the value of default=).


## Change the default colors, fgcolor is the text color, bgcolor is
## the screen background color. (default: fgcolor=white, bgcolor=black)

## Password supplied in plaintext, required for yaboot to boot, unless
## restricted is also present (see below). Be sure to
## chmod 600 /etc/yaboot.conf if you set this!


## Password supplied as an md5 hash, see above


## A password is only required to boot an image specified here if
## parameters are specified on the command line or if the user enters
## an image is not specified in the configuration file at all (ie.
## arbitrary file load). restricted can also be placed in an image
## section in that case any image not including the restricted keyword
## will be fully password protected.


## image is the kernel itself, commonly kept in / but also commonly
## found in /boot. Note that /boot should generally not be its own
## partition on powerpcs, its not necessary and complicates things.
## Make sure /boot is on the partition specified by partition= see
## above. /boot should never be an HFS filesystem. You may point
## image= to a symbolic link so long as the symlink does not cross
## partition boundries.

append="video=radeonfb:1024x768-32@60 quiet splash=silent,theme:KillBillTux-Yellow CONSOLE=/dev/tty1"


maybe this helps you ???
Back to top
View user's profile Send private message

Joined: 23 Sep 2004
Posts: 6

PostPosted: Tue Jul 26, 2005 6:01 pm    Post subject: Reply with quote

i fixed the problem. changed some bits of the yaboot.conf file and used mkofboot --boot /dev/hda2 --config /mnt/gentoo/etc/yaboot.conf and that fixed the problem.
just need to change the timeout and select os x as the default os.

one problem: the kernel cant find the root filesystem even though i told it that it was /dev/sda2. i think it has something to do with the drive not being recognised, probably because i didnt compile in usb support. i'll fix it later.

thank you Fugee47 for your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum