Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
imac 233mhz 64mb "out of memory killed process" [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1355

PostPosted: Mon Jan 16, 2006 6:29 pm    Post subject: imac 233mhz 64mb "out of memory killed process" [ Reply with quote

I have follwoed the ppc manual and am chrooted into my new environment, I just tryed to emerge --sync and It tries 3 times and ends with
Code:
Motd brought to you by motd-o-matic, version 0.3

reciving file list ...
oom-killer: gfp_mask=0xld2
DMA per-cpu:
cpu 0 hot: low 14, high 42, batch 7
cpu 0 cold: low 0, high 14, batch 7
Highmem per-cpu: empty

free pages: 1136kb (0kb highmem) active:9010  inactive:4153 dirty:0 writeback:0 unstable:0 free:284 Slab:1420 mapped:4920 pagetables:57

DMA free:1136kb min:1024kb low:1280kb high:1536kb active:36040kb present:65536kb pages_scanned:4981 all_unreadable? no

......... it continues with similar stuff unitl
Code:
 swap cashe: add 0, delete 0, find 0/0, free swap=0kb


FYI when I formated my hard drive it would not let me delete hda1 - hda3 seemed normal for mac, and i activated 512M of swap.
Is there a way to test swap?
Is there anything I need to add to make.conf considering it is a old machine with little memory, I have herd of people running gentoo on older boxes.
thanks for reading
any advice would be great


Last edited by turtles on Tue Jan 17, 2006 7:18 am; edited 1 time in total
Back to top
View user's profile Send private message
Catch-22
Apprentice
Apprentice


Joined: 22 Oct 2004
Posts: 244

PostPosted: Tue Jan 17, 2006 1:41 am    Post subject: Reply with quote

well the way to 'test' your swap would be to check the output of
Code:
free
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1355

PostPosted: Tue Jan 17, 2006 6:34 am    Post subject: exelent comand Reply with quote

output of
Code:
free
is
Code:
         Total       used        free      shared       buffers         cashed
mem           60968      51332      9636         0             924              41304
+/- buffers cashe          9104       51864       0           
swap                   0             0             0

Looks loke swap not working I try
Code:
swap on /dev/hda5

and I get command not found
if I try to mount /dev/hda5 it tells me it looks like swap.
and Links2 no longer works, problem seems to have started when I chrooted from live cd I
Code:
mount -t proc none /mnt/gentoo/proc
chroot /mnt/gentoo /bin/bash
env-update
export PS1=(chroot) $PS1

did i need to mount anything on the hd besides hda6 my root partition?
If I try to unmount /mnt/gentoo I get not found error?
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Jan 17, 2006 6:46 am    Post subject: Reply with quote

swapon is one word. :)
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1355

PostPosted: Tue Jan 17, 2006 7:17 am    Post subject: Reply with quote

:oops: as you can see from my posts I was not known for my grammer and spelling in school. Exiting chroot and swap on has me emerging --sync on the old imac. exiting chroot also allows links2 to work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum