Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
configure: error: invalid package name: etc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
RaZoR1394
Guru
Guru


Joined: 09 Jan 2005
Posts: 356

PostPosted: Sun Feb 19, 2006 1:08 pm    Post subject: configure: error: invalid package name: etc Reply with quote

I'm getting these two errors during configure of packages after upgrading parts of the system:

Code:

configure: error: expected an absolute directory name for --datadir:

Code:

configure: error: invalid package name:


Some examples:

Code:

>>> emerge (1 of 1) media-sound/alsa-driver-1.0.11_rc3 to /
>>> md5 files   ;-) alsa-driver-1.0.11_rc3.ebuild
>>> md5 files   ;-) alsa-driver-1.0.10-r2.ebuild
>>> md5 files   ;-) files/alsa-driver-1.0.10-gfp-flags.patch
>>> md5 files   ;-) files/alsa-driver-1.0.10-oops.patch
>>> md5 files   ;-) files/digest-alsa-driver-1.0.10-r2
>>> md5 files   ;-) files/digest-alsa-driver-1.0.11_rc3
>>> md5 files   ;-) files/alsa-driver-1.0.10_rc1-include.patch
>>> md5 src_uri ;-) alsa-driver-1.0.11rc3.tar.bz2
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     2.6.16-rc3-nitro1
 * Checking for suitable kernel configuration options:
>>> Unpacking source...
>>> Unpacking alsa-driver-1.0.11rc3.tar.bz2 to /var/tmp/portage/alsa-driver-1.0.11_rc3/work
 * Applying alsa-driver-1.0.10_rc1-include.patch ...                                                                                                                                                          [ ok ]
 * Converting alsa-driver-1.0.11rc3/Makefile to use M= instead of SUBDIRS= ...                                                                                                                                [ ok ]
>>> Source unpacked.
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --with-oss --without-debug --with-kernel=/usr/src/linux --with-build=/usr/src/linux --with-isapnp=yes --with-sequencer=yes --with-cards=emu10k1,intel8x0 --build=i686-pc-linux-gnu
configure: error: invalid package name:

!!! ERROR: media-sound/alsa-driver-1.0.11_rc3 failed.
!!! Function econf, Line 495, Exitcode 0
!!! econf failed


Code:
>>> emerge (1 of 5) sys-apps/file-4.16 to /
>>> md5 files   ;-) file-4.16.ebuild
>>> md5 files   ;-) file-4.13.ebuild
>>> md5 files   ;-) file-4.15-r1.ebuild
>>> md5 files   ;-) file-4.12.ebuild
>>> md5 files   ;-) files/file-4.xx-mips-gentoo.patch
>>> md5 files   ;-) files/digest-file-4.15-r1
>>> md5 files   ;-) files/file-4.13-ia64.patch
>>> md5 files   ;-) files/cracklib.magic
>>> md5 files   ;-) files/file-4.15-libtool.patch
>>> md5 files   ;-) files/file-4.15-empty-mime-buffer.patch
>>> md5 files   ;-) files/misc.magic
>>> md5 files   ;-) files/file-4.16-fix-array-64bit.patch
>>> md5 files   ;-) files/file-4.14-gcc2.patch
>>> md5 files   ;-) files/file-4.15-cracklib-magic.patch
>>> md5 files   ;-) files/digest-file-4.12
>>> md5 files   ;-) files/digest-file-4.13
>>> md5 files   ;-) files/digest-file-4.16
>>> md5 files   ;-) files/file-4.13-cross-compile.patch
>>> md5 src_uri ;-) file-4.16.tar.gz
>>> Unpacking source...
>>> Unpacking file-4.16.tar.gz to /var/tmp/portage/file-4.16/work
 * Applying file-4.16-fix-array-64bit.patch ...                                                                                                                                                               [ ok ]
 * Applying file-4.15-empty-mime-buffer.patch ...                                                                                                                                                             [ ok ]
 * Applying file-4.15-libtool.patch ...                                                                                                                                                                       [ ok ]
 * Running elibtoolize in: file-4.16
 *   Applying portage-1.5.10.patch ...
 *   Applying max_cmd_len-1.5.14.patch ...
 *   Applying sed-1.5.6.patch ...
 *   Applying uclibc-ltconf-1.3.0.patch ...
>>> Source unpacked.
 * econf: updating file-4.16/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating file-4.16/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --datadir=/usr/share/misc --build=i686-pc-linux-gnu
configure: error: expected an absolute directory name for --datadir:

!!! ERROR: sys-apps/file-4.16 failed.
!!! Function econf, Line 495, Exitcode 0
!!! econf failed


Code:

emerge --infoPortage 2.0.54 (default-linux/x86/2005.0, gcc-3.4.5, glibc-2.3.6-r3, 2.6.16-rc3-nitro1 i686)
=================================================================
System uname: 2.6.16-rc3-nitro1 i686 Intel(R) Pentium(R) 4 CPU 2.66GHz
Gentoo Base System version 1.12.0_pre16
ccache version 2.4 [enabled]
dev-lang/python:     2.3.5, 2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -ffast-math -pipe -fomit-frame-pointer -mfpmath=sse,387 -msse2 -mmmx"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -ffast-math -pipe -fomit-frame-pointer -mfpmath=sse,387 -msse2 -mmmx"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://ftp.du.se/pub/os/gentoo http://ds.thn.htu.se/  http://mirror.pudas.net/gentoo/"
LANG="sv_SE.UTF-8"
LC_ALL="sv_SE.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://192.168.0.6/gentoo-portage"
USE="x86 X a52 aac aalib acpi alsa apache2 apm audiofile avi berkdb bitmap-fonts bluetooth bzip2 cddb cdr crypt curl disablexmb divx4linux dts dv dvd dvdr eds emboss encode esd expat f77 faad fam ffmpeg flac foomaticdb fortran gif glut gpm gstreamer gtk gtk2 hal i8x0 idn ieee1394 imlib java javascript joystick jpeg lcms libg++ libwww lirc lm_sensors mad matroska mhash mikmod mmx mng motif mp3 mpeg mysql mythtv ncurses nls nptl ogg oggvorbis opengl oss pam pcre pdflib perl png python qt quicktime readline real samba sdl spell sse sse2 ssl svga tcltk tcpd tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales vcd visualization vorbis win32codecs wxwindows xine xml2 xmms xv xvid xvmc zlib ~x86 userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LINGUAS


These errors started appearing after the system update reloaded Portage. I've already downgraded Portage with two versions so I don't know what else this could be... Any suggestions?
_________________
http://en.wikipedia.org/wiki/Cell_(microprocessor)
Back to top
View user's profile Send private message
Konsti
l33t
l33t


Joined: 10 Dec 2002
Posts: 691

PostPosted: Sun Feb 19, 2006 1:36 pm    Post subject: Reply with quote

Don't you get seg faults also? May be my ulimit setting is different so I get them.
Looks like https://forums.gentoo.org/viewtopic-p-3123028.html#3123028
Back to top
View user's profile Send private message
RaZoR1394
Guru
Guru


Joined: 09 Jan 2005
Posts: 356

PostPosted: Sun Feb 19, 2006 1:59 pm    Post subject: Reply with quote

Yeah it looked similar but I wasn't so shure about it. Now this thread emerged which seems to regard the same problem so any mod can close and throw this thread as they feel like it.
_________________
http://en.wikipedia.org/wiki/Cell_(microprocessor)
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4927
Location: Gothenburg, Sweden

PostPosted: Sun Feb 19, 2006 2:20 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of https://forums.gentoo.org/viewtopic-t-435291.html
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum