Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Install freenx
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 16, 17, 18 ... 28, 29, 30  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
dgdwinte
n00b
n00b


Joined: 18 Nov 2005
Posts: 18

PostPosted: Thu Feb 02, 2006 5:42 pm    Post subject: Starting from the commandline without dialog_box appearing Reply with quote

Sorry if this is a little bit off-topic, but I'm wondering if it is possible to start the nxclient directly if you provide a configuration-file. What I want is just typing:
./nxclient --config /path_to_config_file without the dialog-box appearing in order to be able to use nxclient in scripts to test different parameters.

Any ideas / suggestions?

Thx :-)

Davy.
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 549
Location: uk

PostPosted: Fri Feb 10, 2006 1:49 pm    Post subject: Reply with quote

I couldn't get the 0.4.5 ebuild to unpack, so I'm using the 0.4.4 overlay. Seems to work, but I don't appear to be able to resume sessions and when I use the command line nxserver options, I just get the following output

sempron2600 ~ # nxserver --list
HELLO NXSERVER - Version 1.4.0-44 OS (GPL)
NX> 105

any further input yields

quit
Quit
NX> 999 Bye

Any ideas?

Barrie
Back to top
View user's profile Send private message
thomasvk
Guru
Guru


Joined: 19 Mar 2005
Posts: 597

PostPosted: Tue Feb 14, 2006 3:44 pm    Post subject: Reply with quote

I don't want to hijack any topic here, but how can I install freenx with modular X? It seems freenx depends on nx-x11 which in turn depends on virtual/x11-6.8 and in turn x11-base/xorg-x11-6.8.2-r6.
Back to top
View user's profile Send private message
tagwar
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2004
Posts: 147
Location: Karlsruhe

PostPosted: Tue Feb 14, 2006 4:02 pm    Post subject: Reply with quote

t0maz wrote:
I don't want to hijack any topic here, but how can I install freenx with modular X? It seems freenx depends on nx-x11 which in turn depends on virtual/x11-6.8 and in turn x11-base/xorg-x11-6.8.2-r6.


Take a look at the Unsupported Software forum, you can find an overlay for freenx-0.5.0-r3 there, which depends on modular X.

Greets Tom
Back to top
View user's profile Send private message
Hibbelharry
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2003
Posts: 88
Location: Bremen, Northern Germany

PostPosted: Tue Feb 14, 2006 11:54 pm    Post subject: Reply with quote

Hi People,
i've got freenx-0.45-r3 up and running and i saw there is a patch added which should support session resuming after changing os between windows/linux. This still fails for me. Does this work for anyone ? do i need more patches ? would be really really great if this works sometime...

Greetz
Hibbelharry
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 549
Location: uk

PostPosted: Wed Feb 15, 2006 12:28 pm    Post subject: Reply with quote

Quote:
sempron2600 ~ # nxserver --list
HELLO NXSERVER - Version 1.4.0-44 OS (GPL)
NX> 105


Solved! I had enabled usermode authentication in node.conf, disabled works fine. :oops:

Barrie
Back to top
View user's profile Send private message
odborg
Tux's lil' helper
Tux's lil' helper


Joined: 12 Apr 2002
Posts: 89
Location: Aalborg, Denmark

PostPosted: Sat Feb 18, 2006 7:10 am    Post subject: Reply with quote

When I try to connect i get the following error on the client (0.4.5 ebuild from bugs.gentoo.org):
Code:
NX> 203 NXSSH running with pid: 13299
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: 192.168.200.1 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.4.0-45-SVN OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: odborg
NX> 102 Password:
NX> 103 Welcome to: gatekeeper user: odborg
NX> 105 listsession --user="odborg" --status="suspended,running" --geometry="1600x1200x24+render" --type="unix-kde"
NX> 127 Sessions list of user 'odborg' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: odborg
NX> 105 startsession --session="blabla.com" --type="unix-kde" --cache="8M" --images="32M" --cookie="******" --link="adsl" --kbtype="pc102/dk" --nodelay="1" --encryption="1" --backingstore="when_requested" --geometry="1600x1142" --media="0" --agent_server="" --agent_user="" agent_password="******""  --screeninfo="1600x1142x24+render"

NX> 1000 NXNODE - Version 1.4.0-45-SVN OS (GPL)
NX> 700 Session id: gatekeeper-1017-8B5C40F1E7EFECE1DA16D2C6F8F68B52
NX> 705 Session display: 1017
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: 1e48ca525da8b6ceb453cf933279c5cc
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: 1e48ca525da8b6ceb453cf933279c5cc
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
NX> 710 Session status: running
NX> 1002 Commit
NX> 105 /usr/NX/bin/nxserver: line 880: 25497 Terminated              ( sleep $AGENT_STARTUP_TIMEOUT; exit 1 )
NX> 1006 Session status: running
NX> 504 Session startup failed.
NX> 1004 Error: nxagent failed to start with: NXAGENT: Fatal IO error on display "nx/nx,options=/home/odborg/.nx/C-gatekeeper-1017-8B5C40F1E7EFECE1DA16D2C6F8F68B52/options:1017".
NX> 1001 Bye.
Killed by signal 15.

And the following from the server log (NX_LOG_LEVEL=7)(0.4.5 ebuild from bugs.gentoo.org):
Code:
-- NX SERVER START: -c /usr/NX/bin/nxserver
HELLO NXSERVER - Version 1.4.0-45-SVN OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: odborg
NX> 102 Password:
Info: Auth method: passdb ssh
NX> 103 Welcome to: gatekeeper user: odborg
NX> 105 listsession --user="odborg" --status="suspended,running" --geometry="1600x1200x24+render" --type="unix-kde"
NX> 127 Sessions list of user 'odborg' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: odborg
NX> 105 startsession --session="blabla.com" --type="unix-kde" --cache="8M" --images="32M" --cookie="******" --link="adsl" --kbtype="pc102/dk" --nodelay="1" --encryption="1" --backingstore="when_requested" --geometry="1600x1142" --media="0" --agent_server="" --agent_user="" agent_password="******""  --screeninfo="1600x1142x24+render"

&session=blabla.com&type=unix-kde&cache=8M&images=32M&cookie=******&link=adsl&kbtype=pc102/dk&nodelay=1&encryption=1&backingstore=when_requested&geometry=1600x1142&media=0&agent_server=&agent_user=&agent_password=******&screeninfo=1600x1142x24+render&clientproto=1.5.0&user=odborg&userip=192.168.200.200&uniqueid=36FEFB653EE05CD5D981EE16CC1F8082&display=1017
Password:
NX> 1000 NXNODE - Version 1.4.0-45-SVN OS (GPL)
NX> 700 Session id: gatekeeper-1017-36FEFB653EE05CD5D981EE16CC1F8082
NX> 705 Session display: 1017
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: 1d72628d4b78e98b6777647e406bbc10
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: 1d72628d4b78e98b6777647e406bbc10
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
NX> 105 NX> 710 Session status: running
NX> 1002 Commit
NX> 1006 Session status: running
NX> 1004 Error: nxagent failed to start with: NXAGENT: Fatal IO error on display "nx/nx,options=/home/odborg/.nx/C-gatekeeper-1017-36FEFB653EE05CD5D981EE16CC1F8082/options:1017".
NX> 1001 Bye.
NX> 504 Session startup failed.


Here's my auth.log for 1 connection:
Code:
Feb 18 08:07:33 gatekeeper sshd[26609]: Accepted publickey for nx from 192.168.200.200 port 52662 ssh2
Feb 18 08:07:33 gatekeeper sshd(pam_unix)[26614]: session opened for user nx by (uid=0)
Feb 18 08:07:34 gatekeeper sshd[26649]: Accepted keyboard-interactive/pam for odborg from 127.0.0.1 port 46112 ssh2
Feb 18 08:07:34 gatekeeper sshd(pam_unix)[26655]: session opened for user odborg by (uid=0)
Feb 18 08:07:34 gatekeeper sshd(pam_unix)[26655]: session closed for user odborg
Feb 18 08:07:38 gatekeeper sshd[26785]: Accepted keyboard-interactive/pam for odborg from 127.0.0.1 port 46114 ssh2
Feb 18 08:07:38 gatekeeper sshd(pam_unix)[26791]: session opened for user odborg by (uid=0)
Feb 18 08:07:39 gatekeeper sshd(pam_unix)[26791]: session closed for user odborg
Feb 18 08:07:39 gatekeeper sshd(pam_unix)[26614]: session closed for user nx


so authorization seems ok. any ideas whats wrong?
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Mon Feb 20, 2006 4:16 pm    Post subject: Reply with quote

So, now that I have my NX server up and running with client access from both my gentoo laptop and my work-site Windows XP pc, I want to do some file cleanup on the NX server (if possible).

I note the following instances of authorized_keys2:
Code:
locate authorized_keys2
/usr/NX/home/nx/.ssh/authorized_keys2
/home/cg/.ssh/authorized_keys2
/home/cg/.ssh2/authorized_keys2


Why would I have both a ~/.ssh/ as well as a ~/.ssh2/ directory?

Are both necessary for either NX or OpenSSH?

Should I be able to safely delete one of these directories without mucking up either NX or ssh? If so, which one?

Thanks...
_________________
"Primum non nocere" ---Galen
Back to top
View user's profile Send private message
LosD
n00b
n00b


Joined: 12 Jun 2002
Posts: 61
Location: Taastrup, Denmark

PostPosted: Mon Feb 20, 2006 8:45 pm    Post subject: Reply with quote

I have a strange problem with my server (0.4.5 with 1.5.0 backend) and the 1.5.0 windows client...

Everything works perfectly, except terminating/resuming a session... I HAVE to end my GNOME session, I can't just click the close icon, with 0.4.0 a new window popped up (Inside the X session), asking me if I wanted to Resume or Terminate the session...

And yeah, it's definately much better to end the GNOME session properly (Which, by the way, didn't work before, that wouldn't stop the NX session), but I wanted to experiment with Suspend/Resume, and that is pretty damn hard if you don't get the option... :D

Am I just an idiot, and the whole interface for terminating/resuming changed for 0.4.5/1.5.0 without me being able to find out how?
I was wondering if maybe the application window that normally pops up is broken, if it's a normal X app, then I could try firing it manually, and see what the problem is... Anyone know the name of it?

Thx in advance
Dennis
Back to top
View user's profile Send private message
Joebel
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jun 2003
Posts: 119
Location: Netherlands

PostPosted: Fri Feb 24, 2006 8:07 am    Post subject: Reply with quote

Hello,

I have freenx running (0.4.0) and it's working fine. However, I'm not succeeding in using e17 as a WM in an NX session :oops:.

I know, e17 is alpha etc etc., but I enjoy working with it a lot. I seem to be able to start fluxbox en xfce4 without any problems (very fast actually), but when i try to use e17, I just get a black screen in my client with a bare X mousepointer. Doesn't matter whether I use a Windows client or a linux client. Even when I wait for 15 minutes: no budge, still that black screen.

I can't find anything in logging that seems even remotely connected to this issue.

As a command in the client I already tried:
- /usr/bin/enlightenment-0.17
- /etc/X11/Sessions/e17
- exec /usr/bin/enlightenment-0.17

So:
- Anyone have e recent compilation of e17 wokring with freenx?
- anyone have a suggestion for me to try?
Back to top
View user's profile Send private message
thomasvk
Guru
Guru


Joined: 19 Mar 2005
Posts: 597

PostPosted: Fri Feb 24, 2006 8:53 am    Post subject: Reply with quote

You try looking at ~/.xsession-errors

Also, you can try to put the command you think is working in a script file and redirect all ouput to a file to see what is going on:
Code:
/usr/bin/enlightenment-0.17 &> ~/enlightenment-0.17.log


Perhaps it gives you more information.
Back to top
View user's profile Send private message
Joebel
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jun 2003
Posts: 119
Location: Netherlands

PostPosted: Wed Mar 01, 2006 6:27 am    Post subject: Reply with quote

Actually Tomaz,

Starting up with a script like that made e17 work. Just putting the output in a log file sped thinsg up considerably.

Not sure if it makes sense, but I'm happy!

thanx, man
Back to top
View user's profile Send private message
cgmd
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1585
Location: Louisiana

PostPosted: Fri Mar 03, 2006 4:14 am    Post subject: Reply with quote

After updating my laptop NXClient to version 1.5.0, I have lost connectivity with my gentoo box. The connection stalls during:
Code:
Initializing X protocol compression
...and then the connection times out. The detail report shows:
Code:
NXPROXY - Version 1.5.0

Copyright (C) 2001, 2005 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '9345'.
Warning: Connected to remote NXPROXY version 1.4.0 with local version
1.5.0.
Info: Synchronizing local and remote caches.
Info: Handshaking with remote proxy completed.
Info: Remote proxy doesn't support fake authentication.
Info: Forwarding the real X authorization cookie.
Info: Using cache parameters 4/262144/8192KB/8192KB.
Info: Using image cache parameters 1/1/32768KB.
Info: Using adsl link parameters 8192/8/1/5.
Info: Using pack method '16m-jpeg-7' with session 'unix-kde'.
Info: Using ZLIB data compression level 3.
Info: Using ZLIB data threshold set to 32.
Info: Using ZLIB stream compression level 6.
Info: Using remote ZLIB data compression level 3.
Info: Using remote ZLIB stream compression level 6.
Info: Using cache file
'/home/cgmd/.nx/cache-unix-kde/S-159310002TAFACAC260B541965EB281'.
Info: Starting X protocol compression.
Warning: X connection failed with error 'Invalid MIT-MAGIC-COOKIE-1
key'.
Info: End of session requested by signal '15' 'SIGTERM'.
Info: Waiting for cleanup timeout to complete.
Info: Shutting down the link and exiting.
Warning: Parent process appears to be dead. Exiting keeper.
Warning: Parent process appears to be dead. Exiting watchdog.


My currently installed components on the gentoo box are:
nxserver-freenx-0.4.4
nxssh-1.4.0-r1
nxproxy-1.4.0-r2
nx-x11-1.4.0-r4 (newer version (1.5.0-r3) available, but would not emerge)
nxclient-1.4.0-r5

Im not sure if this is a problem with the laptop nxclient (because that client is able connect to a kubuntu nxserver),
or a problem with the gentoo nxserver (because I am able to connect to the gentoo nxserver from a windows nxclient machine. :?

Both the gentoo laptop and the kubuntu box fail to connect to the gentoo nxserver with:
Quote:
failed with error 'Invalid MIT-MAGIC-COOKIE-1 key'.


I'm now thinking that this is version incompatibility of nxproxy:
Quote:
Warning: Connected to remote NXPROXY version 1.4.0 with local version
1.5.0.


When I switch back to version 1.4.0 on local, the "Invalid MIT-MAGIC-COOKIE-1" error disappears!

Does anyone have any thoughts on this??

Thanks!
_________________
"Primum non nocere" ---Galen


Last edited by cgmd on Sun Mar 05, 2006 7:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
undofen
n00b
n00b


Joined: 13 Jan 2005
Posts: 16

PostPosted: Sat Mar 04, 2006 12:58 am    Post subject: Reply with quote

Is there a possibility to connect to the already running (:0) X server just line in VNC ? Been looking for the answer for the last hour with no results...
Back to top
View user's profile Send private message
codejnki
n00b
n00b


Joined: 08 Aug 2002
Posts: 36

PostPosted: Wed Mar 08, 2006 2:59 am    Post subject: Floating windows work, full session doesn't Reply with quote

I have got a strange problem and I'm not exactly sure where to begin.

I've got the freeNX 0.50 server up and running on my box.

I am connecting from a WinXp box to my Gentoo box.

If I tell the client I want a new GNOME session it fails on me.

If I set the client to do a floating window with an xterm the terminal window opens fine and I am able run programs just fine.

Any suggestions on where I should begin to look?

Thanks.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Wed Mar 08, 2006 3:25 pm    Post subject: Reply with quote

Did you install version 0.5.0 from portage? If so, that uses an old version of 0.5.0. It's technically in pre-release right now. There are newer releases with a lot of fixes. You can get the new pr-release of 0.5.0 from here:
http://svn.gnqs.org/svn/gentoo-nx-overlay/testing/
There are also new 1.5.0 ebuilds there as well. They are still in testing phase, so if there are any issues, let me know and I will try to correct them straight away. The new nx-x11 ebuild should really use a lot of testing since esd stuff is in the ebuild now to be compiled. It compiled for me, but another person said that it didn't compile for him. :S So, I need to hunt down why that is so. If you do run into problems, try to give me as much info as you can and the exact error message, so I can hunt down the problem.

So, maybe the new 0.5.0 ebuild will solve your problems? Hopefully! Oh, I am in the gentoo-nx channel on freenode if you need to talk live. :)

Cheers.

EDIT:
I forgot to say, if you have trouble compiling nx-x11 with esd, then give me the exact error message, but then go ahead and put:
Quote:
net-misc/nx-x11 -esd
in /etc/portage/package.use if you want it installed right away. :)
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
codejnki
n00b
n00b


Joined: 08 Aug 2002
Posts: 36

PostPosted: Wed Mar 08, 2006 5:00 pm    Post subject: Reply with quote

StifflerStealth wrote:

Did you install version 0.5.0 from portage? If so, that uses an old version of 0.5.0. It's technically in pre-release right now. There are newer releases with a lot of fixes. You can get the new pr-release of 0.5.0 from here:
http://svn.gnqs.org/svn/gentoo-nx-overlay/testing/
There are also new 1.5.0 ebuilds there as well. They are still in testing phase, so if there are any issues, let me know and I will try to correct them straight away. The new nx-x11 ebuild should really use a lot of testing since esd stuff is in the ebuild now to be compiled. It compiled for me, but another person said that it didn't compile for him. :S So, I need to hunt down why that is so. If you do run into problems, try to give me as much info as you can and the exact error message, so I can hunt down the problem.


Yes I installed from portage. I keyworded ~x86 for those packages in my /etc/portage/package.keywords file.

:oops: Not to sound completely igonorant but how would I go about using these overlays? A link to instrucations would be great.

Thanks.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Wed Mar 08, 2006 9:52 pm    Post subject: Reply with quote

Instructions are currently being written. :oops: This overlay is brand new and is being worked on. :) Your question is completely valid, so don't be embarrassed. 8)

Steps to using this overlay:
1) Make a directory for the overlay. The most popular way to add extra overlays is to put them in the /usr/local/overlays directory, so for this example I wil use: /usr/local/overlays/nx

2) Edit your make.conf file and add this directoy to your overlay line:
PORTDIR_OVERLAY="/usr/local/portage /usr/local/overlays/nx"
You can have as many overlays as you want to have to keep things separate. I have 4 overlays. :P This is for reference.

3) cd to the new overlay directory, here it's:
cd /usr/local/overlays/nx

4) Type:
svn co http://svn.gnqs.org/svn/gentoo-nx-overlay/testing/net-misc
now you can emerge any file you want to. :)

5) To update your overlay, cd to it and type:
svn up

That's it. :) If you have any problems, let me know. I am usually around when I am not at work.

Cheers
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
codejnki
n00b
n00b


Joined: 08 Aug 2002
Posts: 36

PostPosted: Wed Mar 08, 2006 11:28 pm    Post subject: Reply with quote

StifflerStealth wrote:

Instructions are currently being written. :oops: This overlay is brand new and is being worked on. :) Your question is completely valid, so don't be embarrassed. 8)

*snip*

That's it. :) If you have any problems, let me know. I am usually around when I am not at work.

Cheers


That worked :) I'm posting this from a full screen session from my WinXP box to my Gentoo box.

Thanks for your help.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Wed Mar 08, 2006 11:50 pm    Post subject: Reply with quote

No problem. :) What FreeNX version are you using? Just out of curiosity. And I am glad the ebuilds worked for you. :) That means I didn't make an error so far. :P

EDIT: Snapshot 5 ebuild has been uploaded to the overlay. :) Have fun.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
codejnki
n00b
n00b


Joined: 08 Aug 2002
Posts: 36

PostPosted: Thu Mar 09, 2006 12:04 pm    Post subject: Reply with quote

StifflerStealth wrote:
No problem. :) What FreeNX version are you using? Just out of curiosity. And I am glad the ebuilds worked for you. :) That means I didn't make an error so far. :P

EDIT: Snapshot 5 ebuild has been uploaded to the overlay. :) Have fun.


I'm running freenx-0.5.0.20060307-r4.

I'll update tonight after I get back home from work.

I want to test it from there before I have a chance to break it again.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Thu Mar 09, 2006 12:12 pm    Post subject: Reply with quote

Sweet. :D Thanks for the info and thank you for testing this out. :)
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
codejnki
n00b
n00b


Joined: 08 Aug 2002
Posts: 36

PostPosted: Thu Mar 09, 2006 1:04 pm    Post subject: Reply with quote

Right now I'm using the Nomachine key and would like to change that. Should I follow the instructions off of the Gentoo Wiki?

http://gentoo-wiki.com/HOWTO_FreeNX_Server
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Thu Mar 09, 2006 3:21 pm    Post subject: Reply with quote

Those instructions look good. :)
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
GrimSage
n00b
n00b


Joined: 13 Sep 2004
Posts: 42

PostPosted: Fri Mar 10, 2006 11:43 am    Post subject: Reply with quote

I can not connect. I get connection timeout while negotitaing link
Code:

NXPROXY - Version 1.5.0

Copyright (C) 2001, 2005 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '3300'.
Info: Connecting to remote host '192.168.1.96:5000'.
Info: Connection to remote proxy '192.168.1.96:5000' established.
Info: Synchronizing local and remote caches.
Info: Handshaking with remote proxy completed.
Info: Not using NX delta compression.
Info: Using lan link parameters 16384/8/0/0.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde'.
Info: Not using ZLIB stream compression.
Info: Not using remote ZLIB stream compression.
Info: Not using persistent cache.
Info: Using remote server '192.168.1.96:5000'.
Info: Starting X protocol compression.
Info: End of session requested by signal '15' 'SIGTERM'.


when I try to connect again it tries to resume the session and this is what I get
Code:

NX> 203 NXSSH running with pid: 3340
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: 192.168.1.96 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.5.0-50-SVN OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: methos
NX> 102 Password:
NX> 103 Welcome to: localhost user: methos
NX> 105 listsession --user="methos" --status="suspended,running" --geometry="1600x1200x32+render" --type="unix-kde"
NX> 127 Sessions list of user 'methos' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------
1000    unix-kde         363646031EFA655A4ED7D37669224DB9 -RD--PSA    32 1024x768       Running     Methos


NX> 148 Server capacity: not reached for user: methos
NX> 105 restoresession --id="363646031EFA655A4ED7D37669224DB9"  --resize="1" --session="Methos" --type="unix-kde" --cache="8M" --images="32M" --link="lan" --kbtype="pc102/en_US" --nodelay="1" --encryption="1" --backingstore="when_requested" --geometry="1024x768" --media="0" --agent_server="" --agent_user="" agent_password="******""

NX> 1000 NXNODE - Version 1.5.0-50-SVN OS (GPL)
NX> NXNODE - Detected Xorg-X11 Version 7.0 or newer.
NX> NXNODE - Exporting XKEYSYMDB for enabling keyboard.
NX> 700 Session id: localhost-1000-363646031EFA655A4ED7D37669224DB9
NX> 705 Session display: 1000
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: 35c68012b9ba8b1032896818b1554c78
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: 35c68012b9ba8b1032896818b1554c78
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
Killed by signal 15.

any Idea's?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 16, 17, 18 ... 28, 29, 30  Next
Page 17 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum