Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
strange revdep-rebuild messages after gcc upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
dentament
n00b
n00b


Joined: 16 Jun 2004
Posts: 74

PostPosted: Tue Sep 05, 2006 12:56 pm    Post subject: strange revdep-rebuild messages after gcc upgrade Reply with quote

What could this be?

Code:

Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
  broken /usr/lib/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/ac3pass.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/ac3pass.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/ac3pass.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/audiodec.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/audiodec.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/audiodec.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/audiodec.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/audiodec.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/divx4.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/divx4.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/divx4.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/divx4.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/divx4.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/ffmpeg.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/ffmpeg.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/ffmpeg.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/ffmpeg.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/ffmpeg.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mad_audiodec.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/mad_audiodec.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/mad_audiodec.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mad_audiodec.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mad_audiodec.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mp3lamebin_audioenc.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/mp3lamebin_audioenc.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/mp3lamebin_audioenc.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mp3lamebin_audioenc.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mp3lamebin_audioenc.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mpeg_audiodec.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/mpeg_audiodec.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/mpeg_audiodec.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mpeg_audiodec.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/mpeg_audiodec.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/osmjpeg.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/osmjpeg.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/osmjpeg.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/osmjpeg.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/osmjpeg.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/vorbis_audio.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/vorbis_audio.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/vorbis_audio.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/vorbis_audio.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/vorbis_audio.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/win32.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/win32.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/win32.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/win32.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/win32.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/xvid4.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/avifile-0.7/xvid4.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/avifile-0.7/xvid4.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/xvid4.la (requires /-lstdc++)
  broken /usr/lib/avifile-0.7/xvid4.la (requires /-lstdc++)
  broken /usr/lib/bonobo/libnautilus-printers-view.la (requires /usr/lib/libnautilus-private.la)
  broken /usr/lib/bonobo/libnautilus-printers-view.la (requires /usr/lib/libnautilus.la)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/art.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/avi.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/avs.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/bmp.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/caption.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/cin.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/cip.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/clip.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/cmyk.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/cut.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dcm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dib.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dot.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dps.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dpx.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ept.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/fax.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/fits.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/gif.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/gradient.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/gray.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/histogram.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/html.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/icon.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/jpeg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/label.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/magick.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/map.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mat.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/matte.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/meta.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/miff.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mono.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mpc.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mpeg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mpr.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/msl.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mtv.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mvg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/null.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/otb.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/palm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pattern.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pcd.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pcl.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pcx.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pdb.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pdf.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pict.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pix.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/plasma.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/png.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pnm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/preview.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ps2.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ps3.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/psd.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ps.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pwp.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/raw.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/rgb.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/rla.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/rle.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/scr.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/sct.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/sfw.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/sgi.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/stegano.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/sun.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/svg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/tga.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/tiff.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/tile.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/tim.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ttf.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/txt.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/uil.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/url.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/uyvy.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/vicar.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/vid.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/viff.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/wbmp.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/wmf.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/wpg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xbm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xcf.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xc.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/x.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xpm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xwd.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ycbcr.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/yuv.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/filters/analyze.la (requires /-lstdc++)
  broken /usr/lib/libaviplay.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/libaviplay.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/libaviplay.la (requires /-lstdc++)
  broken /usr/lib/libaviplay.la (requires /-lstdc++)
  broken /usr/lib/libaviplay.la (requires /-lstdc++)
  broken /usr/lib/libqavm.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/libqavm.la (requires /usr/lib/libaviplayavcodec.la)
  broken /usr/lib/libqavm.la (requires /-lstdc++)
  broken /usr/lib/libqavm.la (requires /-lstdc++)
  broken /usr/lib/libqavm.la (requires /-lstdc++)
  broken /usr/lib/transcode/export_af6.la (requires /usr/lib/libaviplayavformat.la)
  broken /usr/lib/transcode/export_af6.la (requires /usr/lib/libaviplayavcodec.la)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

Dynamic linking on your system is consistent... All done.
Back to top
View user's profile Send private message
hanj
Veteran
Veteran


Joined: 19 Aug 2003
Posts: 1410

PostPosted: Wed Sep 06, 2006 1:19 pm    Post subject: Reply with quote

Hello

I have the same problem.
Code:
Configuring search environment for revdep-rebuild
         
Checking reverse dependencies...
         
Packages containing binaries and libraries broken by a package update
will be emerged.
         
Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)
         
Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)
         
Checking dynamic linking consistency...
  broken /usr/bin/cactid (requires  libmysqlclient.so.12)
  broken /usr/kde/3.3/lib/kde3/cupsdconf.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/cupsdconf.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/dcopserver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/dcopserver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabc_dir.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabc_dir.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabc_file.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabc_file.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabc_ldapkio.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabc_ldapkio.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabc_net.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabc_net.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabcformat_binary.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kabcformat_binary.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kaddprinterwizard.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kaddprinterwizard.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kbuildsycoca.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kbuildsycoca.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kbzip2filter.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kbzip2filter.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kcm_kresources.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kcm_kresources.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kconf_update.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kconf_update.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kcookiejar.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kcookiejar.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kcookiejar.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kcookiejar.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kdeprintd.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kdeprintd.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kdetrayproxy.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kdetrayproxy.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kpasswdserver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kpasswdserver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kssld.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kssld.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kwalletd.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_kwalletd.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_proxyscout.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kded_proxyscout.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_cups.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_cups.la (requires /usr/kde/3.3/lib/libkdefakes.la)
  broken /usr/kde/3.3/lib/kde3/kdeprint_cups.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_ext.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_ext.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_lpdunix.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_lpdunix.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_lpr.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_lpr.la (requires /usr/kde/3.3/lib/libkdefakes.la)
  broken /usr/kde/3.3/lib/kde3/kdeprint_lpr.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_rlpr.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_rlpr.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_tool_escputil.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kdeprint_tool_escputil.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kfileaudiopreview.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kfileaudiopreview.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kgzipfilter.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kgzipfilter.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/khtmlimagepart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/khtmlimagepart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_dds.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_dds.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_eps.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_eps.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_ico.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_pcx.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_pcx.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_rgb.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_rgb.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_tga.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_tga.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_tiff.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kimg_xview.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_file.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_file.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_ftp.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_ftp.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_ghelp.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_ghelp.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_help.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_help.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_http.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_http.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_http_cache_cleaner.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_http_cache_cleaner.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_metainfo.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_metainfo.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kio_uiserver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kjavaappletviewer.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kjavaappletviewer.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/klauncher.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/klauncher.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/knotify.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/knotify.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kspell_aspell.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kspell_aspell.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kspell_ispell.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/kspell_ispell.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_autobookmarker.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_autobookmarker.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_docwordcompletion.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_docwordcompletion.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_insertfile.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_insertfile.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_isearch.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_isearch.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_kdatatool.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/ktexteditor_kdatatool.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkatepart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkatepart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkcertpart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkcertpart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkdeprint_management_module.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkdeprint_management_module.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkhtmlpart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkhtmlpart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkmultipart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libkmultipart.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libshellscript.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/libshellscript.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/designer/kdewidgets.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/designer/kdewidgets.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/styles/highcolor.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/styles/highcolor.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/styles/keramik.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/styles/keramik.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/styles/kthemestyle.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/styles/kthemestyle.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/styles/light.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/kde3/plugins/styles/light.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libDCOP.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libartskde.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libartskde.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc_dir.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc_dir.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc_file.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc_file.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc_ldapkio.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc_ldapkio.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc_net.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkabc_net.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkatepartinterfaces.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkatepartinterfaces.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdecore.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdecore.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdefx.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_cupsdconf.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_cupsdconf.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_dcopserver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_dcopserver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kaddprinterwizard.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kaddprinterwizard.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kbuildsycoca.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kbuildsycoca.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kconf_update.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kconf_update.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kcookiejar.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kcookiejar.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kded.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kded.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kio_http_cache_cleaner.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kio_http_cache_cleaner.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kio_uiserver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_kio_uiserver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_klauncher.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeinit_klauncher.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeprint.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeprint.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeprint_management.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeprint_management.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdesasl.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdesasl.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdesu.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdesu.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeui.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkdeui.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkhtml.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkhtml.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkimproxy.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkimproxy.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkio.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkio.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkjava.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkjs.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkmdi.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkmdi.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkmediaplayer.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkmediaplayer.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkmid.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkmid.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libknewstuff.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libknewstuff.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkparts.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkparts.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkresources.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkresources.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkscreensaver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkscreensaver.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkscript.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkscript.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkspell.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkspell.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkspell2.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkspell2.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libktexteditor.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libktexteditor.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkutils.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkutils.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkwalletbackend.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkwalletbackend.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkwalletclient.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libkwalletclient.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libvcard.la (requires /-lstdc++)
  broken /usr/kde/3.3/lib/libvcard.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/art.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/avi.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/avs.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/bmp.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/caption.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/cin.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/cip.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/clip.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/cmyk.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/cut.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dcm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dib.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dot.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dps.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/dpx.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ept.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/fax.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/fits.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/gif.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/gradient.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/gray.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/histogram.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/html.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/icon.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/jpeg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/label.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/magick.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/map.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mat.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/matte.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/meta.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/miff.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mono.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mpc.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mpeg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mpr.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/msl.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mtv.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/mvg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/null.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/otb.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/palm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pattern.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pcd.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pcl.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pcx.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pdb.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pdf.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pict.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pix.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/plasma.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/png.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pnm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/preview.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ps.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ps2.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ps3.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/psd.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/pwp.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/raw.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/rgb.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/rla.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/rle.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/scr.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/sct.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/sfw.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/sgi.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/stegano.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/sun.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/svg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/tga.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/tiff.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/tile.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/tim.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ttf.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/txt.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/uil.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/url.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/uyvy.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/vicar.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/vid.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/viff.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/wbmp.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/wmf.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/wpg.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/x.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xbm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xc.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xcf.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xpm.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/xwd.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/ycbcr.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/coders/yuv.la (requires /-lstdc++)
  broken /usr/lib/ImageMagick-6.2.0/modules-Q16/filters/analyze.la (requires /-lstdc++)
 done.   
  (/root/.revdep-rebuild.3_rebuild)
         
Assigning files to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)
         
Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)
         
Dynamic linking on your system is consistent... All done.


Code:
Portage 2.1-r2 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.16-gentoo-r9 i686)
=================================================================
System uname: 2.6.16-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.12.4
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.4.19, 2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=pentium4 -funroll-loops -fprefetch-loop-arrays -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O3 -march=pentium4 -funroll-loops -fprefetch-loop-arrays -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://172.16.0.2/gentoo-portage"
USE="x86 X alsa apache2 apm arts avi bitmap-fonts bzip2 cli crypt cups curl dlloader dri eds emboss encode esd foomaticdb fortran gd gdbm gif gnome gpm gstreamer gtk gtk2 hardenedphp imlib innodb isdnlog jpeg kde ldap libg++ libwww mad mikmod motif mp3 mpeg mysql ncurses nls nptl nptlonly ogg opengl openssh oss pam pcre pdflib perl php png pppd pwdb python qt3 qt4 quicktime readline reflection samba sdl session spl ssl tcpd truetype truetype-fonts type1-fonts udev vorbis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_ati"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS


Thanks!
hanji
_________________
Server Admin Blog - Uno-Code.com | Gentoo Hosting at Rackspace!
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Wed Sep 06, 2006 2:04 pm    Post subject: Reply with quote

Looks like a bug in revdep-rebuild. What version of gentoolkit are you using? Maybe try a different version.
Back to top
View user's profile Send private message
hanj
Veteran
Veteran


Joined: 19 Aug 2003
Posts: 1410

PostPosted: Wed Sep 06, 2006 2:14 pm    Post subject: Reply with quote

My version is app-portage/gentoolkit-0.2.2

Thanks!
hank
_________________
Server Admin Blog - Uno-Code.com | Gentoo Hosting at Rackspace!
Back to top
View user's profile Send private message
dentament
n00b
n00b


Joined: 16 Jun 2004
Posts: 74

PostPosted: Wed Sep 06, 2006 2:18 pm    Post subject: Reply with quote

Mine too.
Thanks, bye
Back to top
View user's profile Send private message
Dr. Strangelove
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 104
Location: Germania

PostPosted: Fri Sep 08, 2006 12:10 pm    Post subject: Reply with quote

Maybe only the installed package versions are a bit outdated.

avifile is no longer in portage (afaik, there are other packages that do the job now, but don't ask which)
suggestion: unmerge and emerge new package

imagemagick has newer versions in portage
suggestion: update

kde has newer versions in portage
suggestion: update

And btw. you do have checked if there is a libstdc++ on the system?
_________________
Gentoo Linux ~amd64, Kernel 3.6-rc5, Enermax Pro82+ 425W, AMD Athlon 64 X2 BE-2400, Infineon PC800 8GB, ASUS M2NPV-VM, MSI 8600GTS DualHead, SSD OCZ Vertex2 60GB, HDD Samsung Spinpoint F1 320GB HD322HJ, ODD BENQ-DW1640, DVB-S TechniSat SkyStar2
Back to top
View user's profile Send private message
Gergan Penkov
Veteran
Veteran


Joined: 17 Jul 2004
Posts: 1464
Location: das kleinste Kuhdorf Deutschlands :)

PostPosted: Fri Sep 08, 2006 12:55 pm    Post subject: Reply with quote

I would say that these all are stale la-s, changed on previous gcc-update from fix_libtool_files, and after that chaged on the current gcc-update one more time. As they were changed outside of the portage in the first case, on upgrade of their respective pkgs, they were not removed.
Just remove all these la-s (you could query if they belong to some package with equery b /path/to/file) ...
_________________
"I knew when an angel whispered into my ear,
You gotta get him away, yeah
Hey little bitch!
Be glad you finally walked away or you may have not lived another day."
Godsmack
Back to top
View user's profile Send private message
dentament
n00b
n00b


Joined: 16 Jun 2004
Posts: 74

PostPosted: Fri Sep 08, 2006 1:13 pm    Post subject: Reply with quote

Gergan Penkov wrote:
I would say that these all are stale la-s, changed on previous gcc-update from fix_libtool_files, and after that chaged on the current gcc-update one more time. As they were changed outside of the portage in the first case, on upgrade of their respective pkgs, they were not removed.
Just remove all these la-s (you could query if they belong to some package with equery b /path/to/file) ...


That's right, I already did it after reading labor_ratte's post, which put me on right trails by making me realize that I had imagemagick-6.2.8.0 installed, not 6.2.0 .....
Thanks a lot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum