Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
revdep-rebuild and GCC[SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
A.S. Pushkin

Joined: 09 Nov 2002
Posts: 307
Location: dx/dt, dy/dt, dz/dt, t

PostPosted: Wed Feb 14, 2007 6:34 am    Post subject: revdep-rebuild and GCC[SOLVED] Reply with quote

I have run revdep-rebuild numerous times and no matter what I do I get the same output. Originally openldap came up at the same time. I discovered that not reading the emerge log resulted in me not running revdep-rebuild on a number of libraries that resulted in broken libararies. A search of the frums gave me a good lead which I followed. GCC is doing the same.

Here's my output:

revdep-rebuild --ignore --pretend
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.

Collecting complete LD_LIBRARY_PATH... done.

Checking dynamic linking consistency...
broken /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/ (requires /usr/lib/
broken /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/ (requires /usr/lib/
broken /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/ (requires /usr/lib/
broken /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/ (requires /usr/lib/

Assigning files to ebuilds... done.

Evaluating package order... done.

All prepared. Starting rebuild...
emerge --oneshot --pretend =sys-devel/gcc-3.4.6-r2 =sys-devel/gcc-4.1.1-r3

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] sys-devel/gcc-3.4.6-r2
[ebuild R ] sys-devel/gcc-4.1.1-r3
Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.

I run #emerge -ev system with no changes.

Searching the web leaves me with no satisfactory answer. I would very much if anyone has had the same experience.

By the way, I did note something as well. /sbin/ appears to exist three times on my machine. There is one for each of the GCC versions I have as well as the original one listed above. It is not a link.

Feedback would be appreciated.


Problem solved thanks to a rather simple fix.

One question on this, though. Was this error or not or due to something that should have been done during emerge?

In any event I can not save some of that money I've been paying to my electric company!

Thanks again, desultory!

"In a time of universal deceit - telling the truth is a revolutionary act." -- George Orwell

Last edited by A.S. Pushkin on Wed Feb 14, 2007 7:58 pm; edited 2 times in total
Back to top
View user's profile Send private message

Joined: 04 Nov 2005
Posts: 9273

PostPosted: Wed Feb 14, 2007 10:08 am    Post subject: Reply with quote

Try this.

In addition to the posts linked to above by A.S. Pushkin and myself, this has been discussed in topic: "Persistent revdep-rebuild issues: gcc and".

Moved from Portage & Programming to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum