Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UTF-8] Petit problème d'accents
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Sat May 03, 2008 1:53 pm    Post subject: [UTF-8] Petit problème d'accents Reply with quote

Coucou tout le monde,
Ca fait maintenant un petit moment que j'ai ce problème mais il commence à m'énerver de plus en plus.

Je suis en UTF-8 amd 64 avec les pages du man en français.

Un man man par exemple, m'affiche bien les accents.
Code:
ex :
 Spécifie le fichier de configuration à utiliser

Alors qu'un man 2 socket m'affiche des accents vraisemblablement pas d'UTF-8...
Code:
Support de dialogue garantissant l’intégrité


Il doit y avoir un endroit où je me suis foiré mais je ne trouves pas où

man.conf :
Code:
ROFF           /usr/bin/groff -Tps -mandoc -c
NROFF           /usr/bin/nroff -mandoc -c
JNROFF          /usr/bin/groff -Tnippon -mandocj
EQN             /usr/bin/geqn -Tps
NEQN            /usr/bin/geqn -Tlatin1
JNEQN           /usr/bin/geqn -Tnippon
TBL             /usr/bin/gtbl
REFER           /usr/bin/refer
PIC             /usr/bin/pic
VGRIND
GRAP
PAGER           /usr/bin/less -c
BROWSER         /usr/bin/less -c
HTMLPAGER       /usr/bin/lynx -dump
CAT             /bin/cat


Merci d'avance
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Sat May 03, 2008 2:15 pm    Post subject: Reply with quote

Salut,
Les pages man ont toujours eu un problème avec utf8 (il y a plein de post à ce sujet mais flemme de chercher)
Tu peux corriger beaucoups de problèmes en modifiant /etc/man.conf

en remplaçant cette ligne :
NROFF /usr/bin/nroff -mandoc

par :

NROFF iconv -f utf8 -t iso8859-1 | /usr/bin/nroff -mandoc -c -Tutf8

ainsi tu auras de magnifiques accents sur 90 % des pages man fr mais si tu fais un man man pour reprendre ton exemple
tu devrais avoir cette erreur :

lines ?-?/? (END)

S'il existe une formule NROFF "universelle" qui fait marcher toutes les pages man française en utf8 je suis également preneur :wink:
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Sat May 03, 2008 5:36 pm    Post subject: Reply with quote

En utilisant ta commande çà semble fonctionner effectivement....
Mais j'ai de ce fait la même erreur que toi en fesant un man man... sinon avec une NROFF d'origine man man fonctionne ....
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Thu May 15, 2008 9:29 pm    Post subject: Reply with quote

bon j'avais un peu de temps alors je me suis repenché sur ce problème de pages man et de formule NROFF "universelle"...je pense l'avoir trouvé dans ce post :

https://forums.gentoo.org/viewtopic-t-512176-highlight-nroff.html

ce n'est pas celle là: NROFF iconv -f utf8 -t iso8859-1 | /usr/bin/nroff -mandoc -c -Tutf8

mais celle ci :

NROFF /usr/bin/iconv -c -t iso8859-15 | /usr/bin/nroff -mandoc -c

J'ai pas réussi à trouver une page man fr qui se s'affichait pas correctement avec :wink:
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
Tanki
Apprentice
Apprentice


Joined: 29 Mar 2005
Posts: 195
Location: Bordeaux/France

PostPosted: Thu May 15, 2008 9:43 pm    Post subject: Reply with quote

salut

j'avais aussi le problème alors j'ai testé ta solution
en effet les pages man en fr s'affichent bien en revanche pour man man, il saute les accents tout simplement
man man wrote:

man formate et affiche les pages du manuel en ligne. Si section est
spcifie, man ne recherchera que dans cette section du manuel. nom est
le nom de la page qui est gnralement [...]


et comme j'en connais pas plus en modification du man.conf qu'en physique nucleaire, ben je pourrais pas aider
au moins je remonte la ou ça foire (un peu)
mais bon
pour moi ça me va super nikel vu que man man je m'en sers pas (le man non plus en fait, rarement en tout cas :P :lol: )
_________________
Kick Ass !
Dell XPS 13 Developer Edition 9350 | Intel Core i7 @2.20 GHz | 16 Go DDR3 | SSD Samsung PM951 NVMe 512Go
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Thu May 15, 2008 9:51 pm    Post subject: Reply with quote

t'as essayé avec celle que je viens de poster ? même man man marche avec... bon c'est pas pour ce que ça me sert :lol: , jusqu'à présent je me contentais de ma formule précédente efficace pour presque toutes les pages mais du coup vu qu'elles ont l'air de toutes marcher je suis content que master premium ait posé cette question car ça m'a fait chercher et contribuer ainsi à parfaire mon système...

EDIT= Ou là excuses tanki... pas tapé ! il est tard je vais aller me couché....j'avais pas vu qu'il manquait les accents !! :oops:
donc nous n'avons pas encore notre formule universelle....mais c'est plus joli pas d'accent que des caractères bizaroides
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Thu May 15, 2008 10:47 pm    Post subject: Reply with quote

Perso j'utilise un gros hack à base de groff-utf8 et d'un script perso, mais en ce moment j'ai un problème les guillemets ne s'affichent pas dans les terminaux (<ctrl><alt><Fx>) mais je pense que ça vient plutôt de ma configuration des terminaux.

Sinon man = gros caca, ça repose sur un langage crée dans les années 70 par un américain qui n'a évidement pas penser à une balise .ENCODING.
Vive GNU Info, mais ce n'est pas assez utilisé.
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Fri May 16, 2008 9:13 pm    Post subject: Reply with quote

GentooUser@Clubic wrote:
les guillemets ne s'affichent pas dans les terminaux (<ctrl><alt><Fx>) mais je pense que ça vient plutôt de ma configuration des terminaux.


Salut,

ton /etc/conf.d/keymap a bien :

keymap="fr-latin9" ?
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Sat May 17, 2008 12:07 am    Post subject: Reply with quote

Oui, je n'ai ce problème qu'avec les applications en ISO-8859-1[5] (normal je suis en UTF-8 ) et les pages man (là pas normal elles sont sensée êtres en UTF-8 d'ailleurs les accents s'affichent normalement)

EDIT : c'est pas les guillemets qui posent problème c'est l'apostrophe.

EDIT2: après un unicode_stop && unicode_start les apostrophes s'affichent de nouveau correctement, c'est donc l'initialisation des terminaux qui merde, je verrait ça plus tard.

Pour mon gros hack pour les pages man je vais le (re-)donner parce qu'il marche (à ma connaissance) sur toutes les pages fr et sur une partie des pages étrangères.

1: Emerger groff-utf8, ebuild : http://gentoouser.free.fr/gentoo/groff-utf8-0.ebuild
2: Copier ce script dans /usr/local/bin et le rendre exécutable : http://gentoouser.free.fr/gentoo/man2utf8
3: Modifier /etc/man.conf, changer :
Code:
NROFF /usr/bin/nroff -Tascii -c -mandoc

En :
Code:
NROFF /usr/local/bin/man2utf8 | /usr/bin/groff-utf8 -Tutf8 -c -mandoc


C'est un petit peu plus long avec les grosses pages (man mplayer) mais la plupart du temps la différence ne se voit pas.
Bien sûr cette astuce ne marche que si le système est en UTF-8.
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat May 17, 2008 12:51 am    Post subject: Reply with quote

Ton ebuild groff-utf8 fonctionne aussi en amd64.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Sat May 17, 2008 11:33 am    Post subject: Reply with quote

Merci GentooUser@Clubic çà fonctionne avec ceci ...
Le seul problème est que avec groff-utf8 je n'ai plus ma coloration dans man avec less :/ :( alors qu'avec /usr/bin/nroff là je les ai


Bien pratique quand même ces couleurs :)

PS : même problème que toi avec les accents, ils sont remplacés par des "?"
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Sat May 17, 2008 12:27 pm    Post subject: Reply with quote

Merci GentooUser@Clubic pour cet ebuild je vais tester ça
N'ayant aucun soucis dans les terminaux, si ça peut aider je vous post mon /etc/conf.d/keymaps et consolefonts, car je vois pas d'où vos "soucis" puissent venir à par de là...
Code:


jerome@laboussole ~ $ cat /etc/conf.d/keymaps
# Use KEYMAP to specify the default console keymap.  There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.
keymap="fr-latin9"

# Should we first load the 'windowkeys' console keymap?  Most x86 users will
# say "yes" here.  Note that non-x86 users should leave it as "no".
windowkeys="YES"

# The maps to load for extended keyboards.  Most users will leave this as is.
extended_keymaps=""
#extended_keymaps="backspace keypad euro2"

# Tell dumpkeys(1) to interpret character action codes to be
# from the specified character set.
# This only matters if you set unicode="yes" in /etc/rc.conf.
# For a list of valid sets, run `dumpkeys --help`
dumpkeys_charset="iso-8859-15"

# Some fonts map AltGr-E to the currency symbol ¤ instead of the Euro €
# To fix this, set to "yes"
fix_euro="NO"


Code:

jerome@laboussole ~ $ cat /etc/conf.d/consolefont
# consolefont specifies the default font that you'd like Linux to use on the
# console.  You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
# not want to use it, run "rc-update del consolefont" as root).
consolefont="lat9w-16"

# consoletranslation is the charset map file to use.  Leave commented to use
# the default one.  Have a look in /usr/share/consoletrans for a selection of
# map files you can use.
#consoletranslation="8859-15_to_uni"

# unicodemap is the unicode map file to use. Leave commented to use the
# default one. Have a look in /usr/share/unimaps for a selection of map files
# you can use.
#unicodemap="lat9w.uni"


Faîtes attention quand même car j'utilise baselayout2 (mais j'avais pa de problème non plus avec le 1 ) et les fichiers de conf ont peut être changé un peu
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Sat May 17, 2008 3:00 pm    Post subject: Reply with quote

Pour les pages man en couleurs je ne les ai jamais eu même avec nroff donc je peut pas dire.
Pour mon problème de terminal je pense l'avoir résolu en remplaçant lat9w-16 par LatArCyrHeb-16 dans /etc/conf.d/consolefont.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum