Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] compilation php 5.2.6 amd64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
srod
n00b
n00b


Joined: 08 Jul 2007
Posts: 6

PostPosted: Tue May 27, 2008 11:51 am    Post subject: [emerge] compilation php 5.2.6 amd64 Reply with quote

Bonjour à tous,

J'ai un probleme pour compiler la dernière version stable de php5.

Je suis actuellement en :

Code:
ns1 ~ # php -v
PHP 5.2.6RC4-pl0-gentoo (cli) (built: May  3 2008 19:00:52)


Et si je fait un :

Code:
ns1 ~ # emerge =dev-lang/php-5.2.6
Calculating dependencies -
!!! All ebuilds that could satisfy "=dev-lang/php-5.2.6" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/php-5.2.6 (masked by: ~amd64 keyword)



Il me dit qu'il est masqué pour les amd64 ?
C'est bien ca ?

C'est là que j'hésite, est-ce qu'il faut débloquer le keyword en editant le /etc/portage/package.keywords ?
Mais je me demande pourquoi est-ce que c'est masqué pour cette version de php :s

Merci de votre aide ;)


Last edited by srod on Tue May 27, 2008 12:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 115

PostPosted: Tue May 27, 2008 11:53 am    Post subject: Reply with quote

Peut tu mettre ton titre en conformité ?

Et pour ta question, oui, la version 5.2.6 n'est pas stable.
La dernière stable est la 5.2.6_rc4.

Code:
dev-lang/php
     Available versions: 
   (4)   [M]~4.4.8
   (5)   5.2.5-r1 5.2.6_rc4 ~5.2.6 ~5.2.6-r1


Que cherches tu as faire ?

EDIT:
Si tu veut la version stable, tu peut ajouter au fichier /etc/portage/package.keywords:
Code:
~dev-lang/php-5.2.6 ~amd64
Back to top
View user's profile Send private message
srod
n00b
n00b


Joined: 08 Jul 2007
Posts: 6

PostPosted: Tue May 27, 2008 12:09 pm    Post subject: Reply with quote

J'ai mis [emerge] pour le titre, étais-ce bien ca que tu parlais ?


Sinon en fait, pour php, j'ai la RC4 d'installée.
Et comme sur php.net, la version finale est sortie depuis le début du mois, je pensais que dans notre gentoo, c'était de même.

Mais j'ai l'impression que non alors ?
Il vaut mieux que je laisse en RC4 ?
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 115

PostPosted: Tue May 27, 2008 12:26 pm    Post subject: Reply with quote

Tu peut la démasquer pour passer en 5.2.6 finale.

En attendant, la version 5.2.6 finale de portage
ne l'ai pas encore (ca ne devrais pas tarder).
Mais la 5.2.6rc4 ne doit pas être loin de la version finale.
Back to top
View user's profile Send private message
srod
n00b
n00b


Joined: 08 Jul 2007
Posts: 6

PostPosted: Tue May 27, 2008 12:31 pm    Post subject: Reply with quote

Ca marche, merci pour tes réponses :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum