Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[mlabel] Problème pour labeliser un disque fat
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
struddel
Tux's lil' helper
Tux's lil' helper


Joined: 08 Apr 2008
Posts: 82

PostPosted: Sun Aug 17, 2008 12:10 pm    Post subject: [mlabel] Problème pour labeliser un disque fat Reply with quote

Hello,

j'ai toujours eu l'habitude de monter mon disque externe au boot avec fstab en mettant le nom du label de mon disque.

J'ai changé de disque externe récemment, et là ça ne fonctionne plus :

Mon disque externe est en fat et a été reconnu comme sdh1.
Mon ancien disque externe (en fat également) était toujours branché, reconnu en sda2 au moment de l'arrivée du nouveau disque, et labelisé en tant que "DATA"

Jusqu'à présent, pour le monter automatiquement, j'utilisais
Code:
LABEL=DATA                /mnt/data       vfat            user,exec,umask=2,gid=1000      0 0
dans fstab et ça a toujours fonctionné.

Pour labeliser mon nouveau disque, je suis allé dans le fichier /etc/mtools/mtools.conf et j'ai ajouté la ligne
Code:
drive v: file="/dev/sdh1"


Ensuite, j'ai fait
Code:
mlabel v:WD


Du coup, sdh1 = v = WD, j'ai testé en ajoutant WD en montage automatique dans fstab
Code:
LABEL=WD                /mnt/data       vfat            user,exec,umask=2,gid=1000      0 0
ça fonctionne impec'.

Du coup, j'enlève mon ancien disque externe que je voulais refiler à quelqu'un, et au boot d'après, mon nouveau disque passe en sda2, mais logiquement, c'est pas grave puisque je le monte par son label.

Bah si, c'est grave, au boot, le disque n'est pas monté. Je teste moi même avec mount /mnt/data puisqu'il est dans le fstab, et il me sort

Code:
root@gentoo /home/struddel # mount /mnt/data
mount: périphérique spécial /dev/sdh1 n'existe pas


Pourtant dans fstab je veux monter WD, pas sdh1 ... J'ai même tenté de mettre
Code:
drive v: file="/dev/sda2"
dans mtools.conf (ce que je suis pas obligé de faire en toute logique puisque c'est un peu le principe de labeliser son disque : ne plus avoir de problème de changement de nom des périphériques), et j'ai bien
Code:
root@gentoo /home/struddel # mlabel -s v:
 Volume label is WD 


mais rien n'y fait, il me réclament toujours sdh1 :o


Une idée ?

merci !
_________________
Linux c'est vachement compliqué quand on est un chat. J'aimerais pas être un chat.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun Aug 17, 2008 2:18 pm    Post subject: Re: [mlabel] Problème pour labeliser un disque fat Reply with quote

struddel wrote:
Je teste moi même avec mount /mnt/data puisqu'il est dans le fstab, et il me sort

Code:
root@gentoo /home/struddel # mount /mnt/data
mount: périphérique spécial /dev/sdh1 n'existe pas

Question c*n : dans ton fstab, tu n'as bien qu'une seule ligne mentionnant /mnt/data ?
Si ce n'est pas le cas, c'est la première ligne qui est prise en compte.
Back to top
View user's profile Send private message
struddel
Tux's lil' helper
Tux's lil' helper


Joined: 08 Apr 2008
Posts: 82

PostPosted: Sun Aug 17, 2008 4:34 pm    Post subject: Reply with quote

J'en ai qu'une avec LABEL=WD oui, j'ai simplement remplacé DATA par WD (WD pour Western Digital, la marque du disque)
_________________
Linux c'est vachement compliqué quand on est un chat. J'aimerais pas être un chat.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun Aug 17, 2008 6:32 pm    Post subject: Reply with quote

Bon, ben finalement, t'es pas tout seul ! :-(
En jouant avec plusieurs clés USB, j'observe le même phénomène.
Je n'ai pas l'explication exacte mais cela semble lié à l'utilisation des UUID.
Il semblerait que ce soit un bug de blkid.
il y a un workaround ici .

Pour l'explication des UUID, un lien intéressant chez la concurrence ... ;)

[EDIT] bug #225669 !
Back to top
View user's profile Send private message
struddel
Tux's lil' helper
Tux's lil' helper


Joined: 08 Apr 2008
Posts: 82

PostPosted: Sun Aug 17, 2008 6:40 pm    Post subject: Reply with quote

Ah, merci pour le bugzilla, vais aller lire ça de plus près dans la semaine, me disais aussi qu'il y avait un soucis :?
_________________
Linux c'est vachement compliqué quand on est un chat. J'aimerais pas être un chat.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum