Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[résolu][system] mise à jour impossible.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
lcrprod
n00b
n00b


Joined: 07 Sep 2004
Posts: 30

PostPosted: Fri Nov 07, 2008 2:39 pm    Post subject: [résolu][system] mise à jour impossible. Reply with quote

Bonjour,


j'ai réussi en desmsquant 3/4 fichiers à installé firefox 3. je veut faire une mise à jour ssysteme pour être sur que toute mes applications utilisant firefox prennent bien en compte cette version.

Mais voila quand que lance mon emerge -puDNv world comme indique sur un autre thread du forum j'obitent les message suivant:

Quote:
emerge -puDNv world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild U ] dev-libs/gmp-4.2.2-r2 [4.2.2] USE="-doc -nocxx" 1,707 kB
[ebuild U ] sys-devel/autoconf-wrapper-5 [4-r3] 0 kB
[ebuild U ] app-misc/pax-utils-0.1.17 [0.1.16] USE="-caps" 65 kB
[ebuild U ] app-admin/python-updater-0.5 [0.2] 6 kB
[ebuild U ] sys-libs/timezone-data-2008g-r1 [2007k] USE="nls" 355 kB
[ebuild R ] sys-devel/patch-2.5.9 USE="-static (-build%)" 198 kB
[ebuild R ] sys-libs/ncurses-5.6-r2 USE="gpm unicode -debug -doc -minimal -nocxx -profile -trace (-bootstrap%) (-build%)" 2,353 kB
[ebuild U ] dev-libs/mpfr-2.3.1_p1 [2.3.0_p4] 869 kB
[ebuild U ] sys-apps/less-418 [416] USE="unicode" 488 kB
[ebuild N ] x11-libs/startup-notification-0.9 221 kB
[ebuild R ] media-libs/mesa-6.5.2-r1 USE="motif nptl xcb -debug -doc -pic" VIDEO_CARDS="intel* -mach64 -mga -none -r128 -radeon -s3virge -savage -sis (-sunffb) -tdfx -trident -via" 0 kB
[ebuild R ] sys-apps/groff-1.19.2-r1 USE="X* -cjk" 2,836 kB
[ebuild U ] sys-apps/attr-2.4.41 [2.4.39] USE="nls" 112 kB
[ebuild U ] app-editors/nano-2.1.5 [2.0.7] USE="ncurses nls spell* unicode -debug -justify -minimal -slang" 1,422 kB
[ebuild U ] sys-apps/acl-2.2.47 [2.2.45] USE="nls (-nfs)" 152 kB
[ebuild R ] sys-devel/gcc-4.1.2 USE="fortran gtk* mudflap nls (-altivec) -bootstrap -build -d -doc -gcj (-hardened) -ip28 -ip32r10k -libffi% (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla" 38,847 kB
[ebuild R ] sys-libs/glibc-2.6.1 USE="nls -debug -gd -glibc-omitfp (-hardened) (-multilib) -profile (-selinux) -vanilla" CROSSCOMPILE_OPTS="-headers-only%" 16,007 kB
[ebuild U ] sys-libs/db-4.5.20_p2-r1 [4.5.20_p2] USE="java* -bootstrap -doc -nocxx -tcl -test" 9,068 kB
[ebuild U ] sys-devel/libperl-5.8.8-r2 [5.8.8-r1] USE="berkdb gdbm ithreads* -debug" 9,887 kB
[ebuild R ] dev-lang/perl-5.8.8-r5 USE="berkdb gdbm ithreads* -build -debug -doc -perlsuid" 0 kB
[ebuild U ] perl-core/Test-Harness-3.10 [2.64] 173 kB
[ebuild U ] app-admin/perl-cleaner-1.05 [1.04.3] 6 kB
[ebuild U ] dev-libs/openssl-0.9.8h-r1 [0.9.8g-r2] USE="zlib -bindist -gmp -kerberos -sse2 -test" 3,360 kB
[ebuild NS ] dev-lang/python-2.5.2-r7 USE="berkdb gdbm ipv6 ncurses readline ssl threads -build -doc -examples -sqlite -tk -ucs2 -wininst" 9,606 kB
[ebuild U ] app-misc/ca-certificates-20080514-r2 [20070303-r1] 145 kB
[ebuild R ] dev-libs/cyrus-sasl-2.1.22-r2 USE="berkdb crypt gdbm java ldap* pam ssl -authdaemond -kerberos -mysql -ntlm_unsupported_patch -postgres -sample -srp -urandom" 0 kB
[ebuild U ] dev-libs/libxml2-2.7.2 [2.6.30-r1] USE="ipv6 python readline -bootstrap -build -debug -doc -examples% -test" 4,679 kB
[ebuild U ] sys-libs/cracklib-2.8.12 [2.8.10] USE="nls python" 573 kB
[ebuild R ] net-misc/curl-7.18.2 USE="ipv6 ldap* ssl -ares -gnutls -idn -kerberos -libssh2 -nss -test" 0 kB
[ebuild R ] x11-libs/cairo-1.6.4-r1 USE="X directfb glitz opengl svg* xcb -debug -doc -test" 0 kB
[ebuild R ] app-crypt/gnupg-2.0.9 USE="bzip2 ldap* nls -doc -openct -pcsc-lite (-selinux) -smartcard" 0 kB
[ebuild R ] net-misc/openssh-5.1_p1-r1 USE="X ldap* pam tcpd -X509 -hpn -kerberos -libedit (-selinux) -skey -smartcard -static" 18 kB
[ebuild R ] net-print/cups-1.3.8-r2 USE="X acl dbus java jpeg ldap* pam perl png ppds python samba ssl tiff -avahi -gnutls -kerberos -php -slp -static -xinetd -zeroconf" LINGUAS="fr -de -en -es -et -he -id -it -ja -pl -sv -zh_TW" 0 kB
[ebuild R ] x11-base/xorg-server-1.3.0.0-r6 USE="dri ipv6 nptl xorg xprint -3dfx -debug -dmx -kdrive -minimal -sdl" INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="intel* -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx -glint -i128 -i740 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nsc -nv -nvidia -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -vga -via -vmware -voodoo" 0 kB
[ebuild R ] media-gfx/sane-backends-1.0.19-r1 USE="gphoto2 ipv6 usb* v4l -doc" 8 kB
[ebuild R ] kde-base/kdebase-kioslaves-3.5.9 USE="arts hal kdeenablefinal ldap* samba xinerama -debug -kdehiddenvisibility -openexr" 0 kB
[ebuild R ] kde-base/konqueror-3.5.9 USE="arts branding* java kdeenablefinal xinerama -debug -kdehiddenvisibility" 0 kB
[ebuild N ] app-admin/gamin-0.1.9-r1 USE="python -debug" 631 kB
[ebuild R ] kde-base/kdelibs-3.5.9-r4 USE="acl alsa arts branding* cups fam* jpeg2k kdeenablefinal spell tiff xinerama -avahi -bindist -debug -doc -kdehiddenvisibility -kerberos -legacyssl -lua -openexr -utempter" 0 kB
[ebuild R ] dev-libs/glib-2.16.5 USE="fam* -debug -hardened (-selinux) -xattr" 0 kB
[ebuild R ] net-fs/samba-3.0.32 USE="acl cups fam* ipv6 ldap* pam python readline -ads -async -automount -caps -debug -doc -examples -oav -quotas (-selinux) -swat -syslog -winbind" 0 kB
[ebuild R ] net-libs/xulrunner-1.9.0.3 USE="dbus ipv6 java startup-notification* -custom-optimization -gnome" 0 kB
[ebuild R ] www-client/mozilla-firefox-3.0.3 USE="dbus ipv6 java startup-notification* xulrunner -bindist -custom-optimization -gnome -iceweasel -mozdevelop -restrict-javascript" LINGUAS="fr -af -ar -be -bn -bn_IN -ca -cs -da -de -el -en -en_GB -en_US -es -es_AR -es_ES -eu -fi -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hu -id -is -it -ja -ka -kn -ko -ku -lt -mk -mn -mr -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -th -tr -uk -zh -zh_CN -zh_TW" 0 kB
[ebuild U ] sys-fs/e2fsprogs-1.41.2 [1.40.8] USE="nls (-static%)" 4,263 kB
[ebuild N ] sys-libs/e2fsprogs-libs-1.41.2 USE="nls" 479 kB
[blocks B ] sys-libs/ss (is blocking sys-libs/e2fsprogs-libs-1.41.2)
[blocks B ] sys-libs/com_err (is blocking sys-libs/e2fsprogs-libs-1.41.2)
[blocks B ] <sys-fs/e2fsprogs-1.41 (is blocking sys-libs/e2fsprogs-libs-1.41.2)

Total: 45 packages (19 upgrades, 3 new, 1 in new slot, 22 reinstalls, 3 blocks), Size of downloads: 108,517 kB


voici mon make.conf.

Quote:
cat /etc/make.conf
CHOST="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j3"
FEATURES="ccache"

USE="tunepimp qt3support exif kipi xcb amr subtitles mplayer theora real aiglx nsplugin visualization gstreamer imlib -esd gif encode spell mikmod xmms mp3 mpeg -sdl xml png ogg unicode mad motif sndfile truetype javascript iproute2 tiff ppds qt3 qt4 scanner pdf wifi gphoto2 audiofile sensord logitech-mouse xine lm_sensors kdeenablefinal -mythtv -apache2 -apache v4l ffmpeg xvmc aac aalib asf jpeg2k xscreensaver oracle arts glitz cairo nptl nptlonly dri ipv6 -mysql jpg jpeg xprint a52 ssl socks5 mozilla ithreads threads pthreads xosd java -gnome sdk fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow X avi directfb gtk xv dts dvdread dvdr opengl alsa cdrom dvd mmx 3dnow dma udma dri xorg kde avi dga dio dts vorbis win32codecs xinerama dbus hal divx4linux network xvid quicktime xv samba acpi nls xulrunner -firefox"

INPUT_DEVICES="keyboard mouse evdev"
VIDEO_CARDS="intel"
LINGUAS="fr"

GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/ ftp://gentoo.imj.fr/pub/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://ftp.first-world.info/ ftp://ftp.first-world.info/ "

SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"


et pour finir le contenus de mon package.keywords.

Quote:
cat /etc/portage/package.keywords

# ---
# BEGIN: www-client/mozilla-firefox-3.0.3
# ---
=www-client/mozilla-firefox-3.0.3 ~x86
=dev-libs/nspr-4.7.1 ~x86
=dev-libs/nss-3.12 ~x86
=net-libs/xulrunner-1.9.0.3 ~x86
=sys-libs/e2fsprogs-libs-1.41.2 ~x86


mon fichier package.unmask.

Quote:

josiane4 etc # cat /etc/portage/package.unmask

# ---
# BEGIN: www-client/mozilla-firefox-3.0.3
# ---



Quelle connerie aussi grosse que moi j'ai faites.

Cordialement.


Last edited by lcrprod on Fri Nov 07, 2008 5:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 500

PostPosted: Fri Nov 07, 2008 3:32 pm    Post subject: Re: [system] mise à jour impossible. Reply with quote

Bonjour,
lcrprod wrote:
Quelle connerie aussi grosse que moi j'ai faites.

tu n'en a pas encore faite!

En fait, la mise à jour est "impossible" à cause de l'intégration de ss et com_err dans e2fsprog. Cette mise à jour est assez délicate car il faut bien prendre soin de télécharger les sources de e2fsprogs avant de désinstaller com_err et ss.

On en a déjà parler ici, en résumé, il te faut faire:
Code:
emerge -f e2fsprogs

Code:
emerge --unmerge com-err ss e2fsprogs && emerge --oneshot e2fsprogs
pour résoudre le blocage
Back to top
View user's profile Send private message
lcrprod
n00b
n00b


Joined: 07 Sep 2004
Posts: 30

PostPosted: Fri Nov 07, 2008 4:01 pm    Post subject: Reply with quote

j'ai executer les commandes que tu ma donnée

et en voici le résultat pour la seconde:

Quote:

emerge --unmerge com-err && emerge --oneshot e2fsprogs

--- Couldn't find 'com-err' to unmerge.

>>> No packages selected for removal by unmerge
Calculating dependencies... done!
[ebuild N ] sys-libs/e2fsprogs-libs-1.41.2 USE="nls"
[ebuild N ] sys-fs/e2fsprogs-1.41.2 USE="nls"
[blocks B ] sys-libs/com_err (is blocking sys-libs/e2fsprogs-libs-1.41.2)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


cela ne sent pas bon j'ai l'impression
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 500

PostPosted: Fri Nov 07, 2008 4:24 pm    Post subject: Reply with quote

lcrprod wrote:
j'ai executer les commandes que tu ma donnée

et en voici le résultat pour la seconde:

Quote:

emerge --unmerge com-err && emerge --oneshot e2fsprogs

--- Couldn't find 'com-err' to unmerge.

>>> No packages selected for removal by unmerge
Calculating dependencies... done!
[ebuild N ] sys-libs/e2fsprogs-libs-1.41.2 USE="nls"
[ebuild N ] sys-fs/e2fsprogs-1.41.2 USE="nls"
[blocks B ] sys-libs/com_err (is blocking sys-libs/e2fsprogs-libs-1.41.2)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


cela ne sent pas bon j'ai l'impression


Oups typo: com_err ...
Back to top
View user's profile Send private message
lcrprod
n00b
n00b


Joined: 07 Sep 2004
Posts: 30

PostPosted: Fri Nov 07, 2008 5:14 pm    Post subject: Reply with quote

ok super.

je n'avais pas vue la faute de de frappe.

Merci.
je cloture
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum