Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GCC 4.4.0 testing
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 14, 15, 16  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Genewb
Apprentice
Apprentice


Joined: 09 Jan 2007
Posts: 165

PostPosted: Thu Nov 27, 2008 10:30 pm    Post subject: Reply with quote

cneil wrote:
Genewb wrote:
cruzki123 wrote:
had anyone put -fgraphite in his CFLAGS?

On that note, has anyone reading managed/does anyone reading know how to enable graphite?


Here's a list of changes in gcc-4.4:

http://gcc.gnu.org/gcc-4.4/changes.html

It mentions Graphite and how to enable it. That said, you may also want to read this thread on the GCC Mailing List:

http://gcc.gnu.org/ml/gcc/2008-10/msg00191.html

The developers were discussing the Graphite options and the possibility of renaming them. I don't know if they ever did or not.

Thanks for the pointers.

Unfortunately it seems the configure script doesn't like the live version of polylib (gloog), which is the only one in portage:
Quote:

checking for version 0.10 of PPL... yes
checking for correct version of CLooG... no

:|
_________________
I don't give a darn about "experience", just functional copyleft software.
Back to top
View user's profile Send private message
rhill
Retired Dev
Retired Dev


Joined: 22 Oct 2004
Posts: 1629
Location: sk.ca

PostPosted: Sun Nov 30, 2008 8:15 am    Post subject: Reply with quote

the ebuild doesn't have graphite support so you'll get an error if you try to use it. i won't be adding support any time soon, considering one of the library dependencies is only available through a live git repo and all it seems to be good for right now is making the compiler explode. no work is being done to fix the problems for 4.4 since only regression fixes can be applied at this stage. graphite is a new feature and therefore cannot regress.
_________________
by design, by neglect
for a fact or just for effect
Back to top
View user's profile Send private message
Spasswolf
n00b
n00b


Joined: 31 Mar 2008
Posts: 5

PostPosted: Thu Dec 04, 2008 2:36 pm    Post subject: Reply with quote

One should also mention that gc-4.4.0_alpha20081128 builds the L4Ka::Pistachio Microkernel without linking errors:
https://lists.ira.uni-karlsruhe.de/pipermail/l4ka/2006-July/001702.html
Back to top
View user's profile Send private message
zorry
Developer
Developer


Joined: 30 Mar 2008
Posts: 380
Location: Umeå The north part of scandinavia

PostPosted: Sun Dec 07, 2008 12:31 am    Post subject: Reply with quote

Wher to fund the ecj-4.4.jar file?
Going to star testing gcc 4.4 for the hardened overaly
EDIT:
Thanx dirtyepic for the help.
_________________
gcc version 6.1.0 (Gentoo Hardened 6.1.0 p1.1)
Back to top
View user's profile Send private message
zorry
Developer
Developer


Joined: 30 Mar 2008
Posts: 380
Location: Umeå The north part of scandinavia

PostPosted: Sun Dec 07, 2008 10:00 pm    Post subject: Reply with quote

We have started to test gcc 4.4 on or hardened overlay.
_________________
gcc version 6.1.0 (Gentoo Hardened 6.1.0 p1.1)
Back to top
View user's profile Send private message
zorry
Developer
Developer


Joined: 30 Mar 2008
Posts: 380
Location: Umeå The north part of scandinavia

PostPosted: Sun Dec 07, 2008 11:28 pm    Post subject: Reply with quote

Any one got this?
* QA Notice: Package has poor programming practices which may compile
* fine but exhibit random runtime failures.
* /var/tmp/portage/sys-devel/gcc-4.4.0_alpha20081205/work/gcc-4.4-20081205/libgcc/../gcc/unwind-dw2-fde.c:326: warning: dereferencing type-punned pointer will break strict-aliasing rules
_________________
gcc version 6.1.0 (Gentoo Hardened 6.1.0 p1.1)
Back to top
View user's profile Send private message
Basso Buffo
n00b
n00b


Joined: 19 Oct 2007
Posts: 24
Location: North Carolina, USA

PostPosted: Thu Dec 11, 2008 2:32 pm    Post subject: Reply with quote

In trying to build ImageMagick 6.4.7.5 using GCC 4.4 SVN snapshot, I get the following error:

Code:
coders/pnm.c: In function 'ReadPNMImage':
coders/pnm.c:1015: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugs.gentoo.org/> for instructions.
make[1]: *** [coders/coders_pnm_la-pnm.lo] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-gfx/imagemagick-6.4.7.5/work/ImageMagick-6.4.7-5'
make: *** [all] Error 2


I had a look at the GCC bugzilla, but it looks like they expect bugreports with much more detailed internal knowledge of GCC than I have.

(The line of code that makes GCC barf is just a 'case' statement in a select block.)

Code:
$ gcc --version
gcc () 4.4.0-pre9999 built 20081210 (Gentoo SVN ebuild) rev. 142656
Copyright (C) 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Back to top
View user's profile Send private message
zorry
Developer
Developer


Joined: 30 Mar 2008
Posts: 380
Location: Umeå The north part of scandinavia

PostPosted: Fri Dec 12, 2008 8:20 pm    Post subject: Reply with quote

[tracker] GCC 4.4 porting
_________________
gcc version 6.1.0 (Gentoo Hardened 6.1.0 p1.1)
Back to top
View user's profile Send private message
rhill
Retired Dev
Retired Dev


Joined: 22 Oct 2004
Posts: 1629
Location: sk.ca

PostPosted: Sat Dec 13, 2008 3:39 am    Post subject: Reply with quote

PS. anyone posting bugs without patches will be eaten. :P
_________________
by design, by neglect
for a fact or just for effect
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Sat Dec 13, 2008 3:43 am    Post subject: Reply with quote

godd... I still can't trust 4.3.x....

/me crawls back into a whole and starts using egcs...
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
Genewb
Apprentice
Apprentice


Joined: 09 Jan 2007
Posts: 165

PostPosted: Sat Dec 13, 2008 10:09 pm    Post subject: Reply with quote

dirtyepic wrote:
the ebuild doesn't have graphite support so you'll get an error if you try to use it. i won't be adding support any time soon, considering one of the library dependencies is only available through a live git repo and all it seems to be good for right now is making the compiler explode. no work is being done to fix the problems for 4.4 since only regression fixes can be applied at this stage. graphite is a new feature and therefore cannot regress.

Ah, I was under the impression it was in some sort of usable state.

Thanks for your prevention of wasted effort. :P
_________________
I don't give a darn about "experience", just functional copyleft software.
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Mon Dec 15, 2008 6:50 pm    Post subject: Reply with quote

the package tries to overwrite /usr/lib64/security/classpath.security.
i guess this only happens, because i have the gcj useflag enabled.
should i use this?
Code:
FEATURES="-collision-protect" emerge gcc:4.4-svn

or should something in the ebuild be changed?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Dec 15, 2008 6:53 pm    Post subject: Reply with quote

alex.blackbit wrote:
the package tries to overwrite /usr/lib64/security/classpath.security.
i guess this only happens, because i have the gcj useflag enabled.
should i use this?
Code:
FEATURES="-collision-protect" emerge gcc:4.4-svn

or should something in the ebuild be changed?


just let it override or safe that file & let it override, it's the same file :idea:

(at least for me)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Mon Dec 15, 2008 7:07 pm    Post subject: Reply with quote

emerge is running. but... this isn't a long term solution. how can this be solved in the end?
Back to top
View user's profile Send private message
zorry
Developer
Developer


Joined: 30 Mar 2008
Posts: 380
Location: Umeå The north part of scandinavia

PostPosted: Mon Dec 15, 2008 11:31 pm    Post subject: Reply with quote

alex.blackbit wrote:
emerge is running. but... this isn't a long term solution. how can this be solved in the end?

see sys-devel/gcc - gcj stuff not slotted
_________________
gcc version 6.1.0 (Gentoo Hardened 6.1.0 p1.1)
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Tue Dec 16, 2008 12:38 am    Post subject: Reply with quote

Code:
FEATURES="-protect-owned" emerge gcc:4.4-svn

is what was needed to get it done.
i didn't measure it, but it took _VERY_ long to emerge, for sure longer than 4.3.x.
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Sun Dec 21, 2008 5:08 pm    Post subject: Reply with quote

Anyone know the status of 4.4.0 on using it like which compiles and doesn't?
Back to top
View user's profile Send private message
yoshi314
l33t
l33t


Joined: 30 Dec 2004
Posts: 848
Location: PL

PostPosted: Sun Dec 21, 2008 6:35 pm    Post subject: Reply with quote

not really. but you could start by observing that bug: https://bugs.gentoo.org/show_bug.cgi?id=249226
_________________
~amd64
shrink your /usr/portage with squashfs+aufs
Back to top
View user's profile Send private message
Basso Buffo
n00b
n00b


Joined: 19 Oct 2007
Posts: 24
Location: North Carolina, USA

PostPosted: Tue Dec 23, 2008 2:35 pm    Post subject: Reply with quote

xulrunner fails to build with GCC 4.4, but I am not cool enough nor competent enough to come up with a patch; hence I haven't entered it into bugs.gentoo.org.

The same issue also appears in any Mozilla product which is built with USE="-xulrunner", which causes the xulrunner source to be built-into the app.
Back to top
View user's profile Send private message
rsa4046
l33t
l33t


Joined: 07 Feb 2005
Posts: 660
Location: The Big H, a bit SSW

PostPosted: Tue Dec 23, 2008 2:51 pm    Post subject: Re: Getting gcc-4.4 Reply with quote

Fred Krogh wrote:
I have a Fortran code that works just fine with gfortran-4.1.2, and gets the wrong result with gfortran-4.3.2. It also gives the wrong result on a Ubuntu system with gfortran 4.2.4. I'd like to give gfortran-4.4 a try, but don't know how to get it. My thanks for a pointer (and perhaps instructions if the installation procedure is not obvious).
Fred
Have you tried intel's compiler (ifort, dev-lang/ifc-10.1.018)? I've found this far better than gfortran; my experience has been very good with ifort compared to gfortran, which often won't run or even compile the same code.
_________________
I love gentoo, but I am certainly no guru, despite what it says above.
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 534

PostPosted: Mon Dec 29, 2008 9:26 pm    Post subject: Reply with quote

I'd like to try this, and I added the dirtyepic overlay to my list, but my system still doesn't find any ebuild higher than gcc-4.3.1-r1. I have "sys-devel/gcc" in my package.keywords file. I've probably overlooked something obvious, but I don't know what.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7186
Location: Austria

PostPosted: Mon Dec 29, 2008 9:29 pm    Post subject: Reply with quote

Which results gives you equery l -p -o sys-devel/gcc?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 534

PostPosted: Mon Dec 29, 2008 9:30 pm    Post subject: Reply with quote

Code:

[ Searching for package 'gcc' in 'sys-devel' among: ]                         
 * installed packages                                                         
[I--] [  ] sys-devel/gcc-4.1.2 (4.1)                                         
[I--] [  ] sys-devel/gcc-config-1.4.0-r4 (0)                                 
 * Portage tree (/usr/portage)                                               
[-P-] [M ] sys-devel/gcc-2.95.3-r9 (2.95)                                     
[-P-] [M ] sys-devel/gcc-2.95.3-r10 (2.95)                                   
[-P-] [M ] sys-devel/gcc-3.1.1-r2 (3.1)
[-P-] [M ] sys-devel/gcc-3.2.2 (3.2)
[-P-] [M ] sys-devel/gcc-3.2.3-r4 (3.2)
[-P-] [ ~] sys-devel/gcc-3.3.6-r1 (3.3)
[-P-] [  ] sys-devel/gcc-3.4.6-r2 (3.4)
[-P-] [M-] sys-devel/gcc-4.0.4 (4.0)
[-P-] [ ~] sys-devel/gcc-4.1.0-r1 (4.1)
[-P-] [ ~] sys-devel/gcc-4.2.3 (4.2)
[-P-] [ ~] sys-devel/gcc-4.2.4 (4.2)
[-P-] [M ] sys-devel/gcc-4.3.0 (4.3)
[-P-] [ ~] sys-devel/gcc-4.3.1 (4.3)
[-P-] [ ~] sys-devel/gcc-4.3.1-r1 (4.3)
[-P-] [ ~] sys-devel/gcc-4.3.2 (4.3)
[-P-] [ ~] sys-devel/gcc-4.3.2-r1 (4.3)
[-P-] [  ] sys-devel/gcc-config-1.3.16 (0)
[-P-] [M ] sys-devel/gcc-config-1.4.1 (0)
[-P-] [M~] sys-devel/gcc-nios2-5.1 (nios2-elf-3.4)
[-P-] [M-] sys-devel/kgcc64-3.4.6 (x86_64-pc-linux-gnu-3.4)
[-P-] [M-] sys-devel/kgcc64-4.1.2 (x86_64-pc-linux-gnu-4.1)
[-P-] [M-] sys-devel/kgcc64-4.2.4 (x86_64-pc-linux-gnu-4.2)
[-P-] [M ] sys-devel/kgcc64-4.3.1 (x86_64-pc-linux-gnu-4.3)
[-P-] [M ] sys-devel/kgcc64-4.3.2 (x86_64-pc-linux-gnu-4.3)
 * overlay tree (/usr/portage/local/layman/desktop-effects /usr/portage/local/layman/kde-testing /usr/portage/local/layman/gnome /usr/portage/local/layman/berkano /usr/portage/local/layman/dirtyepic /usr/local/portage)
[--O] [M ] sys-devel/gcc-4.3.3_pre9999 (4.3-svn)
[--O] [M ] sys-devel/gcc-4.4.0_pre9999 (4.4-svn)


Edit: I have another question as well: Which version of glibc should I upgrade to? Should I let it go all the way to 2.9, or should I limit it to 2.7 or 2.8 instead?

Edit again: According to this thread, it seems like I should limit it to 2.7, or as low as I can. https://forums.gentoo.org/viewtopic-t-717450-highlight-gcc.html
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 534

PostPosted: Tue Dec 30, 2008 12:32 am    Post subject: Reply with quote

genstorm wrote:
Which results gives you equery l -p -o sys-devel/gcc?


I feel like I'm missing something simple, but I know not what.
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Tue Dec 30, 2008 11:48 am    Post subject: Reply with quote

keet wrote:
genstorm wrote:
Which results gives you equery l -p -o sys-devel/gcc?


I feel like I'm missing something simple, but I know not what.


You may ave keyworded it, but have you unmasked it?
If you do not know how to unmask it, are you sure gcc-4.4 is something for you?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, ... 14, 15, 16  Next
Page 2 of 16

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum