Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 2)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 28, 29, 30  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Fri Dec 26, 2008 8:30 pm    Post subject: Reply with quote

There is a bug in KDE 4.2 & Kopete notifications: http://bugs.kde.org/show_bug.cgi?id=176235
It is fixed with patch for qt. Will it be available in gentoo?
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Fri Dec 26, 2008 9:29 pm    Post subject: Reply with quote

loftwyr wrote:
Until I upgraded to 4.1.85 I could have yakuake loaded. I uninstalled it to upgrade but now it doesn't want to install without installing 4.1 slotted packages. Can anyone tell me what changes I need to make to the ebuild to make it install?


I had try this in the past and the only way I found was to install the yakuake-9999 but I didn't like to install all the 9999 ebuilds so now I amb working only with konsole... If you find any way tell it here!!!

Thanks
Back to top
View user's profile Send private message
lordcris
Apprentice
Apprentice


Joined: 09 Jul 2002
Posts: 248

PostPosted: Sat Dec 27, 2008 12:28 pm    Post subject: Reply with quote

4.1.85 ebuilds have been moved from kde-crazy to kde-testing.
anybody knows why?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7139
Location: Austria

PostPosted: Sat Dec 27, 2008 12:29 pm    Post subject: Reply with quote

That means KDE-4.2 branch ebuilds are stabilizing... and about to be prepared moving into main portage once KDE-4.2.0 is released.

kde-crazy will then switch to KDE-4.3 development.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
alexxy
Developer
Developer


Joined: 28 Jun 2005
Posts: 50
Location: Gatchina, St. Petersburg, Russia

PostPosted: Sat Dec 27, 2008 5:21 pm    Post subject: Reply with quote

lordcris wrote:
4.1.85 ebuilds have been moved from kde-crazy to kde-testing.
anybody knows why?


Future policy for overlay will be
Snapshot with number .60 .70 and :live ebuilds go to kde-crazy
Snapshots with number greater then .80 (betas and rcs) go to kde-testing
Today i finaly remove snapshots from kde-crazy
_________________
Gentoo Team Russia
Working on Gentoo for iPAQ hx4700
Back to top
View user's profile Send private message
alexxy
Developer
Developer


Joined: 28 Jun 2005
Posts: 50
Location: Gatchina, St. Petersburg, Russia

PostPosted: Sat Dec 27, 2008 6:04 pm    Post subject: Reply with quote

ssmaxss wrote:
There is a bug in KDE 4.2 & Kopete notifications: http://bugs.kde.org/show_bug.cgi?id=176235
It is fixed with patch for qt. Will it be available in gentoo?


Already fixed in kde-testing =) sync and update your qt-gui
_________________
Gentoo Team Russia
Working on Gentoo for iPAQ hx4700
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Sat Dec 27, 2008 6:16 pm    Post subject: Reply with quote

Quote:

Already fixed in kde-testing =) sync and update your qt-gui

Thanks. I think it should be in main tree as some other qt-dependent packages my got same problem.
Back to top
View user's profile Send private message
alexxy
Developer
Developer


Joined: 28 Jun 2005
Posts: 50
Location: Gatchina, St. Petersburg, Russia

PostPosted: Sat Dec 27, 2008 6:30 pm    Post subject: Reply with quote

ssmaxss wrote:

Thanks. I think it should be in main tree as some other qt-dependent packages my got same problem.

It wil be in main tree in near future =)
This fix already included in qt-4.5beta1 and will be in qt-4.4.4 =)
_________________
Gentoo Team Russia
Working on Gentoo for iPAQ hx4700
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sun Dec 28, 2008 3:02 pm    Post subject: [solved] Reply with quote

I had installed kde-4.2 beta 2 (kde 4.1.85) from kde-crazy but I have the kde-testing too.

Now when I try to update the world set it says the next:

Code:

akapc ~ # emerge -uDNav world
emerge: the given set 'world' contains a non-existent set named 'kde-4.2'.


What can I do?? Any idea???

Many thanks

P.D. Solved removing and adding the kde-testing overlay.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Sun Dec 28, 2008 3:34 pm    Post subject: Reply with quote

Same problem, adding and removing kde-testing didn't help.

Code:
emerge: the given set 'world' contains a non-existent set named 'kdebase-4.2'.



UPDATE: Solved by adding kde-crazy using layman, not manually using make.conf.
Back to top
View user's profile Send private message
tampakrap
Retired Dev
Retired Dev


Joined: 27 Nov 2007
Posts: 71
Location: Prague, Czech Republic

PostPosted: Sun Dec 28, 2008 6:38 pm    Post subject: Reply with quote

i have made some changes:
keywords now are structured in folders, so we can have snapshots without any live (unslotted) ebuilds :) from now on symlink the /usr/portage/local/layman/kde-*/Documentation/package.keywords/kde-X to your /etc/portage/package.keywords/
also, kde-testing now contains sets and keywords for 3.5, 4.1 and 4.2(snapshots). kde-crazy contains sets and keywords only for -live. When 4.3 snapshots hit the mirrors (and kde-crazy), we'll add 4.3 sets and keywords to kde-crazy too.
Snapshots are completely removed from kde-crazy and are available only by kde-testing, as they are in their beta stages. So please make your changes and check your symlinks
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7139
Location: Austria

PostPosted: Sun Dec 28, 2008 8:49 pm    Post subject: Reply with quote

I have one question: What to do if the name of an installed set changes or it simply gets removed, and portage not only complains about it but refuses work?

In case of @koffice-2 (formerly in kde-crazy) which is now called @koffice (in kde-testing), I just symlinked it under the old name for the time being.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Sun Dec 28, 2008 8:54 pm    Post subject: Reply with quote

errors compilling many kde-9999 applications;


-- Configuring done
CMake Error: INSTALL(EXPORT) given unknown export "kdeworkspaceLibraryTargets"
-- Generating done
-- Build files have been written to: /var/tmp/portage/kde-base/kdm-9999/work/kdm_build

also collisions problems as many packages install the same files.

anybody?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
tampakrap
Retired Dev
Retired Dev


Joined: 27 Nov 2007
Posts: 71
Location: Prague, Czech Republic

PostPosted: Sun Dec 28, 2008 9:12 pm    Post subject: Reply with quote

@genstorm
sets are written in /var/lib/portage/world_sets just remove them from there. When you try to reinstall a set it gets written to world_sets again.
@koffice-2 and @koffice are two completely different sets, the one is for the in-portage koffice and the other is for the kde-crazy unstable one.

@tranquilcool
i'll do a full rebuild tomorrow so no other commits for today :)
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Sun Dec 28, 2008 9:19 pm    Post subject: Reply with quote

tampakrap wrote:
@genstorm
sets are written in /var/lib/portage/world_sets just remove them from there. When you try to reinstall a set it gets written to world_sets again.
@koffice-2 and @koffice are two completely different sets, the one is for the in-portage koffice and the other is for the kde-crazy unstable one.

@tranquilcool
i'll do a full rebuild tomorrow so no other commits for today :)


thanks for the sets thing.

i'll wait for tomorrow to get these problems solved hopefully.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43788
Location: 56N 3W

PostPosted: Sun Dec 28, 2008 10:53 pm    Post subject: Reply with quote

This thread has got too big.
Locked in favour of part 3
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 28, 29, 30
Page 30 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum