Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Emerge] Plus rien ne compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Sun Aug 16, 2009 4:29 pm    Post subject: [Emerge] Plus rien ne compile Reply with quote

VOila depuis peu, plus aucun package ne compile avec une erreur identique pour tous, en voici un exemple :

Quote:
>>> Emerging (1 of 1) sys-apps/portage-2.1.6.13
* portage-2.1.6.13.patch.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* portage-2.1.6.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
*
* ERROR: sys-apps/portage-2.1.6.13 failed.
* Call stack:
* ebuild.sh, line 1776: Called die
* The specific snippet of code:
* preprocess_ebuild_env || \
* die "error processing environment"
* The die message:
* error processing environment
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.1.6.13/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.1.6.13/temp/environment'.
*

>>> Failed to emerge sys-apps/portage-2.1.6.13, Log file:

>>> '/var/tmp/portage/sys-apps/portage-2.1.6.13/temp/build.log'

* Messages for package sys-apps/portage-2.1.6.13:

*
* ERROR: sys-apps/portage-2.1.6.13 failed.
* Call stack:
* ebuild.sh, line 1776: Called die
* The specific snippet of code:
* preprocess_ebuild_env || \
* die "error processing environment"
* The die message:
* error processing environment
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.1.6.13/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.1.6.13/temp/environment'.


Le build log du package :

Quote:
^[[31;01m*^[[0m
^[[31;01m*^[[0m ERROR: sys-apps/portage-2.1.6.13 failed.
^[[31;01m*^[[0m Call stack:
^[[31;01m*^[[0m ebuild.sh, line 1776: Called die
^[[31;01m*^[[0m The specific snippet of code:
^[[31;01m*^[[0m preprocess_ebuild_env || \
^[[31;01m*^[[0m die "error processing environment"
^[[31;01m*^[[0m The die message:
^[[31;01m*^[[0m error processing environment
^[[31;01m*^[[0m
^[[31;01m*^[[0m If you need support, post the topmost build error, and the call stack if relevant.
^[[31;01m*^[[0m A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.1.6.13/temp/build.log'.
^[[31;01m*^[[0m The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.1.6.13/temp/environment'.
^[[31;01m*^[[0m


Voici mon emerge --info :

Quote:
Gentoo siou # emerge --info
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.2.4, glibc-2.10.1-r0, 2.6.26-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo-r1-x86_64-Intel-R-_Core-TM-2_CPU_6400_@_2.13GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 15 Aug 2009 23:00:01 +0000
ccache version 2.4 [disabled]
app-shells/bash: 4.0_p24
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python: 2.4.4-r15, 2.5.4-r2, 2.6.2-r1, 3.1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache: 2.4-r8
dev-util/cmake: 2.6.4-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc: 0.4.3-r3
sys-apps/sandbox: 2.0
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils: 2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6a
virtual/os-headers: 2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -msse3 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/glftpd/etc /opt/glftpd/ftp-data /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -msse3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" http://mirror.ovh.net/gentoo-distfiles/ "
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/zugaina /usr/local/portage/layman/Spring /usr/portage/local/layman/gnome-experimental /usr/portage/local/layman/sunrise /usr/portage/local/layman/xwing /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acc acl alsa alsancurses amd64 avi berkdb bitmap-fonts browserplugin bzip2 cairo cdr cli cracklib crypt cups dbus dlloader dri dvd dvdr dvdread eds emboss encode esd evdev fam firefox fortran gdbm gif gnome gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog jpeg ldap libg++ mad mastroka mikmod mmx mono mp3 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ogg oggvorbis opengl openmp oss pam pcre pdf pdflib perl png ppds pppd python quicktime readline reflection samba sdl session spell spl sse sse2 ssl sysfs tcpd tiff tk truetype truetype-fonts type1-fonts udev unicode usb v4l vorbis xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Je ne vois pas ce que je puisse faire la. Ca faisait un moment que j'avais pas eu ce type de problème ( ca fait 6 ans que je suis sous gentoo .. ).

Merci d'avance.
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Sun Aug 16, 2009 5:13 pm    Post subject: Reply with quote

salut,

je pense a la piste de python 3.1
assures toi que cette version ne soit pas utilisée, portage ne l'aime pas pour l'instant.

Cordialement,
Elyes
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Sun Aug 16, 2009 6:30 pm    Post subject: Reply with quote

Quote:
Gentoo siou # eselect python list
Available python interpreters:
[1] python2.4
[2] python2.5
[3] python2.6 *
[4] python3.1


Non ca vient pas de la malheureusement :(
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Sun Aug 16, 2009 6:50 pm    Post subject: Reply with quote

Hello,

Peux-tu poster :
Code:

# cat /etc/make.conf
# cat /var/tmp/portage/sys-apps/portage-2.1.6.13/temp/environment
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Sun Aug 16, 2009 7:09 pm    Post subject: Reply with quote

Quote:
Gentoo siou # cat /etc/make.conf
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
#CFLAGS="-O2 -pipe"
CFLAGS="-march=nocona -msse3 -O2 -pipe"
#CFLAGS="-O2 -march=pentium-m -msse3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j3"
PORTAGE_NICENESS="10"
LANG="fr_FR.UTF-8"
LINGUAS="fr"
FEATURES="ccache"
CCACHE_SIZE="4G"
ACCEPT_KEYWORDS="~amd64"
#INPUT_DEVICES="keyboard mouse"
INPUT_DEVICES="evdev"
VIDEO_CARDS="nvidia"
ALSA_CARDS="hda_intel"
USE=" X gtk amd64 alsa -arts -qt avi berkdb bitmap-fonts cairo cdr cli crypt cups dbus dlloader dri dvd dvdr \
eds elibc_glibc emboss encode esd fam firefox fortran \
gdbm gif gnome gpm gstreamer gtk gtk2 hal input_devices_evdev input_devices_keyboard \
input_devices_mouse ipv6 isdnlog jpeg -kde kernel_linux ldap libg++ evdev \
dvdread mad mastroka mikmod mp3 mpeg mmx sse sse2 v4l usb linguas_fr xv xvid oggvorbis \
ogg acc alsancurses nptl nptlonly ogg opengl oss pam pcre pdf pdflib \
perl png ppds pppd python -qt3 quicktime readline reflection sdl session \
tiff spell spl ssl tcpd truetype tk truetype-fonts type1-fonts udev unicode \
userland_GNU vorbis xml xorg xv zlib mono samba nsplugin browserplugin xulrunner"

GENTOO_MIRRORS=" http://mirror.ovh.net/gentoo-distfiles/ "
#GENTOO_MIRRORS="http://ftp.heanet.ie/pub/gentoo/ http://ftp.easynet.nl/mirror/gentoo/
# http://www.gigaload.org/gentoo.org/ http://trumpetti.atm.tut.fi/gentoo/ ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo/
# ftp://files.gentoo.gr/
# http://gentoo.localhost.net.ar/ ftp://mirrors.localhost.net.ar/pub/mirrors/gentoo http://www.las.ic.unicamp.br/pub/gentoo/
# ftp://ftp.las.ic.unicamp.br/pub/gentoo/ ftp://ftp.lug.ro/gentoo http://ftp.lug.ro/gentoo/ http://ftp.roedu.net/pub/mirrors/gentoo.org/
# ftp://ftp.roedu.net/pub/mirrors/gentoo.org/ ftp://ftp.romnet.org/gentoo/ http://ftp.romnet.org/gentoo/ "

FEATURES=""
PORTDIR_OVERLAY="/usr/local/portage"
source /usr/portage/local/layman/make.conf
source /usr/local/portage/layman/make.conf
#source /usr/portage/local/layman
APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias"
PORTAGE_ECLASS_WARNING_ENABLE="0"


Quote:
Gentoo siou # cat /var/tmp/portage/sys-apps/portage-2.1.6.13/temp/environment
Gentoo siou # cat /var/tmp/portage/sys-apps/portage-2.1.6.13/temp/environment.filtered


Les deux sont vierges ~~[/code]
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Sun Aug 16, 2009 7:16 pm    Post subject: Reply with quote

Salut,

As-tu fait un python_updater après avoir passé à la version 2.6 ?

En tous cas, évite de passer à la 3.1 c'est pas bon, rien ne marche ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Sun Aug 16, 2009 8:35 pm    Post subject: Reply with quote

Désactive tes overlays, réinstalle portage manuellement, et essaye un emerge portage.
Tu peux aussi vider le répertoire /var/tmp/portage/ et vérifier que le système de fichier ne contient pas d'erreur, et que son montage se fait correctement.
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Mon Aug 17, 2009 7:23 pm    Post subject: Reply with quote

J'ai fait un python updater, mais sans succée puisque je ne peux rien compiler ..

J'ai ensuite réinstallé maunellement portage, sans effet.

Je commence a craindre le pire !
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Wed Aug 19, 2009 4:48 pm    Post subject: Reply with quote

Aunce idée ?! :(
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Wed Aug 19, 2009 5:44 pm    Post subject: Reply with quote

SiOu wrote:
Quote:
Gentoo siou # eselect python list
Available python interpreters:
[1] python2.4
[2] python2.5
[3] python2.6 *
[4] python3.1


Non ca vient pas de la malheureusement :(


Quelque part tu as 4 version de python alors que du devrais avoir que la v2.5 par défault. Ca viendrait peut-être de là non?

Est-ce que tu as essayé en remplacant la v2.6 par la v2.5 ?
_________________
Gentoo rocks
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Wed Aug 19, 2009 6:13 pm    Post subject: Reply with quote

WHaouuu c'était ca ;... MERCIII !!

M'enfin ca commence a devenir n'importe quoi portage, pouvoir installer 2 versions de python qui ruine emerge en toute impunité ..
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Wed Aug 19, 2009 6:18 pm    Post subject: Reply with quote

Tu es en ~arch. Portage fonctionne avec python 2.6 :
Code:

$ eselect python list
Available python interpreters:
  [1]   python2.6 *

Et, à priori, la fonction qui foire est une fonction bash.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Wed Aug 19, 2009 8:24 pm    Post subject: Reply with quote

Oui, mais une fois le "eselect python set XXX", il faut faire "python_updater" ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Tue Sep 01, 2009 10:23 am    Post subject: Reply with quote

XavierMiller wrote:
Oui, mais une fois le "eselect python set XXX", il faut faire "python_updater" ;)


Euhh oui, mais quand tu ne peux plus emerge, le python updater sert un peu a rien :D

Sinon le probleme a été résolue sur la branche 2.6 de python ? et la 3.1 ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Tue Sep 01, 2009 10:34 am    Post subject: Reply with quote

Surtout pas la 3.1 !!!

C'est une erreur fondamentale de l'avoir tild-arché... rien ne fonctionne en 3.1, la syntaxe a changé et n'est pas rétro-compatible.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Tue Sep 01, 2009 10:38 am    Post subject: Reply with quote

Hello,
bah écoute si le python_updater ne fait rien chez toi, c'est bizarre, car moi tout fonctionne très bien avec la 2.6:

eselect python list wrote:

Available python interpreters:
[1] python2.6 *
[2] python3.1

Comme tu peux le voir, je n'ai plus de traces de la v2.4 et v2.5...
Je suis en ~amd64
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Tue Sep 01, 2009 10:41 am    Post subject: Reply with quote

En tous cas, sur le forum principal (anglophone), ça hurlait pas mal à ce sujet, ces derniers jours.

Vérifie le lien symbolique /usr/bin/python, et son contenu.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Wed Sep 02, 2009 8:23 am    Post subject: Reply with quote

le plus simple c'est de réparer portage manuellement http://www.gentoo.org/proj/en/portage/doc/manually-fixing-portage.xml (attention il faut adapter à ta version de portage (eix -s portage), ensuite revdep-rebuild ou ton python-updater...

mes 0.02 cents
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
mrpouet
Retired Dev
Retired Dev


Joined: 29 Jul 2008
Posts: 87
Location: Bordeaux, France

PostPosted: Wed Sep 02, 2009 8:58 am    Post subject: Reply with quote

SiOu wrote:
WHaouuu c'était ca ;... MERCIII !!

M'enfin ca commence a devenir n'importe quoi portage, pouvoir installer 2 versions de python qui ruine emerge en toute impunité ..


Ben disons que c'est pas évident à traiter car çà imposerait que portage-2.1.6.13 qui est full stable sur la pluspart des arch soit fonctionnel avec une version de python qui contient moins d'arch stabilisées:

Code:

Keywords: python-2.6.2-r1[2.6]: alpha amd64 arm m68k x86 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86-fbsd



Code:

Keywords: portage-2.1.6.13[0]: alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86


de ce fait portage-2.1.16.13 ne pourrait pas être stable pour hppa, ia64, ppc, ppc64, s390, sh, sparc ce qui est balaud finalement.
secondo si tu fait en sorte que cette version soit fonctionnelle avec python-2.6 celà veut dire qu'on va devoir touché au code de portage-2.1.6.13, donc faire une revision bump et de ce fait le mettre en testing... ce qui implicitement donne plus de taffe aux arch teams... il y a aussi que portage-2.5 a beaucoup plus de maturité que la 2.6 (on parle d'un profile stable là, donc çà requit des paquet ayant pas mal de bouteille dans le main tree et ayant été beaucoup testé ).
La team portage bosse activement sur la 2.2 (d'ailleur la 2.1 est toujours maintenue ?) , enfin aprés je ne fais pas partie de la herd portage alors je ne peux pas te dire dans le détails mais je pense qu'ils doivent avoir un ensemble de raisons (le mieux serait d'envoyer un mail à zmedico et de lui demander poliment pourquoi)
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Fri Sep 04, 2009 8:10 pm    Post subject: Reply with quote

S'il n'y avait que python encore qui merdait ... udev-145 ... une blague lui aussi :D

Impossible de démarrer la machine avec, fallut que je trouve un live-cd pour remettre une version antèrieure !

Le ~amd64, c'est plus ce que c'était faut le dir :/
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Fri Sep 04, 2009 8:50 pm    Post subject: Reply with quote

Hello,
euh le ~amd64 fonctionne bien chez moi... (juste gegl qui merdouille et donc par conséquent pas encore de gimp 2.6.7 mais c'est tout...)
Après il faut relativiser, on ne fait pas ses mises à jours de ~amd64 comme pour la stable, et faut voire ce que l'on met à jour...

<perso>
Si c'est pour passer d'une version de gimp-2.6.6 à gimp-2.6.7 oui tu peux lancer ta mises à jour tout en faisant ton travail à coté bien sur... mais pas quand il s'agit de baselayout/openrc ou d'autres programmes important comme ça, il faut prendre le temps de faire la mise à jour et être sur de ne pas faire de conneries histoire de garder une machine en état de marche ou de revenir très vite en arrière quand il s'agit d'une station de travail...
</perso>
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
mrpouet
Retired Dev
Retired Dev


Joined: 29 Jul 2008
Posts: 87
Location: Bordeaux, France

PostPosted: Sat Sep 05, 2009 6:34 pm    Post subject: Reply with quote

SiOu wrote:
S'il n'y avait que python encore qui merdait ... udev-145 ... une blague lui aussi :D

Impossible de démarrer la machine avec, fallut que je trouve un live-cd pour remettre une version antèrieure !


euhh.. impossible de démarrer la machine mais encore ? t'avais pas un message ni rien ?
Tu verrai tout les trucs que l'on doit gérer... ya du taff ;)
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Sun Sep 06, 2009 12:38 am    Post subject: Reply with quote

Je ne critique pas votre travail ! Loin dela ! Je trouve juste décevant que la branche ~ devienne le bac à essaie, meme si cela a toujours été le cas, et le but, jen suis conscient !

Mais la je ne comprends pas pourquoi python3-1 et udev-145 ne sont pas hardmasked !

Sinon concernant le package udev-145, il semblerait qu'il n'arrivait pas ouvrir les différents tty, et ne pouvait charger le module réseau et surment bien d'autres erreurs.

Puis une erreur fatal qui dit que udev n'a pu s'intialiser correctement, il me semble.
Back to top
View user's profile Send private message
mrpouet
Retired Dev
Retired Dev


Joined: 29 Jul 2008
Posts: 87
Location: Bordeaux, France

PostPosted: Sun Sep 06, 2009 9:34 am    Post subject: Reply with quote

SiOu wrote:
Je ne critique pas votre travail ! Loin dela ! Je trouve juste décevant que la branche ~ devienne le bac à essaie, meme si cela a toujours été le cas, et le but, jen suis conscient !

Mais la je ne comprends pas pourquoi python3-1 et udev-145 ne sont pas hardmasked !

Sinon concernant le package udev-145, il semblerait qu'il n'arrivait pas ouvrir les différents tty, et ne pouvait charger le module réseau et surment bien d'autres erreurs.

Puis une erreur fatal qui dit que udev n'a pu s'intialiser correctement, il me semble.


python3.1 et udev-145 on été masqués à titre d'informations ;)
concernant ton problême d'udev, il y a tout plein de message aprés l'emergé de udev dans le postinst() (la phase aprés la copie des fichiers sur /), les as tu lu ?

Ben le but d'une branche testing c'est de tester... comme tu le fais si bien remarqué
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Mon Sep 07, 2009 2:45 am    Post subject: Reply with quote

Et donc, qu'en est t-il, comme lu fut mentionné, du lien symbolique /usr/bin/python?
Code:
file /usr/bin/python
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum