Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XFCE]Installation de Xfce
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Gros Rems
n00b
n00b


Joined: 01 Sep 2009
Posts: 8

PostPosted: Tue Sep 01, 2009 7:32 pm    Post subject: [XFCE]Installation de Xfce Reply with quote

Bonjour a tous

J'ai suivis le handbook pour installer Linux Gentoo, ainsi que X11 et mes pilotes nvidia mais toujours en suivant le handbook je n'arrive pas a installer Xfce.

Le handbook me dit de lancer : emerge -avt xfce4 xfce4-settings
Mais emerge me repond : there are no ebuild to satisfy "xfce4"

J'ai deja essayé pas mal de choses, mais aucuns résultats...


Quelqu'un pourrait prendre quelques minutes pour m'aider ?

Merci
_________________
Avant que le gros ne soit maigre le maigre serat mort !


Last edited by Gros Rems on Tue Sep 01, 2009 9:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Tue Sep 01, 2009 8:16 pm    Post subject: Reply with quote

Salut,

Je suppose que tu utilises le Guide de configuration de Xfce. Tu noteras dans la marge droite qu'il est indiqué que "Une version originale plus récente datée du 28 août 2009 existe." En fait depuis peu il faut utiliser le paquet xfce4-meta, c'est ce que tu verras dans la version anglaise de la documentation:
Code:
# emerge -avt xfce4-meta
Back to top
View user's profile Send private message
Gros Rems
n00b
n00b


Joined: 01 Sep 2009
Posts: 8

PostPosted: Tue Sep 01, 2009 8:20 pm    Post subject: Reply with quote

J'avais deja essayé d'installer xfce4-meta, ca fait partit des nombreuses choses que j'ai essayé.

Mais emerge me repond "Blocked Packages", et je ne comprend vraiment pas avec quoi xfce peut etre en conflit, surtout que mon instalation Gentoo est toute fraiche et que presque rien n'y est encore installer ...
_________________
Avant que le gros ne soit maigre le maigre serat mort !
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Sep 01, 2009 9:14 pm    Post subject: Reply with quote

Salut et bienvenue ! Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)
Back to top
View user's profile Send private message
Gros Rems
n00b
n00b


Joined: 01 Sep 2009
Posts: 8

PostPosted: Wed Sep 02, 2009 7:38 am    Post subject: Reply with quote

En redirigeant les sorties de la commande vers un fichier j'ai deja plus de details :

[blocks B ] sys-libs/com_err ("sys-libs/com_err" is blocking sys-libs/e2fsprogs-libs-1.41.3-r1)
[blocks B ] sys-libs/ss ("sys-libs/ss" is blocking sys-libs/e2fsprogs-libs-1.41.3-r1
[blocks B ] <sys-fs/e2fsprogs-1.41 ("<sys-fs/e2fsprogs-1.41" is blocking sys-libs/e2fsprogs-libs-1.41.3-r1

Mais je ne comprend pas bien ...
_________________
Avant que le gros ne soit maigre le maigre serat mort !
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8105
Location: ~Brussels - Belgique

PostPosted: Wed Sep 02, 2009 7:43 am    Post subject: Reply with quote

Gros Rems wrote:
En redirigeant les sorties de la commande vers un fichier j'ai deja plus de details :

[blocks B ] sys-libs/com_err ("sys-libs/com_err" is blocking sys-libs/e2fsprogs-libs-1.41.3-r1)
[blocks B ] sys-libs/ss ("sys-libs/ss" is blocking sys-libs/e2fsprogs-libs-1.41.3-r1
[blocks B ] <sys-fs/e2fsprogs-1.41 ("<sys-fs/e2fsprogs-1.41" is blocking sys-libs/e2fsprogs-libs-1.41.3-r1

Mais je ne comprend pas bien ...


Salut,

Ca arrive de temps en temps : un nouveau paquet ne veut pas s'installer si une certaine version d'un autre est présente (parce qu'il la remplace ou a besoin d'une autre version)

"XXX is blocking YYY" : désinstalle "XXX" en faisant "emerge -C XXX", et TOUT DE SUITE APRES "emerge -DuNav world", sinon ton système risque d'être non fonctionnel.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Gros Rems
n00b
n00b


Joined: 01 Sep 2009
Posts: 8

PostPosted: Wed Sep 02, 2009 8:14 am    Post subject: Reply with quote

Et si j'ai juste fait "emerge e2fsprogs" je risque d'avoir des problemes ? ^^
J'ai pensé que ca mettrait simplement le paquet a jour.

Je l'est fait quelques minutes avant ton post ...
xfce-meta est en train de s'instaler.
_________________
Avant que le gros ne soit maigre le maigre serat mort !
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8105
Location: ~Brussels - Belgique

PostPosted: Wed Sep 02, 2009 8:17 am    Post subject: Reply with quote

Salut,

Tu peux, mais mets l'option "-1", sinon tu te trouveras avec "e2fsutils" dans ton World, ce qui n'est pas nécessaire (paquet du système). Idéalement, "emerge -C blahbha && emerge -DuNav world && revdep-rebuild -i", puis "dispatch-conf" et éventuellement "elogv" (si installé, un MUST) est la solution la plus sûre
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Gros Rems
n00b
n00b


Joined: 01 Sep 2009
Posts: 8

PostPosted: Wed Sep 02, 2009 8:41 am    Post subject: Reply with quote

Ok merci bien! Je vais tacher de decrypter tout ca ^^

Et derniere question :

J'ai ce message a la fin de l'installe de Xfce :

IMPORTANT: 7 config files in '/etc' need updating.
See the CONFIGURATION FILES section if the emerge
man page to learn how to update config files

IMPORTANT: 1 news items need reading for repository 'gentoo'.
Use eselect news to read news items.


Que faut-il faire pour ca ?
_________________
Avant que le gros ne soit maigre le maigre serat mort !
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8105
Location: ~Brussels - Belgique

PostPosted: Wed Sep 02, 2009 8:46 am    Post subject: Reply with quote

installer gentoolkit, et utiliser dispatch-conf pour intégrer les modifications aux fichiers de configuration

installe aussi elogv, très utile pour voir les messages emerge par après.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum