Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] multiple pb de compilation[resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Oct 06, 2009 1:07 pm    Post subject: [emerge] multiple pb de compilation[resolu] Reply with quote

Bonjour,
Après plusieurs emerge --resume --skipfirst voilà la liste des paquet pour lesquels la compilation reste impossible.
Code:
ataualpa ben # emerge -DuvaN world --with-bdeps y

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-python/lxml-2.2.2 [2.2.1] USE="threads -doc -examples" 0 kB
[ebuild     U ] dev-java/sun-jdk-1.6.0.15 [1.6.0.14] USE="X alsa -derby -doc -examples -jce -nsplugin -odbc" 0 kB
[ebuild     U ] dev-libs/soprano-2.3.1 [2.2.4] USE="clucene dbus java* raptor -debug -doc -redland*" 0 kB
[ebuild     U ] dev-python/PyQt4-4.5.4-r4 [4.5.4] USE="X dbus kde opengl svg webkit -assistant -debug -doc -examples -phonon -sql -xmlpatterns" 0 kB
[ebuild     U ] kde-base/pykde4-4.2.4-r3 [4.2.4-r2] USE="-akonadi (-aqua) -debug -examples (-kdeprefix) -semantic-desktop" 0 kB
[ebuild     U ] dev-python/qscintilla-python-2.4 [2.3.2-r2] USE="qt4 -debug%" 0 kB
[ebuild     U ] dev-python/PyQt-3.18.1 [3.17.6] USE="-debug -doc -examples" 0 kB
[ebuild     U ] media-sound/amarok-1.4.10_p20090130-r3 [1.4.10_p20090130-r2] USE="amazon kde mysql opengl python -daap -debug -ifp -ipod -mp4 -mtp -musicbrainz -njb -postgres (-real) -visualization -xinerama" LINGUAS="fr -af -ar -az -be -bg -bn -br -ca -cs -cy -da -de -el -en_GB -eo -es -et -eu -fa -fi -ga -gl -he -hi -hu -id -is -it -ja -km -ko -ku -lo -lt -mk -ms -nb -nds -ne -nl -nn -pa -pl -pt -pt_BR -ro -ru -rw -se -sk -sl -sq -sr -sr@Latn -ss -sv -ta -tg -th -tr -uk -uz -zh_CN -zh_TW" 0 kB

Total: 8 packages (8 upgrades), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]

En prime je n'arrive plus à lancer une session depuis kdm.
Beaucoup de ces paquets tournent autour de java et python... une idée ?
Par quel bout prendre ce pb (il y a trop de message d'erreur pour que je les mettes tous ici.).


Last edited by BENJI on Fri Oct 09, 2009 7:30 am; edited 1 time in total
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Tue Oct 06, 2009 1:22 pm    Post subject: Reply with quote

Ben écoute, sans les messages d'erreur, on ne peut rien pour toi !
Tout ce que je peux dire c'est que chezmoiçamarche :roll:

Concentre-toi par exemple sur le premier paquet et donne-nous le log à partir de l'endroit de la première erreur ...

Idem pour kdm : sans plus de détails, on ne va pas aller loin !
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Tue Oct 06, 2009 1:24 pm    Post subject: Reply with quote

Hello,
La question du jour: avec quelle version de python tournes-tu ? la 2.6 ou la 3.1 ? (eselect python list)
Donnes-nous ton emerge --info, donnes-nous aux moins quelques messages d'erreurs, sous prétexte qu'il yen a beaucoup ça te décourage de les faire un par un ? et çe n'est pas beaucoup d'ebuilds qui plantent, juste 8, faut tout de même pas pousser :?
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Oct 06, 2009 1:36 pm    Post subject: Reply with quote

ouais je vous donne pas tort mais j'suis au boulot aussi.
laissons tomber kdm pour le moment à mon avis c'est le même problème.
Voici pour le premier paquet qui plante c'est le log avec tac je pensais qu'il serait plus long
Code:
ataualpa ben # tac /var/tmp/portage/dev-python/lxml-2.2.2/temp/build.log | less
 *
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/lxml-2.2.2/temp/environment'.
 * A complete build log is located at '/var/tmp/portage/dev-python/lxml-2.2.2/temp/build.log'.
 * If you need support, post the topmost build error, and the call stack if relevant.
 *
 *   Building failed with Python 2.6 in building() function
 *  The die message:
 *                       die "${failure_message}";
 * The specific snippet of code:
 *             environment, line 2873:  Called die
 *             environment, line  818:  Called python_execute_function 'building'
 *             environment, line 3291:  Called distutils_src_compile
 *               ebuild.sh, line   49:  Called src_compile
 * Call stack:
 * ERROR: dev-python/lxml-2.2.2 failed.
 *
lxml requires cython-0.9.6.10 or later.
python2.6 setup.py build -b build-2.6
 * Building of dev-python/lxml-2.2.2 with Python 2.6...
>>> Compiling source in /var/tmp/portage/dev-python/lxml-2.2.2/work/lxml-2.2.2 ...
>>> Source configured.
>>> Configuring source in /var/tmp/portage/dev-python/lxml-2.2.2/work/lxml-2.2.2 ...
>>> Source prepared.
  [ ok ]
 * Applying lxml-2.0.3-no-fake-pyrex.patch ...
>>> Preparing source in /var/tmp/portage/dev-python/lxml-2.2.2/work/lxml-2.2.2 ...
>>> Source unpacked in /var/tmp/portage/dev-python/lxml-2.2.2/work
>>> Unpacking lxml-2.2.2.tgz to /var/tmp/portage/dev-python/lxml-2.2.2/work
>>> Unpacking source...

Sinon
Code:
ataualpa ben # eselect python list
Available python interpreters:
  [1]   python2.5
  [2]   python2.6 *

2.6 donc et pas de 3.1.
et enfin
Code:
ataualpa ben # emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.29-gentoo-r5-i686-Intel-R-_Celeron-TM-_CPU_1300MHz-with-gentoo-1.12.11.1
Timestamp of tree: Mon, 28 Sep 2009 06:30:01 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.5.4-r3, 2.6.2-r1
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo http://gentoo.modulix.net/gentoo/ "
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j2"
PKGDIR="/mnt/oasis/gentoo_package"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/armagetron /usr/portage/local/layman/pro-audio /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl alsa apache2 berkdb bzip2 cli cracklib crypt cups dri dvd dvdread encode fortran fr gd gdbm gif gpm hal iconv ipv6 isdnlog jpeg kde lirc modules mp3 mudflap mysql ncurses nls nptl nptlonly opengl openmp pam pcre perl png pppd python qt3 qt4 readline reflection samba sdl session simplexml spl ssl sysfs tcpd tiff truetype unicode usb v4l vorbis x86 xml xml2 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="fbdev nv nvidia vesa vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Tue Oct 06, 2009 2:06 pm    Post subject: Reply with quote

BENJI wrote:
Voici pour le premier paquet qui plante c'est le log avec tac je pensais qu'il serait plus long

Heu, tac, c'est peut-être pas une bonne idée : ça oblige de lire de bas en haut :(
Utilise plutôt tail --lines=nn pour afficher les nn dernières lignes ;)

Cela dit, ton extrait donne uniquement le retour d'erreur d'emerge.
La véritable erreur de compilation est située plus haut (... ou plus bas dans ton tac, enfin bref ...)
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Oct 06, 2009 2:39 pm    Post subject: Reply with quote

ben, il y a la totalité du log dans ce que j'ai donné :(
Code:
ataualpa ben # cat /var/tmp/portage/dev-python/lxml-2.2.2/temp/build.log | less
>>> Unpacking source...
>>> Unpacking lxml-2.2.2.tgz to /var/tmp/portage/dev-python/lxml-2.2.2/work
>>> Source unpacked in /var/tmp/portage/dev-python/lxml-2.2.2/work
>>> Preparing source in /var/tmp/portage/dev-python/lxml-2.2.2/work/lxml-2.2.2 ...
 * Applying lxml-2.0.3-no-fake-pyrex.patch ...
  [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/lxml-2.2.2/work/lxml-2.2.2 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-python/lxml-2.2.2/work/lxml-2.2.2 ...
 * Building of dev-python/lxml-2.2.2 with Python 2.6...
python2.6 setup.py build -b build-2.6
lxml requires cython-0.9.6.10 or later.
 *
 * ERROR: dev-python/lxml-2.2.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3291:  Called distutils_src_compile
 *             environment, line  818:  Called python_execute_function 'building'
 *             environment, line 2873:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *  The die message:
 *   Building failed with Python 2.6 in building() function
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-python/lxml-2.2.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/lxml-2.2.2/temp/environment'.

voilà pour le paquet suivant (java) :
Code:
>>> Emerging (1 of 7) dev-java/sun-jdk-1.6.0.15
!!! Insufficient space to store jdk-6u15-dlj-linux-i586.bin in /usr/portage/distfiles
!!! Insufficient privileges to use remaining space.
!!! You may set FEATURES="-userfetch" in /etc/make.conf in order to fetch with
!!! superuser privileges.
 * jdk-6u15-dlj-linux-i586.bin RMD160 SHA1 SHA256 size ;-) ...                                                                        [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                [ ok ]
>>> Unpacking source...
You will need atleast 259116 kBytes of Disk Free
Please free up the required Disk Space and try again
 *
 * ERROR: dev-java/sun-jdk-1.6.0.15 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2789:  Called die
 * The specific snippet of code:
 *       sh "${DISTDIR}"/${A} --accept-license --unpack || die "Failed to unpack"
 *  The die message:
 *   Failed to unpack
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-java/sun-jdk-1.6.0.15/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/sun-jdk-1.6.0.15/temp/environment'.
 *

>>> Failed to emerge dev-java/sun-jdk-1.6.0.15, Log file:

>>>  '/var/tmp/portage/dev-java/sun-jdk-1.6.0.15/temp/build.log'

 * Messages for package dev-java/sun-jdk-1.6.0.15:

 *
 * ERROR: dev-java/sun-jdk-1.6.0.15 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2789:  Called die
 * The specific snippet of code:
 *       sh "${DISTDIR}"/${A} --accept-license --unpack || die "Failed to unpack"
 *  The die message:
 *   Failed to unpack
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-java/sun-jdk-1.6.0.15/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/sun-jdk-1.6.0.15/temp/environment'.

Puis le suivant
Code:
>>> Emerging (1 of 6) dev-libs/soprano-2.3.1
!!! Insufficient space to store soprano-2.3.1.tar.bz2 in /usr/portage/distfiles
!!! Insufficient privileges to use remaining space.
!!! You may set FEATURES="-userfetch" in /etc/make.conf in order to fetch with
!!! superuser privileges.
 * soprano-2.3.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                              [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                [ ok ]
Traceback (most recent call last):
  File "/usr/bin/java-config-2", line 8, in <module>
    from java_config_2 import __version__
ImportError: No module named java_config_2
 *
 * Can't run java-config --help
 * Have you upgraded python recently but haven't
 * run python-updater yet?
 *
 * ERROR: dev-libs/soprano-2.3.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called pkg_setup
 *    soprano-2.3.1.ebuild, line   40:  Called java-pkg-opt-2_pkg_setup
 *   java-pkg-opt-2.eclass, line   45:  Called java-pkg_init
 *     java-utils-2.eclass, line 2050:  Called die
 * The specific snippet of code:
 *              die "Can't run java-config --help"
 *  The die message:
 *   Can't run java-config --help
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-libs/soprano-2.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/soprano-2.3.1/temp/die.env'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info

>>> Failed to emerge dev-libs/soprano-2.3.1, Log file:

>>>  '/var/tmp/portage/dev-libs/soprano-2.3.1/temp/build.log'

 * Messages for package dev-libs/soprano-2.3.1:

 *
 * Can't run java-config --help
 * Have you upgraded python recently but haven't
 * run python-updater yet?
 *
 * ERROR: dev-libs/soprano-2.3.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called pkg_setup
 *    soprano-2.3.1.ebuild, line   40:  Called java-pkg-opt-2_pkg_setup
 *   java-pkg-opt-2.eclass, line   45:  Called java-pkg_init
 *     java-utils-2.eclass, line 2050:  Called die
 * The specific snippet of code:
 *              die "Can't run java-config --help"
 *  The die message:
 *   Can't run java-config --help
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-libs/soprano-2.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/soprano-2.3.1/temp/die.env'.

un petit dernier
Code:

>>> Emerging (1 of 5) dev-python/PyQt4-4.5.4-r4
!!! Insufficient space to store PyQt-x11-gpl-4.5.4.tar.gz in /usr/portage/distfiles
!!! Insufficient privileges to use remaining space.
!!! You may set FEATURES="-userfetch" in /etc/make.conf in order to fetch with
!!! superuser privileges.
 * PyQt-x11-gpl-4.5.4.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                          [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                [ ok ]
>>> Unpacking source...
>>> Unpacking PyQt-x11-gpl-4.5.4.tar.gz to /var/tmp/portage/dev-python/PyQt4-4.5.4-r4/work
>>> Source unpacked in /var/tmp/portage/dev-python/PyQt4-4.5.4-r4/work
>>> Preparing source in /var/tmp/portage/dev-python/PyQt4-4.5.4-r4/work/PyQt-x11-gpl-4.5.4 ...
 * Applying configure.py.patch ...                                                                                                     [ ok ]
 * Applying PyQt4-4.5.4-qgraphicslinearlayout-fix.patch ...                                                                            [ ok ]
 * Preparation of dev-python/PyQt4-4.5.4-r4 with Python 2.6...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/PyQt4-4.5.4-r4/work/PyQt-x11-gpl-4.5.4 ...
 * Configuration of dev-python/PyQt4-4.5.4-r4 with Python 2.6...
python2.6 configure.py --confirm-license --bindir=/usr/bin --destdir=/usr/lib/python2.6/site-packages --sipdir=/usr/share/sip --enable=QtCore --enable=QtNetwork --enable=QtScript --enable=QtTest --enable=QtXml --enable=QtGui --enable=QtDesigner --enable=QtScriptTools --enable=QtOpenGL --enable=QtSvg --enable=QtWebKit CC=i686-pc-linux-gnu-gcc CXX=i686-pc-linux-gnu-g++ LINK=i686-pc-linux-gnu-g++ LINK_SHLIB=i686-pc-linux-gnu-g++ CFLAGS='-O2 -march=pentium3 -pipe' CXXFLAGS='-O2 -march=pentium3 -pipe' LFLAGS='-Wl,-O1'
Traceback (most recent call last):
  File "configure.py", line 42, in <module>
    import sipconfig
ImportError: No module named sipconfig
 *
 * ERROR: dev-python/PyQt4-4.5.4-r4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 3488:  Called python_execute_function '-s' 'configuration'
 *             environment, line 2943:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *  The die message:
 *   Configuration failed with Python 2.6 in configuration() function
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-python/PyQt4-4.5.4-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/PyQt4-4.5.4-r4/temp/environment'.
 *

>>> Failed to emerge dev-python/PyQt4-4.5.4-r4, Log file:

>>>  '/var/tmp/portage/dev-python/PyQt4-4.5.4-r4/temp/build.log'

 * Messages for package dev-python/PyQt4-4.5.4-r4:

 *
 * ERROR: dev-python/PyQt4-4.5.4-r4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 3488:  Called python_execute_function '-s' 'configuration'
 *             environment, line 2943:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *  The die message:
 *   Configuration failed with Python 2.6 in configuration() function
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-python/PyQt4-4.5.4-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/PyQt4-4.5.4-r4/temp/environment'.
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Tue Oct 06, 2009 2:46 pm    Post subject: Reply with quote

Hello,
et bien plusieurs choses devraient te guider :wink: :
Je les cites:

dev-python/lxml-2.2.2 wrote:

lxml requires cython-0.9.6.10 or later.

As-tu le paquet cython supérieur ou égale à la version 0.9.6.10 ?

dev-java/sun-jdk-1.6.0.1 wrote:

You will need atleast 259116 kBytes of Disk Free
Please free up the required Disk Space and try again

Là il s'agit d'un problème d'espace disque... ta partition est pleine apparemment.... que te retourne un "df -h" ?

dev-libs/soprano-2.3.1 wrote:

* Can't run java-config --help
* Have you upgraded python recently but haven't
* run python-updater yet?

Encore une fois, tout est expliqué de façon claire: as-tu fais un python-updater pour voir ?

Pour ce qui est de PyQt, je pense qu'en résolvant le problème de python-updater, ça devrait aller...(parce que l'erreur est sur "sipconfig" qui fait partie du "site-packages" de python....)
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Oct 06, 2009 3:11 pm    Post subject: Reply with quote

:oops: j'ai honte.
Faut que je dorme j'ai de la merde dans les yeux.
python-updater est en cours.
pour cython j'ai ce qu'il faut mais j'avoue dans le message d'erreur cru à une erreur de frappe cython au lieu de python et j'ai ignoré le message.
Pour java le df-kh n'est pas bon j'ai mon / à 100%.

Comment je libère de la place rapidement ?
Y a t-il des fichiers temporaires que je pourrais dégagés sans risque ? Ou se trouvent-ils ?
J'ai KDE3.5 et KDE4 je peux supprimer KDE3.5 il me semble je ne l'utilise que très peu ? Le moyen le plus rapide ?
Vous auriez pas une petite commande qui vous liste les 10 + gros dossier dans le répertoire courant ?
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Tue Oct 06, 2009 3:30 pm    Post subject: Reply with quote

'alute

Ben déjà tu peux faire un eclean-{pkg,dist} voire virer complètement le repertoire distfiles ;-)
Après en fonction tu peux regarder si tu des sources kernels out-to-date (emerge -C =<sources_kernel_version>)
Et si tu manques encore de place, tu passeras à la désintallation des applis obsoletes ou que tu utilises peu/plus (i.e. emerge -pv --depclean, ou plus spécifiquement)

Sinon y'a encore d'autres possibilités (portage en squashfs/aufs, abaisser le seuil des 5% de root, ...) mais c'est autre chose

Enfin, généralement, avec 1°) et 2°) on fait souvent pas mal de ménage :mrgreen:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Oct 06, 2009 3:56 pm    Post subject: Reply with quote

python-updater a planté...
j'ai supprimer tout le contenu du répertoire /usr/portage/distfile et j'ai gagné... 4Go !
j'ai relancé python-updater, 39 paquets sont à mettre à jour et pour l'instant ça tourne.
Merci pour le coup de main je vous tiens au courant !
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Oct 09, 2009 7:30 am    Post subject: Reply with quote

Tout est rentré dans l'ordre, merci.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum