Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Frage zu "preserved-rebuild"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Mon Oct 26, 2009 5:55 pm    Post subject: Frage zu "preserved-rebuild" Reply with quote

Hallo Zusammen,

seit einger Zeit bekomme ich nach jedem "emerge" folgende Meldung:

Code:
!!! existing preserved libs:
>>> package: media-gfx/graphviz-2.24.0-r2
 *  - /usr/lib/libgvc.so.4
 *  - /usr/lib/libgvc.so.4.0.0
 *      used by /usr/lib/ImageMagick-6.5.2/modules-Q32/coders/dot.so (media-gfx/imagemagick-6.5.2.9)
 *      used by /usr/lib/graphviz/tcl/libgv_tcl.so (media-gfx/graphviz-2.24.0-r2)
 *      used by /usr/lib/graphviz/tcl/libtcldot.so.0.0.0 (media-gfx/graphviz-2.24.0-r2)
>>> package: media-libs/jpeg-7
 *  - /usr/lib/libjpeg.so.62
 *  - /usr/lib/libjpeg.so.62.0.0
 *      used by /opt/vmware/server/console/lib/libconf/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-jpeg.so (app-emulation/vmware-server-console-1.0.8.126538)
 *      used by /opt/vmware/server/lib/libconf/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-jpeg.so (app-emulation/vmware-server-1.0.9.156507)
 *      used by /usr/bin/LinuxVNC (net-libs/libvncserver-0.9.1)
 *      used by 1322 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries


Wenn ich nun aber, wie empfohlen "emerge @preserved-rebuild" ausführe, bekomme ich diesen Fehler angezeigt:

Code:
vdr02 ~ # emerge @preserved-rebuild
 
 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
 
Calculating dependencies ... done!
 
emerge: there are no ebuilds to satisfy "x11-themes/nvidia:0".
 
 
 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
 
vdr02 ~ #


Hat Jemand eine Idee, wie man das Problem lösen kann?
Back to top
View user's profile Send private message
few
Guru
Guru


Joined: 03 Mar 2008
Posts: 448

PostPosted: Mon Oct 26, 2009 6:47 pm    Post subject: Reply with quote

Removing x11-themes/nvidia should fix it.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3655
Location: Germany

PostPosted: Mon Oct 26, 2009 7:30 pm    Post subject: Reply with quote

Quote:
* IMPORTANT: 2 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Beachte, die News sind zum lesen da, idR sind dies wichtige Mitteilungen!

==========================================================

evtl. hilft dir https://forums.gentoo.org/viewtopic-p-6002522.html?sid=16cd29967acfd8e23839a2f8789ef6e5#6002522
auch weiter, vorausgesetzt du liest es... :wink:

MfG
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Mon Oct 26, 2009 7:33 pm    Post subject: Reply with quote

few wrote:
Removing x11-themes/nvidia should fix it.


thx, that fixed it. :)
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Mon Oct 26, 2009 10:18 pm    Post subject: Reply with quote

Leider zu früh gefreut. :(

Jetzt kommt:

Code:
vdr02 ~ # emerge @preserved-rebuild
Calculating dependencies ... done!

!!! All ebuilds that could satisfy "kde-base/noatun:3.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/noatun-3.5.10 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (24 Oct 2009)
# Deprecated aRts support wrt bug #270575
# Masked for removal in 30 days.


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

vdr02 ~ #


Das Seltsame ist nur, dass ich KDE-3.5.x garnicht installiert habe, sondern KDE-4.3.2.

Und nun???
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Mon Oct 26, 2009 10:39 pm    Post subject: Reply with quote

3PO wrote:
Leider zu früh gefreut. :(

Jetzt kommt:

Code:
vdr02 ~ # emerge @preserved-rebuild
Calculating dependencies ... done!

!!! All ebuilds that could satisfy "kde-base/noatun:3.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/noatun-3.5.10 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (24 Oct 2009)
# Deprecated aRts support wrt bug #270575
# Masked for removal in 30 days.


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

vdr02 ~ #


Das Seltsame ist nur, dass ich KDE-3.5.x garnicht installiert habe, sondern KDE-4.3.2.
Und nun???

emerge -C kde-base/noatun
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Tue Oct 27, 2009 8:28 am    Post subject: Reply with quote

AmonAmarth wrote:
emerge -C kde-base/noatun


Thx, auch das hat geholfen. :)

Leider hängt es nun bei:

Code:
vdr02 ~ # emerge @preserved-rebuild --skipfirst
Calculating dependencies  \
 * One or more packages are either masked or have missing dependencies:
 *
 *   ~dev-python/gnome-python-base-2.22.3 pulled in by:
 *     ('installed', '/', 'dev-python/libgnome-python-2.22.3', 'nomerge')
 *
 *   ~dev-python/gnome-python-base-2.22.3 pulled in by:
 *     ('installed', '/', 'dev-python/gnome-vfs-python-2.22.3', 'nomerge')
 *
 *   ~dev-python/gnome-python-base-2.22.3 pulled in by:
 *     ('installed', '/', 'dev-python/libbonobo-python-2.22.3', 'nomerge')
 *
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.
vdr02 ~ #


So langsam habe ich das Gefühl, dass das eine endlose Geschichte wird....
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Oct 27, 2009 8:38 am    Post subject: Reply with quote

dev-python/gnome-python-base-2.22.3 ist das installiert?
Hast Du vorher ein Update erfolgreich durchgeführt?
(emerge --update --deep @system @world -av --tree --newuse --keep-going)

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Tue Oct 27, 2009 8:50 am    Post subject: Reply with quote

Finswimmer wrote:
dev-python/gnome-python-base-2.22.3 ist das installiert?


Nein.
Installiert ist 2.26.1

Code:
vdr02 ~ #  eix dev-python/gnome-python-base
[I] dev-python/gnome-python-base
     Available versions:  (2)  2.22.3!t 2.26.1!t ~2.28.0!t[1]
        {debug}
     Installed versions:  2.26.1(2)!t(08:38:20 27.10.2009)(-debug)
     Homepage:            http://pygtk.org/
     Description:         Provides the base files for the gnome-python bindings

[1] layman/gnome
vdr02 ~ #


Finswimmer wrote:
Hast Du vorher ein Update erfolgreich durchgeführt?
(emerge --update --deep @system @world -av --tree --newuse --keep-going)


Ja, habe ich, allerdings so:

Code:
emerge -avuDN world



Bei "emerge --update --deep @system @world -av --tree --newuse --keep-going"
bekomme ich diesen Fehler:

Code:
vdr02 ~ # emerge --update --deep @system @world -av --tree --newuse --keep-going

These are the packages that would be merged, in reverse order:

Calculating dependencies ... done!
[nomerge      ] media-sound/alsamixergui-0.9.0.1.2-r4
[ebuild     U ]  x11-libs/fltk-1.1.9 [1.1.7-r2] USE="opengl xinerama%* -doc% -examples% -games% -threads% -xft% (-debug%) (-noxft%)" 0 kB
[ebuild     UD]   sys-libs/glibc-2.9_p20081201-r2 [2.10.1] USE="gd nls -debug -glibc-omitfp (-hardened) (-multilib) -profile (-selinux) -vanilla" 0 kB

Total: 2 packages (1 upgrade, 1 downgrade), Size of downloads: 0 kB

!!! One or more updates have been skipped due to a dependency conflict:

sys-libs/glibc:2.2

  ('ebuild', '/', 'sys-libs/glibc-2.10.1', 'merge') conflicts with
    <sys-libs/glibc-2.10 required by ('ebuild', '/', 'x11-libs/fltk-1.1.9', 'merge')

app-emulation/vmware-modules:0

  ('ebuild', '/', 'app-emulation/vmware-modules-1.0.0.25', 'merge') conflicts with
    ~app-emulation/vmware-modules-1.0.0.15 required by ('installed', '/', 'app-emulation/vmware-server-1.0.9.156507', 'nomerge')


Would you like to merge these packages? [Yes/No]

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 2) sys-libs/glibc-2.9_p20081201-r2
 * glibc-2.9-ports-20081201.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                                     [ ok ]
 * glibc-2.9-20081201.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                                           [ ok ]
 * glibc-2.9-patches-5.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                                          [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                                                    [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                                                   [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                                                  [ ok ]
 * Sanity check to keep you from breaking your system:
 *  Downgrading glibc is not supported and a sure way to destruction
 * ERROR: sys-libs/glibc-2.9_p20081201-r2 failed:
 *   aborting to save your system
 *
 * Call stack:
 *                       ebuild.sh, line  49:  Called pkg_setup
 *   glibc-2.9_p20081201-r2.ebuild, line 179:  Called eblit-run 'pkg_setup'
 *   glibc-2.9_p20081201-r2.ebuild, line 165:  Called eblit-glibc-pkg_setup
 *                 pkg_setup.eblit, line  12:  Called die
 * The specific snippet of code:
 *                      die "aborting to save your system"
 *
 * If you need support, post the output of 'emerge --info =sys-libs/glibc-2.9_p20081201-r2',
 * the complete build log and the output of 'emerge -pqv =sys-libs/glibc-2.9_p20081201-r2'.
 * The complete build log is located at '/log/portage/sys-libs:glibc-2.9_p20081201-r2:20091027-084256.log'.
 * The ebuild environment file is located at '/mnt/data/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/temp/die.env'.
 * S: '/mnt/data/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/glibc-2.9-20081201'

>>> Failed to emerge sys-libs/glibc-2.9_p20081201-r2, Log file:

>>>  '/log/portage/sys-libs:glibc-2.9_p20081201-r2:20091027-084256.log'
*** Resuming merge...

These are the packages that would be merged, in reverse order:

Calculating dependencies ... done!
 * emerge --keep-going: x11-libs/fltk-1.1.9 dropped due to unsatisfied
 * dependency.
 *
 * The following 2 packages have failed to build or install:
 *
 *  ('ebuild', '/', 'sys-libs/glibc-2.9_p20081201-r2', 'merge'), Log file:
 *   '/log/portage/sys-libs:glibc-2.9_p20081201-r2:20091027-084256.log'
 *  ('ebuild', '/', 'x11-libs/fltk-1.1.9', 'merge')
 *
vdr02 ~ #
Back to top
View user's profile Send private message
few
Guru
Guru


Joined: 03 Mar 2008
Posts: 448

PostPosted: Tue Oct 27, 2009 9:06 am    Post subject: Reply with quote

Please post your emerge --info. Your system seems to be in a strange state...
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Tue Oct 27, 2009 10:42 am    Post subject: Reply with quote

few wrote:
Please post your emerge --info. Your system seems to be in a strange state...


Code:
vdr02 ~ # emerge --info
Portage 2.2_rc46 (default/linux/x86/10.0, gcc-4.3.4, glibc-2.10.1-r0, 2.6.30-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r6-i686-Intel-R-_Core-TM-2_Quad_CPU_@_2.66GHz-with-gentoo-1.12.11.1
Timestamp of tree: Mon, 26 Oct 2009 18:30:01 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.5.4-r3, 2.6.2-r1
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://ftp.gentoo.skynet.be/pub/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/"
LANG="de_DE.iso885915@euro"
LC_ALL="de_DE.iso885915@euro"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
LINGUAS="de en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/voyageur /usr/portage/local/layman/kde-testing /usr/portage/local/layman/toolchain /usr/portage/local/layman/vdr-testing /usr/portage/local/layman/zugaina /usr/local/portage/myoverlays"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aio alsa animgif apache2 arts asf automount berkdb bzip2 caps child-protection cli cmdctrl cmdsubmenu cracklib crypt cups curl dbus ddepgentry dga dolby-record-switch dolbyinrec dri dts dv dvb dvbplayer dvbsetup dvd dvdread evo exif extrafilters fat ffmpeg fortran gd gdbm gif gpm gtk htmlhandbook httpd iconv icq imagemagick imon ipv6 isdnlog jpeg jumpplay kde lcd lesstif liemikuutio lirc live lm_sensors matroska matrox mjpeg mmx mmxext modules mp3 mpeg mudflap mysql ncurses network nls noepg nptl nptlonly ntfs nvidia nvram ogg opengl openmp oss pam pcmcia pcre pdf perl php png pppd projectx python qt3support qt4 readline reelchannelscan reflection rtc samba sasl screen server session simplexml slang smartcard sockets sourcecaps spl sql sse sse2 ssl stream svg svga swat sysfs tcpd timerinfo unicode usb v4l v4l2 vcd vdpau vdr vdr-net vfat vorbis wareagleicon webkit win32codecs wxwindows x264 x509 x86 xfs xinerama xml xorg xsl xvid xvmc zlib" ALSA_CARDS="hda-intel oss" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="joystick keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text cfontzpacket cwlinux eyeboxone graphlcd icpa106 imon iowarrior lcterm md8800 ms6931 mtcs16209x noritakevfd pyramid sed1330 sed1520 serialvfd sli stv5730 svga t6963 tyan xosd" LINGUAS="de en" LIRC_DEVICES="serial" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa vga xvfb"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

vdr02 ~ #
Back to top
View user's profile Send private message
few
Guru
Guru


Joined: 03 Mar 2008
Posts: 448

PostPosted: Tue Oct 27, 2009 10:54 am    Post subject: Reply with quote

Du mixt stable und unstable Pakete (z.B. glibc-2.10). Wenn du sowas keywordest, solltest du auch wissen wie man mit dem Block umgeht. Du brauch =x11-libs/fltk-1.1.9-r1.
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1105
Location: Schwabenländle

PostPosted: Tue Oct 27, 2009 11:23 am    Post subject: Reply with quote

few wrote:
[...] Du brauch =x11-libs/fltk-1.1.9-r1.


Ok, thx, damit geht es nun. :)

Aber weshalb will er jetzt bei "emerge @preserved-rebuild" ca. 250 Pakete "kde-base/xxxx-3.5.10" installieren?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum