Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Festplatte kaputt?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Mon Nov 23, 2009 5:47 am    Post subject: Festplatte kaputt? Reply with quote

Hi,

ich habe an einen PCI Sata Adapter eine neue (so wurde mir gesagt) Festplatte angeschlossen.
Nun sehe ich folgendes:
Code:
EXT3-fs error (device sda1): ext3_free_blocks_sb: bit already cleared for block 15132120
EXT3-fs error (device sda1): ext3_free_blocks_sb: bit already cleared for block 15132121
EXT3-fs error (device sda1): ext3_free_blocks_sb: bit already cleared for block 15132122
EXT3-fs error (device sda1): ext3_free_blocks_sb: bit already cleared for block 15132123
EXT3-fs error (device sda1): ext3_free_blocks_sb: bit already cleared for block 15132124
EXT3-fs error (device sda1): ext3_free_blocks_sb: bit already cleared for block 15132125
EXT3-fs error (device sda1): ext3_free_blocks_sb: bit already cleared for block 15132126
EXT3-fs error (device sda1): ext3_free_blocks_sb: bit already cleared for block 15132127
EXT3-fs error (device sda1): ext3_free_blocks_sb: bit already cleared for block 15132128
...
...
spurious 8259A interrupt: IRQ15.                                                       
kjournald starting.  Commit interval 5 seconds                                         
EXT3-fs warning: mounting unchecked fs, running e2fsck is recommended                   
EXT3 FS on sda1, internal journal                                                       
EXT3-fs: mounted filesystem with writeback data mode.                                   
kjournald starting.  Commit interval 5 seconds                                         
EXT3 FS on sda1, internal journal                                                       
EXT3-fs: mounted filesystem with writeback data mode.                                   
ata2: lost interrupt (Status 0x50)             
  ata2: lost interrupt (Status 0x50)                                                     
sd 1:0:0:0: [sda] Unhandled error code                                                 
sd 1:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x06                                 
end_request: I/O error, dev sda, sector 488143591                                       
Aborting journal on device sda1.                                                       
EXT3-fs error (device sda1) in ext3_reserve_inode_write: Journal has aborted           
EXT3-fs error (device sda1) in ext3_dirty_inode: Journal has aborted                   
ext3_abort called.                                                                     
EXT3-fs error (device sda1): ext3_journal_start_sb: Detected aborted journal           
Remounting filesystem read-only                                                         
ext3_abort called.                                                                     
EXT3-fs error (device sda1): ext3_put_super: Couldn't clean up the journal             
ata2: lost interrupt (Status 0x58)                                                     
ata2: lost interrupt (Status 0x58)                                                     
kjournald starting.  Commit interval 5 seconds                                         
EXT3-fs warning (device sda1): ext3_clear_journal_err: Filesystem error recorded from previous mount: IO failure
EXT3-fs warning (device sda1): ext3_clear_journal_err: Marking fs in need of filesystem check.                 
EXT3-fs warning: mounting fs with errors, running e2fsck is recommended                                         
EXT3 FS on sda1, internal journal                                                                               
EXT3-fs: recovery complete.                                                                                     
EXT3-fs: mounted filesystem with writeback data mode.                                                           
ata2: lost interrupt (Status 0x50)                                                                             
sd 1:0:0:0: [sda] Unhandled error code                                                                         
sd 1:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x06                                                         
end_request: I/O error, dev sda, sector 488371143                                                               
Aborting journal on device sda1.                                                                               
EXT3-fs error (device sda1) in ext3_reserve_inode_write: Journal has aborted                                   
EXT3-fs error (device sda1) in ext3_dirty_inode: Journal has aborted                                           
EXT3-fs error (device sda1) in ext3_new_blocks: Journal has aborted                                             
ext3_abort called.                                                                                             
EXT3-fs error (device sda1): ext3_journal_start_sb: Detected aborted journal                                   
Remounting filesystem read-only                                                                                 
EXT3-fs error (device sda1) in ext3_orphan_add: Journal has aborted                                             
ext3_abort called.                                                                                             
EXT3-fs error (device sda1): ext3_put_super: Couldn't clean up the journal                                     
kjournald starting.  Commit interval 5 seconds                                                                 
EXT3-fs warning (device sda1): ext3_clear_journal_err: Filesystem error recorded from previous mount: IO failure
EXT3-fs warning (device sda1): ext3_clear_journal_err: Marking fs in need of filesystem check.                 
EXT3-fs warning: mounting fs with errors, running e2fsck is recommended                                         
EXT3 FS on sda1, internal journal                                                                               
EXT3-fs: recovery complete.                                                                                     
EXT3-fs: mounted filesystem with writeback data mode.                                                           
ata2: lost interrupt (Status 0x50)                                                                             
sd 1:0:0:0: [sda] Unhandled error code                                                                         
sd 1:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x06                                                         
end_request: I/O error, dev sda, sector 603095495                                                               
Buffer I/O error on device sda1, logical block 75386929                                                         
lost page write due to I/O error on sda1                                                                       
Buffer I/O error on device sda1, logical block 75386930                                                         
lost page write due to I/O error on sda1                                                                       
Buffer I/O error on device sda1, logical block 75386931                                                         
lost page write due to I/O error on sda1                                                                       
Buffer I/O error on device sda1, logical block 75386932                                                         
lost page write due to I/O error on sda1                                                                       
Buffer I/O error on device sda1, logical block 75386933                                                         
lost page write due to I/O error on sda1                             
lost page write due to I/O error on sda1                                                                       
ata2: lost interrupt (Status 0x50)                                                                             
sd 1:0:0:0: [sda] Unhandled error code                                                                         
sd 1:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x06                                                         
end_request: I/O error, dev sda, sector 328079247                                                               
__ratelimit: 118 callbacks suppressed 
ata2: lost interrupt (Status 0x50)                                                                             
sd 1:0:0:0: [sda] Unhandled error code                                                                         
sd 1:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x06                                                         
end_request: I/O error, dev sda, sector 488116303                                                               
__ratelimit: 118 callbacks suppressed                                                                           
Buffer I/O error on device sda1, logical block 61014530                                                         
lost page write due to I/O error on sda1                                                                       
------------[ cut here ]------------                                                                           
WARNING: at fs/buffer.c:1152 mark_buffer_dirty+0x23/0x78()                                                     
Hardware name: KM266-8237                                                                                       
Modules linked in: nls_iso8859_1 cifs nls_base ext3 jbd mbcache ext2 snd_via82xx snd_ac97_codec ac97_bus snd_pcm snd_timer snd_page_alloc snd_mpu401_uart snd_rawmidi snd soundcore                                                                                                                                               
Pid: 8264, comm: umount Not tainted 2.6.31.5 #3                                                                                                                 
Call Trace:                                                                                                                                                     
 [<c01120f1>] warn_slowpath_common+0x60/0x77                                                                                                                     
 [<c0112115>] warn_slowpath_null+0xd/0x10                                                                                                                       
 [<c0164068>] mark_buffer_dirty+0x23/0x78                                                                                                                       
 [<f826c74f>] journal_update_superblock+0x4d/0x81 [jbd]                                                                                                         
 [<f826b725>] cleanup_journal_tail+0x79/0x86 [jbd]                                                                                                               
 [<f826ba08>] log_do_checkpoint+0x29c/0x2bd [jbd]                                                                                                               
 [<c010eef4>] ? __enqueue_entity+0x9c/0xa4                                                                                                                       
 [<c010ef95>] ? enqueue_task_fair+0x99/0x9e                                                                                                                     
 [<c010e724>] ? update_curr+0x60/0x8f                                                                                                                           
 [<c010eda0>] ? __dequeue_entity+0x23/0x27
 [<c02a9c56>] ? schedule+0x256/0x272
 [<c010fa2b>] ? __wake_up+0x11/0x1a
 [<f826d4a1>] journal_destroy+0x9d/0x141 [jbd]
 [<c011f37d>] ? autoremove_wake_function+0x0/0x33
 [<f82a26d1>] ext3_put_super+0x25/0x17c [ext3]
 [<c014da78>] generic_shutdown_super+0x40/0xac
 [<c014db01>] kill_block_super+0x1d/0x31
 [<c014dd35>] deactivate_super+0x2f/0x41
 [<c015c486>] mntput_no_expire+0x4d/0x60
 [<c015c8b1>] sys_umount+0x239/0x271
 [<c015c8f6>] sys_oldumount+0xd/0xf
 [<c0102708>] sysenter_do_call+0x12/0x26
---[ end trace 61f0aef84fb1902f ]---
ata2: lost interrupt (Status 0x50)
sd 1:0:0:0: [sda] Unhandled error code
sd 1:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x06
end_request: I/O error, dev sda, sector 488116303
Buffer I/O error on device sda1, logical block 61014530
lost page write due to I/O error on sda1
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: mounting fs with errors, running e2fsck is recommended
EXT3 FS on sda1, internal journal
EXT3-fs: mounted filesystem with writeback data mode.


Was ist da denn nun alles kaputt?
Der Controller? Die Festplatte?
SMART hat vorhin noch keinen Fehler gefunden:
Code:

smartctl --all -d ata /dev/sda
smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Home page is http://smartmontools.sourceforge.net/                       

=== START OF INFORMATION SECTION ===
Device Model:     ST3500320NS       
Serial Number:    9QM1JL3N         
Firmware Version: SN04             
User Capacity:    500,107,862,016 bytes
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   6                                                     
ATA Standard is:  ATA/ATAPI-6 T13 1410D revision 2                     
Local Time is:    Mon Nov 23 06:46:21 2009 CET                         
SMART support is: Available - device has SMART capability.             
SMART support is: Enabled                                               

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x82) Offline data collection activity
                                        was completed without error.   
                                        Auto Offline Data Collection: Enabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                        without error or no self-test has ever 
                                        been run.                               
Total time to complete Offline                                                 
data collection:                 ( 634) seconds.                               
Offline data collection                                                         
capabilities:                    (0x7b) SMART execute Offline immediate.       
                                        Auto Offline data collection on/off support.
                                        Suspend Offline collection upon new         
                                        command.                                   
                                        Offline surface scan supported.             
                                        Self-test supported.                       
                                        Conveyance Self-test supported.             
                                        Selective Self-test supported.             
SMART capabilities:            (0x0003) Saves SMART data before entering           
                                        power-saving mode.                         
                                        Supports SMART auto save timer.             
Error logging capability:        (0x01) Error logging supported.                   
                                        General Purpose Logging supported.         
Short self-test routine                                                             
recommended polling time:        (   1) minutes.                                   
Extended self-test routine                                                         
recommended polling time:        ( 120) minutes.                                   
Conveyance self-test routine                                                       
recommended polling time:        (   2) minutes.                                   
SCT capabilities:              (0x003d) SCT Status supported.                       
                                        SCT Feature Control supported.             
                                        SCT Data Table supported.                   

SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds: 
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   117   100   006    Pre-fail  Always       -       159542030
  3 Spin_Up_Time            0x0003   095   095   000    Pre-fail  Always       -       0       
  4 Start_Stop_Count        0x0032   100   100   020    Old_age   Always       -       11       
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0       
  7 Seek_Error_Rate         0x000f   063   060   030    Pre-fail  Always       -       2106411 
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       324     
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0       
 12 Power_Cycle_Count       0x0032   100   100   020    Old_age   Always       -       11       
184 Unknown_Attribute       0x0032   100   100   099    Old_age   Always       -       0       
187 Reported_Uncorrect      0x0032   100   100   000    Old_age   Always       -       0       
188 Unknown_Attribute       0x0032   100   100   000    Old_age   Always       -       0       
189 High_Fly_Writes         0x003a   100   100   000    Old_age   Always       -       0       
190 Airflow_Temperature_Cel 0x0022   065   056   045    Old_age   Always       -       35 (Lifetime Min/Max 25/39)
194 Temperature_Celsius     0x0022   035   044   000    Old_age   Always       -       35 (0 20 0 0)
195 Hardware_ECC_Recovered  0x001a   035   024   000    Old_age   Always       -       159542030
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0010   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age   Always       -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Extended offline    Completed without error       00%       281         -

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.


In Sachen Hardware bin ich relativ ratlos...
Vielen Dank!

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Mon Nov 23, 2009 8:59 am    Post subject: Reply with quote

Raw_Read_Error_Rate ist bei Festplatten die keinen defekt haben 0, bei dir ist 159542030 schon ganz schön hoch. Mach mit ddrescue eine sicherung auf eine andere Platte, bevor du die Daten gar nicht mehr lesen kannst. Anschließend Dateisystem überprüfen lassen.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Nov 23, 2009 10:32 am    Post subject: Reply with quote

Wo hast du die Platte denn her, Die Formulierung "wurde mir gesagt" klingt nicht so Vertrauen erweckend. War das fs schon drauf oder hast du es selber drauf getan?

Was für Geräusche macht die Platte, läuft sie normal rund oder hörst so kratzende oder klackende Geräusche?
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Mon Nov 23, 2009 11:21 am    Post subject: Reply with quote

Klaus Meier wrote:
Wo hast du die Platte denn her, Die Formulierung "wurde mir gesagt" klingt nicht so Vertrauen erweckend. War das fs schon drauf oder hast du es selber drauf getan?

Was für Geräusche macht die Platte, läuft sie normal rund oder hörst so kratzende oder klackende Geräusche?

Jupp, dass wäre mal interesannt, immerhin lief sie schon 324 Stunden.
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 269

PostPosted: Mon Nov 23, 2009 1:19 pm    Post subject: Reply with quote

Der Raw_Read_Error_Rate Wert wird von Seagate-Paltten aber gerne auf hohe Werte gesetzt und oft gleich wie Hardware_ECC_Recovered, was bei ihm der Fall ist.
Dafür hat die Platte noch keine Reserve-Sektoren angelegt - Reallocated_Sector_Ct = 0 und das ist schon mal nicht schlecht.

Ich würde mich mehr mit Seek_Error_Rate beschäftigen, denn dieser Wert sagt etwas über die Positionierung der Köpfe und Beschaffenheit der Oberfläche aus. Da werden auch die I/O-Fehler herkommen.

Die Platte ist zwar 324 Std gelaufen, dafür wurde sie aber nur 11x eingeschaltet, d.h. sie läuft im Schnitt 30 Std durch.
Sein Gehäuse ist auch schlecht belüftet, denn mit 35°C ist die Platte ziemlich warm, was die Lebensdauer auch schon kräftig reduziert hat.

Das alles muss nichts bedeuten. Die Platte kann noch Wochen und Monate laufen, ohne dass etwas passiert.
Und ein Backup hat "man" immer.

Jean-Paul
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Mon Nov 23, 2009 8:10 pm    Post subject: Reply with quote

Oberflächentemperaturen von 35-50 Grad sind bei aktuellen Festplatten vollkommen normal, siehe zum Beispiel:

http://www.tomshardware.com/de/charts/35-festplatten-charts/Maximum-Drive-Surface-Temperature,665.html
http://www.tomshardware.com/de/charts/desktop-hard-disk-charts-3.5-2009/Drive-Surface-Temperature,1015.html,
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Mon Nov 23, 2009 8:55 pm    Post subject: Reply with quote

Die Platte habe ich von einem Arbeitskollegen bekommen, da keine neue gekauft werden sollte/wurde/whatever.
Es hieß, sie wäre nur kurz in Betrieb gewesen und dann gegen eine größere ersetzt worden, daher ist sie frei.

Nun stellt sich die Frage:
Soll/kann ich sie weiterlaufen lassen? Die Ironie an der Geschichte ist, dass es ein Backup "Server" ist. De facto ein Rechner, der Backups mit rsync ausm Internet zieht.
Sorgen macht mir vor allem, dass sie ab und zu nur read-only gemountet wird...

Danke!

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
mrsteven
Veteran
Veteran


Joined: 04 Jul 2003
Posts: 1938

PostPosted: Mon Nov 23, 2009 11:29 pm    Post subject: Reply with quote

Das könnte auch am Kabel oder schlimmstenfalls am Controller liegen. Es gibt zwei Sachen, die mir merkwürdig vorkommen:

  1. Der SMART-Plattentest läuft problemlos durch. Nun ja, so weit ich weiß macht den die Platte selbst, weitestgehend ohne dass das Betriebssystem oder der Controller eingreift (nur zum Starten). Das heißt, es könnte ein Problem mit der Kommunikation zur Festplatte sein, also ein defektes oder lockeres Kabel - oder eben ein Festplattencontroller, der so langsam in den Ruhestand will. Andererseits ist dieser Test auch keine Garantie für eine intakte Platte, denn was bei so einem SMART-Test passiert weiß nur der Hersteller.

  2. Warum gehen Interrupts verloren? Ich denke, das dürfte nicht passieren, wenn "nur" die Festplatte kaputt ist. So sieht das für mich eher nach einem kaputten Festplattencontroller oder einem Treiberproblem aus.


Wie gesagt, es kommt mir merkwürdig vor und ganz sicher bin ich mir auch nicht. Falls es irgendwie geht und keiner eine bessere Idee hat, dann bleibt dir wohl nichts anderes übrig, als die Platte mal an einen anderen Rechner anzuschließen, den Kernel zu wechseln oder eine andere Platte auszuprobieren, also jede Fehlerquelle auszuschließen.
_________________
Unix philosophy: "Do one thing and do it well."
systemd: "Do everything and do it wrong."
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Nov 23, 2009 11:37 pm    Post subject: Reply with quote

Finswimmer wrote:
Die Platte habe ich von einem Arbeitskollegen bekommen, da keine neue gekauft werden sollte/wurde/whatever.
Es hieß, sie wäre nur kurz in Betrieb gewesen und dann gegen eine größere ersetzt worden, daher ist sie frei.

Nun stellt sich die Frage:
Soll/kann ich sie weiterlaufen lassen? Die Ironie an der Geschichte ist, dass es ein Backup "Server" ist. De facto ein Rechner, der Backups mit rsync ausm Internet zieht.
Sorgen macht mir vor allem, dass sie ab und zu nur read-only gemountet wird...

Danke!

Tobi
Na gut, zu der Logik, eine so gut wie neue Festplatte gegen eine andere zu ersetzen muss wohl nichts weiter gesagt werden. Hast das FS komplett selber angelegt?Würde da mal eine Low Level Formatierung und/oder Oberflächenanalyse drüber laufen lassen.

Aber die Geschichte klingt für mich nicht sehr Vertrauen erweckend. Und sag jetzt nicht, es ist eine Samsung... Wie groß ist sie denn? Und wie wichtig die Daten. Man bekommt doch heute für 50€ schon große Teile. Ist die Frage, ob dir der Stress das wert ist.
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Mon Nov 23, 2009 11:53 pm    Post subject: Reply with quote

Vielleicht wäre auch mal eine komplettes dmesg log file nützlich, denn
Code:

ata2: lost interrupt (Status 0x50)

ist ja auch nicht normal.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3668
Location: Germany

PostPosted: Tue Nov 24, 2009 12:56 am    Post subject: Reply with quote

Off Topic

@Klaus Meier
Nein es ist keine Samsung, es ist wohl eine Seagate Barracuda 500GB (steht auch im SMART Log)
Aber nicht alle Samsung Platten sind schlecht, es gibt auch sehr gute, langlebige HDDs von Samsung.
Es gibt da nahezu bei allen Herstellern "gute" , und weniger gute Serien...

....................................................................
Zum Thema

Ich könnte mir auch vorstellen das es evtl. ein Problem, oder eine Inkompatibilität des
PCI Sata Adapter
oder deren Treiber ist.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Nov 24, 2009 5:51 am    Post subject: Reply with quote

Erstmal vielen Dank für die zahleichen Antworten!

in einen anderen Rechner einbauen wäre eine Idee, allerdings treten die I/O Fehler sehr sporadisch auf, damit ist es schwierig zu sagen, dass dann alles in Ordnung ist.
2.6.31.5 vanilla läuft als Kernel.
Festeingebaut ist dieser Treiber:
CONFIG_SATA_SIL: │
│ │
│ This option enables support for Silicon Image Serial ATA.

Der Treiber ist doch korrekt? Soll ich auf den nächsten Kernel updaten? Downgraden?

FS ist ext3 und selbst angelegt mit mkfs.ext3 /dev/sda1.

Kompletter dmesg ist nicht "möglich", da die Fehler oben den Startvorgang abgeschnitten haben...


Vielen Dank für Eure Unterstützung!
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Nov 24, 2009 10:36 am    Post subject: Reply with quote

Josef.95 wrote:
Off Topic

@Klaus Meier
Nein es ist keine Samsung, es ist wohl eine Seagate Barracuda 500GB (steht auch im SMART Log)
Aber nicht alle Samsung Platten sind schlecht, es gibt auch sehr gute, langlebige HDDs von Samsung.
Es gibt da nahezu bei allen Herstellern "gute" , und weniger gute Serien...

....................................................................
Zum Thema

Ich könnte mir auch vorstellen das es evtl. ein Problem, oder eine Inkompatibilität des
PCI Sata Adapter
oder deren Treiber ist.

Sorry, dieses Hellgrün ist auf meinem Moni echt schwer zu lesen, strengt total an.... Aber es sind mal sehr viele Samsungs abgeraucht, War selber davon betroffen. Und habe zwangsweise gerade wieder eine drin, die scheint echt zu halten, bin aber immer irgendwie am Zittern.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Tue Nov 24, 2009 11:46 am    Post subject: Reply with quote

Finswimmer wrote:
Der Treiber ist doch korrekt? Soll ich auf den nächsten Kernel updaten? Downgraden?

Ich hab jetzt keine Linuxkiste hier, aber irgendwo hab ich mal gelesen, dass man die "speziellen" SATA-Treiber nur dann nehmen sollte, wenn die kein AHCI können. Das ist der von Intel verabschiedete offizielle Standard. Einen anderen Treiber solltest du auch nicht verwenden.

Klaus:
Also ich hab bisher mit Samsung ganz gute Erfahrungen. Mein Trauma ist IBM-/Hitachi-Deskstar. Von den 6 Festplatten, die ich bisher in meinem Leben mein Eigen nennen konnte, waren 2 Deskstars. Und bisher waren genau 2 Festplatten von den 6 abgeraucht. Rate mal welche.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Nov 24, 2009 12:03 pm    Post subject: Reply with quote

musv wrote:
Finswimmer wrote:
Der Treiber ist doch korrekt? Soll ich auf den nächsten Kernel updaten? Downgraden?

Ich hab jetzt keine Linuxkiste hier, aber irgendwo hab ich mal gelesen, dass man die "speziellen" SATA-Treiber nur dann nehmen sollte, wenn die kein AHCI können. Das ist der von Intel verabschiedete offizielle Standard. Einen anderen Treiber solltest du auch nicht verwenden.


Das wäre super, wenn Du da mal dann nachschauen könntest. Ich finde auf die Schnelle leider nun den Treiber, den ich jetzt schon nutze.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Tue Nov 24, 2009 12:10 pm    Post subject: Reply with quote

Code:

CONFIG_SATA_AHCI:

This option enables support for AHCI Serial ATA.

If unsure, say N.

Symbol: SATA_AHCI [=y]
Prompt: AHCI SATA support
  Defined at drivers/ata/Kconfig:50
  Depends on: ATA && PCI
  Location:
    -> Device Drivers
      -> Serial ATA (prod) and Parallel ATA (experimental) drivers (ATA [=y])

Und das BIOS umstellen nicht vergessen ;)
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Tue Nov 24, 2009 2:38 pm    Post subject: Reply with quote

musv wrote:
Also ich hab bisher mit Samsung ganz gute Erfahrungen. Mein Trauma ist IBM-/Hitachi-Deskstar. Von den 6 Festplatten, die ich bisher in meinem Leben mein Eigen nennen konnte, waren 2 Deskstars. Und bisher waren genau 2 Festplatten von den 6 abgeraucht. Rate mal welche.


Auch wenn's langsam OT wird: das deckt sich 100% mit meinen Erfahrung. Letztlich ist das wie mit Distributionen, Dateisystemen etc. eine reine Glaubensfrage. :wink:
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Nov 24, 2009 4:24 pm    Post subject: Reply with quote

escor wrote:
Code:

CONFIG_SATA_AHCI:

This option enables support for AHCI Serial ATA.

If unsure, say N.

Symbol: SATA_AHCI [=y]
Prompt: AHCI SATA support
  Defined at drivers/ata/Kconfig:50
  Depends on: ATA && PCI
  Location:
    -> Device Drivers
      -> Serial ATA (prod) and Parallel ATA (experimental) drivers (ATA [=y])

Und das BIOS umstellen nicht vergessen ;)


Cool. Werde ich mal testen. Da es aber eine PCI Karte ist, muss ich mal schauen, ob man da was umstellen kann. Es muss dann auf AHCI stehen, gell?

Vielen Dank
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Tue Nov 24, 2009 4:47 pm    Post subject: Reply with quote

Ja, das sollte man sowieso immer machen, damit NCQ aktiv ist.
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Nov 27, 2009 7:52 am    Post subject: Reply with quote

Hi,

mit AHCI erkennt er nur sda. Aber nicht die Partition.
Wenn ich beides aktiviere, kommt:

Code:
ata2: lost interrupt (Status 0x50)
sd 1:0:0:0: [sda] Unhandled error code
sd 1:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x06
end_request: I/O error, dev sda, sector 976773152
Buffer I/O error on device sda, logical block 122096644


Was kann ich noch tun, ist die Platte kaputt?

Danke
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Fri Nov 27, 2009 9:12 am    Post subject: Reply with quote

Finswimmer wrote:
Hi,

mit AHCI erkennt er nur sda. Aber nicht die Partition.
Wenn ich beides aktiviere, kommt:

Code:
ata2: lost interrupt (Status 0x50)
sd 1:0:0:0: [sda] Unhandled error code
sd 1:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x06
end_request: I/O error, dev sda, sector 976773152
Buffer I/O error on device sda, logical block 122096644


Was kann ich noch tun, ist die Platte kaputt?

Danke

Hast du Einstellung auch im BIOS umgestellt?
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Nov 27, 2009 12:38 pm    Post subject: Reply with quote

Klaus Meier wrote:
Finswimmer wrote:
Hi,

mit AHCI erkennt er nur sda. Aber nicht die Partition.
Wenn ich beides aktiviere, kommt:

Code:
ata2: lost interrupt (Status 0x50)
sd 1:0:0:0: [sda] Unhandled error code
sd 1:0:0:0: [sda] Result: hostbyte=0x00 driverbyte=0x06
end_request: I/O error, dev sda, sector 976773152
Buffer I/O error on device sda, logical block 122096644


Was kann ich noch tun, ist die Platte kaputt?

Danke

Hast du Einstellung auch im BIOS umgestellt?


Da habe ich keine Möglichkeit gefunden. Es ist ja eine PCI Karte mit eigenem "BIOS". Auch dort gab es keine Einstellungen diebezüglich...

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sat Nov 28, 2009 12:51 am    Post subject: Reply with quote

Ups, sorry... Na dann mußt mal schauen, was für Modi dein Adapter unterstützt. Ist ne heftige Kiste das jetzt so per Forum zu beurteilen. Aber ich denke, es gibt zwei Möglichkeiten: Platte kaputt, dafür spricht irgendwie die Vorgeschichte oder Platte und Controller mögen sich nicht.

Kennst jemanden, mit einem relativ aktuellen Board, der soll die Platte mal dranhängen und eine Oberflächenanalyse machen.

Ansonsten ist SATA per PCI an sich schon peng, weil der PCI Bus gerade mal das her gibt. Und wenn du da noch anderes dran hängen hast, wie Netzwerkkarte, Soundkarte, Fernsehkarte usw. dann kackt der PCI Bus ab.

Was für ein Board hast du denn überhaupt und was hängt an dem PCI Bus?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum