Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Nagios] Not Found The requested URL /nagios/cgi-bin/*.cgi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
reyale
n00b
n00b


Joined: 15 Oct 2009
Posts: 27

PostPosted: Mon Nov 30, 2009 9:24 am    Post subject: [Nagios] Not Found The requested URL /nagios/cgi-bin/*.cgi Reply with quote

Bonjour,

J'ai depuis peu fait une mise à jour de mon Gentoo, et malheureusement, une erreur arrive sur mon Nagios.

Au départ, il ne trouvait même pas l'adresse nagios.siesa.ch mais j'ai en bidouillant le fichier httpd.conf (/etc/apache2) et default_vhost.include (/etc/apache2/vhosts.d) réparer ce problème là.

Par contre, maintenant, j'ai lorsque je clique sur n'importe quels liens, une erreur comme quoi il ne me trouve pas le fichier *.cgi.

J'ai bien sur recherché sur internet mais je n'ai rien trouvé du tout.

Version de nagios : Version 3.0.6.

En espérant pouvoir trouver de l'aide sur ce forum, je vous remercie d'avance.
_________________
-------------
Je crois que Linux va devenir grand, mais, hé, qui suis-je pour dire ça?
Linuxworld, New York, 2 février 2000.
Citations de Linus Torvalds


Last edited by reyale on Wed Dec 02, 2009 7:13 am; edited 4 times in total
Back to top
View user's profile Send private message
reyale
n00b
n00b


Joined: 15 Oct 2009
Posts: 27

PostPosted: Mon Nov 30, 2009 2:03 pm    Post subject: Re : Nagios Reply with quote

Personne n'aurait une idée ?
_________________
-------------
Je crois que Linux va devenir grand, mais, hé, qui suis-je pour dire ça?
Linuxworld, New York, 2 février 2000.
Citations de Linus Torvalds
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8078
Location: ~Brussels - Belgique

PostPosted: Mon Nov 30, 2009 2:26 pm    Post subject: Reply with quote

Peut-être, mais pas dans les 3h ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Nov 30, 2009 5:33 pm    Post subject: Reply with quote

Salut ! Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)

Et en nous donnant les détails de ta config on pourra sans doute mieux t'aider, là c'est un peu vague pour le moment...
Back to top
View user's profile Send private message
reyale
n00b
n00b


Joined: 15 Oct 2009
Posts: 27

PostPosted: Tue Dec 01, 2009 7:17 am    Post subject: Reply with quote

Rebonjour,

Premièrement, merci pour ta réponse et désoler pour l'ancien titre mal fait.

Deuxièmement, il faut savoir qu'avant la mise à jour de l'OS (gentoo) tout fonctionnait parfaitement. C'est depuis cette modification que ces erreurs arrivent.

Dans etc/apache2/modules.d, il y a le fichier 99_nagios3.conf qui est comme cela :
<IfDefine NAGIOS>
ScriptAlias /nagios/cgi-bin/ /usr/lib/nagios/cgi-bin/
<Directory "/usr/lib/nagios/cgi-bin/">
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all
</Directory>
Alias /nagios /usr/share/nagios/htdocs
<Directory "/usr/share/nagios/htdocs">
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
</IfDefine>

Le chemin /usr/lib/nagios/cgi-bin/ est pourtant bien correct est correspond bien. Mais le problème c'est que j'ai bien l'impression que "apache" ne prend pas en compte ce chemin de fichier ....

J'ai également modifier le documentRoot dans /etc/vhosts.d/default_vhost.include pour mettre : DocumentRoot "/usr/share/nagios/htdocs/".

Lorsque je vais sur les propriétés d'un des fameux lien ne fonctionnant pas, il pointe sur : http://nagios.siesa.ch/nagios/cgi-bin/status.cgi?host=all > ce qui correspond à rien du tout en fait.
J'ai alors tester de copier le fichier status.cgi dans un dossier nagios que j'ai créé (usr/share/nagios/htdocs) mais cela ne change à rien du tout le problème. Il propose sur mon Firefox de télécharger le fichier.....
Merci pour ton aide
_________________
-------------
Je crois que Linux va devenir grand, mais, hé, qui suis-je pour dire ça?
Linuxworld, New York, 2 février 2000.
Citations de Linus Torvalds
Back to top
View user's profile Send private message
reyale
n00b
n00b


Joined: 15 Oct 2009
Posts: 27

PostPosted: Wed Dec 02, 2009 7:11 am    Post subject: Reply with quote

Bonjour à tous,

J'ai après moulte recherche réussi à résoudre le problème.

Résolution :

Dans le fichier /etc/apache2/modules.d/99_nagios3.conf, j'ai supprimer deux lignes :


<IfDefine NAGIOS>
ScriptAlias /nagios/cgi-bin/ /usr/lib/nagios/cgi-bin/
<Directory "/usr/lib/nagios/cgi-bin/">
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all
</Directory>
Alias /nagios /usr/share/nagios/htdocs
<Directory "/usr/share/nagios/htdocs">
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>
</IfDefine>

J'ai enlever la balise </IFDefine> et tout refonctionne à merveille.

Merci tout de même pour votre aide.
_________________
-------------
Je crois que Linux va devenir grand, mais, hé, qui suis-je pour dire ça?
Linuxworld, New York, 2 février 2000.
Citations de Linus Torvalds
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Wed Dec 02, 2009 7:38 am    Post subject: Reply with quote

Hello,

Plutôt que de supprimer ces 2 lignes, moi j'aurais lu les notices de fin d'emerge ;)
A la fin de l'emerge de nagios-core, on trouve ça :

Code:
178                 elog "Also edit /etc/conf.d/apache2 and add \"-D NAGIOS\""

Ca aurait aussi résolu ton problème ! (et de manière plus propre)

plusieurs moyens pour lire ces notices lors des installations :
- à la fin des emerges dans la console
- dans /var/log/portage/elog/
- configurer le make.conf pour les recevoir par mail
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum