Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WEB-Cam MSI U100 funktioniert mit Kernelupdate nicht mehr
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Sun Jan 17, 2010 5:25 pm    Post subject: WEB-Cam MSI U100 funktioniert mit Kernelupdate nicht mehr Reply with quote

Hallo Leute,

leider funktioniert meine eingebaute WEB-Cam auf einmal nicht mehr. Weder in Kopete noch in Skype. Mit dem 2.6.30-r6 alle ohne Probleme (Modul uvcvideo). Ohne weitere Änderungen dann auf 2.6.31-r6 geupdatet und dann immer die Fehlermeldung, wenn ich den Treiber manuell versuche einzubinden:
Code:
kernel: uvcvideo: Found UVC 1.00 device USB 2.0 Camera (0c45:62c0)
kernel: uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
kernel: uvcvideo: Failed to query (129) UVC probe control : -108 (exp. 26).
kernel: uvcvideo: Failed to initialize the device (-5).
kernel: usbcore: registered new interface driver uvcvideo
kernel: USB Video Class driver (v0.1.0)


Bei Rechnerstart (also in modulea.autoload) kommt zwar diese Meldung, doch das Ergebnis ist das Gleiche: Keine Kamera!
Code:
kernel: Linux video capture interface: v2.00
kernel: uvcvideo: Found UVC 1.00 device USB 2.0 Camera (0c45:62c0)
kernel: input: USB 2.0 Camera as /devices/pci0000:00/0000:00:1d.7/usb1/1-5/1-5:1.0/input/input10
kernel: usbcore: registered new interface driver uvcvideo
kernel: USB Video Class driver (v0.1.0)


Hat jemand eine Idee, wo ich da ansetzen kann? Ich habe schon alle komischsten Kenel-Configs ausprobiert, doch alles ohne Erfolg. Auch http://en.gentoo-wiki.com/wiki/HOWTO_Install_a_webcam hilft mir leider nicht weiter.
Back to top
View user's profile Send private message
monade
Apprentice
Apprentice


Joined: 17 Mar 2005
Posts: 204
Location: Berlin

PostPosted: Sun Jan 17, 2010 6:50 pm    Post subject: Reply with quote

Lustigerweise hatte ich heute ein ziemlich ähnliches Problem, leider auch noch ohne Lösung.

Bei mir: Kernel 2.6.32

Heute morgen ging es noch, dann hab ich den Kernel neu gebaut (aber gleiche Versionsnummer des Kernels). Und dabei eigentlich ausschließlich die Option "Userspace VESA VGA graphics support" aktiviert (ich sähe jetzt nicht den Zusammenhang). Neustart -> Webcam funktioniert nicht mehr.

Ich hab uvcvideo allerdings nicht als Modul, sondern fest einkompiliert.

Wenn ich Zeit hab, werd ich versuchen, die Option wieder rauszunehmen und dann nochmal testen..

EDIT: bei mir taucht die Webcam auch nicht mehr bei 'lsusb' auf. Bei dir noch?

EDIT2: so.. zwei Neustarts später, dazwischen einmal die Cam mit Windows getestet, ansonsten ohne jede Veränderung: 'lsusb' zeigt dir Kamera wieder und sie funktioniert auch wieder! Insofern kann ich dir jetzt nur sagen, dass Kernel 2.6.32 + "fest einkompiliert" auf meinem System funktioniert. Ich hoffe auch ab jetzt wieder beständiger.. ;-)


Last edited by monade on Sun Jan 17, 2010 7:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Sun Jan 17, 2010 7:49 pm    Post subject: Reply with quote

Ja:
Code:
Microdia Sonix USB 2.0 Camera
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4472

PostPosted: Sun Jan 17, 2010 8:02 pm    Post subject: Reply with quote

monade wrote:
EDIT2: so.. zwei Neustarts später, dazwischen einmal die Cam mit Windows getestet, ansonsten ohne jede Veränderung: 'lsusb' zeigt dir Kamera wieder und sie funktioniert auch wieder! Insofern kann ich dir jetzt nur sagen, dass Kernel 2.6.32 + "fest einkompiliert" auf meinem System funktioniert. Ich hoffe auch ab jetzt wieder beständiger.. ;-)

Vermutlich hatte der windows treiber die kamera deaktiviert, und so konnte linux die kamera nicht mehr finden. Durch deinen Test mit windows wurde die Kamera wieder aktiviert aber beim beenden von windows nicht deaktiviert.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4472

PostPosted: Sun Jan 17, 2010 8:04 pm    Post subject: Reply with quote

LinuxTom wrote:
Ja:
Code:
Microdia Sonix USB 2.0 Camera

da gibt es wohl eine regression im uvcvideo treiber bezüglich dieser cam:
http://bbs.archlinux.org/viewtopic.php?id=70685
http://developer.berlios.de/support/?func=detailsupport&support_id=102913&group_id=5681
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
LinuxTom
l33t
l33t


Joined: 26 Mar 2006
Posts: 798

PostPosted: Mon Jan 18, 2010 7:40 am    Post subject: Reply with quote

Ja, das habe ich auch schon gesehen. Leider passt der Patch nicht einfach so und das EBuild für *30-r6 ist leider auch schon wieder aus dem Portage raus (und ich leider schon gelöscht), so dass ich das mal nach schauen könnte, was sich da geändert hat. :(

Ich werde aber am nächsten Wochenende, vorher komme ich an Rechner nicht ran, noch mal versuchen den Patch logisch zu analysieren und zu integrieren.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum