Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Emerge Blockers: Bitte helft mir!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Thu Jan 21, 2010 6:23 pm    Post subject: [gelöst] Emerge Blockers: Bitte helft mir! Reply with quote

Ich hatte meinen Desktop-Computer fast ein halbes Jahr vom Netz. Ein emerge -uNDav world führt zu zahlreichen Blocks.

Ich habe zunächst gedacht, dass ich einige Packete ja einfach emergen könnte, um die Liste einzugrenzen, bei denen es hakt... aber das war ein Fehler. xorg bricht nach dem Login ab.

Die Blocker
Code:

Total: 190 packages (160 upgrades, 8 downgrades, 12 new, 2 in new slots, 8 reinstalls, 2 uninstalls), Size of downloads: 284,831 kB
Conflict: 7 blocks (3 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [?] indicates that the source repository could not be determined

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'x11-libs/libXxf86dga-1.0.2', 'nomerge') pulled in by
    x11-libs/libXxf86dga required by ('installed', '/', 'x11-apps/xf86dga-1.0.2', 'nomerge')

  ('ebuild', '/', 'x11-proto/xineramaproto-1.2', 'merge') pulled in by
    x11-proto/xineramaproto required by ('ebuild', '/', 'kde-base/systemsettings-4.3.4', 'merge')
    >=x11-proto/xineramaproto-1.1.3 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.4', 'merge')
    x11-proto/xineramaproto required by ('ebuild', '/', 'media-libs/xine-lib-1.1.17', 'merge')
    (and 9 more)

  ('ebuild', '/', 'x11-proto/xf86vidmodeproto-2.3', 'merge') pulled in by
    x11-proto/xf86vidmodeproto required by ('ebuild', '/', 'kde-base/kdialog-4.3.4', 'merge')
    x11-proto/xf86vidmodeproto required by ('ebuild', '/', 'media-libs/xine-lib-1.1.17', 'merge')
    x11-proto/xf86vidmodeproto required by ('ebuild', '/', 'kde-base/kmimetypefinder-4.3.4', 'merge')
    (and 85 more)

  ('installed', '/', 'x11-libs/libXinerama-1.0.3', 'nomerge') pulled in by
    x11-libs/libXinerama required by ('ebuild', '/', 'kde-base/systemsettings-4.3.4', 'merge')
    x11-libs/libXinerama required by ('ebuild', '/', 'media-libs/xine-lib-1.1.17', 'merge')
    x11-libs/libXinerama required by ('ebuild', '/', 'kde-base/ksplash-4.3.4', 'merge')
    (and 12 more)

  ('installed', '/', 'x11-libs/libXxf86vm-1.0.2', 'nomerge') pulled in by
    x11-libs/libXxf86vm required by ('ebuild', '/', 'kde-base/kcmshell-4.3.4', 'merge')
    x11-libs/libXxf86vm required by ('installed', '/', 'x11-libs/wxGTK-2.8.10.1-r1', 'nomerge')
    x11-libs/libXxf86vm required by ('installed', '/', 'net-p2p/ktorrent-3.2.3-r1', 'nomerge')
    (and 98 more)

  ('ebuild', '/', 'x11-proto/xf86dgaproto-2.1', 'merge') pulled in by
    >=x11-proto/xf86dgaproto-2.0.99.1 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.4', 'merge')


Bitte bitte helft mir. Das System läuft schon seit Jahren, bisher hab ich es immer selbst hingekriegt. Aber hier hänge ich fest!
_________________
I could be arguing on my own time.


Last edited by Karsten1973 on Sat Jan 23, 2010 7:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3668
Location: Germany

PostPosted: Thu Jan 21, 2010 7:30 pm    Post subject: Reply with quote

Hi
Quote:
Ich hatte meinen Desktop-Computer fast ein halbes Jahr vom Netz.

dann hast du vermutlich auch noch nicht das libxcb-1.4-upgrade durch ?
siehe hierzu:
http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml

Aktualisiere doch ansonsten erst mal das Grundsystem, zb via "emerge -avuDN system"
und bring das in Ordnung.
Ansonsten poste doch bitte auch deinen eingegebenen Befehl der ausgaben mit..
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Thu Jan 21, 2010 7:58 pm    Post subject: Reply with quote

Ich hab einfach mal
Code:
emerge -uNDav system


probiert:

Quote:
sys-libs/timezone-data-2009u 369 kB
sys-apps/sysvinit-2.86-r10
x11-proto/xf86vidmodeproto-2.3
x11-libs/libXi-1.3
x11-proto/fixesproto-4.1.1
x11-apps/xauth-1.0.4
sys-apps/man-pages-3.23
sys-fs/udev-146-r1
media-libs/mesa-7.5.2
dev-libs/DirectFB-1.4.2
media-libs/libsdl-1.2.13-r1
sys-apps/sysvinit-2.86-r11
("<sys-apps/sysvinit-2.86-r11" is blocking sys-apps/openrc-0.4.3-r3)
("<x11-libs/libXxf86vm-1.0.99.1" is blocking x11-proto/xf86vidmodeproto-2.3)

Total: 11 packages (7 upgrades, 1 downgrade, 2 new, 1 reinstall), Size of downloads: 9,710 kB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

('installed', '/', 'x11-libs/libXxf86vm-1.0.2', 'nomerge') pulled in by
x11-libs/libXxf86vm required by ('ebuild', '/', 'media-libs/mesa-7.5.2', 'merge')

('installed', '/', 'sys-apps/openrc-0.4.3-r3', 'nomerge') pulled in by
sys-apps/openrc required by ('installed', '/', 'sys-apps/baselayout-2.0.1', 'nomerge')

('ebuild', '/', 'sys-apps/sysvinit-2.86-r10', 'merge') pulled in by
>=sys-apps/sysvinit-2.86-r6 required by ('installed', '/', 'virtual/init-0', 'nomerge')
>=sys-apps/sysvinit-2.86-r6 required by ('installed', '/', 'sys-apps/openrc-0.4.3-r3', 'nomerge')

('ebuild', '/', 'x11-proto/xf86vidmodeproto-2.3', 'merge') pulled in by
x11-proto/xf86vidmodeproto required by ('ebuild', '/', 'media-libs/mesa-7.5.2', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3668
Location: Germany

PostPosted: Thu Jan 21, 2010 8:21 pm    Post subject: Reply with quote

Na das schaut doch erst mal etwas übersichtlicher aus... :wink:

Zu
Code:
sys-apps/sysvinit-2.86-r11
("<sys-apps/sysvinit-2.86-r11" is blocking sys-apps/openrc-0.4.3-r3)
Wenn du baselayout-2 mit OpenRC nutzen möchtest, dann wirst du wohl noch "sys-apps/sysvinit" aus dem Testing Zweig demaskieren müssen.
Wenn du auf OpenRC wechselst beachte bitte unbedingt den Migration Leitfaden :!:
http://www.gentoo.org/doc/de/openrc-migration.xml

Zu
Code:
("<x11-libs/libXxf86vm-1.0.99.1" is blocking x11-proto/xf86vidmodeproto-2.3)
Beachte Version "xf86vidmodeproto-2.3" ist aus dem Testing Zweig
wenn du da ansonsten ein Stable System hast solltest du mit Xorg und deren Abhängigkeiten auch im Stable Zweig bleiben, eine Mischung wird hier zu zahlreichen Blocks führen.
Vermutlich hast du da einzelne Pakete demaskiert (zb xf86vidmodeproto-2.3) , nimm die aus der package.keywords raus, dann sollte es problemlos klappen.
(vergiss aber nicht das libxcb-1.4-upgrade ! )
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Thu Jan 21, 2010 8:25 pm    Post subject: Reply with quote

Danke für die Hilfe. libxcb war bei mir kein Problem, da war alles okay. Ich hab den Leitfaden abgeklappert, dennoch alles gut.

Mit der Freigabe von sysvinit hab ich einen Block weg. Jetzt geh ich mal alles was nach xorg aussieht in meiner package.keywords kommentieren und melde mich dann wieder!
_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Thu Jan 21, 2010 8:29 pm    Post subject: Reply with quote

So, durch das auskommentieren von allem, was wie Xorg aussieht, hab ich die Blocker in system weg. Das Hauptproblem war wohl, dass ich - weil ich mittelfristig wieder stable werden will - in meiner package.keywords <=konkretes Packet nutze. Und hier war ein aktuelleres, instabiles sysvinit von nöten.

Wenn system kompiliert hat, gucke ich mir mal world an... und melde mich.
_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Thu Jan 21, 2010 9:06 pm    Post subject: Reply with quote

Zu meiner Verblüfffung ist ein revdep-rebuild durchgelaufen. Er will 54 Einträge neu kompilieren. Davon erhoffe ich mir natürlich eine Menge. Noch startet X nicht...

Ich meld mich dann morgen zurück. Bis dahin vielen Dank an alle, die geholfen haben!
_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Thu Jan 21, 2010 9:19 pm    Post subject: Reply with quote

Letzter Post für heute - die Blocks aus emerge -uNDav world, jetzt wo system schon läuft, X aber noch nicht:

Quote:
!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-emulation/emul-linux-x86-xlibs:0

('installed', '/', 'app-emulation/emul-linux-x86-xlibs-20091231', 'nomerge') pulled in by
~app-emulation/emul-linux-x86-xlibs-20091231 required by ('installed', '/', 'app-emulation/emul-linux-x86-medialibs-20091231', 'nomerge')
~app-emulation/emul-linux-x86-xlibs-20091231 required by ('installed', '/', 'app-emulation/emul-linux-x86-sdl-20091231', 'nomerge')
~app-emulation/emul-linux-x86-xlibs-20091231 required by ('installed', '/', 'app-emulation/emul-linux-x86-qtlibs-20091231', 'nomerge')
(and 7 more)

('ebuild', '/', 'app-emulation/emul-linux-x86-xlibs-20081109', 'merge') pulled in by
=app-emulation/emul-linux-x86-xlibs-20081109 required by ('installed', '/', 'app-emulation/emul-linux-x86-gtklibs-20081109', 'nomerge')
(and 6 more)

net-fs/samba:0

('ebuild', '/', 'net-fs/samba-3.0.37', 'merge') pulled in by
=net-fs/samba-3.0* required by ('ebuild', '/', 'kde-base/kdebase-kioslaves-4.3.4', 'merge')
(and 7 more)

('ebuild', '/', 'net-fs/samba-3.3.10', 'merge') pulled in by
net-fs/samba required by ('ebuild', '/', 'media-video/mplayer-1.0_rc4_p20091026-r1', 'merge')
>=net-fs/samba-3.0.8 required by ('installed', '/', 'net-print/cups-1.3.11-r1', 'nomerge')
net-fs/samba required by world
(and 4 more)

app-emulation/emul-linux-x86-baselibs:0

('ebuild', '/', 'app-emulation/emul-linux-x86-baselibs-20091231', 'merge') pulled in by
~app-emulation/emul-linux-x86-baselibs-20091231 required by ('installed', '/', 'app-emulation/emul-linux-x86-xlibs-20091231', 'nomerge')
~app-emulation/emul-linux-x86-baselibs-20091231 required by ('installed', '/', 'app-emulation/emul-linux-x86-medialibs-20091231', 'nomerge')
~app-emulation/emul-linux-x86-baselibs-20091231 required by ('installed', '/', 'app-emulation/emul-linux-x86-sdl-20091231', 'nomerge')
(and 9 more)

('installed', '/', 'app-emulation/emul-linux-x86-baselibs-20081109', 'nomerge') pulled in by
=app-emulation/emul-linux-x86-baselibs-20081109 required by ('ebuild', '/', 'app-emulation/emul-linux-x86-xlibs-20081109', 'merge')
=app-emulation/emul-linux-x86-baselibs-20081109 required by ('installed', '/', 'app-emulation/emul-linux-x86-gtklibs-20081109', 'nomerge')
(and 6 more)



_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2229
Location: Germany

PostPosted: Fri Jan 22, 2010 12:50 am    Post subject: Reply with quote

Hallo Karsten1973,

also bei diesen Paketen app-emulation/emul-linux-x86-baselibs-20081109 kommst du ganz leicht weiter, indem du deine installierten Pakete entfernst und in der aktuellen Version mit emerge installierst.

Also einfach
emerge -C emul-linux-x86-baselibs emul-linux-x86-xlibs emul-linux-x86-sdl emul-linux-x86-gtklibs emul-linux-x86-medialibs
... aber hier solltest du auch auch noch die anderen 9 oder 6 Pakete entfernen und neu installieren. Sofern es sich dabei um diese emul-linux-x86.. handelt.

Naja und mit Samba musste einfach mal schauen was du da machst, vermute aber das das auch einfach updaten kannst indem du die alte Version vorher entfernst.

Hast du das X-Update noch mitgemacht, wo die xorg.conf Konfigurations-Datei "verschwindet"*? Wenn nicht solltest dir vorher einprägen wie eine Englische Tastatur aussieht (für den Notfall) und unbedingt einen Blick in die Dokumentation werfen, als auch hier im Forum zu dem Thema den ein oder anderen Thread lesen. Weil man für das Keyboard+Maus eine hal-policy-Datei anlegen sollte (sonnst bekommt man ein Amerikanisches Tastatur-Layout). Ausserdem muss man die Treiber dafür emergen.. und darauf achten das sie bei einem neubau/Versionssprung vom X-Server auch neu compiliert werden, weil dieser sonst Probleme hat die Module zu laden, und wenn das nicht geht kann es passieren das Gentoo + X zwar starten, aber man weder Tastaur noch Maus benutzen kann!

xorg-server-1.6-upgrade-guide.xml

Code:
$ cat /etc/hal/fdi/policy/10-xinput-configuration.fdi
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
<device>
   <match key="info.capabilities" contains="input.keyboard">
      <merge key="input.x11_options.XkbDriver" type="string">evdev</merge>
      <merge key="input.x11_options.XkbModel" type="string">evdev</merge>
      <merge key="input.x11_options.XkbProtocol" type="string">evdev</merge>
      <merge key="input.x11_options.XkbLayout" type="string">de</merge>
      <merge key="input.x11_options.XkbRules" type="string">xorg</merge>
      <merge key="input.x11_options.xkbOptions" type="string">terminate:ctrl_alt_bksp</merge>
   </match>

   <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">evdev</merge>
      <merge key="input.x11_options.Protocol" type="string">evdev</merge>
      <merge key="input.x11_options.CorePointer">true</merge>
   </match>

 </device>
</deviceinfo>


Als Beispiel zu meiner Konfiguration, hier den entsprechende Treiber:

Code:

eix evdev
[I] x11-drivers/xf86-input-evdev
     Available versions:  2.1.3 ~2.2.2 2.2.5 2.3.1 ~2.3.2 {debug hal}
     Installed versions:  2.3.1(17:23:02 16.01.2010)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         Generic Linux input driver


Grüße

Chris

*wenn man Hal benutzt.
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3495

PostPosted: Fri Jan 22, 2010 8:52 am    Post subject: Reply with quote

Kann nur empfehlen: Nach größeren Updates vorsichtshalber abschliessend immer ein revdep-rebuild aus app-portage/gentoolkit ausführen.
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2050
Location: My own world! I and Gentoo!

PostPosted: Fri Jan 22, 2010 12:29 pm    Post subject: Reply with quote

Und bei xorg würde ich trotz allem hal-geraffel dafür plädieren die xorg.conf zu behalten und nur die Maus/Tastatur Configuration über hal laufen zu lassen (also das Server-Layout sowie die Eingabegeräte-configuration auskommentieren) und die Treibercofiugration für Grafik in der xorg.conf stehen nzu lassen.

funktioniert zuhause hervorragend.

Ich widme mich wieder meiner Arbeit ^^
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Fri Jan 22, 2010 6:23 pm    Post subject: Reply with quote

Meine Herren,

danke erstmal. Ich hab die 54 Pakete, die revdep kompilieren wollte, heute mal gestartet. ist natürlich abgebrochen, ich versuche jetzt erstmal den Rest hinzubekommen.

Vorab eine Frage:

Code:
startx


erzeugt bei mir als Fehler, dass die Module "freetype, dri und dri2" nicht geladen werden können.

Was muss ich da tun?
_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2050
Location: My own world! I and Gentoo!

PostPosted: Fri Jan 22, 2010 7:11 pm    Post subject: Reply with quote

Die gleichen Fehlermeldungen bekomm ich auch...
dri sowie dri2 werden vom Grafiktreiber mitgeliefert wenn man den nvidia bzw. ati Treiber aus den zugehörigen Paketen nutzt. (nvidia-drivers aka ati-drivers)
freetype gibt es wohl einfach nicht mehr, keine Ahnung, bei mir kommt da der gleiche Fehler.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Fri Jan 22, 2010 9:14 pm    Post subject: Reply with quote

läuft X denn bei dir?
_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2050
Location: My own world! I and Gentoo!

PostPosted: Fri Jan 22, 2010 10:18 pm    Post subject: Reply with quote

Jupp.

/etc/X11/xorg.conf --> http://nopaste.info/55c6e35d41.html
/etc/hal/fdi/policy/10-x11-input.fdi --> http://nopaste.info/ef85822077.html

Hoffe dir hilfts ^^

Achja hab ne NVidia GraKa, falls es dich interessiert.

Aber das gleiche Schema kannst du auch mit allen anderen GraKas nutzen.
Aber man kann davon ausgehen das X die GraKa-Einstellungen für andere KArten als ATI/Nvidia selbst passend findet, bzw für alle Open-Source X11-GraKa-Treiber
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3668
Location: Germany

PostPosted: Fri Jan 22, 2010 10:25 pm    Post subject: Reply with quote

Karsten, vergiss doch erst mal das X "Problem"
Ich würde erst mal versuchen das komplette world Update und ein sauberes "revdep-rebuild" durchzubringen...

Evtl. wäre für weitere Hilfe auch deine "emerge --info" Ausgabe hilfreich.
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Fri Jan 22, 2010 11:29 pm    Post subject: Reply with quote

@Josef.95: Weißt du wie lästig das ist, ohne X googlen zu müssen? Das war mich echt wichtig.

Zwischenstand:

Ich hab ein xfce zu laufen bekommen, kde noch nicht.

Weder revdep noch emerge -uNDav world laufen durch, ich habe noch blocker... unter anderem kde-libs.

Aber ich taste mich jetzt langsam an die Sache ran, habe schon so 30-40 Paket kompliliert bekommen. Mal sehen, wo ich hängen bleibe.

Bis dahin erstmal vielen Dank!
_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Fri Jan 22, 2010 11:40 pm    Post subject: Reply with quote

beim revdeppen:

Quote:
/var/tmp/portage/kde-base/ksysguard-4.3.4/work/ksysguard-4.3.4/ksysguard/gui/Wor
kspace.cc:151: Warnung: unbenutzter Parameter »index«
/var/tmp/portage/kde-base/ksysguard-4.3.4/work/ksysguard-4.3.4/ksysguard/gui/Wor
kspace.cc:151: Warnung: unbenutzter Parameter »point«
Linking CXX shared library ../../lib/libkdeinit4_ksysguard.so
[ 98%] Built target kdeinit_ksysguard
Scanning dependencies of target ksysguard
[100%] Building CXX object ksysguard/gui/CMakeFiles/ksysguard.dir/ksysguard_dumm
y.o
Linking CXX executable ksysguard
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/../../../../x86_64-pc-linux-gnu/bin/ld: w
arning: libQtOpenGL.so.4, needed by /usr/lib64/libplasma.so.3.0.0, not found (tr
y using -rpath or -rpath-link)
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLPixelBuffer::format()
const'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLWidget::bindTexture(QI
mage const&, unsigned int, int)'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLPixelBuffer::QGLPixelB
uffer(int, int, QGLFormat const&, QGLWidget*)'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLFormat::~QGLFormat()'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLPixelBuffer::makeCurre
nt()'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLWidget::makeCurrent()'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLPixelBuffer::toImage()
const'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLWidget::deleteTexture(
unsigned int)'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLFormat::setAlphaBuffer
Size(int)'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLPixelBuffer::QGLPixelB
uffer(QSize const&, QGLFormat const&, QGLWidget*)'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLFormat::setSampleBuffe
rs(bool)'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLWidget::QGLWidget(QWid
get*, QGLWidget const*, QFlags<Qt::WindowType>)'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLWidget::isValid() cons
t'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLFormat::defaultFormat(
)'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLPixelBuffer::isValid()
const'
/usr/lib64/libplasma.so.3.0.0: undefined reference to `QGLPixelBuffer::hasOpenGL
Pbuffers()'
collect2: ld gab 1 als Ende-Status zurück
make[2]: *** [ksysguard/gui/ksysguard] Fehler 1
make[1]: *** [ksysguard/gui/CMakeFiles/ksysguard.dir/all] Fehler 2
make: *** [all] Fehler 2
*
* ERROR: kde-base/ksysguard-4.3.4 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 4130: Called kde4-meta_src_compile
* environment, line 3230: Called kde4-base_src_compile
* environment, line 2898: Called cmake-utils_src_compile
* environment, line 1053: Called _execute_optionaly 'src_compile'
* environment, line 482: Called enable_cmake-utils_src_compile
* environment, line 1422: Called cmake-utils_src_make
* environment, line 1072: Called die
* The specific snippet of code:
* emake "$@" || die "Make failed!";
* The die message:
* Make failed!

_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Sat Jan 23, 2010 12:14 am    Post subject: Reply with quote

So, jetzt hänge ich wieder fest. Revdep will - egal wie ich es drehe - kdelibs rekomplilieren. Es bricht mit der folgenden Meldung ab:

Quote:
[ 78%] Building CXX object plasma/CMakeFiles/plasma.dir/widgets/webview.o
[ 78%] Building CXX object plasma/CMakeFiles/plasma.dir/glapplet.o
[ 78%] Built target file-handbook
make[2]: *** Keine Regel vorhanden, um das Target »/usr/lib64/qt4/libQtOpenGL.so«,
benötigt von »lib/libplasma.so.3.0.0«, zu erstellen. Schluss.
make[2]: *** Warte auf noch nicht beendete Prozesse...
[ 78%] Building CXX object plasma/CMakeFiles/plasma.dir/widgets/videowidget.o
Scanning dependencies of target help-handbook
[ 78%] Generating index.cache.bz2
make[1]: *** [plasma/CMakeFiles/plasma.dir/all] Fehler 2
make[1]: *** Warte auf noch nicht beendete Prozesse...
[ 78%] Built target ftp-handbook
[ 78%] Built target help-handbook
make: *** [all] Fehler 2
*
* ERROR: kde-base/kdelibs-4.3.4 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3778: Called kde4-base_src_compile
* environment, line 2869: Called cmake-utils_src_compile
* environment, line 1010: Called _execute_optionaly 'src_compile'
* environment, line 429: Called enable_cmake-utils_src_compile
* environment, line 1379: Called cmake-utils_src_make
* environment, line 1029: Called die
* The specific snippet of code:
* emake "$@" || die "Make failed!";
* The die message:
* Make failed!
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.3.4/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.3.4/temp/environment'.
*

>>> Failed to emerge kde-base/kdelibs-4.3.4, Log file:

>>> '/var/tmp/portage/kde-base/kdelibs-4.3.4/temp/build.log'

* Messages for package kde-base/kdelibs-4.3.4:

*
* ERROR: kde-base/kdelibs-4.3.4 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3778: Called kde4-base_src_compile
* environment, line 2869: Called cmake-utils_src_compile
* environment, line 1010: Called _execute_optionaly 'src_compile'
* environment, line 429: Called enable_cmake-utils_src_compile
* environment, line 1379: Called cmake-utils_src_make
* environment, line 1029: Called die
* The specific snippet of code:
* emake "$@" || die "Make failed!";
* The die message:
* Make failed!
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.3.4/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.3.4/temp/environment'.
*

* Regenerating GNU info directory index...
* Processed 137 info files.
* revdep-rebuild failed to emerge all packages.
* you have the following choices:
* - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
* - Use /etc/portage/package.keywords to unmask a newer version of the package.
* (and remove 5_order.rr to be evaluated again)
* - Modify the above emerge command and run it manually.
* - Compile or unmerge unsatisfied packages manually,
* remove temporary files, and try again.
* (you can edit package/ebuild list first)
* To remove temporary files, please run:
* rm /var/cache/revdep-rebuild/*.rr


Hat jemand eine Idee?
_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3668
Location: Germany

PostPosted: Sat Jan 23, 2010 12:37 am    Post subject: Reply with quote

Quote:
Zwischenstand:

Ich hab ein xfce zu laufen bekommen, kde noch nicht.

Weder revdep noch emerge -uNDav world laufen durch, ich habe noch blocker... unter anderem kde-libs.
Na dann sollte X doch laufen, sonnst würde xfce4 ja nicht funken.

Ich würde da zuerst mal die Blocks beseitigen,
bei den "app-emulation/*" Paketen kann ich aber kaum weiterhelfen, habe ich noch nie genutzt.
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Sat Jan 23, 2010 12:37 pm    Post subject: Reply with quote

Ja, X läuft, wie du schon ganz richtig bemerktest, kde4 aber noch nicht. Mit xfce hab ich immerhin eine grafische Oberfläche. Jetzt läuft auch firefox wieder... ein echter Fortschritt.

Blocker scheine ich nicht mehr zu haben. Jetzt kämpfe ich nur noch mit nicht komplilierbaren Paketen.

Dazu gehören kdelibs und ksysguard (jeweils 4.3.4).

Sagen irgendjemand die Fehlermeldungen was sinnvolles?
_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sat Jan 23, 2010 12:53 pm    Post subject: Reply with quote

Welche QT Version hast du?
x11-libs/qt-opengl-4.5.3-r1 brauchst du, um den vorletzten Fehler zu beheben.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2050
Location: My own world! I and Gentoo!

PostPosted: Sat Jan 23, 2010 12:54 pm    Post subject: Reply with quote

Hmmm, kannst du uns mal die komplette build.log gnopasten? soll heißen:
cat /var/tmp/portage/kde-base/kdelibs-4.3.4/temp/build.log | gnopaster
(Von allen Paketen wo du akut Fehler findest.
(Gibt auch andere nopaste Dienste.)

wie sieht deine aktuelle make.conf aus?
cat /etc/make.conf | gnopaster

Mit qt-4.6 läufts auch.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Sat Jan 23, 2010 1:03 pm    Post subject: Reply with quote

Nach etwas gezielten hinzufügen von Paketen hat sich die Fehlermeldung von kdelibs geändert:

Quote:
[ 77%] Building CXX object plasma/CMakeFiles/plasma.dir/widgets/webview.o
/var/tmp/portage/kde-base/kdelibs-4.3.4/work/kdelibs-4.3.4/kate/tests/completiontest.cpp: In member function »void CompletionTest::testAbortImmideatelyAfterStart()«:
/var/tmp/portage/kde-base/kdelibs-4.3.4/work/kdelibs-4.3.4/kate/tests/completiontest.cpp:447: Warnung: Variable »model« wird nicht verwendet
/var/tmp/portage/kde-base/kdelibs-4.3.4/work/kdelibs-4.3.4/kate/tests/completiontest.cpp:449: Warnung: Variable »testModel« wird nicht verwendet
[ 77%] Linking CXX executable testkateregression
Building CXX object plasma/CMakeFiles/plasma.dir/glapplet.o
make[2]: *** Keine Regel vorhanden, um das Target »/usr/lib64/qt4/libQtOpenGL.so«,
benötigt von »lib/libplasma.so.3.0.0«, zu erstellen. Schluss.
make[2]: *** Warte auf noch nicht beendete Prozesse...
[ 77%] Building CXX object plasma/CMakeFiles/plasma.dir/widgets/videowidget.o
Scanning dependencies of target file-handbook
[ 77%] Generating index.cache.bz2
make[1]: *** [plasma/CMakeFiles/plasma.dir/all] Fehler 2
make[1]: *** Warte auf noch nicht beendete Prozesse...
[ 78%] Built target testkateregression
[ 78%] Built target file-handbook
make: *** [all] Fehler 2
*
* ERROR: kde-base/kdelibs-4.3.4 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3778: Called kde4-base_src_compile
* environment, line 2869: Called cmake-utils_src_compile
* environment, line 1010: Called _execute_optionaly 'src_compile'
* environment, line 429: Called enable_cmake-utils_src_compile
* environment, line 1379: Called cmake-utils_src_make
* environment, line 1029: Called die
* The specific snippet of code:
* emake "$@" || die "Make failed!";
* The die message:
* Make failed!
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.3.4/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.3.4/temp/environment'.
*

>>> Failed to emerge kde-base/kdelibs-4.3.4, Log file:

_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Karsten1973
Apprentice
Apprentice


Joined: 17 Dec 2004
Posts: 298
Location: Berlin, Germany

PostPosted: Sat Jan 23, 2010 1:04 pm    Post subject: Reply with quote

Finswimmer wrote:
Welche QT Version hast du?
x11-libs/qt-opengl-4.5.3-r1 brauchst du, um den vorletzten Fehler zu beheben.

Tobi

Danke - hab ich!
_________________
I could be arguing on my own time.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum