Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
revdep-rebuild und /usr/lib/libGL.la
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
hitachi
Guru
Guru


Joined: 20 Feb 2006
Posts: 472
Location: Freiburg / Deutschland

PostPosted: Mon Jan 25, 2010 4:22 pm    Post subject: revdep-rebuild und /usr/lib/libGL.la Reply with quote

Hallo zusammen,

ich habe folgendes Problem:

Code:
revdep-rebuild -iv -- --ask


Quote:

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Generated new 2_ldpath.rr
* Checking dynamic linking consistency
[ 69% ] * broken /usr/lib/libGL.la (requires -lSM)
* broken /usr/lib/libGL.la (requires -lICE)
* broken /usr/lib/libGL.la (requires -lXmu)
* broken /usr/lib/libGL.la (requires -lXt)
* broken /usr/lib/libGL.la (requires -lXext)
* broken /usr/lib/libGL.la (requires -lXi)
* broken /usr/lib/libGL.la (requires -lX11)
[ 100% ]
* Generated new 3_broken.rr
* Assigning files to packages
* !!! /usr/lib/libGL.la not owned by any package is broken !!!
* /usr/lib/libGL.la -> (none)
* Generated new 4_raw.rr and 4_owners.rr
* Found some broken files, but none of them were associated with known packages
* Unable to proceed with automatic repairs.
* The broken files are listed in 4_owners.rr
* The broken files are:
* /usr/lib/libGL.la


Die Lib gehört doch zu opengl, oder? Das hat etwas mit Computergrofik zu tun. Auf jeden Fall ist das auf meinem Server und der hat keinen Monitor und kein X.
Wie kann ich das Problem beheben. Kann ich die Datei löschen, oder werde ich dann Probleme bekommen?

Danke für die Antworten.
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Mon Jan 25, 2010 5:38 pm    Post subject: Reply with quote

gehört zu eselect-opengl

führ mal

lafilefixer --justfixit


solltest du das noch nicht installiert haben: emerge lafilefixer
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6290

PostPosted: Mon Jan 25, 2010 5:50 pm    Post subject: Re: revdep-rebuild und /usr/lib/libGL.la Reply with quote

hitachi wrote:
Kann ich die Datei löschen, oder werde ich dann Probleme bekommen?

Lösch die Datei. Die hat vermutlich irgendeine alte Version von eselect-opengl mal erzeugt; überflüssig wie ein Kropf.
Back to top
View user's profile Send private message
hitachi
Guru
Guru


Joined: 20 Feb 2006
Posts: 472
Location: Freiburg / Deutschland

PostPosted: Mon Jan 25, 2010 8:17 pm    Post subject: Reply with quote

ScytheMan wrote:
führ mal

lafilefixer --justfixit


Das hat das Problem nicht behoben. Ich habe es jetzt einfach mal gelöscht. Mal schauen was passiert.
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Mon Jan 25, 2010 10:33 pm    Post subject: Reply with quote

http://archives.gentoo.org/gentoo-dev/msg_3fea6303ab4056b7fb24ae1ad1c5d7a1.xml
in dem thread wurde das problem glaub ich diskutiert.

hast du eselect-opengl-1.1.1-r2 installiert?
Back to top
View user's profile Send private message
hitachi
Guru
Guru


Joined: 20 Feb 2006
Posts: 472
Location: Freiburg / Deutschland

PostPosted: Tue Jan 26, 2010 8:27 am    Post subject: Reply with quote

Nein, habe ich nicht.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum