Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -pvDt world ? (SOLVED)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
sogwp
n00b
n00b


Joined: 21 Jan 2010
Posts: 20
Location: sullivan mo usa

PostPosted: Fri Jan 29, 2010 3:27 pm    Post subject: emerge -pvDt world ? (SOLVED) Reply with quote

SOLVED IT BY DOING A RE-INSTALL OF EVERY THING WIPE OUT EVERY THING DELETE IT ALL
Thank you for the help I am still very new the fix for me was start over

would some one advise on what i need to do Thank you
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-dbus:4

('ebuild', '/', 'x11-libs/qt-dbus-4.5.3-r1', 'merge') pulled in by
~x11-libs/qt-dbus-4.5.3[debug] required by ('ebuild', '/', 'x11-libs/qt-webkit-4.5.3-r1', 'merge')
~x11-libs/qt-dbus-4.5.3[debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.3-r2', 'merge')

('installed', '/', 'x11-libs/qt-dbus-4.5.3-r1', 'nomerge') pulled in by
>=x11-libs/qt-dbus-4.4.0:4 required by ('ebuild', '/', 'media-sound/phonon-4.3.50_pre20090520', 'merge')
=x11-libs/qt-dbus-4.5*:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge')

x11-libs/qt-core:4

('ebuild', '/', 'x11-libs/qt-core-4.5.3-r2', 'merge') pulled in by
~x11-libs/qt-core-4.5.3[debug,qt3support] required by ('ebuild', '/', 'x11-libs/qt-opengl-4.5.3-r1', 'merge')
~x11-libs/qt-core-4.5.3[debug] required by ('ebuild', '/', 'x11-libs/qt-dbus-4.5.3-r1', 'merge')
~x11-libs/qt-core-4.5.3[ssl,debug] required by ('ebuild', '/', 'x11-libs/qt-webkit-4.5.3-r1', 'merge')
(and 4 more)

('installed', '/', 'x11-libs/qt-core-4.5.3-r2', 'nomerge') pulled in by
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/knotify-4.3.3', 'merge')
=x11-libs/qt-core-4.5*:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge')
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/solid-4.3.3', 'merge')
(and 157 more)

dev-python/PyQt4:0

('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge') pulled in by
>=dev-python/PyQt4-4.5[dbus,sql,svg,webkit,X] required by ('ebuild', '/', 'kde-base/pykde4-4.3.3', 'merge')
dev-python/PyQt4:0

('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge') pulled in by
dev-python/PyQt4:0


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously. You may want to try a larger value of the
--backtrack option, such as --backtrack=30, in order to see if that will
solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/qt-sql-4.5.0:4[sqlite,mysql]".
!!! One of the following packages is required to complete your request:
- x11-libs/qt-sql-4.5.3 (Change USE: +mysql)
(dependency required by "app-office/akonadi-server-1.2.1" [ebuild])
(dependency required by "app-office/akonadi-server:0" [argument])


* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

*
* revdep-rebuild failed to emerge all packages.
* you have the following choices:
* - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
* - Use /etc/portage/package.keywords to unmask a newer version of the package.
* (and remove 5_order.rr to be evaluated again)
* - Modify the above emerge command and run it manually.
* - Compile or unmerge unsatisfied packages manually,
* remove temporary files, and try again.
* (you can edit package/ebuild list first)
*
* To remove temporary files, please run:
* rm /var/cache/revdep-rebuild/*.rr
* Found some broken files that weren't associated with known packages
* The broken files are:
* /usr/lib/qt4/plugins/designer/libpythonplugin.so
localhost sogwp # emerge -pvDt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild R ] sys-kernel/gentoo-sources-2.6.31-r6 USE="symlink -build" 0 kB
[ebuild R ] sys-devel/gcc-4.3.4 USE="fortran gtk mudflap nls nptl openmp -altivec -bootstrap -build -doc (-fixed-point) -gcj (-hardened) (-libffi) (-multilib) -multislot (-n32) (-n64) -nocxx -nopie -objc -objc++ -objc-gc -test -vanilla" 0 kB
[ebuild R ] sys-fs/udev-146-r1 USE="devfs-compat -extras (-selinux)" 0 kB
[ebuild R ] sys-libs/glibc-2.10.1-r1 USE="debug* nls -gd -glibc-omitfp (-hardened) (-multilib) -profile (-selinux) -vanilla" 0 kB
[ebuild R ] x11-misc/xac-0.6_pre4 USE="-livecd" 0 kB
[ebuild R ] x11-base/xorg-x11-7.2 0 kB
[ebuild R ] sys-apps/pmount-0.9.20 USE="crypt hal" 0 kB
[ebuild R ] x11-base/xorg-server-1.6.5-r1 USE="debug* hal ipv6 nptl xorg -dmx -kdrive -minimal -sdl -tslib" 0 kB
[ebuild R ] sys-apps/hal-0.5.13-r2 USE="X consolekit crypt debug* (-acpi) -apm (-dell) -disk-partition -doc (-laptop) -policykit (-selinux)" 0 kB
[ebuild R ] www-client/mozilla-firefox-3.5.6 USE="alsa dbus gnome java sqlite -bindist -custom-optimization -iceweasel -mozdevelop -startup-notification" LINGUAS="-af -ar -as -be -bg -bn -bn_BD -bn_IN -ca -cs -cy -da -de -el -en -en_GB -en_US -eo -es -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -id -is -it -ja -ka -kk -kn -ko -ku -lt -lv -mk -ml -mn -mr -nb -nb_NO -nl -nn -nn_NO -oc -or -pa -pa_IN -pl -pt -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW" 0 kB
[ebuild R ] www-plugins/swfdec-mozilla-0.8.2 0 kB
[ebuild R ] gnome-base/gnome-2.26.3 USE="cups -accessibility -cdr -dvdr -esd -ldap (-mono)" 0 kB
[ebuild R ] xfce-extra/xfce4-mixer-4.6.1 USE="debug* -alsa -oss" 0 kB
[ebuild R ] net-print/xfprint-4.6.1 USE="cups debug*" 0 kB
[ebuild R ] app-cdr/gnomebaker-0.6.4 USE="-dvdr -flac -libnotify -mp3 -vorbis" 0 kB
[ebuild R ] xfce-extra/xfce4-screenshooter-1.6.0 USE="debug* -zimagez" 0 kB
[ebuild R ] net-libs/gtk-vnc-0.3.8-r1 USE="python -examples" 0 kB
[ebuild R ] app-text/evince-2.26.2 USE="dbus debug* tiff -djvu -doc -dvi -gnome-keyring -nautilus -t1lib" 0 kB
[ebuild R ] media-libs/swfdec-0.8.4 USE="gtk -alsa -doc -ffmpeg -gstreamer -pulseaudio" 0 kB
[ebuild R ] gnome-base/gdm-2.20.10-r2 USE="consolekit debug* ipv6 pam tcpd xinerama -accessibility -afs -branding -dmx -gnome-keyring -remote (-selinux)" 0 kB
[ebuild R ] x11-wm/metacity-2.26.0-r1 USE="debug* xinerama -test" 0 kB
[ebuild R ] net-print/cups-1.3.11-r1 USE="X acl avahi dbus java jpeg pam perl png python samba ssl tiff -gnutls -kerberos -ldap -php -ppds -slp -static -xinetd -zeroconf" LINGUAS="-de -en -es -et -fr -he -id -it -ja -pl -sv -zh_TW" 0 kB
[ebuild R ] net-dns/avahi-0.6.24-r2 USE="dbus gdbm gtk ipv6 mdnsresponder-compat python qt4* -autoipd -bookmarks -doc -howl-compat (-mono) -test" 0 kB
[ebuild R ] x11-libs/gtk+-2.16.6 USE="cups debug* jpeg tiff xinerama -doc -jpeg2k -test -vim-syntax" 0 kB
[ebuild R ] xfce-base/xfce4-meta-4.6.1 USE="session -minimal" 0 kB
[ebuild R ] x11-themes/xfwm4-themes-4.6.0 0 kB
[ebuild R ] app-misc/mc-4.7.0_pre3 USE="X edit gpm nls samba -slang" 0 kB
[ebuild R ] sys-fs/e2fsprogs-1.41.9 USE="nls" 0 kB
[nomerge ] net-dns/avahi-0.6.24-r2 USE="dbus gdbm gtk ipv6 mdnsresponder-compat python qt4* -autoipd -bookmarks -doc -howl-compat (-mono) -test"
[nomerge ] x11-libs/qt-core-4.5.3-r2 USE="debug* glib iconv qt3support ssl (-aqua) -doc -pch"
[nomerge ] x11-libs/qt-gui-4.5.3-r2 USE="accessibility cups dbus debug glib gtk qt3support tiff xinerama (-aqua) -mng -nas -nis -pch -raster"
[ebuild N ] x11-libs/qt-qt3support-4.5.3 USE="accessibility debug kde (-aqua) -pch -phonon" 0 kB
[ebuild N ] x11-libs/qt-sql-4.5.3 USE="debug iconv odbc qt3support sqlite (-aqua) (-firebird) -mysql -pch -postgres" 0 kB
[ebuild R ] app-xemacs/emerge-1.11 0 kB
[ebuild R ] virtual/jdk-1.6.0 0 kB
[ebuild R ] app-portage/gentoolkit-0.2.4.5 0 kB
[ebuild R ] sys-apps/file-5.03 USE="python" 0 kB
[ebuild R ] media-libs/mesa-7.5.2 USE="debug* nptl -motif -pic -xcb" VIDEO_CARDS="(-intel) -mach64 -mga -none -r128 -radeon -radeonhd (-s3virge) (-savage) (-sis) (-sunffb) (-tdfx) (-trident) (-via)" 0 kB
[ebuild R ] x11-libs/cairo-1.8.8 USE="X debug* glitz opengl svg (-aqua) -cleartype (-directfb) -doc -xcb" 0 kB
[ebuild R ] sys-process/vixie-cron-4.1-r10 USE="debug* pam (-selinux)" 0 kB
[ebuild R ] x11-misc/slim-1.3.1-r5 USE="pam -branding -screenshot" 0 kB
[ebuild R ] sys-apps/busybox-1.14.2 USE="debug* pam -make-symlinks -savedconfig (-selinux) -static" 0 kB
[ebuild R ] net-misc/openssh-5.2_p1-r3 USE="X pam tcpd -X509 -hpn -kerberos -ldap -libedit -pkcs11 (-selinux) -skey -smartcard -static" 0 kB
[ebuild R ] sys-apps/shadow-4.1.2.2 USE="cracklib nls pam (-audit) (-selinux) -skey" 0 kB
[ebuild R ] x11-terms/xterm-250 USE="truetype unicode -Xaw3d -toolbar" 0 kB
[ebuild R ] x11-apps/xdm-1.1.8 USE="debug* ipv6 pam" 0 kB
[ebuild R ] sys-apps/ibm-powerpc-utils-1.1.0 0 kB
[ebuild R ] media-sound/alsa-utils-1.0.20-r5 USE="nls -doc -minimal" 0 kB
[ebuild R ] sys-process/psmisc-22.7 USE="X ipv6 nls (-selinux)" 0 kB
[ebuild R ] sys-fs/hfsplusutils-1.0.4-r1 0 kB
[ebuild R ] sys-apps/man-pages-3.23 USE="nls" LINGUAS="-cs -da -de -es -fr -it -ja -nl -pl -ro -ru -zh_CN" 0 kB
[ebuild R ] sys-apps/module-init-tools-3.5 USE="-old-linux" 0 kB
[ebuild R ] sys-apps/baselayout-1.12.13 USE="unicode -bootstrap -build -static" 0 kB
[nomerge ] gnome-base/gnome-2.26.3 USE="cups -accessibility -cdr -dvdr -esd -ldap (-mono)"
[nomerge ] net-misc/vino-2.26.2-r1 USE="avahi crypt ipv6 jpeg zlib -debug -gnome-keyring -gnutls -libnotify"
[ebuild N ] x11-libs/libXtst-1.0.3 USE="debug" 0 kB
[ebuild R ] sys-libs/readline-6.0_p4 0 kB
[nomerge ] x11-libs/qt-qt3support-4.5.3 USE="accessibility debug kde (-aqua) -pch -phonon"
[ebuild N ] x11-libs/qt-gui-4.5.3-r2 USE="accessibility cups dbus debug glib gtk qt3support tiff xinerama (-aqua) -mng -nas -nis -pch -raster" 0 kB
[ebuild N ] x11-libs/libXi-1.2.1 USE="debug" 0 kB
[ebuild R ] sys-devel/libtool-2.2.6b USE="-test -vanilla" 0 kB
[ebuild R ] sys-devel/automake-1.10.2 0 kB
[ebuild R ] sys-apps/man-1.6f-r3 USE="nls -lzma" 0 kB
[nomerge ] x11-libs/qt-gui-4.5.3-r2 USE="accessibility cups dbus debug glib gtk qt3support tiff xinerama (-aqua) -mng -nas -nis -pch -raster"
[ebuild R ] x11-libs/qt-dbus-4.5.3-r1 USE="debug* (-aqua) -pch" 0 kB
[ebuild R ] sys-apps/dbus-1.2.3-r1 USE="X debug* -doc (-selinux)" 0 kB
[ebuild R ] sys-apps/util-linux-2.16.2 USE="crypt nls perl unicode -loop-aes -old-linux (-selinux) -slang (-uclibc)" 0 kB
[ebuild R ] sys-devel/autoconf-2.63-r1 USE="-emacs" 0 kB
[ebuild R ] dev-util/lafilefixer-0.5 0 kB
[ebuild R ] sys-apps/net-tools-1.60_p20090728014017-r1 USE="nls -static" 0 kB
[ebuild R ] sys-apps/diffutils-2.8.7-r2 USE="nls -static" 0 kB
[ebuild R ] sys-apps/kbd-1.15 USE="nls" 0 kB
[ebuild R ] app-arch/tar-1.20 USE="nls -static" 0 kB
[ebuild R ] sys-apps/gawk-3.1.6 USE="nls" 0 kB
[ebuild R ] app-arch/gzip-1.3.12-r1 USE="nls -pic -static" 0 kB
[ebuild R ] net-misc/wget-1.12 USE="debug* ipv6 nls ssl -idn -ntlm -static" 0 kB
[ebuild R ] virtual/editor-0 0 kB
[ebuild R ] sys-devel/binutils-2.19.1-r1 USE="nls -multislot -multitarget -test -vanilla" 0 kB
[ebuild R ] sys-devel/bison-2.3 USE="nls -static" 0 kB
[ebuild R ] sys-devel/make-3.81 USE="nls -static" 0 kB
[ebuild R ] sys-apps/grep-2.5.4-r1 USE="nls pcre" 0 kB
[ebuild R ] sys-apps/findutils-4.4.0 USE="nls (-selinux) -static" 0 kB
[ebuild R ] sys-devel/flex-2.5.35 USE="nls -static" 0 kB
[ebuild R ] sys-apps/coreutils-7.5-r1 USE="acl nls -caps -gmp (-selinux) -static -vanilla -xattr" 0 kB
[ebuild R ] sys-apps/texinfo-4.13 USE="nls -static" 0 kB
[ebuild R ] sys-apps/sed-4.2 USE="acl nls -static" 0 kB
[nomerge ] x11-libs/qt-gui-4.5.3-r2 USE="accessibility cups dbus debug glib gtk qt3support tiff xinerama (-aqua) -mng -nas -nis -pch -raster"
[ebuild R ] x11-libs/qt-script-4.5.3-r1 USE="debug* iconv (-aqua) -pch" 0 kB
[ebuild R ] x11-libs/qt-core-4.5.3-r2 USE="debug* glib iconv qt3support ssl (-aqua) -doc -pch" 0 kB
[ebuild R ] sys-boot/yaboot-static-1.3.14 USE="ibm" 0 kB
[ebuild R ] x11-misc/Xorgautoconfig-0.2.4-r1 0 kB
[ebuild R ] net-misc/dhcpcd-4.0.15 USE="compat zeroconf" 0 kB
[ebuild R ] virtual/pager-0 0 kB
[ebuild R ] net-misc/iputils-20071127 USE="ipv6 -doc -static" 0 kB
[ebuild R ] sys-fs/hfsutils-3.2.6-r5 USE="-tcl -tk" 0 kB
[ebuild R ] sys-devel/patch-2.5.9 USE="-static" 0 kB
[ebuild R ] sys-apps/which-2.20 0 kB
[ebuild R ] sys-process/procps-3.2.8 USE="unicode (-n32)" 0 kB
[ebuild R ] app-arch/cpio-2.9-r2 USE="nls" 0 kB
[ebuild R ] net-misc/rsync-3.0.6 USE="acl iconv ipv6 -static -xattr" 0 kB
[ebuild R ] sys-apps/powerpc-utils-1.1.3.18-r2 0 kB
[ebuild R ] app-cdr/cdrtools-2.01.01_alpha57-r1 USE="acl unicode" 0 kB
[ebuild R ] app-shells/bash-4.0_p35 USE="net nls -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 0 kB
[ebuild R ] sys-libs/ncurses-5.7-r3 USE="cxx debug gpm unicode -ada -doc -minimal -profile -trace" 0 kB
[ebuild R ] sys-kernel/linux-headers-2.6.27-r2 0 kB
[ebuild R ] sys-devel/m4-1.4.12 USE="-examples" 0 kB
[ebuild R ] sys-apps/eject-2.1.5-r2 USE="nls" 0 kB
[ebuild R ] sys-devel/gnuconfig-20090203 0 kB
[ebuild R ] app-arch/bzip2-1.0.5-r1 USE="-static" 0 kB
[ebuild R ] sys-libs/zlib-1.2.3-r1 0 kB
[ebuild R ] sys-apps/portage-2.1.7.16 USE="-build -doc -epydoc (-python3) (-selinux)" LINGUAS="-pl" 0 kB

Total: 103 packages (5 new, 98 reinstalls), Size of downloads: 0 kB

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

localhost sogwp #


Last edited by sogwp on Tue Feb 09, 2010 5:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6319
Location: /usr/lib64/lv2

PostPosted: Fri Jan 29, 2010 3:43 pm    Post subject: Reply with quote

Can you post your emerge --info?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Fri Jan 29, 2010 3:44 pm    Post subject: Reply with quote

most likely a deprecated x11-libs/qt installation. qt4 is split - unmerge =qt-4*, and try again.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6319
Location: /usr/lib64/lv2

PostPosted: Fri Jan 29, 2010 3:45 pm    Post subject: Reply with quote

I think Veldrin is right. That was my first thought, too. I wanted to see if you also have the qt3support use flag enabled - if not, enable it in make.conf.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Jan 29, 2010 11:34 pm    Post subject: Reply with quote

The first issue may be related to the second.

As it says here:
Quote:

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/qt-sql-4.5.0:4[sqlite,mysql]".
!!! One of the following packages is required to complete your request:
- x11-libs/qt-sql-4.5.3 (Change USE: +mysql)
(dependency required by "app-office/akonadi-server-1.2.1" [ebuild])
(dependency required by "app-office/akonadi-server:0" [argument])


You need to add mysql to the USE flags for this package. Since this is a qt library, it may be that newer versions of other libraries require this library and as such, the dependency chain is broken, causing the error.

Try fixing the above error first and if you continue to have blockers, please post the output again.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
sogwp
n00b
n00b


Joined: 21 Jan 2010
Posts: 20
Location: sullivan mo usa

PostPosted: Sat Jan 30, 2010 3:05 am    Post subject: this is my make conf Reply with quote

audiodef wrote:
I think Veldrin is right. That was my first thought, too. I wanted to see if you also have the qt3support use flag enabled - if not, enable it in make.conf.

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe "
CXXFLAGS="-O2 -pipe -mcpu=970 "
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="powerpc64-unknown-linux-gnu"
MAKEOPTS="-j4"
ACCEPT_LICENSE="IBM-J1.6"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
XUSE="truetype X new-login xorg xscreensaver xv xcomposite xinerama opengl aiglx"
MEDIAUSE="alsa mad vidix asf dvd mp4 aac xvid nsplugin mp3 real snd-aoa gstreamer"

backtrack=30
GNOMEUSE="consolekit guile artworkextra keyrings gtk avahi mdnsresponder-compat networking cups cairo glitz gnome firefox"
KDEUSE="kde handbook semantic-desktop arts qt3support qt4"

SYSTEM="hal fam dbus aoss threads"
GENERAL="samba odbc java bzip2 symlink sqlite spell xml"
IMAGEUSE="jpeg gif tiff png svg pdf"

USE="${NOTUSE} ${SYSTEM} ${GENERAL} ${IMAGEUSE} ${XUSE} ${MEDUSE} ${GNOMEUSE} ${KDEUSE} "
VIDEO_CARDS="nv"
PORTIR_OVERLAY="/path/to/local/overlay"
Back to top
View user's profile Send private message
sogwp
n00b
n00b


Joined: 21 Jan 2010
Posts: 20
Location: sullivan mo usa

PostPosted: Sat Jan 30, 2010 3:21 am    Post subject: emerge --info Reply with quote

JoseJX wrote:
The first issue may be related to the second.

As it says here:
Quote:

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/qt-sql-4.5.0:4[sqlite,mysql]".
!!! One of the following packages is required to complete your request:
- x11-libs/qt-sql-4.5.3 (Change USE: +mysql)
(dependency required by "app-office/akonadi-server-1.2.1" [ebuild])
(dependency required by "app-office/akonadi-server:0" [argument])


You need to add mysql to the USE flags for this package. Since this is a qt library, it may be that newer versions of other libraries require this library and as such, the dependency chain is broken, causing the error.

Try fixing the above error first and if you continue to have blockers, please post the output again.


Thanks I am not sure if this will help find the fix

>>> Failed to emerge x11-libs/libXi-1.2.1, Log file:

>>> '/var/tmp/portage/x11-libs/libXi-1.2.1/temp/build.log'

* Messages for package x11-libs/libXi-1.2.1:

* ERROR: x11-libs/libXi-1.2.1 failed:
* emake failed
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 3254: Called x-modular_src_compile
* environment, line 4074: Called x-modular_src_make
* environment, line 4112: Called die
* The specific snippet of code:
* emake || die "emake failed"
*
* If you need support, post the output of 'emerge --info =x11-libs/libXi-1.2.1',
* the complete build log and the output of 'emerge -pqv =x11-libs/libXi-1.2.1'.
* The complete build log is located at '/var/tmp/portage/x11-libs/libXi-1.2.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-libs/libXi-1.2.1/temp/environment'.
* S: '/var/tmp/portage/x11-libs/libXi-1.2.1/work/libXi-1.2.1'

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

localhost sogwp # emerge --info =x11-libs/libXi-1.2.1
Portage 2.1.7.16 (default/linux/powerpc/ppc64/10.0/64bit-userland, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 ppc64)
=================================================================
System Settings
=================================================================
System uname: Linux-2.6.31-gentoo-r6-ppc64-PPC970,_altivec_supported-with-gentoo-1.12.13
Timestamp of tree: Fri, 29 Jan 2010 15:00:23 +0000
app-shells/bash: 4.0_p35
dev-java/java-config: 2.1.10
dev-lang/python: 2.6.4
dev-util/cmake: 2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox: 1.6-r2
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.6.3, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils: 2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6b
virtual/os-headers: 2.6.27-r2
ACCEPT_KEYWORDS="ppc64"
ACCEPT_LICENSE="* -@EULA IBM-J1.6"
CBUILD="powerpc64-unknown-linux-gnu"
CFLAGS="-O2 -pipe "
CHOST="powerpc64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -mcpu=970 "
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl aiglx aoss arts artworkextra avahi berkdb bzip2 cairo cli consolekit cracklib crypt cups cxx dbus dri fam firefox fortran gdbm gif glitz gnome gpm gtk guile hal handbook ibm iconv ipv6 java jpeg kde keyrings mdnsresponder-compat modules mudflap ncurses networking new-login nls nptl nptlonly odbc opengl openmp pam pcre pdf perl png ppc64 pppd python qt3support qt4 readline reflection samba semantic-desktop session spell spl sqlite ssl svg symlink sysfs tcpd threads tiff truetype unicode xcomposite xinerama xml xorg xscreensaver xv zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

localhost sogwp #
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Jan 31, 2010 4:31 pm    Post subject: Reply with quote

Sorry, the actual error would be further back in the text that scrolled. If you can paste that, we might be able to help.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum