Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] sys-apps/file benötigt python-2.7
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Feb 09, 2010 8:50 am    Post subject: [SOLVED] sys-apps/file benötigt python-2.7 Reply with quote

Hi,

Code:
tobi-lap tobi # emerge --deep file -pv

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=dev-lang/python-2.7*".
(dependency required by "sys-apps/file-5.04" [ebuild])
(dependency required by "file" [argument])



Das Erstaunliche ist, dass es kein 2.7 im Portage gibt. Aus dem Ebuild wird mir auch nicht ersichtlich, woher die 2.7 kommt.
Als Overlay ist nur kde-testing installiert.

Hat jemand eine Idee?

Danke
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke


Last edited by Finswimmer on Wed Feb 10, 2010 9:36 am; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Tue Feb 09, 2010 12:50 pm    Post subject: Reply with quote

Hm.., würde hier problemlos funken
Code:
# emerge --deep file -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-apps/file-5.04  USE="python" 0 kB
(und sich auch bauen lassen)
(Timestamp of tree: Tue, 09 Feb 2010 02:20:01 +0000)

Was nutzt du den da für eine python Version?
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Feb 09, 2010 12:54 pm    Post subject: Reply with quote

Josef.95 wrote:
Hm.., würde hier problemlos funken
Code:
# emerge --deep file -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-apps/file-5.04  USE="python" 0 kB
(und sich auch bauen lassen)
(Timestamp of tree: Tue, 09 Feb 2010 02:20:01 +0000)

Was nutzt du den da für eine python Version?


Code:
tobi-lap tobi # eselect python list
Available Python interpreters:
  [1]   python2.5
  [2]   python2.6 *
  [3]   python3.1


Code:

tobi-lap tobi # USE="-python" emerge file -pv

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild     U ] sys-apps/file-5.04 [5.03] USE="-python*" 607 kB

Total: 1 package (1 upgrade), Size of downloads: 607 kB


Würde wohl funktionieren...?
Danke
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Tue Feb 09, 2010 1:14 pm    Post subject: Reply with quote

Das sollte eigentlich funktionieren :?
Gabs da evtl. einen Fehler im ebuild, hast du schon mal ein neuen --sync gemacht?
oder das ebuild von hier nehmen: http://www.gentoo-portage.com/sys-apps/file

Ansonsten hab ich da zZt auch keine bessere Idee...

MfG
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6289

PostPosted: Tue Feb 09, 2010 1:50 pm    Post subject: Reply with quote

Eventuell mal /var/cache/edb/dep löschen (oder umbenennen, wenn Du der Sache später noch nachgehen willst): Vielleicht ist der Portage-Cache defekt, und wenn die Dateien auch noch ein falsches Datum haben, kann Portage denken, er sei aktuell.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Feb 09, 2010 3:30 pm    Post subject: Reply with quote

mv wrote:
Eventuell mal /var/cache/edb/dep löschen (oder umbenennen, wenn Du der Sache später noch nachgehen willst): Vielleicht ist der Portage-Cache defekt, und wenn die Dateien auch noch ein falsches Datum haben, kann Portage denken, er sei aktuell.


Hilft leider nichts. Er hat zwar viel gerechnet, aber die Fehlermeldung ist gleich geblieben.
Das System ist ein stabiles x86.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Tue Feb 09, 2010 3:45 pm    Post subject: Reply with quote

Scheint im Ebuild an folgendem zu liegen:
aus dem Ebuild:

RESTRICT_PYTHON_ABIS="3.*"

warum deswegen aber 2.7 ist mir schleierhaft. sollte eher 3.x wollen.


KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
seh es aber nirgends als stabil markiert für x86.

gruß ScytheMan
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Feb 09, 2010 4:14 pm    Post subject: Reply with quote

Bei 5.04 hast du recht, das ist unstable.
Aber ein Diff zu 5.03 liefert keinen Unterschied (außer Header und Keywords). Und da will es auch nicht. :/

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6289

PostPosted: Tue Feb 09, 2010 9:19 pm    Post subject: Reply with quote

Nun, Du kannst ja genau nachlesen, was file-5.04 will:
/usr/portage/metadata/cache/sys-apps/file-5.04 wrote:
>=app-admin/eselect-python-20090804 python? ( || ( =dev-lang/python-2.7* =dev-lang/python-2.6* =dev-lang/python-2.5* =dev-lang/python-2.4* ) )
Also jedes dev-lang/python-2-* sollte die Dependency erfüllen. Probleme kann es höchstens geben, wenn Du alle dev-lang/python-2.* deinstalliert hast, dann versucht er das (nicht-existente) 2.7 als erstes.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Wed Feb 10, 2010 9:36 am    Post subject: Reply with quote

Ist gelöst.
Da ich von ~x86 auf x86 umsteige, habe ich alle Pakete, die kleiner-gleich meinen installierten Paketen sind, maskiert.

Daher kam dann der Fehler...

Danke :)
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum