Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
usb stick / firmware problem [erstmal erledigt]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Feb 23, 2010 8:09 am    Post subject: usb stick / firmware problem [erstmal erledigt] Reply with quote

hallo,

wenn ich meine usb dvb-t stick anschliesse, dann passiert das:

dmesg:
Code:

usb 1-7: skipped 1 descriptor after interface
usb 1-7: default language 0x0409
usb 1-7: udev 5, busnum 1, minor = 4
usb 1-7: New USB device found, idVendor=15a4, idProduct=9016
usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-7: Product: DVB-T 2
usb 1-7: Manufacturer: Afatech
usb 1-7: SerialNumber: #
usb 1-7: usb_probe_device
usb 1-7: configuration #1 chosen from 1 choice
usb 1-7: adding 1-7:1.0 (config #1, interface 0)
usb 1-7:1.0: uevent
usb 1-7: adding 1-7:1.1 (config #1, interface 1)
usb 1-7:1.1: uevent
usbhid 1-7:1.1: usb_probe_interface
usbhid 1-7:1.1: usb_probe_interface - got id
usb 1-7: uevent
Afatech DVB-T 2: Fixing fullspeed to highspeed interval: 10 -> 7
input: Afatech DVB-T 2 as /devices/pci0000:00/0000:00:1d.7/usb1/1-7/1-7:1.1/input/input5
usb 1-7: link qh8-0001/ffff8800bf8023c0 start 1 [2/0 us]
generic-usb 0003:15A4:9016.0004: input,hidraw3: USB HID v1.01 Keyboard [Afatech DVB-T 2] on usb-0000:00:1d.7-7/input1
drivers/usb/core/inode.c: creating file '005'
hub 1-0:1.0: state 7 ports 8 chg 0000 evt fe80
usb 1-7:1.1: uevent
usb 1-7: uevent
usb 1-7:1.1: uevent
dvb_usb_af9015 1-7:1.0: usb_probe_interface
dvb_usb_af9015 1-7:1.0: usb_probe_interface - got id
af9015: tuner id:179 not supported, please report!
usbcore: registered new interface driver dvb_usb_af9015


lsmod:
Code:

Module                  Size  Used by
dvb_usb_af9015         32548  0
dvb_usb                18316  1 dvb_usb_af9015
dvb_core               99056  1 dvb_usb


die firmware musste ich manuell unter /lib/firmware ablegen (usr/lib/hotplug/firmware exitstiert nicht) da emerge linuxtv-dvb-firmware mit einer fehlermeldung abbricht (bugreport existiert - dort gab es auch den link zum direkten download)

im 'prinzip' scheint ja alles zu funktionieren, ausser das kein dvb device generiert wird. ich vermute das liegt daran das die firmware nicht geladen/gefunden wird

in einem anderen forum (http://www.gentooforum.de/artikel/15878/dvb-t-usb-stick-von-digittrade.html) habe ich den hinweis gefunden, das CONFIG_KMOD=y im kernel aktiviert sein soll, allerdings existiert die zeile nicht in meiner .config (der hinweis ist auch >1 jahr alt und bezieht sich vermutlich auf ein aelteres kernel - ich habe 2.6.31-gentoo-r6 64bit)

hier meine kerneleinstellungen bzgl. hotplug - da weiss ich nicht so recht, ob das ok ist
Code:

(/sbin/hotplug) path to uevent helper                            | | 
  | |    [*] Select only drivers that don't need compile-time external fir| | 
  | |    [*] Prevent firmware from being built                            | | 
  | |    -*- Userspace firmware loading support                           | | 
  | |    [*]   Include in-kernel firmware blobs in kernel binary          | | 
  | |    ()    External firmware blobs to build into the kernel binary


ich hoffe mir kann jemand sagen, wo das problem liegt bzw. liegen koennte.

ps:
ich habe ein aehnliches problem mit einem usb-wlan stick - der will auch nicht, obwohl er erkannt wird - von daher vermute ich das es am laden der firmware liegt, wobei hier zwar der 'not supported' hinweis kommt, aber da der chipsatz unterstuetzt wird sollte das doch eigentlich dennoch funktionieren.

danke


Last edited by andi_s on Tue Feb 23, 2010 11:17 am; edited 2 times in total
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4473

PostPosted: Tue Feb 23, 2010 8:33 am    Post subject: Re: usb stick / firmware problem Reply with quote

andi_s wrote:
Code:
af9015: tuner id:179 not supported, please report!

wie es hier steht scheint der treiber den eingebauten tuner nicht zu unterstützen.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3655
Location: Germany

PostPosted: Tue Feb 23, 2010 9:14 am    Post subject: Reply with quote

Hm.., sollte eigentlich möglich sein,
Quote:
AF9015 Chipsatz. Treiber wird seit Kernel 2.6.28 unterstützt.

siehe zb http://de.gentoo-wiki.com/wiki/TerraTec_Cinergy_T_USB_XE
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Feb 23, 2010 9:39 am    Post subject: Reply with quote

Josef.95 wrote:
Hm.., sollte eigentlich möglich sein,
Quote:
AF9015 Chipsatz. Treiber wird seit Kernel 2.6.28 unterstützt.

siehe zb http://de.gentoo-wiki.com/wiki/TerraTec_Cinergy_T_USB_XE


ja, sollte...
genau nach diesem wiki-eintrag bin ich auch vorgegangen... nur eben das die AF9015 firmware in dem package fehlt (emerge error)

https://bugs.gentoo.org/181908

also habe ich sie wie oben beschrieben manuell in /lib/firmware kopiert... sieht ja auch alles gut aus - module werden geladen etc - es wird nur einfach kein /dev/dvb erzeugt.

@firefly
bzgl. des tuners habe ich mal den entwickler angeschrieben... mal sehen was er dazu sagt - wollte ja nen report, also hoffe ich das er auch antwortet ;)

dennoch habe ich irgendwie den verdacht das an meinen kernel-einstellungen irgendetwas nicht stimmt... wie gesagt ich habe ein aehnliches problem mit einem usb-wlan stick, wo andere berichtet haben das er funktioniert, wenn die firmware geladen wird. bei mir wird aber kein device erzeugt.
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Feb 23, 2010 11:17 am    Post subject: Reply with quote

ok, habe gerade eine antwort vom entwickler erhalten: fuer den tuner gibt es noch keinen treiber :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum