Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Truecrypt und Berechtigungsprobleme
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Klueze
n00b
n00b


Joined: 23 Jan 2010
Posts: 7

PostPosted: Tue Feb 23, 2010 9:15 am    Post subject: [Solved] Truecrypt und Berechtigungsprobleme Reply with quote

Hallo zusammen,

ich bin gerade von einem Windows System auf ein Gentoo gewechselt, mit Ausnahme von ein paar Schönheitsfehler alles super!

Jetzt habe ich Truecrypt installiert und es als user gestartet. Wenn ich nun versuche eine vorher in Windows erstellte Platte zu mounten sagt er immer ich soll mein User-Passwort oder Adminpasswort eingeben, leider funktioniert keins von beiden. What can i do?

Wenn ich truecrypt als Admin starte kann ich die Platte normal mounten, aber erstens ist das ja wol nicht Sinn der Sache und zweitens wird die Platte mit den falschen Rechten gestartet, vermutlich fehlen mir hier einfach die -mount options?

Vielen Dank schonmal.


Last edited by Klueze on Sat Feb 27, 2010 9:03 am; edited 1 time in total
Back to top
View user's profile Send private message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Tue Feb 23, 2010 9:48 am    Post subject: Reply with quote

hallo,
schonmal mit

Code:

sudo truecrypt ...


probiert?

bei ntfs ggf. noch als filesystem ntfs-3g angeben...
Back to top
View user's profile Send private message
Klueze
n00b
n00b


Joined: 23 Jan 2010
Posts: 7

PostPosted: Tue Feb 23, 2010 9:50 am    Post subject: Reply with quote

Auch sudo fragt nur nach dem passwort, immer und immer wieder.

Das richtige Passwort hab ich übrigens, gerade mit eingeloggt! Das macht er bei jedem Programm wo ich sudo versuche :(

Ein su auf root funktioniert aber
Back to top
View user's profile Send private message
b3cks
Veteran
Veteran


Joined: 23 Mar 2004
Posts: 1481
Location: Bremen (GER)

PostPosted: Tue Feb 23, 2010 11:53 am    Post subject: Reply with quote

Oh heiliges Orakel, digitale Glaskugel: http://en.gentoo-wiki.com/wiki/TrueCrypt#Mount_volumes_as_a_normal_user
_________________
I am /root and if you see me laughing you better have a backup.
Back to top
View user's profile Send private message
Klueze
n00b
n00b


Joined: 23 Jan 2010
Posts: 7

PostPosted: Tue Feb 23, 2010 2:18 pm    Post subject: Reply with quote

Genau so etwas habe ich gesucht. Werde es ausprobieren sobald ich zuhause bin.

Vielen Dank.

Edit: Sehr schön, kann die Festplatte nun laden und auf sie wie gewünscht zugreifen, einziges neues Problem: Keine schreibtrechte. Habe schon versucht chmod oder benutzer/gruppe ändern versucht, gibt mir jedoch immer nur den fehler:

chgrp: Ändern der Gruppe für »/mnt/extern/«: Das Dateisystem ist nur lesbar

Auch der bootparameter rw hat nichts gebracht. Über Vorschläge würde ich mich freuen.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Wed Feb 24, 2010 6:04 am    Post subject: Reply with quote

Da du das ganze unter Windows angefangen hast wird das wohl ein NTFS Dateisystem sein, für Schreibzugriff brauchst du da noch die entsprechenden ntfs-3g Treiber (der NTFS Support im Kernel unterstützt quasi keine Schreibzugriffe).
Back to top
View user's profile Send private message
Klueze
n00b
n00b


Joined: 23 Jan 2010
Posts: 7

PostPosted: Wed Feb 24, 2010 7:45 am    Post subject: Reply with quote

Den habe ich bereits installiert, wie bekomme ich den nun zusammen mit True-Crypt ans laufen? Der Mount-Parameter ntfs-3g (oder ntfs3g) bringt mir leider nur Fehler
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Thu Feb 25, 2010 10:18 am    Post subject: Reply with quote

Es wäre schon hilfreich zu wissen, a) welchen Befehl du konkret probierst und b) wie die genauen Fehlermeldungen lauten ...
"bringt nur Fehler" ist nämlich ähnlich hilfreich wie "mein Internet geht nicht" was die Fehlersuche angeht.
Back to top
View user's profile Send private message
Klueze
n00b
n00b


Joined: 23 Jan 2010
Posts: 7

PostPosted: Fri Feb 26, 2010 6:03 pm    Post subject: Reply with quote

So die Klausis sind zuende und ich hab wieder Zeit für mein Gentoo.

Folgender stand: Habe mir ntfs-3g installiert und kann damit auch andere ntfs-partitionen mounten und beschreiben.

Diesen ntfs-3g treiber muss ich nun beim mounten einer Partition von Truecrypt eingebunden bekommen, das bekomme ich nicht hin. Vorschläge?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Fri Feb 26, 2010 8:18 pm    Post subject: Reply with quote

Klueze wrote:
So die Klausis sind zuende und ich hab wieder Zeit für mein Gentoo.

Folgender stand: Habe mir ntfs-3g installiert und kann damit auch andere ntfs-partitionen mounten und beschreiben.

Diesen ntfs-3g treiber muss ich nun beim mounten einer Partition von Truecrypt eingebunden bekommen, das bekomme ich nicht hin. Vorschläge?
Sorry, da nimmt sich ein Developer (Genone) sich die Zeit sich mit deinem Windows Problem zu beschäftigen, und du gehst nicht mal auf seine Fragen ein 8O
oder hast du sie übersehen?
Back to top
View user's profile Send private message
Klueze
n00b
n00b


Joined: 23 Jan 2010
Posts: 7

PostPosted: Sat Feb 27, 2010 1:25 am    Post subject: Reply with quote

Ups, hab ich in der Tat überlesen, war wol noch etwas groggy von dem ganzen Stress.

Habe versucht mit dem parameter --filesystem=ntfs3g das ganze zu mounten, bekomme aber immer den folgenden Fehler:

mount: wrong fs type, bad option, bad superblock on /dev/mapper/truecrypt1

Edit: Habs jetzt doch noch geschafft mir selbst zu helfen. Falls das hier jemand später liest: --filesystem=ntfs-3g (DEN BINDESTRICH BEACHTEN!) war mein fehler

Nochma danke an alle die sich Zeit für mein Problem genommen haben.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Sat Feb 27, 2010 3:00 am    Post subject: Reply with quote

Na prima...
wenn du jetzt noch ein "[Solved]" vor den Thread Titel setzt (zb indem du deinen ersten Beitrag noch mal bearbeitest)
sind alle zufrieden :wink:
Back to top
View user's profile Send private message
Klueze
n00b
n00b


Joined: 23 Jan 2010
Posts: 7

PostPosted: Sat Feb 27, 2010 9:03 am    Post subject: Reply with quote

Done ;) Ich merks mir.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum