Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[masked x86 keyword] bon ou mauvais ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
mysix
Apprentice
Apprentice


Joined: 26 Mar 2010
Posts: 183

PostPosted: Fri Apr 09, 2010 11:46 am    Post subject: [masked x86 keyword] bon ou mauvais ? Reply with quote

J'ai envie d'installer un packages me permetant de faire une vidéo de ma capture d'écran.
Maintenant ca me donne ca :
Code:
mygen applications # emerge gst-plugins-xvid xvidcap
Calculating dependencies... done!

!!! All ebuilds that could satisfy "media-plugins/gst-plugins-xvid" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-plugins/gst-plugins-xvid-0.10.18 (masked by: ~x86 keyword)
- media-plugins/gst-plugins-xvid-0.10.17 (masked by: ~x86 keyword)
- media-plugins/gst-plugins-xvid-0.10.14 (masked by: ~x86 keyword)


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

mygen applications #


Est-que ça sent mauvais si je fais un :
ACCEPT_KEYWORDS="~x86"
emerge -1 xvidcap gst-plugins-xvid
?

Tout en sachant que je tourne en x86...
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8041
Location: ~Brussels - Belgique

PostPosted: Fri Apr 09, 2010 12:05 pm    Post subject: Reply with quote

Oui, c'est mauvais, car au prochain "emerge --update", ton paquet sera à nouveau masqué.
Passe, comme dit dans la doc, via les fichiers package.unmask et package.keywords.

De plus, si tu fais "emerge --oneshot", au prochain "--depclean", ton paquet disparaîtra. Si tu veux explicitement un paquet, ne mets pas l'option "--oneshot" (-1)

Il te faudra probablement démasquer plusieurs paquets.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
mysix
Apprentice
Apprentice


Joined: 26 Mar 2010
Posts: 183

PostPosted: Fri Apr 09, 2010 12:23 pm    Post subject: Reply with quote

ok merci,
mais comme j'ai cru comprendre en enlevant le x86, il ne va pas avoir des problèmes d'instabilités ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8041
Location: ~Brussels - Belgique

PostPosted: Fri Apr 09, 2010 12:29 pm    Post subject: Reply with quote

en "~x86", tu n'auras pas autant de stabilité qu'en "x86", mais franchement, c'est très stable.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Fri Apr 09, 2010 12:42 pm    Post subject: Reply with quote

Tu n'enlèves pas le x86; tu ne fais qu'accepter aussi les ~x86 ! ;-)
Cela dit, par définition, un paquet instable n'est pas stable. :P
Si des paquets ne sont pas marqués comme "stables", c'est que les mainteneurs n'ont pas encore une certitude suffisante quant à leur solidité.
Des problèmes ne sont pas exclus. Ils risquent en tout cas d'être plus fréquents que sur la version stable.
En général, il n'y a pas grand risque de catastrophe si on maîtrise suffisamment Gentoo et ses outils mais parfois, ça demande quand même pas mal de boulot et de recherche quand ça déraille.
A toi de voir si tu te sens capable d'assumer ! ;-)
Back to top
View user's profile Send private message
mysix
Apprentice
Apprentice


Joined: 26 Mar 2010
Posts: 183

PostPosted: Fri Apr 09, 2010 1:26 pm    Post subject: Reply with quote

Ok merci !

Maintenant j'ai ce message :
Code:
[blocks B     ] <x11-libs/libXext-1.0.99 ("<x11-libs/libXext-1.0.99" is blocking x11-proto/xextproto-7.1.1)


Mais j'ignore comment dire à emerge de ne pas installer x11-proto/xextproto-7.1.1

J'ai essayé avec package.mask mais sans résultat.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8041
Location: ~Brussels - Belgique

PostPosted: Fri Apr 09, 2010 1:35 pm    Post subject: Reply with quote

Salut,

A partir du moment où tu démasques un paquet, tu devras débloquer ses dépendances. Et apparemment ici, tu en auras beaucoup (XOrg & Co).
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Fri Apr 09, 2010 2:42 pm    Post subject: Reply with quote

C'est ce que je disais : il faut assumer ! :lol:
Tu es notamment sensé savoir ce que signifient les messages de type "[blocks B ]" et pouvoir y faire face.

Du reste, ton message d'erreur est incomplet : il devrait lister les paquets qui réclament les versions respectives de libXext : c'est ce qui te permettra d'avancer ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum