Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[GDM] en azerty[resolu]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Mon Apr 26, 2010 9:47 am    Post subject: [GDM] en azerty[resolu] Reply with quote

Bonjour,

voila, je ne trouve pas comment basculer gdm en azerty et taper des mots de passe en qwerty c'est plus que pénible.
gdm s'affiche bien en français mais le clavier est en qwerty. Gnome est en français et azerty lui par contre.

Seul gdm pose problème (la console/ou la console dans gnome, le mdp du screensaver ... tout est en azerty, sauf dans gdm)

Ca semble identique à ce post https://forums.gentoo.org/viewtopic-t-819120-highlight-gdm.html

pour mes fichiers config... j'ai un post en anglais qui les montre : https://forums.gentoo.org/viewtopic-t-825059-highlight-.html

Si quelqu'un a la solution je suis preneur.
Merci.


Last edited by krinn on Tue Apr 27, 2010 9:45 am; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7961
Location: ~Brussels - Belgique

PostPosted: Mon Apr 26, 2010 9:50 am    Post subject: Reply with quote

Quelle version de xorg-server ?
Hal est-il activé ?

As-tu bien configuré le clavier pour xorg ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Mon Apr 26, 2010 10:25 am    Post subject: Re: [GDM] en azerty Reply with quote

krinn wrote:

Seul gdm pose problème (la console/ou la console dans gnome, le mdp du screensaver ... tout est en azerty, sauf dans gdm)



Code:
/etc/init.d/hald status && emerge -pv xorg-server
 * status: started

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-base/xorg-server-1.7.6  USE="hal ipv6 kdrive nptl sdl xorg -debug -dmx -minimal -tslib" 0 kB
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7961
Location: ~Brussels - Belgique

PostPosted: Mon Apr 26, 2010 10:33 am    Post subject: Reply with quote

Peux-tu répondre à toutes mes questions stp ?

HAL est activé. As-tu configuré ton clavier via /etc/hal/fdi/policy/ ?

Que ça marche par Gnome est dû au fait que Gnome configure le clavier après démarrage de la session.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Mon Apr 26, 2010 10:51 am    Post subject: Reply with quote

oops, donc oui j'ai un fichier fdi comme ça:

Code:
cat 10-x11-input.fdi
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keys">
          <merge key="input.x11_options.XkbRules" type="string">evdev</merge>
          <merge key="input.x11_options.XkbModel" type="string">evdev</merge>
          <merge key="input.xkb.layout" type="string">fr</merge>
          <merge key="input.x11_options.XkbOptions" type="string">compose:menu</merge>
   </match>
  </device>
</deviceinfo>
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7961
Location: ~Brussels - Belgique

PostPosted: Mon Apr 26, 2010 11:40 am    Post subject: Reply with quote

OK, et hal est-il démarré ?

Peux-tu donner le contenu de /var/log/X.org.log ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Mon Apr 26, 2010 12:51 pm    Post subject: Reply with quote

voila :
Code:

cat /var/log/Xorg.0.log

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32.11 i686
Current Operating System: Linux saruman 2.6.32.11 #1 SMP PREEMPT Fri Apr 23 11:35:33 CEST 2010 i686
Kernel command line: root=/dev/sda1 panic=20
Build Date: 25 April 2010  01:01:11AM
 
Current version of pixman: 0.18.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 26 14:48:57 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.Org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "MonitorNEC"
(**) |   |-->Device "Card0"
(**) Option "AllowMouseOpenFail" "true"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
(==) ModulePath set to "/usr/lib/xorg/modules"
(**) Extension "Composite" is enabled
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
   If no devices become available, reconfigure HAL or disable AutoAddDevices.
(II) Loader magic: 0x81eaa80
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 6.0
   X.Org XInput driver : 7.0
   X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:1:0:0) 10de:0392:1458:341a nVidia Corporation G73 [GeForce 7600 GS] rev 161, Mem @ 0xfd000000/16777216, 0xe0000000/268435456, 0xfc000000/16777216, I/O @ 0x0000dc00/128, BIOS @ 0x????????/131072
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules/libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.1.0
   ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
   Module class: X.Org Server Extension
(II) NVIDIA GLX Module  195.36.15  Thu Mar 11 23:39:48 PST 2010
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(WW) Warning, couldn't open module dri
(II) UnloadModule: "dri"
(EE) Failed to load module "dri" (module does not exist, 0)
(II) LoadModule: "dri2"
(WW) Warning, couldn't open module dri2
(II) UnloadModule: "dri2"
(EE) Failed to load module "dri2" (module does not exist, 0)
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
   Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  195.36.15  Thu Mar 11 22:01:49 PST 2010
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Option "AllowGLXWithComposite" "true"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "true"
(**) Apr 26 14:48:57 NVIDIA(0): Enabling RENDER acceleration
(II) Apr 26 14:48:57 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Apr 26 14:48:57 NVIDIA(0):     enabled.
(II) Apr 26 14:48:58 NVIDIA(0): NVIDIA GPU GeForce 7600 GS (G73) at PCI:1:0:0 (GPU-0)
(--) Apr 26 14:48:58 NVIDIA(0): Memory: 262144 kBytes
(--) Apr 26 14:48:58 NVIDIA(0): VideoBIOS: 05.73.22.50.02
(II) Apr 26 14:48:58 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Apr 26 14:48:58 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Apr 26 14:48:58 NVIDIA(0): Connected display device(s) on GeForce 7600 GS at PCI:1:0:0:
(--) Apr 26 14:48:58 NVIDIA(0):     NEC LCD73V (CRT-0)
(--) Apr 26 14:48:58 NVIDIA(0): NEC LCD73V (CRT-0): 400.0 MHz maximum pixel clock
(II) Apr 26 14:48:58 NVIDIA(0): Assigned Display Device: CRT-0
(II) Apr 26 14:48:58 NVIDIA(0): Validated modes:
(II) Apr 26 14:48:58 NVIDIA(0):     "1280x1024"
(II) Apr 26 14:48:58 NVIDIA(0):     "1024x768"
(II) Apr 26 14:48:58 NVIDIA(0):     "800x600"
(II) Apr 26 14:48:58 NVIDIA(0):     "640x480"
(II) Apr 26 14:48:58 NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) Apr 26 14:48:58 NVIDIA(0): DPI set to (95, 96); computed from "UseEdidDpi" X config
(--) Apr 26 14:48:58 NVIDIA(0):     option
(**) Apr 26 14:48:58 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) Apr 26 14:48:58 NVIDIA(0): Initialized GPU GART.
(II) Apr 26 14:48:58 NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
(II) Apr 26 14:48:58 NVIDIA(0):     may not be running or the "AcpidSocketPath" X
(II) Apr 26 14:48:58 NVIDIA(0):     configuration option may not be set correctly.  When the
(II) Apr 26 14:48:58 NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
(II) Apr 26 14:48:58 NVIDIA(0):     try to use it to receive ACPI event notifications.  For
(II) Apr 26 14:48:58 NVIDIA(0):     details, please see the "ConnectToAcpid" and
(II) Apr 26 14:48:58 NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
(II) Apr 26 14:48:58 NVIDIA(0):     Config Options in the README.
(II) Apr 26 14:48:58 NVIDIA(0): Setting mode "1280x1024"
(II) Loading extension NV-GLX
(II) Apr 26 14:48:58 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Apr 26 14:48:58 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 2.4.0
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 7.0
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "fr"
(**) Option "xkb_variant" "fr"
(**) Option "xkb_options" "compose:menu"
(II) config/hal: Adding input device Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)
(**) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): always reports core events
(**) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): Device: "/dev/input/event4"
(II) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): Found 3 mouse buttons
(II) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): Found scroll wheel(s)
(II) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): Found relative axes
(II) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): Found x and y relative axes
(II) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): Configuring as mouse
(**) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): YAxisMapping: buttons 4 and 5
(**) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)" (type: MOUSE)
(**) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): (accel) keeping acceleration scheme 1
(**) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): (accel) acceleration profile 0
(II) Microsoft Microsoft 3-Button Mouse with IntelliEye(TM): initialized for relative axes.
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event2"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "fr"
(**) Option "xkb_variant" "fr"
(**) Option "xkb_options" "compose:menu"
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event3"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "fr"
(**) Option "xkb_variant" "fr"
(**) Option "xkb_options" "compose:menu"
(II) Apr 26 14:49:11 NVIDIA(0): Setting mode "1280x1024"
(II) Apr 26 14:49:11 NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
(II) Apr 26 14:49:11 NVIDIA(0):     may not be running or the "AcpidSocketPath" X
(II) Apr 26 14:49:11 NVIDIA(0):     configuration option may not be set correctly.  When the
(II) Apr 26 14:49:11 NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
(II) Apr 26 14:49:11 NVIDIA(0):     try to use it to receive ACPI event notifications.  For
(II) Apr 26 14:49:11 NVIDIA(0):     details, please see the "ConnectToAcpid" and
(II) Apr 26 14:49:11 NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
(II) Apr 26 14:49:11 NVIDIA(0):     Config Options in the README.

Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7961
Location: ~Brussels - Belgique

PostPosted: Mon Apr 26, 2010 1:13 pm    Post subject: Reply with quote

C'est bizarre... ton clavier est bien en "fr" selon X.Org...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Mon Apr 26, 2010 1:37 pm    Post subject: Reply with quote

c'est bien ce que je dis :D

et toi ton gdm est en azerty ?
Peux-t on me fournir un fdi azerty d'une personne avec un gdm qui fonctionne en azerty ainsi que la version de gdm qui fonctionne, parceque là je vois pas trop de solution au problème.
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1685
Location: 127.0.0.1

PostPosted: Mon Apr 26, 2010 3:18 pm    Post subject: Reply with quote

gdm-2.20.10-r2, xorg-server-1.7.6.
Avec la config suivante, clavier fr chargé par défaut, alt+shift pour passer du clavier fr au clavier us.
Code:

$ cat /etc/hal/fdi/policy/10-x11-input.fdi
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
   <device>
      <match key="info.capabilities" contains="input.mouse">
         <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
      <match key="info.capabilities" contains="input.keymap">
         <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
      </match>
      <match key="info.capabilities" contains="input.keys">
         <merge key="input.x11_driver" type="string">evdev</merge>
         <merge key="input.x11_options.XkbModel" type="string">evdev</merge>
         <merge key="input.x11_options.XkbLayout" type="string">fr,us</merge>
         <merge key="input.x11_options.XkbOptions" type="string">grp:alt_shift_toggle</merge>
      </match>
   </device>
</deviceinfo>
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Mon Apr 26, 2010 3:55 pm    Post subject: Reply with quote

bon ben voila, avec ce fdi j'ai plus de clavier du tout dans gdm
et en replacant l'ancien fdi, le clavier ne fonctionne plus.


putain que j'en ai marre de hal & gdm, me revoila revenu a mon problème initial :(
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Mon Apr 26, 2010 4:04 pm    Post subject: Reply with quote

krinn wrote:
bon ben voila, avec ce fdi j'ai plus de clavier du tout dans gdm
et en replacant l'ancien fdi, le clavier ne fonctionne plus.


putain que j'en ai marre de hal & gdm, me revoila revenu a mon problème initial :(


Passe alors à Xorg 1.8 :)
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Mon Apr 26, 2010 4:23 pm    Post subject: Reply with quote

oui je vais tester ça, j'ai pas trop le choix, il me faut un gdm qui fonctionne pour demain.

y'a un thread pour l'upgrade en 1.8 ?
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Mon Apr 26, 2010 4:25 pm    Post subject: Reply with quote

krinn wrote:
oui je vais tester ça, j'ai pas trop le choix, il me faut un gdm qui fonctionne pour demain.

y'a un thread pour l'upgrade en 1.8 ?

https://forums.gentoo.org/viewtopic-t-821857.html
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1685
Location: 127.0.0.1

PostPosted: Mon Apr 26, 2010 4:58 pm    Post subject: Reply with quote

krinn wrote:
oui je vais tester ça, j'ai pas trop le choix, il me faut un gdm qui fonctionne pour demain.

Surtout que d'après l'emerge --info que tu donnes dans l'autre thread tu es en ~arch, donc aucune raison que tu sois encore avec le xorg stable.
Mixer les branches arch et ~arch peut parfois avoir des effets de bord, là c'est dans l'autre sens.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Mon Apr 26, 2010 6:52 pm    Post subject: Reply with quote

je n'ai pas mixer stable & unstable, juste blacklisté xorg 1.8 (et maintenant je sais pourquoi).
le mismatch api avec les drivers nvidia...

Bref je suis revenu au 1.7, de toutes façons xorg en lui même marche, y'a que gdm qui me pose soucis, et le fait d'avoir pas de clavier ou un clavier en qwerty sans même savoir pourquoi gdm me fait ça, c'est plus qu'énervant (sans parler du fait qu'il rend ma machine impossible a utiliser par 2 personnes).

Sur un autre ordi j'ai le même soucis d'ailleurs (j'en ai que 2 avec xorg d'installé), gdm est en qwerty (bon au moins le clavier marche sur celui la, mais j'ai encore rien touché), et pourtant tout marche en azerty dessus là encore.

Donc y'a un gros soucis sur gdm a mon avis.
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Mon Apr 26, 2010 7:12 pm    Post subject: Reply with quote

salut,

une question peut etre stupide :oops:
as tu un 10-keymap.fdi ?

cordialement,
Elyes
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Mon Apr 26, 2010 7:31 pm    Post subject: Reply with quote

Passe à SLiM :lol:
Back to top
View user's profile Send private message
bivittatus
l33t
l33t


Joined: 31 Jan 2006
Posts: 687
Location: Roissy-en-Brie (France)

PostPosted: Mon Apr 26, 2010 8:23 pm    Post subject: Reply with quote

Les drivers nvidia et xorg-server-1.8 sont maintenant compatibles, donc pas de soucis!

Pour slim, je suis assez d'accord, même si dernièrement j'ai eu pas mal de problèmes avec qui m'ont fait revenir (temporairement?) à gdm...
_________________
Linus TORVALDS: "Je ne suis pas là pour détruire Microsoft. Ce sera juste un effet secondaire tout à fait involontaire."
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Mon Apr 26, 2010 9:23 pm    Post subject: Reply with quote

krinn wrote:
oui je vais tester ça, j'ai pas trop le choix, il me faut un gdm qui fonctionne pour demain.

y'a un thread pour l'upgrade en 1.8 ?


Pourquoi obligé d'avoir un gdm ? Tu ne connais pas startx ?
_________________
Get Up and Go !
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Mon Apr 26, 2010 10:27 pm    Post subject: Reply with quote

bon j'ai trouvé, il suffit de
echo "setxkbmap fr" >> /etc/X11/gdm/Init/Default

je vais tester slim quand même.

elyes: non j'en ai pas, mais même avec celui de hal (en changeant us->fr) ça marchait pas. Et la question n'est pas stupide
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Tue Apr 27, 2010 7:58 am    Post subject: Reply with quote

Pour info, j'ai également ce léger désagrément avec gdm et xorg-server 1.8, juste pour vous prévenir, la solution de krinn devrait être la bonne, je testerai ce soir. Ce n'est donc pas Hal (de toute façon tu devrais virer cette daube)
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7056

PostPosted: Tue Apr 27, 2010 9:45 am    Post subject: Reply with quote

j'ai fait un patch plus propre pour ce fichier que je joins ici pour ceux qui auraient le même soucis (et contrairement a ce qui semble être, on devrait être nombreux a avoir ce soucis)
Ca lit /etc/conf.d/keymaps et ca force le clavier a basculer dans la même langue, donc en fr si keymap="fr"
Code:

--- /etc/X11/gdm/Init/Default   2010-04-26 23:50:26.000000000 +0200
+++ patch_gdm_init.txt   2010-04-26 23:36:39.000000000 +0200
@@ -86,4 +86,10 @@
   fi
 fi
 
+# force setxkbmap to be as set in /etc/conf.d/keymaps
+if [ -e "/etc/conf.d/keymaps" ]; then
+   FINDKEYMAP=`grep "^keymap" '/etc/conf.d/keymaps' | awk -F"=" '{ print $2 }'`
+   $SETXKBMAP $FINDKEYMAP
+   fi
 exit 0
+
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Tue Apr 27, 2010 10:12 am    Post subject: Reply with quote

Je ne comprends rien.

Je n'ai jamais eu besoin de bidouiller un quelconque fichier de configuration de GDM pour avoir un clavier FR.
Avant Xorg 1.8, je mettais mon clavier en fr dans /etc/conf.d/keymaps, et dans /etc/hal/fdi/policy/10-xinput-configuration.fdi.
Et pis c'est tout. GDM se mettait en FR.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7961
Location: ~Brussels - Belgique

PostPosted: Tue Apr 27, 2010 11:00 am    Post subject: Reply with quote

idem pour moi : xorg-1.8 et gdm, et tout s'est toujours bien passé : via HAL et maintenant via /etc/X11/xorg.conf.d
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum