Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[alsa] Carte son non reconnue (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sat May 15, 2010 1:25 pm    Post subject: [alsa] Carte son non reconnue (résolu) Reply with quote

Bonjour,

Je n'arrive pas à faire fonctionner ma carte son.

alsaconf me donne :
Code:
modinfo: could not find module snd
No supported PnP or PCI card found.


Code:
localhost linux # lspci -v | grep -i audio
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)

_________________
emerge --info
dmesg
lspci
.config


Last edited by Neuromancien on Sat May 15, 2010 5:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sat May 15, 2010 2:16 pm    Post subject: Reply with quote

Code:

cat /usr/src/linux/.config | grep HDA
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sat May 15, 2010 3:41 pm    Post subject: Reply with quote

Poussin wrote:
Code:

cat /usr/src/linux/.config | grep HDA


Code:
# CONFIG_SENSORS_HDAPS is not set
CONFIG_SND_HDA_INTEL=y
CONFIG_SND_HDA_HWDEP=y
# CONFIG_SND_HDA_RECONFIG is not set
# CONFIG_SND_HDA_INPUT_BEEP is not set
# CONFIG_SND_HDA_INPUT_JACK is not set
# CONFIG_SND_HDA_PATCH_LOADER is not set
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_SIGMATEL=y
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_ATIHDMI=y
CONFIG_SND_HDA_CODEC_NVHDMI=y
CONFIG_SND_HDA_CODEC_INTELHDMI=y
CONFIG_SND_HDA_ELD=y
CONFIG_SND_HDA_CODEC_CIRRUS=y
CONFIG_SND_HDA_CODEC_CONEXANT=y
CONFIG_SND_HDA_CODEC_CA0110=y
CONFIG_SND_HDA_CODEC_CMEDIA=y
CONFIG_SND_HDA_CODEC_SI3054=y
CONFIG_SND_HDA_GENERIC=y
# CONFIG_SND_HDA_POWER_SAVE is not set

_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Sat May 15, 2010 3:55 pm    Post subject: Reply with quote

hem... c'est "Y" donc PAS en module :?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Sat May 15, 2010 3:57 pm    Post subject: Reply with quote

alsaconf il a pas besoin que tout soit en module en ce qui concerne les drivers de cartes? (vu qu'il trifouille une config modutils).
Je me souviens qu'il me faisait la même erreur sur une carte de type hda, les drivers en dur, or alsamixer trouvait bien la carte.

Que te donnes alsamixer?
Essais en module pour les drivers sinon, pour être sûr qu'ils soient chargés avec les bon paramètres.
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sat May 15, 2010 4:47 pm    Post subject: Reply with quote

kwenspc wrote:
alsaconf il a pas besoin que tout soit en module en ce qui concerne les drivers de cartes? (vu qu'il trifouille une config modutils).
Je me souviens qu'il me faisait la même erreur sur une carte de type hda, les drivers en dur, or alsamixer trouvait bien la carte.

Que te donnes alsamixer?
Essais en module pour les drivers sinon, pour être sûr qu'ils soient chargés avec les bon paramètres.

alsamixer me donne :
Code:
Card: HDA NVidia
Chip: Realtek ALC662 rev1

J'essaie avec CONFIG_SND_HDA_INTEL en module.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sat May 15, 2010 4:51 pm    Post subject: Reply with quote

Perso, j'ai tjs eu des problèmes avec les pilotes alsa en dur... En modules, aucun soucis.

Accessoirement, dans les "codecs", tu n'as besoin que de celui-ci:
Code:

CONFIG_SND_HDA_CODEC_NVHDMI=y
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sat May 15, 2010 5:35 pm    Post subject: Reply with quote

kwenspc wrote:
Essais en module pour les drivers sinon, pour être sûr qu'ils soient chargés avec les bon paramètres.

C'était bien ça. En module ça marche parfaitement. Merci. :)
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum