Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[nvidia drivers] probleme deja dans emerge nvidia-drivers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
rocky800_1
n00b
n00b


Joined: 26 May 2010
Posts: 32

PostPosted: Wed Jun 09, 2010 8:03 pm    Post subject: [nvidia drivers] probleme deja dans emerge nvidia-drivers Reply with quote

Bonjour

me revoila pour un nouveau post :D

donc j 'essaye maintenant que j'ai un bureau gnome de mettre les pilotes nvidia parce que quand je deplace une fenetre je vois les saccades c est affreux.

mais pendant l emerge ... j ''obtiens des erreurs provenant du kernel comme quoi il n'arrive pas a compiler .

je vous envois quoi comme fichier un emerge --info ?
_________________
Mess with the best or die like the rest !
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Wed Jun 09, 2010 8:25 pm    Post subject: Reply with quote

oui et les erreurs de compilation + regardes cette doc (existe en français mais sûrement plus à jour)
http://www.gentoo.org/doc/en/nvidia-guide.xml
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
rocky800_1
n00b
n00b


Joined: 26 May 2010
Posts: 32

PostPosted: Wed Jun 09, 2010 8:31 pm    Post subject: Reply with quote

c est exactement ce que je fais
et ca coince dans la section Code Listing 3.9: Installing the nVidia drivers


je vais essayer de mettre les erreurs de compilation dans 1 fichier
_________________
Mess with the best or die like the rest !
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Wed Jun 09, 2010 8:33 pm    Post subject: Reply with quote

bah maintenant que t'as un X t'as qu'à faire un copier/collé...
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
rocky800_1
n00b
n00b


Joined: 26 May 2010
Posts: 32

PostPosted: Wed Jun 09, 2010 8:40 pm    Post subject: Reply with quote

yes vive le X mdr

voici le copier-coller

Emerging (1 of 2) x11-drivers/nvidia-drivers-190.42-r3
* NVIDIA-Linux-x86_64-190.42-pkg2.run RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* CPV: x11-drivers/nvidia-drivers-190.42-r3
* REPO: gentoo
* USE: acpi amd64 elibc_glibc gtk kernel_linux multilib userland_GNU
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found kernel object directory:
* /lib/modules/2.6.32-gentoo-r7/build
* Found sources for kernel version:
* 2.6.32-gentoo-r7
* Checking for MTRR support ... [ ok ]
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-190.42-pkg2.run to /var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/work/NVIDIA-Linux-x86_64-190.42-pkg2
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/work
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/work/NVIDIA-Linux-x86_64-190.42-pkg2 ...
* Applying NVIDIA_glx-defines.patch ... [ ok ]
* Applying NVIDIA_glx-glheader.patch ... [ ok ]
* Converting NVIDIA-Linux-x86_64-190.42-pkg2/usr/src/nv/Makefile.kbuild to use M= instead of SUBDIRS= ... [ ok ]
>>> Source prepared.
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/work/NVIDIA-Linux-x86_64-190.42-pkg2 ...
>>> Source configured.
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/work/NVIDIA-Linux-x86_64-190.42-pkg2 ...
* Preparing nvidia module
make -j3 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/2.6.32-gentoo-r7/build HOST_CC=x86_64-pc-linux-gnu-gcc clean module
Your kernel was configured to include nvidiafb support!

The nvidiafb driver conflicts with the NVIDIA driver, please
reconfigure your kernel and *disable* nvidiafb support, then
try installing the NVIDIA kernel module again.

*** Failed nvidiafb sanity check. Bailing out! ***

make[1]: *** [build-sanity-checks] Error 1
make: *** [module] Error 2
* ERROR: x11-drivers/nvidia-drivers-190.42-r3 failed:
* Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/2.6.32-gentoo-r7/build HOST_CC=x86_64-pc-linux-gnu-gcc clean module
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 4151: Called linux-mod_src_compile
* environment, line 3083: Called die
* The specific snippet of code:
* eval "emake HOSTCC=\"$(tc-getBUILD_CC)\" CROSS_COMPILE=${CHOST}- LDFLAGS=\"$(get_abi_LDFLAGS)\" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
*
* If you need support, post the output of 'emerge --info =x11-drivers/nvidia-drivers-190.42-r3',
* the complete build log and the output of 'emerge -pqv =x11-drivers/nvidia-drivers-190.42-r3'.
* The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment'.
* S: '/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/work/NVIDIA-Linux-x86_64-190.42-pkg2'
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory
/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment: line 86: warning: setlocale: LC_COLLATE: cannot change locale (c): No such file or directory

>>> Failed to emerge x11-drivers/nvidia-drivers-190.42-r3, Log file:

>>> '/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/build.log'

* Messages for package x11-drivers/nvidia-drivers-190.42-r3:

* ERROR: x11-drivers/nvidia-drivers-190.42-r3 failed:
* Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/2.6.32-gentoo-r7/build HOST_CC=x86_64-pc-linux-gnu-gcc clean module
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 4151: Called linux-mod_src_compile
* environment, line 3083: Called die
* The specific snippet of code:
* eval "emake HOSTCC=\"$(tc-getBUILD_CC)\" CROSS_COMPILE=${CHOST}- LDFLAGS=\"$(get_abi_LDFLAGS)\" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
*
* If you need support, post the output of 'emerge --info =x11-drivers/nvidia-drivers-190.42-r3',
* the complete build log and the output of 'emerge -pqv =x11-drivers/nvidia-drivers-190.42-r3'.
* The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/temp/environment'.
* S: '/var/tmp/portage/x11-drivers/nvidia-drivers-190.42-r3/work/NVIDIA-Linux-x86_64-190.42-pkg2'



une idee ?
_________________
Mess with the best or die like the rest !
Back to top
View user's profile Send private message
Ey
l33t
l33t


Joined: 07 Apr 2005
Posts: 863
Location: Paris

PostPosted: Wed Jun 09, 2010 8:41 pm    Post subject: Reply with quote

Comme indique dans le log et dans la doc referencee plus haut, tu dois retirer le framebuffer nvidia il entre en conflit avec le driver de nvidia.
Back to top
View user's profile Send private message
rocky800_1
n00b
n00b


Joined: 26 May 2010
Posts: 32

PostPosted: Wed Jun 09, 2010 8:50 pm    Post subject: [resolu] Reply with quote

super effectivement , je pensais que c'etait plutot la VESA qu il fallait desactiver

soit ca compile , je continue sur le reste

merci encore ,

tiens au fait j 'ai fais un autre post sur un probleme de clavier azerty et qwarty en console , si par hazard tu vois aussi mon probleme , tu seras mon heros de cette soirée mdr
_________________
Mess with the best or die like the rest !
Back to top
View user's profile Send private message
rocky800_1
n00b
n00b


Joined: 26 May 2010
Posts: 32

PostPosted: Wed Jun 09, 2010 9:01 pm    Post subject: Reply with quote

au fait pour ce post précis pour NVIDIA

je ne comprends pas un truc dans la doc .

a 1 moment , je dois editer mon fichier Xorg.conf pour remplacer le driver nv par nvidia d'apres la doc

mais je n'ai aucun fichier Xorg.conf juste un xorg.conf.example

est ce que je dois changer quelque chose dans le.example et puis le renomer en xorg.conf ??

est ce que ca va foutre la merde ?
_________________
Mess with the best or die like the rest !
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Wed Jun 09, 2010 9:05 pm    Post subject: Reply with quote

Ton xorg est < à 1.8 et compilé avec hal, du coup xorg.conf est facultatif, mais à mon avis tu devra en créer un

J'ai du garder ça dans le mien :
Code:

Section "Device"
 Identifier  "GeForce GTS 250"
 Driver      "nvidia"
EndSection

_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
rocky800_1
n00b
n00b


Joined: 26 May 2010
Posts: 32

PostPosted: Wed Jun 09, 2010 9:09 pm    Post subject: Reply with quote

exactement , j'ai compile avec hal ouais tout juste

donc je ne mets que ces quelques lignes dans le fichier xorg.conf que je vais creer.

ca ne va rien changer a la couche hal alors ?
_________________
Mess with the best or die like the rest !
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Wed Jun 09, 2010 9:16 pm    Post subject: Reply with quote

par contre rien avoir avec ton clavier là!
moi si j'ai gardé ça c'est que sinon mon driver nvidia n'est pas utilisé...
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
rocky800_1
n00b
n00b


Joined: 26 May 2010
Posts: 32

PostPosted: Wed Jun 09, 2010 9:39 pm    Post subject: Reply with quote

je comprends pas ce que tu veux dire ,

certes je dois avoir plus d'un problème c 'est sur dont le clavier lol

mais donc ici , mon probleme c est quoi alors ,

certes j'ai pas de clavier en fr avec X

, donc je ne dois pas avoir de xorg.conf , tout doit rester gerer par HAL ?
_________________
Mess with the best or die like the rest !
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Wed Jun 09, 2010 9:43 pm    Post subject: Reply with quote

c'est vrai qu'à parler sur plusieurs post on se mélange....
Je veux dire qu'en théorie, dans ta config, tu n'as pas besoin d'xorg.conf.
Je t'ai posté le mien au cas ou ton X n'utiliserai pas le driver nvidia que tu viens de compiler (car c'était le cas chez moi d'où ces lignes que j'ai du conserver de mon vieil xorg...)
Essaies d'abord sans xorg.conf du tout et vois si ça marche
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
rocky800_1
n00b
n00b


Joined: 26 May 2010
Posts: 32

PostPosted: Fri Jun 11, 2010 9:45 am    Post subject: Reply with quote

ok donc si je resume pour bien comprendre

la couche HAL gere le xorg , ok je comprends , ce qui explique que le fichier xorg.conf n'existe pas.

tu me suggères d'en créer un donc comme tu as fais toi avec juste ces qq lignes , ok
mais comment faire compendre ensuite , que les drivers doivent etre interprété par le nouveau xorg.conf que je viendrais de créer car c'est HAL qui gere ça en fait.

:-)
Merci de m'eclairer sur cette voie
_________________
Mess with the best or die like the rest !
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Fri Jun 11, 2010 11:14 am    Post subject: Reply with quote

Lorsque j'utilisais le "viel" xorg compilé avec le USE hal (je ne suis pas en stable et les choses ont changées depuis xorg-server -1.8 ) les drivers claviers, souris étaient gérés par hal via des fichiers .fdi, sauf pour le driver video qui continuait de l'être par xorg via xor.conf... en tous cas dans mon cas particulier à moi....

en effet sans ces lignes :

Section "Device"
Identifier "GeForce GTS 250"
Driver "nvidia"
EndSection

ma CG n'était pas reconnue et le driver nvidia ne se chargeait pas... je t'ai indiqué ceci juste au cas où, malgré ta compilation réussie des drivers nvidia, il y aurait un problème dans leur chargement...

Si tu n'as pas rencontré ce soucis alors tu n'est pas obligé de créer un xorg.conf et tout va bien ! :wink:

Edit : si j'ai dis "à mon avis tu devras en créer un" c'est que pas mal de monde a du "préciser" malgré tout sa conf via un xorg.conf pour faire en sorte que tout tourne au poil...
Si par exemple tu veux passer des options particulières au driver nvidia (qui ne sont donc pas présente par défaut) ton seul moyen est de passer par xorg.conf.... c'est plus clair ???
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8080
Location: ~Brussels - Belgique

PostPosted: Fri Jun 11, 2010 12:02 pm    Post subject: Reply with quote

Oui, pour les cartes nVidia, xorg veut utiliser le pilote libre nv. Pour forcer cela, il faut mentionner qu'il faut passer par le pilote propriétaire.
Et ne pas oublier de faire
Code:
eselect opengl set nvidia


Pour ma part, j'utilise nouveau et suis plus que satisfait pour mon usage bureautique.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum