Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
blockierende pakete
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Wed Jul 21, 2010 9:40 pm    Post subject: blockierende pakete Reply with quote

hab ein
emerge --sync ; emerge -uaDvN world ; revdep-rebuild
gemacht
alles soweit gut bis zum revdep-rebuild
das zeigt es mir an
Code:
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.                                                     

 * Collecting system binaries and libraries
 * Found existing 1_files.rr               
 * Collecting complete LD_LIBRARY_PATH     
 * Found existing 2_ldpath.rr.             
 * Checking dynamic linking consistency   
 * Found existing 3_broken.rr.             
 * Assigning files to packages             
 * Found existing 4_raw.rr                 
 * Cleaning list of packages to rebuild   
 * Found existing 4_pkgs.rr               
 * Assigning packages to ebuilds           
 * Found existing 4_ebuilds.rr             
 * Evaluating package order               
[ebuild   R   ] dev-cpp/cairomm-1.6.0     
[ebuild   R   ] dev-cpp/pangomm-2.26.0     
[ebuild   R   ] gnome-base/libglade-2.6.4 
[ebuild   R   ] x11-libs/libsexy-0.1.11-r1
[ebuild   R   ] x11-libs/libwnck-2.28.0   
[ebuild   R   ] dev-cpp/gtkmm-2.18.2       
[ebuild   R   ] gnome-base/gnome-keyring-2.28.2
[ebuild   R   ] gnome-base/libgnomecanvas-2.26.0
[ebuild   R   ] gnome-base/libgnomeprintui-2.18.5
[ebuild  N    ] kde-base/libknotificationitem-4.3.5
[ebuild  N    ] kde-base/kontactinterfaces-4.3.5   
[ebuild   R   ] kde-base/kontact-4.3.5             
[ebuild   R   ] kde-base/kaddressbook-4.3.5-r1     
[ebuild   R   ] kde-base/akregator-4.3.5           
[ebuild   R   ] kde-base/kjots-4.3.5               
[ebuild   R   ] kde-base/kmail-4.3.5               
[ebuild   R   ] kde-base/knode-4.3.5               
[ebuild   R   ] kde-base/knotes-4.3.5               
[ebuild   R   ] kde-base/korganizer-4.3.5           
[ebuild   R   ] kde-base/kontact-specialdates-4.3.5
[ebuild   R   ] kde-base/ktimetracker-4.3.5         
[ebuild   R   ] x11-libs/libnotify-0.4.5           
[ebuild   R   ] x11-misc/notification-daemon-0.4.0-r1
[ebuild   R   ] gnome-base/libbonoboui-2.24.3         
[ebuild   R   ] gnome-base/libgnomeui-2.24.3         
[ebuild   R   ] net-libs/webkit-gtk-1.1.15.4         
[blocks B     ] kde-base/kontactinterfaces:4.3[-kdeprefix] ("kde-base/kontactinterfaces:4.3[-kdeprefix]" is blocking kde-base/kdepimlibs-4.4.4)
[blocks B     ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  ('installed', '/', 'kde-base/kdepimlibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kmail-4.3.5', 'merge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkleo-4.3.5', 'nomerge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkdepim-4.3.5', 'nomerge')
    (and 15 more)                                                                                                     

  ('installed', '/', 'kde-base/kdelibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libksieve-4.3.5', 'nomerge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/korganizer-4.3.5', 'merge')   
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/akregator-4.3.5', 'merge')     
    (and 17 more)                                                                                                   

  ('ebuild', '/', 'kde-base/kontactinterfaces-4.3.5', 'merge') pulled in by
    >=kde-base/kontactinterfaces-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')

  ('ebuild', '/', 'kde-base/libknotificationitem-4.3.5', 'merge') pulled in by
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkpgp-4.3.5', 'nomerge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/knode-4.3.5', 'merge')       
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')     
    (and 15 more)                                                                                                             

 *
 * Warning: Failed to resolve package order.
 * Will merge in arbitrary order           
 *                                         
Possible reasons:                           
- An ebuild is no longer in the portage tree.
- An ebuild is masked, use /etc/portage/packages.keyword
and/or /etc/portage/package.unmask to unmask it         
.....                                                   
 * All prepared. Starting rebuild                       
emerge --oneshot   dev-cpp/cairomm:0                   
dev-cpp/gtkmm:2.4                                       
dev-cpp/pangomm:2.4                                     
gnome-base/gnome-keyring:0                             
gnome-base/libbonoboui:0                               
gnome-base/libglade:2.0                                 
gnome-base/libgnomecanvas:0                             
gnome-base/libgnomeprintui:2.2                         
gnome-base/libgnomeui:0                                 
kde-base/akregator:4.3                                 
kde-base/kaddressbook:4.3                               
kde-base/kjots:4.3                                     
kde-base/kmail:4.3                                     
kde-base/knode:4.3                                     
kde-base/knotes:4.3                                     
kde-base/kontact:4.3                                   
kde-base/kontact-specialdates:4.3                       
kde-base/korganizer:4.3                                 
kde-base/ktimetracker:4.3                               
net-libs/webkit-gtk:0                                   
x11-libs/libnotify:0                                   
x11-libs/libsexy:0                                     
x11-libs/libwnck:0                                     
x11-misc/notification-daemon:0                         
..........                                             
Calculating dependencies... done!                       
[ebuild  N    ] kde-base/libknotificationitem-4.3.5  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"
[ebuild   R   ] gnome-base/libglade-2.6.4                                                               
[ebuild   R   ] dev-cpp/cairomm-1.6.0                                                                   
[ebuild   R   ] gnome-base/gnome-keyring-2.28.2                                                         
[ebuild   R   ] x11-libs/libsexy-0.1.11-r1                                                               
[ebuild   R   ] x11-libs/libwnck-2.28.0                                                                 
[ebuild   R   ] net-libs/webkit-gtk-1.1.15.4                                                             
[ebuild   R   ] gnome-base/libgnomecanvas-2.26.0                                                         
[ebuild   R   ] dev-cpp/pangomm-2.26.0                                                                   
[ebuild  N    ] kde-base/kontactinterfaces-4.3.5  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"   
[ebuild   R   ] kde-base/kontact-4.3.5                                                                   
[ebuild   R   ] gnome-base/libbonoboui-2.24.3                                                           
[ebuild   R   ] dev-cpp/gtkmm-2.18.2                                                                     
[ebuild   R   ] gnome-base/libgnomeprintui-2.18.5
[ebuild   R   ] kde-base/kaddressbook-4.3.5-r1
[ebuild   R   ] gnome-base/libgnomeui-2.24.3
[ebuild   R   ] kde-base/akregator-4.3.5
[ebuild   R   ] kde-base/kjots-4.3.5
[ebuild   R   ] kde-base/kmail-4.3.5
[ebuild   R   ] kde-base/knode-4.3.5
[ebuild   R   ] kde-base/knotes-4.3.5
[ebuild   R   ] kde-base/ktimetracker-4.3.5
[ebuild   R   ] kde-base/korganizer-4.3.5
[ebuild   R   ] kde-base/kontact-specialdates-4.3.5
[ebuild   R   ] x11-libs/libnotify-0.4.5
[ebuild   R   ] x11-misc/notification-daemon-0.4.0-r1
[blocks B     ] kde-base/kontactinterfaces:4.3[-kdeprefix] ("kde-base/kontactinterfaces:4.3[-kdeprefix]" is blocking kde-base/kdepimlibs-4.4.4)
[blocks B     ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'kde-base/kdepimlibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kmail-4.3.5', 'merge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/knotes-4.3.5', 'merge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-specialdates-4.3.5', 'merge')
    (and 8 more)

  ('installed', '/', 'kde-base/kdelibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/korganizer-4.3.5', 'merge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/akregator-4.3.5', 'merge')
    (and 9 more)

  ('ebuild', '/', 'kde-base/kontactinterfaces-4.3.5', 'merge') pulled in by
    >=kde-base/kontactinterfaces-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')

  ('ebuild', '/', 'kde-base/libknotificationitem-4.3.5', 'merge') pulled in by
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/knode-4.3.5', 'merge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kjots-4.3.5', 'merge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')
    (and 8 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 *
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 *
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr


ich verstehe nicht ganz was da wer wen wo und warum blockiert

wie loese ich die blockierenden sachen auf ?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1189

PostPosted: Wed Jul 21, 2010 9:59 pm    Post subject: Reply with quote

Quote:
>=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkpgp-4.3.5', 'nomerge')


wenn ich das richtig lese ist libkgpg noch in der alten Version installiert. mach doch nochmal ein "emerge -uaDvN world" oder versuch mal rauszufinden, wieso das nicht geupdatet wird/wurde.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Thu Jul 22, 2010 3:31 am    Post subject: Reply with quote

Das Problem ist das manche Pakete immer noch die kdelibs-4.3.5 haben möchten, beide kdelibs kannst du aber nicht gleichzeitig installieren. Also eigentlich geht es doch aber das will man nicht unbedingt guck die Diskussion hier.

Darum empfehle ich folgendes:

Maskiere kdelibs-4.3.5, entferne alle Programme die kdelibs-4.3.5 noch haben möchten, anschließend entfernst du kdelibs-4.3.5 auch, installierst dann die neue kdelibs-4.4.4 und schaust ob du die Pakte die eben noch kdelibs-4.3.5 haben wollten in einer neueren Version emergen kannst.

Du hast da aber auch einen zweiten Block der sind irgendwo zwischen "ktimetracker, korganizer, kdepim-kresources, kdepimlibs" versteckt :D
Ich weiß jetzt nicht welche Pakte es waren aber manche wurden auch noch aus dem Portage-Tree entfernt oder bekamen andere Namen (?) so genau weiß ich das nicht mehr. Letztlich habe ich so lange die Pakete entfernt bis ich kein 4.3.5-Pakte von ktimetracker bis kdepimlibs, mehr installiert hatte und das dann durch die neue Version ersetzt.

Tipp:
Wenn du gerade jetzt Updates machst.. achte auch auf das libpng-Udate!
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Thu Jul 22, 2010 8:21 pm    Post subject: Reply with quote

erstmal zu dem ersten block ...

Code:
equery d kdelibs-4.3.5
[ Searching for packages depending on kdelibs-4.3.5... ]
!!! Warning: No packages found matching kdelibs-4.3.5

es gibt keine packete die davon abhaengig sind ?

Code:
emerge -avC kdelibs
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

>>> These are the packages that would be unmerged:

 kde-base/kdelibs
    selected: 4.4.4
   protected: none
     omitted: none
ich kann nur version 4.4.4 deinstallieren ?
mit der angabe von:
emerge -avC kde-base/kdelibs-4.3.5 oder emerge -avC =kdelibs-4.3.5
kommt da nichts, ausser das er es nicht findet ? mache ich etwas falsch ?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1189

PostPosted: Thu Jul 22, 2010 8:29 pm    Post subject: Reply with quote

pieter_parker wrote:
erstmal zu dem ersten block ...

Code:
equery d kdelibs-4.3.5
[ Searching for packages depending on kdelibs-4.3.5... ]
!!! Warning: No packages found matching kdelibs-4.3.5

es gibt keine packete die davon abhaengig sind ?

Code:
emerge -avC kdelibs
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

>>> These are the packages that would be unmerged:

 kde-base/kdelibs
    selected: 4.4.4
   protected: none
     omitted: none
ich kann nur version 4.4.4 deinstallieren ?
mit der angabe von:
emerge -avC kde-base/kdelibs-4.3.5 oder emerge -avC =kdelibs-4.3.5
kommt da nichts, ausser das er es nicht findet ? mache ich etwas falsch ?


nein, es ist nix anderes installiert.

probier doch mal ein
"equery d libkpgp"
ich denke, dass es da dran liegt.
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Thu Jul 22, 2010 9:23 pm    Post subject: Reply with quote

Code:
equery d libkpgp
[ Searching for packages depending on libkpgp... ]
kde-base/kdepim-meta-4.3.5 (!kdeprefix? >=kde-base/libkpgp-4.3.5[aqua=,-kdeprefix])
                           (kdeprefix? >=kde-base/libkpgp-4.3.5:4.3[aqua=,kdeprefix])
kde-base/kmail-4.3.5 (!kdeprefix? >=kde-base/libkpgp-4.3.5[aqua=,-kdeprefix])
                     (kdeprefix? >=kde-base/libkpgp-4.3.5:4.3[aqua=,kdeprefix])
kde-base/knode-4.3.5 (!kdeprefix? >=kde-base/libkpgp-4.3.5[aqua=,-kdeprefix])
                     (kdeprefix? >=kde-base/libkpgp-4.3.5:4.3[aqua=,kdeprefix])

kde-base/kdepim-meta-4.3.5
kde-base/kmail-4.3.5
kde-base/knode-4.3.5
die pakete alle deinstallieren ?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1189

PostPosted: Thu Jul 22, 2010 9:47 pm    Post subject: Reply with quote

hmm, ich find es eigentlich seltsam, dass diese pakete nicht geupdatetet werden wollen. schau mal welche versionen von kmail verfügbar sind. ("eix kmail" oder "emerge -s kmail")

EDIT: -s, nicht -S
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Fri Jul 23, 2010 1:19 am    Post subject: Reply with quote

beim emerge -s kmail sehe ich
Code:
Searching...
[ Results for search key : kmail ]
[ Applications found : 2 ]

*  kde-base/kmail
      Latest version available: 4.4.4
      Latest version installed: 4.3.5
      Size of files: 9,135 kB
      Homepage:      http://www.kde.org/
      Description:   KMail is the email component of Kontact, the integrated personal information manager of KDE.
      License:       GPL-2

*  kde-base/kmailcvt
      Latest version available: 4.3.5
      Latest version installed: 4.3.5
      Size of files: 10,990 kB
      Homepage:      http://www.kde.org/
      Description:   KMail Import Filters
      License:       GPL-2
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3721
Location: Germany

PostPosted: Fri Jul 23, 2010 1:34 am    Post subject: Reply with quote

Welche KDE Version möchtest du den letztendlich eigentlich nutzen?
4.4.4 (aktuell im stable Zweig)
oder
4.4.5 (aktuell im testing Zweig)
Beide zusammen geht idR nicht!

Wenn du 4.4.4 nutzen möchtest:
solltest du alle demaskierungen in der package.keywords für 4.4.5 rausnehmen.

Wenn du 4.4.5 nutzen möchtest:
solltest du alle benötigten Pakete für 4.4.5 demaskieren.
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Fri Jul 23, 2010 1:54 am    Post subject: Reply with quote

ich will die stabel 4.4.4 version von kde benutzen
in /etc/portage/package.keywords habe ich garnichts von kde drinstehen
die ist doch stable, oder ?!
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jul 23, 2010 6:14 am    Post subject: Reply with quote

Mach mal ein "emerge kmail -av --tree" und schau, ob er die 4.4.4 installieren will.
Wenn dann irgendein Block kommt, solltest du direkter als bei revdep sehen, warum KMail nicht will.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Fri Jul 23, 2010 9:03 pm    Post subject: Reply with quote

Code:
emerge kmail -av --tree

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=kde-base/kdelibs-4.4.4[semantic-desktop,-kdeprefix,-aqua]".
!!! One of the following packages is required to complete your request:
- kde-base/kdelibs-4.4.4 (Change USE: +semantic-desktop)
(dependency required by "kde-base/kmail-4.4.4" [ebuild])
(dependency required by "kmail" [argument])
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1189

PostPosted: Fri Jul 23, 2010 9:28 pm    Post subject: Reply with quote

na dann solltest du die kdelibs mal mit semantic-desktop bauen. Vermutlich ist es sogar am besten, wenn du semantic-desktop global aktivierst, vermutlich gibt es sonst noch weitere Probleme.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3721
Location: Germany

PostPosted: Fri Jul 23, 2010 9:32 pm    Post subject: Reply with quote

Heißt wenn du kmail nutzen möchtest muss kdelibs mit USE="semantic-desktop" gebaut werden, also zb
Code:
# echo "kde-base/kdelibs semantic-desktop" >> /etc/portage/package.use


BTW:
Was für ein Profil nutzt du den eigentlich?
Code:
eselect profile show
?
Eventuell empfiehlt es sich das "desktop/kde" Subprofil zu verwenden wenn du KDE verwendest?!
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Fri Jul 23, 2010 9:47 pm    Post subject: Reply with quote

Code:
eselect profile show
Current make.profile symlink:
  default/linux/x86/10.0/desktop


soetwas wie kmail benutze ich garnicht und habe es auch nicht vor


habe
Code:
echo "kde-base/kdelibs semantic-desktop" >> /etc/portage/package.use

gemacht


Code:
emerge -uaDvN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-libs/shared-desktop-ontologies-0.4  88 kB
[ebuild   R   ] kde-base/kdelibs-4.4.4  USE="acl alsa bzip2 fam handbook mmx nls opengl semantic-desktop* spell sse sse2 ssl -3dnow (-altivec) (-aqua) -bindist -debug -doc -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -openexr -policykit -test -zeroconf" 0 kB
[ebuild  N    ] kde-base/nepomuk-4.4.4  USE="handbook (-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB

Total: 3 packages (2 new, 1 reinstall), Size of downloads: 88 kB

Would you like to merge these packages? [Yes/No]

er baut nun die 3 pakete neu
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3721
Location: Germany

PostPosted: Fri Jul 23, 2010 10:11 pm    Post subject: Reply with quote

Quote:
* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Found existing 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Found existing 2_ldpath.rr.
* Checking dynamic linking consistency
* Found existing 3_broken.rr.
* Assigning files to packages
........
......

Kann es sein das du da nur alte (vormals abgebrochene) Pakete vom revdep-rebuild versuchst durchzubringen?
Nutze bei revdep-rebuild am besten die "-i" Option mit, also zb
Code:
# revdep-rebuild -i


man revdep-rebuild wrote:
-i | --ignore
Delete temporary files from previous runs.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jul 23, 2010 11:51 pm    Post subject: Reply with quote

Wenn du KMail nicht willst, warum installierst du es dann?
Du kannst auch nur die KDE-Programme installieren, die du willst. Z.B.: K3B, Kopete, etc.

So ziehst du dir nur unnötigen Ballast auf die Platte.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Sun Jul 25, 2010 5:35 pm    Post subject: Reply with quote

bisher hab ich es immer als sehr praktisch gefunden einfach das gesammte kde zuinstallieren und immer alles da zuhaben falls ich es dochmal nutzen moechte

Code:
[blocks B     ] kde-base/kontactinterfaces:4.3[-kdeprefix] ("kde-base/kontactinterfaces:4.3[-kdeprefix]" is blocking kde-base/kdepimlibs-4.4.4)
[blocks B     ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.4)


ich dachte kontactinterfaces und libknotificationitem seien die probleme, mir ist noch nicht ganz klar wie ihr auf kmail kommt ?
wie ging das nochmal das ich kde ohne kmail benutze ? wenn das hilft das revdeb-rebuild nun endlich durchlaeuft, mache ich das auch so



Code:
revdep-rebuild -i
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.                                                     

 * Collecting system binaries and libraries
 * Generated new 1_files.rr               
 * Collecting complete LD_LIBRARY_PATH     
 * Generated new 2_ldpath.rr               
 * Checking dynamic linking consistency   
[ 17% ]  *   broken /usr/bin/kontact (requires libkontactinterfaces.so.4)
 *   broken /usr/bin/korgac (requires libknotificationitem-1.so.1)       
[ 52% ]  *   broken /usr/lib/kde4/kontact_akregatorplugin.so (requires libkontactinterfaces.so.4)
 *   broken /usr/lib/kde4/kontact_journalplugin.so (requires libkontactinterfaces.so.4)         
 *   broken /usr/lib/kde4/kontact_kaddressbookplugin.so (requires libkontactinterfaces.so.4)     
 *   broken /usr/lib/kde4/kontact_kjotsplugin.so (requires libkontactinterfaces.so.4)           
 *   broken /usr/lib/kde4/kontact_kmailplugin.so (requires libkontactinterfaces.so.4)           
 *   broken /usr/lib/kde4/kontact_knodeplugin.so (requires libkontactinterfaces.so.4)           
 *   broken /usr/lib/kde4/kontact_knotesplugin.so (requires libkontactinterfaces.so.4)           
 *   broken /usr/lib/kde4/kontact_korganizerplugin.so (requires libkontactinterfaces.so.4)       
 *   broken /usr/lib/kde4/kontact_ktimetrackerplugin.so (requires libkontactinterfaces.so.4)     
 *   broken /usr/lib/kde4/kontact_plannerplugin.so (requires libkontactinterfaces.so.4)         
 *   broken /usr/lib/kde4/kontact_specialdatesplugin.so (requires libkontactinterfaces.so.4)     
 *   broken /usr/lib/kde4/kontact_summaryplugin.so (requires libkontactinterfaces.so.4)         
 *   broken /usr/lib/kde4/kontact_todoplugin.so (requires libkontactinterfaces.so.4)             
[ 60% ]  *   broken /usr/lib/libbonoboui-2.la (requires -lpng12)                                 
 *   broken /usr/lib/libbonoboui-2.la (requires /usr/lib/libpng12.la)                           
[ 61% ]  *   broken /usr/lib/libcairomm-1.0.la (requires -lpng12)                               
[ 63% ]  *   broken /usr/lib/libgcr.la (requires /usr/lib/libpng12.la)                           
 *   broken /usr/lib/libgdkmm-2.4.la (requires /usr/lib/libpng12.la)                             
 *   broken /usr/lib/libgdkmm-2.4.la (requires -lpng12)                                         
 *   broken /usr/lib/libglade-2.0.la (requires -lpng12)                                         
 *   broken /usr/lib/libglade/2.0/libbonobo.la (requires -lpng12)                               
 *   broken /usr/lib/libglade/2.0/libbonobo.la (requires /usr/lib/libpng12.la)                   
 *   broken /usr/lib/libglade/2.0/libcanvas.la (requires /usr/lib/libpng12.la)                   
 *   broken /usr/lib/libglade/2.0/libcanvas.la (requires -lpng12)                               
 *   broken /usr/lib/libglade/2.0/libgnome.la (requires -lpng12)                                 
 *   broken /usr/lib/libglade/2.0/libgnome.la (requires /usr/lib/libpng12.la)                   
[ 64% ]  *   broken /usr/lib/libgnomecanvas-2.la (requires /usr/lib/libpng12.la)                 
 *   broken /usr/lib/libgnomecanvas-2.la (requires -lpng12)                                     
 *   broken /usr/lib/libgnomeprintui-2-2.la (requires -lpng12)                                   
 *   broken /usr/lib/libgnomeprintui-2-2.la (requires /usr/lib/libpng12.la)                     
 *   broken /usr/lib/libgnomeui-2.la (requires -lpng12)                                         
 *   broken /usr/lib/libgnomeui-2.la (requires /usr/lib/libpng12.la)                             
[ 68% ]  *   broken /usr/lib/libgtkmm-2.4.la (requires /usr/lib/libpng12.la)                     
 *   broken /usr/lib/libgtkmm-2.4.la (requires -lpng12)                                         
[ 71% ]  *   broken /usr/lib/libkontactprivate.so.4.3.0 (requires libkontactinterfaces.so.4)     
[ 73% ]  *   broken /usr/lib/libnotify.la (requires -lpng12)                                     
 *   broken /usr/lib/libpangomm-1.4.la (requires -lpng12)                                       
 *   broken /usr/lib/libpangomm-1.4.la (requires /usr/lib/libpng12.la)                           
[ 75% ]  *   broken /usr/lib/libsexy.la (requires -lpng12)                                       
[ 77% ]  *   broken /usr/lib/libwebkit-1.0.la (requires /usr/lib/libpng12.la)                   
 *   broken /usr/lib/libwnck-1.la (requires /usr/lib/libpng12.la)                               
[ 80% ]  *   broken /usr/lib/notification-daemon-1.0/engines/libstandard.la (requires -lpng12)   
 *   broken /usr/lib/notification-daemon-1.0/engines/libstandard.la (requires /usr/lib/libpng12.la)
[ 100% ]                                                                                           
 * Generated new 3_broken.rr                                                                       
 * Assigning files to packages                                                                     
 *   /usr/bin/kontact -> kde-base/kontact                                                         
 *   /usr/bin/korgac -> kde-base/korganizer                                                       
 *   /usr/lib/kde4/kontact_akregatorplugin.so -> kde-base/akregator                               
 *   /usr/lib/kde4/kontact_journalplugin.so -> kde-base/korganizer                                 
 *   /usr/lib/kde4/kontact_kaddressbookplugin.so -> kde-base/kaddressbook                         
 *   /usr/lib/kde4/kontact_kjotsplugin.so -> kde-base/kjots                                       
 *   /usr/lib/kde4/kontact_kmailplugin.so -> kde-base/kmail                                       
 *   /usr/lib/kde4/kontact_knodeplugin.so -> kde-base/knode                                       
 *   /usr/lib/kde4/kontact_knotesplugin.so -> kde-base/knotes                                     
 *   /usr/lib/kde4/kontact_korganizerplugin.so -> kde-base/korganizer                             
 *   /usr/lib/kde4/kontact_ktimetrackerplugin.so -> kde-base/ktimetracker                         
 *   /usr/lib/kde4/kontact_plannerplugin.so -> kde-base/korganizer                                 
 *   /usr/lib/kde4/kontact_specialdatesplugin.so -> kde-base/kontact-specialdates                 
 *   /usr/lib/kde4/kontact_summaryplugin.so -> kde-base/kontact                                   
 *   /usr/lib/kde4/kontact_todoplugin.so -> kde-base/korganizer                                   
 *   /usr/lib/libbonoboui-2.la -> gnome-base/libbonoboui                                           
 *   /usr/lib/libcairomm-1.0.la -> dev-cpp/cairomm                                                 
 *   /usr/lib/libgcr.la -> gnome-base/gnome-keyring                                               
 *   /usr/lib/libgdkmm-2.4.la -> dev-cpp/gtkmm                                                     
 *   /usr/lib/libglade-2.0.la -> gnome-base/libglade                                               
 *   /usr/lib/libglade/2.0/libbonobo.la -> gnome-base/libbonoboui                                 
 *   /usr/lib/libglade/2.0/libcanvas.la -> gnome-base/libgnomecanvas                               
 *   /usr/lib/libglade/2.0/libgnome.la -> gnome-base/libgnomeui                                   
 *   /usr/lib/libgnomecanvas-2.la -> gnome-base/libgnomecanvas                                     
 *   /usr/lib/libgnomeprintui-2-2.la -> gnome-base/libgnomeprintui                                 
 *   /usr/lib/libgnomeui-2.la -> gnome-base/libgnomeui                                             
 *   /usr/lib/libgtkmm-2.4.la -> dev-cpp/gtkmm                                                     
 *   /usr/lib/libkontactprivate.so.4.3.0 -> kde-base/kontact                                       
 *   /usr/lib/libnotify.la -> x11-libs/libnotify                                                   
 *   /usr/lib/libpangomm-1.4.la -> dev-cpp/pangomm                                                 
 *   /usr/lib/libsexy.la -> x11-libs/libsexy                                                       
 *   /usr/lib/libwebkit-1.0.la -> net-libs/webkit-gtk                                             
 *   /usr/lib/libwnck-1.la -> x11-libs/libwnck                                                     
 *   /usr/lib/notification-daemon-1.0/engines/libstandard.la -> x11-misc/notification-daemon       
 * Generated new 4_raw.rr and 4_owners.rr                                                         
 * Cleaning list of packages to rebuild                                                           
 * Generated new 4_pkgs.rr                                                                         
 * Assigning packages to ebuilds                                                                   
 * Generated new 4_ebuilds.rr                                                                     
 * Evaluating package order                                                                       
[ebuild   R   ] dev-cpp/cairomm-1.6.0                                                             
[ebuild   R   ] dev-cpp/pangomm-2.26.0                                                             
[ebuild   R   ] gnome-base/libglade-2.6.4                                                         
[ebuild   R   ] x11-libs/libsexy-0.1.11-r1                                                         
[ebuild   R   ] x11-libs/libwnck-2.28.0                                                           
[ebuild   R   ] dev-cpp/gtkmm-2.18.2                                                               
[ebuild   R   ] gnome-base/gnome-keyring-2.28.2                                                   
[ebuild   R   ] gnome-base/libgnomecanvas-2.26.0                                                   
[ebuild   R   ] gnome-base/libgnomeprintui-2.18.5                                                 
[ebuild  N    ] kde-base/libknotificationitem-4.3.5                                               
[ebuild  N    ] kde-base/kontactinterfaces-4.3.5                                                   
[ebuild   R   ] kde-base/kontact-4.3.5                                                             
[ebuild   R   ] kde-base/kaddressbook-4.3.5-r1                                                     
[ebuild   R   ] kde-base/akregator-4.3.5                                                           
[ebuild   R   ] kde-base/kjots-4.3.5                                                               
[ebuild   R   ] kde-base/kmail-4.3.5                                                               
[ebuild   R   ] kde-base/knode-4.3.5                                                               
[ebuild   R   ] kde-base/knotes-4.3.5                                                             
[ebuild   R   ] kde-base/korganizer-4.3.5                                                         
[ebuild   R   ] kde-base/kontact-specialdates-4.3.5                                               
[ebuild   R   ] kde-base/ktimetracker-4.3.5                                                       
[ebuild   R   ] x11-libs/libnotify-0.4.5                                                           
[ebuild   R   ] x11-misc/notification-daemon-0.4.0-r1                                             
[ebuild   R   ] gnome-base/libbonoboui-2.24.3                                                     
[ebuild   R   ] gnome-base/libgnomeui-2.24.3                                                       
[ebuild   R   ] net-libs/webkit-gtk-1.1.15.4                                                       
[blocks B     ] kde-base/kontactinterfaces:4.3[-kdeprefix] ("kde-base/kontactinterfaces:4.3[-kdeprefix]" is blocking kde-base/kdepimlibs-4.4.4)
[blocks B     ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  ('installed', '/', 'kde-base/kdepimlibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kmail-4.3.5', 'merge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkleo-4.3.5', 'nomerge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkdepim-4.3.5', 'nomerge')
    (and 15 more)                                                                                                     

  ('installed', '/', 'kde-base/kdelibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/korganizer-4.3.5', 'merge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')   
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/ktimetracker-4.3.5', 'merge')
    (and 19 more)                                                                                                 

  ('ebuild', '/', 'kde-base/kontactinterfaces-4.3.5', 'merge') pulled in by
    >=kde-base/kontactinterfaces-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')

  ('ebuild', '/', 'kde-base/libknotificationitem-4.3.5', 'merge') pulled in by
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkpgp-4.3.5', 'nomerge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/knode-4.3.5', 'merge')       
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')     
    (and 15 more)                                                                                                             

 *
 * Warning: Failed to resolve package order.
 * Will merge in arbitrary order           
 *                                         
Possible reasons:                           
- An ebuild is no longer in the portage tree.
- An ebuild is masked, use /etc/portage/packages.keyword
and/or /etc/portage/package.unmask to unmask it         
.....                                                   
 * All prepared. Starting rebuild                       
emerge --oneshot   dev-cpp/cairomm:0                   
dev-cpp/gtkmm:2.4                                       
dev-cpp/pangomm:2.4                                     
gnome-base/gnome-keyring:0                             
gnome-base/libbonoboui:0                               
gnome-base/libglade:2.0                                 
gnome-base/libgnomecanvas:0                             
gnome-base/libgnomeprintui:2.2                         
gnome-base/libgnomeui:0                                 
kde-base/akregator:4.3                                 
kde-base/kaddressbook:4.3                               
kde-base/kjots:4.3                                     
kde-base/kmail:4.3                                     
kde-base/knode:4.3                                     
kde-base/knotes:4.3                                     
kde-base/kontact:4.3                                   
kde-base/kontact-specialdates:4.3                       
kde-base/korganizer:4.3                                 
kde-base/ktimetracker:4.3                               
net-libs/webkit-gtk:0                                   
x11-libs/libnotify:0                                   
x11-libs/libsexy:0                                     
x11-libs/libwnck:0                                     
x11-misc/notification-daemon:0                         
..........                                             
Calculating dependencies... done!                       
[ebuild  N    ] kde-base/libknotificationitem-4.3.5  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"
[ebuild   R   ] gnome-base/libglade-2.6.4                                                               
[ebuild   R   ] dev-cpp/cairomm-1.6.0                                                                   
[ebuild   R   ] gnome-base/gnome-keyring-2.28.2                                                         
[ebuild   R   ] x11-libs/libsexy-0.1.11-r1                                                               
[ebuild   R   ] x11-libs/libwnck-2.28.0                                                                 
[ebuild   R   ] net-libs/webkit-gtk-1.1.15.4                                                             
[ebuild   R   ] gnome-base/libgnomecanvas-2.26.0                                                         
[ebuild   R   ] dev-cpp/pangomm-2.26.0                                                                   
[ebuild  N    ] kde-base/kontactinterfaces-4.3.5  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"   
[ebuild   R   ] kde-base/kontact-4.3.5                                                                   
[ebuild   R   ] gnome-base/libbonoboui-2.24.3                                                           
[ebuild   R   ] dev-cpp/gtkmm-2.18.2                                                                     
[ebuild   R   ] gnome-base/libgnomeprintui-2.18.5
[ebuild   R   ] kde-base/kaddressbook-4.3.5-r1
[ebuild   R   ] gnome-base/libgnomeui-2.24.3
[ebuild   R   ] kde-base/akregator-4.3.5
[ebuild   R   ] kde-base/kjots-4.3.5
[ebuild   R   ] kde-base/kmail-4.3.5
[ebuild   R   ] kde-base/knode-4.3.5
[ebuild   R   ] kde-base/knotes-4.3.5
[ebuild   R   ] kde-base/ktimetracker-4.3.5
[ebuild   R   ] kde-base/korganizer-4.3.5
[ebuild   R   ] kde-base/kontact-specialdates-4.3.5
[ebuild   R   ] x11-libs/libnotify-0.4.5
[ebuild   R   ] x11-misc/notification-daemon-0.4.0-r1
[blocks B     ] kde-base/kontactinterfaces:4.3[-kdeprefix] ("kde-base/kontactinterfaces:4.3[-kdeprefix]" is blocking kde-base/kdepimlibs-4.4.4)
[blocks B     ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'kde-base/kdepimlibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kmail-4.3.5', 'merge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/knotes-4.3.5', 'merge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-specialdates-4.3.5', 'merge')
    (and 8 more)

  ('installed', '/', 'kde-base/kdelibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/korganizer-4.3.5', 'merge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/akregator-4.3.5', 'merge')
    (and 9 more)

  ('ebuild', '/', 'kde-base/kontactinterfaces-4.3.5', 'merge') pulled in by
    >=kde-base/kontactinterfaces-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')

  ('ebuild', '/', 'kde-base/libknotificationitem-4.3.5', 'merge') pulled in by
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/knode-4.3.5', 'merge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kjots-4.3.5', 'merge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')
    (and 8 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 *
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 *
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3721
Location: Germany

PostPosted: Sun Jul 25, 2010 5:54 pm    Post subject: Reply with quote

Wenn du das aktuelle stable KDE-4.4 nutzen möchtest, dann wirst du dich von
Quote:
* kde-base/kontactinterfaces
Available versions: (4.3) 4.3.5

und

* kde-base/kontact-specialdates
Available versions: (4.3) 4.3.5
trennen müssen, da es diese nur für kde:4.3 gibt.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1189

PostPosted: Sun Jul 25, 2010 6:52 pm    Post subject: Reply with quote

kde ohne kmail geht einfach indem du kmail nicht installierst :)
also "emerge -c kmail". entweder irgendwas hängt noch von kmail ab oder es wird deinstalliert.

damit aber das emergen läuft, wirst du, wie josef sagt kontactinterfaces und kontact-specialdates entfernen müssen.
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Sun Jul 25, 2010 9:21 pm    Post subject: Reply with quote

Code:
revdep-rebuild                     
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.                                                     

 * Collecting system binaries and libraries
 * Found existing 1_files.rr               
 * Collecting complete LD_LIBRARY_PATH     
 * Found existing 2_ldpath.rr.             
 * Checking dynamic linking consistency   
 * Found existing 3_broken.rr.             
 * Assigning files to packages             
 * Found existing 4_raw.rr                 
 * Cleaning list of packages to rebuild   
 * Found existing 4_pkgs.rr               
 * Assigning packages to ebuilds           
 * Found existing 4_ebuilds.rr             
 * Evaluating package order               
[ebuild   R   ] dev-cpp/cairomm-1.6.0     
[ebuild   R   ] dev-cpp/pangomm-2.26.0     
[ebuild   R   ] gnome-base/libglade-2.6.4 
[ebuild   R   ] x11-libs/libsexy-0.1.11-r1
[ebuild   R   ] x11-libs/libwnck-2.28.0   
[ebuild   R   ] dev-cpp/gtkmm-2.18.2       
[ebuild   R   ] gnome-base/gnome-keyring-2.28.2
[ebuild   R   ] gnome-base/libgnomecanvas-2.26.0
[ebuild   R   ] gnome-base/libgnomeprintui-2.18.5
[ebuild  N    ] kde-base/libknotificationitem-4.3.5
[ebuild  N    ] kde-base/kontactinterfaces-4.3.5   
[ebuild   R   ] kde-base/kontact-4.3.5             
[ebuild   R   ] kde-base/kaddressbook-4.3.5-r1     
[ebuild   R   ] kde-base/akregator-4.3.5           
[ebuild   R   ] kde-base/kjots-4.3.5               
[ebuild  N    ] kde-base/kmail-4.3.5               
[ebuild   R   ] kde-base/knode-4.3.5               
[ebuild   R   ] kde-base/knotes-4.3.5               
[ebuild   R   ] kde-base/korganizer-4.3.5           
[ebuild  N    ] kde-base/kontact-specialdates-4.3.5
[ebuild   R   ] kde-base/ktimetracker-4.3.5         
[ebuild   R   ] x11-libs/libnotify-0.4.5           
[ebuild   R   ] x11-misc/notification-daemon-0.4.0-r1
[ebuild   R   ] gnome-base/libbonoboui-2.24.3         
[ebuild   R   ] gnome-base/libgnomeui-2.24.3         
[ebuild   R   ] net-libs/webkit-gtk-1.1.15.4         
[blocks B     ] kde-base/kontactinterfaces:4.3[-kdeprefix] ("kde-base/kontactinterfaces:4.3[-kdeprefix]" is blocking kde-base/kdepimlibs-4.4.4)
[blocks B     ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  ('installed', '/', 'kde-base/kdepimlibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kmail-4.3.5', 'merge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkleo-4.3.5', 'nomerge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkdepim-4.3.5', 'nomerge')
    (and 15 more)                                                                                                     

  ('installed', '/', 'kde-base/kdelibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/korganizer-4.3.5', 'merge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')   
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/ktimetracker-4.3.5', 'merge')
    (and 19 more)                                                                                                 

  ('ebuild', '/', 'kde-base/kontactinterfaces-4.3.5', 'merge') pulled in by
    >=kde-base/kontactinterfaces-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')

  ('ebuild', '/', 'kde-base/libknotificationitem-4.3.5', 'merge') pulled in by
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/libkpgp-4.3.5', 'nomerge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/knode-4.3.5', 'merge')       
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')     
    (and 15 more)                                                                                                             

 *
 * Warning: Failed to resolve package order.
 * Will merge in arbitrary order           
 *                                         
Possible reasons:                           
- An ebuild is no longer in the portage tree.
- An ebuild is masked, use /etc/portage/packages.keyword
and/or /etc/portage/package.unmask to unmask it         
.....                                                   
 * All prepared. Starting rebuild                       
emerge --oneshot   dev-cpp/cairomm:0                   
dev-cpp/gtkmm:2.4                                       
dev-cpp/pangomm:2.4                                     
gnome-base/gnome-keyring:0                             
gnome-base/libbonoboui:0                               
gnome-base/libglade:2.0                                 
gnome-base/libgnomecanvas:0                             
gnome-base/libgnomeprintui:2.2                         
gnome-base/libgnomeui:0                                 
kde-base/akregator:4.3                                 
kde-base/kaddressbook:4.3                               
kde-base/kjots:4.3                                     
kde-base/kmail:4.3                                     
kde-base/knode:4.3                                     
kde-base/knotes:4.3                                     
kde-base/kontact:4.3                                   
kde-base/kontact-specialdates:4.3                       
kde-base/korganizer:4.3                                 
kde-base/ktimetracker:4.3                               
net-libs/webkit-gtk:0                                   
x11-libs/libnotify:0                                   
x11-libs/libsexy:0                                     
x11-libs/libwnck:0                                     
x11-misc/notification-daemon:0                         
..........                                             
Calculating dependencies... done!                       
[ebuild  N    ] kde-base/libknotificationitem-4.3.5  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"
[ebuild   R   ] gnome-base/libglade-2.6.4                                                               
[ebuild   R   ] dev-cpp/cairomm-1.6.0                                                                   
[ebuild   R   ] gnome-base/gnome-keyring-2.28.2                                                         
[ebuild   R   ] x11-libs/libsexy-0.1.11-r1                                                               
[ebuild   R   ] x11-libs/libwnck-2.28.0                                                                 
[ebuild   R   ] net-libs/webkit-gtk-1.1.15.4                                                             
[ebuild   R   ] gnome-base/libgnomecanvas-2.26.0                                                         
[ebuild   R   ] dev-cpp/pangomm-2.26.0                                                                   
[ebuild  N    ] kde-base/kontactinterfaces-4.3.5  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"   
[ebuild   R   ] kde-base/kontact-4.3.5                                                                   
[ebuild   R   ] gnome-base/libbonoboui-2.24.3                                                           
[ebuild   R   ] dev-cpp/gtkmm-2.18.2                                                                     
[ebuild   R   ] gnome-base/libgnomeprintui-2.18.5                                                       
[ebuild   R   ] kde-base/kaddressbook-4.3.5-r1                                                           
[ebuild   R   ] gnome-base/libgnomeui-2.24.3                                                             
[ebuild   R   ] kde-base/akregator-4.3.5                                                                 
[ebuild   R   ] kde-base/kjots-4.3.5                                                                     
[ebuild  N    ] kde-base/kmail-4.3.5  USE="handbook kontact (-aqua) -debug (-kdeenablefinal) (-kdeprefix) -semantic-desktop"
[ebuild   R   ] kde-base/knode-4.3.5                                                                                         
[ebuild   R   ] kde-base/knotes-4.3.5                                                                                       
[ebuild   R   ] kde-base/ktimetracker-4.3.5                                                                                 
[ebuild   R   ] kde-base/korganizer-4.3.5                                                                                   
[ebuild  N    ] kde-base/kontact-specialdates-4.3.5  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"                     
[ebuild   R   ] x11-libs/libnotify-0.4.5                                                                                     
[ebuild   R   ] x11-misc/notification-daemon-0.4.0-r1                                                                       
[blocks B     ] kde-base/kontactinterfaces:4.3[-kdeprefix] ("kde-base/kontactinterfaces:4.3[-kdeprefix]" is blocking kde-base/kdepimlibs-4.4.4)
[blocks B     ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  ('installed', '/', 'kde-base/kdepimlibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kmail-4.3.5', 'merge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/knotes-4.3.5', 'merge')
    >=kde-base/kdepimlibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-specialdates-4.3.5', 'merge')
    (and 8 more)                                                                                                             

  ('installed', '/', 'kde-base/kdelibs-4.4.4', 'nomerge') pulled in by
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/korganizer-4.3.5', 'merge')
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')   
    >=kde-base/kdelibs-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/akregator-4.3.5', 'merge')
    (and 9 more)                                                                                               

  ('ebuild', '/', 'kde-base/kontactinterfaces-4.3.5', 'merge') pulled in by
    >=kde-base/kontactinterfaces-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')

  ('ebuild', '/', 'kde-base/libknotificationitem-4.3.5', 'merge') pulled in by
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/knode-4.3.5', 'merge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kjots-4.3.5', 'merge')
    >=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kontact-4.3.5', 'merge')
    (and 8 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 *
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 *
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr



der will die pakete neuinstallieren ?
verstehe das nicht so ganz seltsam
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1189

PostPosted: Sun Jul 25, 2010 9:28 pm    Post subject: Reply with quote

deinstallieren->emerge -uDN world->revdep-rebuild
probiers mal so, und kein revdep-rebuild, bevor das updaten nicht durch ist
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3721
Location: Germany

PostPosted: Sun Jul 25, 2010 10:04 pm    Post subject: Reply with quote

Und nochmals, nutze nach so einem abgebrochenen revdep-rebuild bitte die "-i" Option mit, oder beachte
Quote:
* To remove temporary files, please run:
* rm /var/cache/revdep-rebuild/*.rr
:wink:
Ansonsten wird revdep-rebuild immer wieder die selben, schon vormals abgebrochenen Paket versuchen neu zu bauen. (auch wenn sie gar nicht mehr benötigt würden)
IdR kannst/solltest du revdep-rebuild immer mit "-i" nutzen.

Du musst/solltest zuerst herausfinden welches Paket immer noch kde:4.3 Abhängigkeiten zieht, erst wenn diese nicht mehr vorhanden sind hat ein revdep-rebuild überhaupt aussicht auf Erfolg.
Also deinstalliere zunächst alles was kde:4.3 als Abhängigkeit hat.
Für eine grobe Übersicht könntest du zb
Code:
$ eix -Ic | grep 4.3
nutzen, oder manuell das world File durchsehen und säubern.
Back to top
View user's profile Send private message
pieter_parker
Veteran
Veteran


Joined: 07 Aug 2006
Posts: 1488
Location: 127.0.0.1

PostPosted: Mon Jul 26, 2010 1:14 am    Post subject: Reply with quote

Code:
eix -Ic | grep 4.3
[I] app-text/docbook-xml-dtd (4.2-r2(4.2)@21.05.2010 4.3-r1(4.3)@20.06.2010 4.5-r1(4.5)@21.05.2010): Docbook DTD for XML
[I] dev-libs/gmp (4.3.2@16.02.2010): Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers
[I] dev-libs/soprano (2.4.3@01.07.2010): Library that provides a nice Qt interface to RDF storage solutions
[I] gnome-base/gnome-vfs (2.24.3-r1(2)@20.06.2010): Gnome Virtual Filesystem
[I] gnome-base/gvfs (1.4.3-r1@20.06.2010): GNOME Virtual Filesystem Layer
[I] gnome-base/libbonobo (2.24.3@20.06.2010): GNOME CORBA framework
[I] gnome-base/libbonoboui (2.24.3@20.06.2010): User Interface part of libbonobo
[I] gnome-base/libgnomeui (2.24.3@20.06.2010): User Interface routines for Gnome
[U] kde-base/akregator (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE news feed aggregator.
[U] kde-base/kabcclient (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): A command line client for accessing the KDE addressbook
[U] kde-base/kaddressbook (4.3.5-r1(4.3)@26.03.2010 -> 4.3.5-r1(4.3) 4.4.4(4.4)): The KDE Address Book
[U] kde-base/kalarm (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): Personal alarm message, command and email scheduler for KDE
[I] kde-base/kappfinder (4.3.5(4.3)@21.05.2010): KDE tool that looks for well-known apps in your path and creates entries for them in the KDE menu
[U] kde-base/kdepim-icons (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE PIM icons
[U] kde-base/kdepim-kresources (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE PIM groupware plugin collection
[U] kde-base/kdepim-meta (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): kdepim - merge this to pull in all kdepim-derived packages
[U] kde-base/kdepim-strigi-analyzer (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): kdepim: strigi plugins
[U] kde-base/kdepim-wizards (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE PIM wizards
[I] kde-base/kdessh (4.3.5(4.3)@07.03.2010): KDE frontend to ssh
[U] kde-base/kdewebdev-meta (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE WebDev - merge this to pull in all kdewebdev-derived packages
[U] kde-base/kfilereplace (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE web development - powerful search and replace in multiple files
[U] kde-base/kimagemapeditor (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE web development - image map editor
[U] kde-base/kjots (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE note taking utility
[U] kde-base/kleopatra (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): Kleopatra - KDE X.509 key manager
[U] kde-base/klinkstatus (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE web development - link validity checker
[I] kde-base/kmailcvt (4.3.5(4.3)@07.03.2010): KMail Import Filters
[U] kde-base/knode (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3)!t 4.4.4(4.4)!t): A newsreader for KDE
[U] kde-base/knotes (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE Notes application
[U] kde-base/kommander (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE dialog system for scripting
[U] kde-base/konsolekalendar (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): A command line interface to KDE calendars
[U] kde-base/kontact (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE personal information manager
[U] kde-base/korganizer (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3)!t 4.4.4(4.4)): A Personal Organizer for KDE
[U] kde-base/ktimetracker (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KTimeTracker tracks time spent on various tasks.
[I] kde-base/kxsldbg (4.3.5(4.3)@07.03.2010): A KDE KPart Application for xsldbg, an XSLT debugger
[U] kde-base/libkdepim (4.3.5(4.3)@06.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): Common library for KDE PIM apps
[U] kde-base/libkleo (4.3.5(4.3)@06.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE library for encryption handling.
[U] kde-base/libkpgp (4.3.5(4.3)@07.03.2010 -> 4.3.5(4.3) 4.4.4(4.4)): KDE pgp abstraction library
[I] kde-base/libksieve (4.3.5(4.3)@07.03.2010): library enable support for sieve (imap server-side filtering standard) in kde apps, used by kmail
[I] kde-base/mimelib (4.3.5(4.3)@07.03.2010): KDE mime library
[I] media-libs/libpng (1.2.44(1.2)@01.07.2010 1.4.3@01.07.2010): Portable Network Graphics library
[I] net-misc/stunnel (4.31-r1@26.06.2010): TLS/SSL - Port Wrapper
[I] sys-devel/gcc (4.3.4(4.3)@06.03.2010 4.4.3-r2(4.4)@20.06.2010): The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking
[I] x11-proto/trapproto (3.4.3@06.03.2010): X.Org Trap protocol headers


eh, welche der kde sachen sollte ich denn jetzt alle deinstallieren ?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3721
Location: Germany

PostPosted: Mon Jul 26, 2010 6:57 am    Post subject: Reply with quote

pieter_parker wrote:
eh, welche der kde sachen sollte ich denn jetzt alle deinstallieren ?
All die Pakete die es für kde:4.4 nicht geben würde.
Zum beispiel kde-base/kdessh wäre so ein Kandidat.

Es können aber durchaus noch mehr Pakete dabei sein, müsstest es halt kurz überprüfen.

/edit:
Folgende Pakete solltest du runter schmeißen
Code:
 kde-base/kappfinder kde-base/kmailcvt kde-base/kontact-specialdates kde-base/kontactinterfaces kde-base/kxsldbg kde-base/libksieve kde-base/mimelib kde-base/kdessh

Dann sollte ein
Code:
# emerge -avuDN world
und
# revdep-rebuild -i
eigentlich durchgehen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum