Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
System auf Englisch umstellen [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
72_6f_6c_61_6e_64
Guru
Guru


Joined: 16 Nov 2009
Posts: 438
Location: 39° 6′ 18″ N, 76° 44′ 29″ W

PostPosted: Mon Nov 08, 2010 12:43 pm    Post subject: System auf Englisch umstellen [solved] Reply with quote

Hallo,

ich hab mein System auf UTF-8 umgestellt und hab jetzt das "Problem" dass mein gesamtes System auf Deutsch ist.

Ich hätte es aber gerne auf Englisch. Nur das Tastaturlayout soll auf deutsch sein, ist es zur Zeit ja eh.

Wie mach ich das? Das ist doch mit den locales irgendwie einzustellen oder?

Mein Output von locale sieht so aus (als user):
Code:
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

Meine /etc/env.d/02locale sieht so aus:
Code:
LANG="de_DE.UTF-8"

LG Roland
_________________
Man gewöhnt sich an allem, sogar am Dativ.


Last edited by 72_6f_6c_61_6e_64 on Mon Nov 08, 2010 5:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Mon Nov 08, 2010 1:03 pm    Post subject: Reply with quote

Du brauchst en_US.UTF-8 als locale. Dann ist weder alles Englisch.

Sebastian
Back to top
View user's profile Send private message
root_tux_linux
l33t
l33t


Joined: 21 Dec 2003
Posts: 966

PostPosted: Mon Nov 08, 2010 4:26 pm    Post subject: Re: System auf Englisch umstellen Reply with quote

Lösch doch einfach wieder /etc/env.d/02locale und dann env-update?

Wenn du sowieso nur die Tastatur deutsch will.
_________________
Intel Core i7 6700K@4.6GHz, Gigabyte GTX 980 Ti G1, Gigabyte Gaming 7, Hyper X Fury 32GB, 2 TB Samsung EVO 840 Basic
ASUS ROG Swift PG348Q Display
ASUS ROG ASUS G771JW Notebook
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Mon Nov 08, 2010 4:30 pm    Post subject: Reply with quote

Er will doch aber auch Sonderzeichen in der Konsole haben.

Schreib einfach in die 02locale en_US.UTF8

In der locale.gen muss das natürlich auch drin stehen und generieren musst du es auch. Alles wie bei de_DE.UTF8 nur halt mit en_US.UTF8.

Sebastian
Back to top
View user's profile Send private message
72_6f_6c_61_6e_64
Guru
Guru


Joined: 16 Nov 2009
Posts: 438
Location: 39° 6′ 18″ N, 76° 44′ 29″ W

PostPosted: Mon Nov 08, 2010 5:32 pm    Post subject: Reply with quote

Hallo, ich hab jetzt in der 02locale einfach
LANG="en_US.UTF-8" stehen.

Und jetzt gehts :lol:

Danke
_________________
Man gewöhnt sich an allem, sogar am Dativ.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Mon Nov 08, 2010 5:57 pm    Post subject: Reply with quote

Hi Leute.

Ist vielleicht etwas an 72_6f_6c_61_6e_64's Fragestellung vorbei, denn er wollte ja alles auf englisch umstellen, ausser dem Tastaturlayout.
Sollte es jedoch nur deshalb sein, um die Portage (Fehler)meldungen auf englisch zu erhalten, zum Bug reporting z.B., dann gibt es eine elegantere Lösung, die ich nicht mehr missen möchte.

Mein System ist also vollständig de wo's geht, der Rest, quasi als Fallback ist englisch, und Portage generell.
In erster Linie erreicht man das durch anlegen der Datei, mit folgendem Inhalt:
Code:

cat /etc/portage/bashrc
export LC_ALL="C"
export LANG="C"


den Rest hab ich wie folgt eingestellt:
Code:

cat /etc/locale.gen
en_US ISO-8859-1
en_US.UTF-8 UTF-8
de_DE.UTF-8 UTF-8
de_DE ISO-8859-1
de_DE@euro ISO-8859-15


Code:

cat /etc/env.d/02locale
LANG="de_DE.UTF-8"
LANGUAGE="de_DE.UTF-8"
GDM_LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"


Das Tastaturlayout wird hier gesetzt, kann aber je nach Tastatur anders erforderlich sein
Code:
cat /etc/conf.d/keymaps
keymap="de-latin1-nodeadkeys"
windowkeys="YES"
extended_keymaps="backspace keypad euro2"
fix_euro="NO"


Und natürlich je nach DE ist das ganze via GUI dafür nochmal getrennt einzustellen.

Hoffe das is'n Tipp der dem ein oder anderem was bringt.

Viel Spaß damit,

Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Mon Nov 08, 2010 9:20 pm    Post subject: Reply with quote

Ein klein wenig Off-Topic

@Randy Andy

Das setzen von LC_ALL sollte eigentlich vermieden werden, siehe zb auch:
Gentoo Linux: Anleitung zur deutschen Lokalisierung wrote:
Warnung: Vom Gebrauch von LC_ALL wird energisch abgeraten, da diese Variable später nicht einfach überschrieben werden kann. Bitte benutzen Sie es nur zum Testen und setzen Sie es niemals in einer Startdatei.
Soweit mir bekannt kann es zb beim perl Update zu Problemen kommen.

Ich hatte mir mein System mit KDE einst mal so eingerichtet das die Lokalisierung nur für den User gesetzt wird, das Basssystem als root jedoch weiter vollständig englisch bleibt. Falls es jemanden interessiert, ich hatte es Hier mal ein wenig beschrieben.
Zusätzlich zu dem genannten würde ich noch gcc mit USE=-nls bauen.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Tue Nov 09, 2010 9:46 am    Post subject: noch mehr OT Reply with quote

Hi Josef.

Die Lokalisierungsanleitung und den Warnhinweis kenne ich zwar, auch hab ich mein nls Flag global gesetzt, trotzdem habe ich dank bzw. seit meiner o.a. Settings in der bashrc nie wieder Probleme gehabt.
Auch nicht bei Perl updates oder anderen Kompilier-Orgien, vorher allerdings schon.

Insofern erreiche ich doch eigentlich mit weniger Aufwand fast das gleiche wie du in deiner verlinkten Beschreibung.

Wer ganz auf Nummer Sicher gehen will, könnte doch sattt wie von mir gezeigt, die /etc/env.d/02locale so befüllen, oder wie siehst du das?
Code:

LANG=de_DE.UTF-8
LANGUAGE="de_DE.UTF-8"
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE=C
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES=de_DE.UTF-8
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"                                                                                                               
LC_IDENTIFICATION="de_DE.UTF-8"                                                                                                             
GDM_LANG="de_DE.UTF-8"
LC_ALL=


Zur Vollständigkeit noch der Hinweis auf ein Wiki, da in der Gentoo Lokalisierungsanleitung GDM_LANG keine Erwähnung findet.
Hab ich noch aus meiner 2Wöchigen GNOME Testphase gesetzt, als ich bei KDE-4.0 kurz mal abtrünnig wurde, und bleibt erstmal drin.
Wenn ich mich recht entsinne, dann war das der Schlüssel zur deutschen Tastatur für den GDM-Login Manager.
In beiden Referenzen wird auf LANGUAGE="" nicht eingegangen, insofern gibt's immer noch kein vollständiges Gesamtdokument zu dem Thema.
http://de.gentoo-wiki.com/wiki/Deutsche_Lokalisierung

P.S. Als ich das erste und letzte mal meine Lokalisierungseinstellungen verändert habe, war die Gentoo Lokalisierungsanleitung noch deutlich schlechter, als die jetzige Version.
Insofern immer mal schön zu sehen das sie stetig besser wird durch entsprechend Pflege.

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum