Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]Aktuelle, stabile Methode für Adobe Flashplayer
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gilgwath
n00b
n00b


Joined: 09 Dec 2010
Posts: 22

PostPosted: Mon Dec 27, 2010 6:55 pm    Post subject: [gelöst]Aktuelle, stabile Methode für Adobe Flashplayer Reply with quote

Hallo liebe Gentoogemeinde

Ich arbeite erst seit zwei jahren mit Linux und mein Gentoo funktioniert auch erst seit einer Woche (mehr oder weniger), also bitte nicht gleich beissen :)

Zuerst einige Infos über meiner Installation

Gentoo: amd64_x86
Desktop: KDE4.4.5
Profil: default/linux/amd64/10.0/desktop/kde

Ich wollte Adobe Flashplayer installieren, also habe ich wie jeder brave User erstmal die FAQ gecheckt. Unter 4.1 ist dort auch wunderbar beschrieben, wie man die 64-bit-Version von Adobe Flashpalyer installiert. So einfach? Gut! Gelesen, getan. Funktioniert hats leider nicht, weder FF noch Konqueror erkennen mein Flashplugin. Also habe ich angefangen das Internet umzupflügen.

Ziemlich schnell habe ich einige zutreffende Hilfethemen gefunden und durchgelesen. Einge Tassen Kaffe später war ich immer noch nicht wirklich schlauer geworden, weil sich Adobe in letzter Zeit nicht wirklich entscheiden kann, ob und wie sie jetzt 64-bit-Systeme unterstützen wollen. Meine Frage ist nun: Welches ist die momentan empfehlenswerte Methode um den Flashplayer zum Laufen zu bringen?

Flash-Version
Code:
# emerge --search adobe-flash
Searching...   
[ Results for search key : adobe-flash ]
[ Applications found : 1 ]

*  www-plugins/adobe-flash
      Latest version available: 10.1.102.64
      Latest version installed: 10.1.102.64
      Size of files: 4,787 kB
      Homepage:      http://www.adobe.com/
      Description:   Adobe Flash Player
      License:       AdobeFlash-10.1


package.use
Code:
www-plugins/adobe-flash -32bit


Vielen Dank für eure Hilfe. :)

Lg Gilgwath

edit1: [gelöst] zum Titel hinzugfügt


Last edited by Gilgwath on Mon Dec 27, 2010 9:23 pm; edited 2 times in total
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Dec 27, 2010 7:41 pm    Post subject: Reply with quote

Quote:
eix adobe-flash
[I] www-plugins/adobe-flash
Available versions: (~)9.0.289.0!m!s (~)10.1_beta3!s[1] 10.1.102.64!m!s (~)10.2.161.23_pre20100927!m!s (~)10.2.161.23_pre20101117!m!s {+32bit +64bit multilib nspluginwrapper}
Installed versions: 10.2.161.23_pre20101117!m!s(09:55:26 PM 12/02/2010)(32bit 64bit multilib -nspluginwrapper)
Homepage: http://www.adobe.com/
Description: Adobe Flash Player


echo "=www-plugins/adobe-flash-10.2*" >> /etc/portage/package.unmask

echo "=www-plugins/adobe-flash-10.2* **" >> /etc/portage/package.keywords

und zu /etc/portage/package.use

Code:
www-plugins/adobe-flash 32bit 64bit multilib


hinzufügen

damit hast du die neuste 64bit Version von Flash, die auch mit Binary-Versionen von Firefox, etc. funktioniert
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4468

PostPosted: Mon Dec 27, 2010 7:45 pm    Post subject: Reply with quote

das problem ist, dass die stabile version von adobe-flash (10.1.102.64) keinen 64Bit support hat. Für flash 10.1 hat adobe keine 64bit fassung bereitgestellt.
Entweder du installiersst adobe-flash mit dem useflag nspluginwrapper oder du installierst eine der 10.2 er versionen.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Mon Dec 27, 2010 7:49 pm    Post subject: Reply with quote

Hallo und willkommen im Forum

Deine aktuell installierte Version adobe-flash-10.1.102.64 ist noch eine die kein 64 bit Support hat.
Dies kannst du zb auch schon anhand der Use-Flags einsehen
Code:
$ equery uses =www-plugins/adobe-flash-10.1.102.64
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for www-plugins/adobe-flash-10.1.102.64:
 U I
 - - nspluginwrapper : For amd64-multilib, installs www-plugins/nspluginwrapper to allow use in a 64-bit browser. (Not recommended, see
                       http://bugs.gentoo.org/324365)
Wie du siehst gibt es bei dieser Version weder 32 noch eine 64 Bit Flag.

Vorschlag: Nutze besser die aktuelle Version =www-plugins/adobe-flash-10.2.161.23_pre20101117 aus dem testing Zweig, diese ist auch wieder in einer 64 Bit Version verfügbar.
Da diese Version aktuell noch im testing Zweig ist wirst du sie demaskieren müssen indem du sie in die package.keywords einträgst.
Code:
# echo "=www-plugins/adobe-flash-10.2.161.23_pre20101117" >> /etc/portage/package.keywords
Nun sollte sich diese Version installieren lassen. (und auch mit einem 64 Bit Browser funktionieren ;) )

/edit: Oh.., da waren andere ein wenig schneller...
Back to top
View user's profile Send private message
Gilgwath
n00b
n00b


Joined: 09 Dec 2010
Posts: 22

PostPosted: Mon Dec 27, 2010 9:17 pm    Post subject: Reply with quote

Vielen Dank für all die schnellen und guten Antworten :-) Hat reibungslos funktioniert. Vielleicht sollte man die FAQ ergänzen, was Google im Moment mit verschiedenen Suchparameter so ausspuckt ist wirklich ein wenig verwirrend.

---solved & close please---
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum