Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Update Gentoo Hardened] Conflit de paquets (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
jaypeche
Apprentice
Apprentice


Joined: 13 Jun 2007
Posts: 161
Location: France

PostPosted: Sun Jan 02, 2011 3:48 pm    Post subject: [Update Gentoo Hardened] Conflit de paquets (Résolu) Reply with quote

Bonjour à tous et meilleurs voeux,

Voila j'ai içi un petit serveur en 'Hardened' avec un raid miroir et LVM par dessus, je cherche à mettre à jour mon système, cependant j'ai 2 conflits de paquets. Avant de faire une grosse bourde (parce que déja fait... lol, vive les backups, le raid et l'accès physique au serveur..), je souhaiterais avoir quelques explications sur la façon de solutionner ces conflits sans mettre en péril mon système.

Code:
Linux xxxxxx 2.6.28-hardened-r9 #1 SMP Mon Oct 12 03:06:41 CEST 2009 i686 Intel(R) Celeron(TM) CPU 1200MHz GenuineIntel GNU/Linux


Kernel config @pastebin.com : http://pastebin.com/3zV6ytBH

Code:
# emerge -upv system

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] sys-libs/ncurses-5.7-r3 [5.6-r2] USE="cxx%* gpm unicode -ada% -debug -doc -minimal -profile -trace (-nocxx%)" 2,388 kB
[ebuild     U ] sys-devel/gnuconfig-20100924 [20090203] 49 kB
[ebuild  N    ] dev-libs/gmp-4.3.2  USE="-nocxx" 1,854 kB
[ebuild     U ] sys-devel/autoconf-wrapper-10-r1 [6] 0 kB
[ebuild  N    ] sys-fs/sysfsutils-2.1.0  771 kB
[ebuild     U ] app-arch/gzip-1.4 [1.3.12-r1] USE="nls* pic -static" 887 kB
[ebuild     U ] sys-apps/kbd-1.15 [1.13-r1] USE="nls*" 1,289 kB
[ebuild     U ] sys-apps/busybox-1.17.4 [1.13.2] USE="mdev%* pam -debug -ipv6% -make-symlinks -savedconfig (-selinux) -static" 2,045 kB
[ebuild     U ] app-arch/tar-1.23-r2 [1.20] USE="nls* -static" 2,139 kB
[ebuild     U ] app-arch/bzip2-1.0.6 [1.0.5-r1] USE="-static" 764 kB
[ebuild     U ] app-arch/cpio-2.11 [2.9-r2] USE="nls*" 995 kB
[ebuild     U ] net-misc/wget-1.12-r3 [1.12] USE="nls ssl -debug -idn -ipv6 -ntlm -static" 0 kB
[ebuild     U ] sys-devel/binutils-2.20.1-r1 [2.18-r3] USE="nls* -multislot -multitarget -test -vanilla (-gold%)" 17,106 kB
[ebuild     U ] app-shells/bash-4.1_p7 [4.0_p35] USE="net nls -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 6,456 kB
[ebuild     U ] sys-apps/man-1.6f-r4 [1.6f-r3] USE="nls* -lzma" 249 kB
[ebuild     U ] sys-apps/sed-4.2.1 [4.2] USE="acl nls* (-selinux) -static" 879 kB
[ebuild     U ] sys-apps/shadow-4.1.4.2-r6 [4.1.2.2] USE="cracklib nls* pam -audit (-selinux) -skey" 1,749 kB
[ebuild     U ] sys-apps/findutils-4.4.2 [4.4.0] USE="nls* (-selinux) -static" 2,100 kB
[ebuild  N    ] dev-libs/mpfr-2.4.2_p3  1,053 kB
[ebuild     U ] sys-apps/file-5.04 [5.03] USE="python" 607 kB
[ebuild     U ] net-misc/rsync-3.0.7 [3.0.6] USE="acl iconv -ipv6 -static -xattr (-xinetd%)" 762 kB
[ebuild     U ] net-misc/iputils-20100418-r1 [20071127] USE="ssl%* -SECURITY_HAZARD% -doc -idn% -ipv6 -static" 114 kB
[ebuild     U ] sys-process/procps-3.2.8 [3.2.7] USE="unicode%* (-n32)" 280 kB
[ebuild     U ] sys-devel/make-3.81-r2 [3.81] USE="nls* -static" 1,125 kB
[ebuild     U ] sys-apps/man-pages-3.28 [3.22] USE="nls" LINGUAS="fr -cs -da -de -it -ja -nl -pl -ro -ru -zh_CN (-es%)" 1,101 kB
[ebuild  N    ] app-arch/xz-utils-4.999.9_beta  USE="nls threads -static-libs" 0 kB
[uninstall    ] app-arch/lzma-utils-4.32.7  USE="-nocxx"
[blocks b     ] app-arch/lzma-utils ("app-arch/lzma-utils" is blocking app-arch/xz-utils-4.999.9_beta)
[ebuild     U ] sys-devel/m4-1.4.15 [1.4.12] USE="-examples" 925 kB
[ebuild     U ] sys-apps/coreutils-8.7 [7.5-r1] USE="acl nls unicode%* -caps -gmp (-selinux) -static -vanilla -xattr" 4,604 kB
[ebuild     U ] sys-apps/net-tools-1.60_p20090728014017-r1 [1.60_p20071202044231-r1] USE="nls* -static" 195 kB
[ebuild     U ] sys-devel/autoconf-2.65-r1 [2.63-r1] USE="-emacs" 1,302 kB
[ebuild     U ] sys-devel/bison-2.4.2 [2.3] USE="nls* -static" 1,579 kB
[ebuild  NS   ] sys-devel/libtool-2.2.10 [2.2.6b] USE="-vanilla" 771 kB
[uninstall    ] sys-devel/libtool-2.2.6b  USE="-test -vanilla"
[blocks b     ] =sys-devel/libtool-2*:1.5 ("=sys-devel/libtool-2*:1.5" is blocking sys-devel/libtool-2.2.10)
[ebuild     U ] sys-libs/readline-6.1 [6.0_p3] 2,209 kB
[ebuild     U ] sys-process/psmisc-22.12 [22.6] USE="nls* -X -ipv6 (-selinux)" 366 kB
[ebuild     U ] net-misc/openssh-5.6_p1-r2 [5.5_p1-r2] USE="pam tcpd -X -X509 -hpn -kerberos -ldap -libedit (-selinux) -skey -static" 1,092 kB
[ebuild     U ] sys-apps/baselayout-1.12.14-r1 [1.12.11.1] USE="unicode* -bootstrap -build -static" 265 kB
[ebuild  NS   ] sys-devel/gcc-4.4.4-r2 [3.4.6-r2] USE="hardened mudflap nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) -fortran -gcj -graphite -gtk (-libffi) (-multilib) -multislot (-n32) (-n64) -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla" 61,588 kB
[ebuild     U ] sys-libs/glibc-2.11.2-r3 [2.9_p20081201-r2] USE="gd* hardened nls* -debug -glibc-omitfp (-multilib) -profile (-selinux) -vanilla" 16,008 kB
[ebuild     U ] sys-fs/udev-151-r4 [141] USE="-devfs-compat% -extras% -old-hd-rules% (-selinux) -test%" 498 kB
[blocks B     ] <sys-fs/lvm2-2.02.45 ("<sys-fs/lvm2-2.02.45" is blocking sys-fs/udev-151-r4)
[blocks B     ] sys-fs/device-mapper ("sys-fs/device-mapper" is blocking sys-fs/udev-151-r4)

Total: 39 packages (33 upgrades, 4 new, 2 in new slots, 2 uninstalls), Size of downloads: 138,145 kB
Conflict: 4 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-151-r4, ebuild scheduled for merge) pulled in by
    virtual/dev-manager required by @system

  (sys-fs/device-mapper-1.02.24-r1, installed) pulled in by
    sys-fs/device-mapper required by @selected

  (sys-fs/lvm2-2.02.36, installed) pulled in by
    sys-fs/lvm2 required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


J'ai l'impression que lvm2 et device-mapper sont pris en charge par Udev ?? Sans certitude, une idée ? :idea:

Merçi par avance pour votre aide !
_________________
:-) Gentoo Linux Rullez !


Last edited by jaypeche on Tue Jan 04, 2011 4:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Sun Jan 02, 2011 5:39 pm    Post subject: Re: [Update Gentoo Hardened] Conflit de paquets () Reply with quote

jaypeche wrote:

J'ai l'impression que lvm2 et device-mapper sont pris en charge par Udev ?? Sans certitude, une idée ? :idea:

Non. device-mapper a été mergé dans lvm2. Donc quand tu upgraderas lvm2, device-mapper sera désinstallé.
Les lignes :
Code:

[ebuild     U ] sys-fs/udev-151-r4 [141] USE="-devfs-compat% -extras% -old-hd-rules% (-selinux) -test%" 498 kB
[blocks B     ] <sys-fs/lvm2-2.02.45 ("<sys-fs/lvm2-2.02.45" is blocking sys-fs/udev-151-r4)

nous montrent que ton emerge -u system veut mettre à jour udev à la version 151-r4, mais que cette version est incompatible avec ta version actuelle de lvm2 ("<sys-fs/lvm2-2.02.45" is blocking sys-fs/udev-151-r4).

Donc si tu veux avancer, vas y par étapes. Commence par mettre à jour lvm2.
Back to top
View user's profile Send private message
jaypeche
Apprentice
Apprentice


Joined: 13 Jun 2007
Posts: 161
Location: France

PostPosted: Sun Jan 02, 2011 8:28 pm    Post subject: Reply with quote

Merçi netfab pour ces précisions !

J'y vois un peu plus clair, je comprends un peu mieux comment interpreter les dépendances dans portage.

L'update de lvm2 a malheureusement cassé mon système, j'ai une erreur au moment de charger ma partition système non LVM en /dev/md2. J'ai une erreur me disant que mon système ext2 n'est pas accessible, or je suis en ext3 et fstab est correct. Je pense à device-mapper sans grande certitude...

# cat /proc/mdstat ne me retourne aucune erreur ! E2fsck ne me retourne aucune erreur non plus, je n'ai peut être pas été assez vigilant aux alertes de portage !! Je tente une recompil de mon kernel et l'initrd...

++ Rien n'y fait ! Serveur Out !

La mise à jour de udev a apparement foutu la zone sur mon système (à confirmer) !
Le système me retourne un '/dev/md2 no such file or directory', en effet je n'aperçois pas d'entrée en /dev/md*, je suppose donc qu'il y a un souçi avec udev. D'après ce que j'ai vu en emergeant celui-çi, il faut désactiver des options du Kernel : CONFIG_IDE, CONFIG_SYSFS... que je ne trouvent pas d'ailleurs !

Je verrai cela à tête reposée... :(
_________________
:-) Gentoo Linux Rullez !
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Mon Jan 03, 2011 10:14 am    Post subject: Reply with quote

De mémoire, vérifie que le service device-mapper ou lvm est bien démarrer ; en fonction du baselayout il faut ou non les ajouter au boot (me semble qu'en baselayout-1 il faut l'ajouter, et pas en v2).
_________________
Ez.
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Mon Jan 03, 2011 12:48 pm    Post subject: Reply with quote

Ezka wrote:
De mémoire, vérifie que le service device-mapper ou lvm est bien démarrer ; en fonction du baselayout il faut ou non les ajouter au boot (me semble qu'en baselayout-1 il faut l'ajouter, et pas en v2).

Ce n'est valable que pour base-layout 2 si je ne m'abuse.
A mon avis, jaypeche, il est possible que tu aies un noyau mal configuré/mal maîtrisé, reviens aux fondamentaux en ne modifiant qu'un paramètre à la fois (1 noyau qui marche avec genkernel, puis un custom, etc) :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
jaypeche
Apprentice
Apprentice


Joined: 13 Jun 2007
Posts: 161
Location: France

PostPosted: Mon Jan 03, 2011 2:48 pm    Post subject: Reply with quote

@Ezka : D'abord tous mes voeux pour 2011 !
Merçi pour ta réponse, effectivement il y a une histoire comme cela, avec le profil hardened je suis en baselayout 1, donc pas besoin d'activer lvm au boot.

Code:
* lvm volumes are no longer automatically created for
 * baselayout-2 users. If you are using baselayout-2, be sure to
 * run: # rc-update add lvm boot
 * Do NOT add it if you are using baselayout-1 still.
>>> Regenerating /etc/ld.so.cache...

 * Messages for package sys-fs/lvm2-2.02.73-r1:

 * Warning, we no longer overwrite /sbin/lvm and /sbin/dmsetup with
 * their static versions. If you need the static binaries,
 * you must append .static the filename!
 * USE flag nocman is deprecated and replaced
 * with the cman USE flag.
 *
 * USE flags clvm and cman are masked
 * by default and need to be unmasked to use them
 *
 * If you are using genkernel and root-on-LVM, rebuild the initramfs.
 * lvm volumes are no longer automatically created for
 * baselayout-2 users. If you are using baselayout-2, be sure to
 * run: # rc-update add lvm boot
 * Do NOT add it if you are using baselayout-1 still.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * Regenerating GNU info directory index...

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


@El'Goretto : Meilleurs voeux également !

Concernant mon kernel, ma config 'hardened-grsec' ne me posait aucun souçi jusqu'à présent, je fonctionne avec 2 noyaux l'ancien auquel je ne touche pas, et un autre que j'adapte pour tester. Je pense sincérement que la source de mon problème est du à Udev, voila ce qui me le laisse penser :

Code:
*   CONFIG_SYSFS_DEPRECATED:    should not be set. But it is.
 *   CONFIG_SYSFS_DEPRECATED_V2:         should not be set. But it is.
 *   CONFIG_IDE:         should not be set. But it is.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.
 *
 * udev-151 does not support Linux kernel before version 2.6.25!
 * For a reliable udev, use at least kernel 2.6.27
 *
 * udev cannot be restarted after emerging,
 * as your running kernel version (2.6.24-gentoo-r5) is too old.
 * You really need to use a newer kernel after a reboot!
 *
 * Updating persistent-net rules file
 * Not restarting udevd, as your kernel is too old!
 *
 * If after the udev update removable devices or CD/DVD drives
 * stop working, try re-emerging HAL before filling a bug report
 *
 * persistent-net does assigning fixed names to network devices.
 * If you have problems with the persistent-net rules,
 * just delete the rules file
 *      rm /etc/udev/rules.d/70-persistent-net.rules
 * and then reboot.
 *
 * This may however number your devices in a different way than they are now.
 *
 * If you build an initramfs including udev, then please
 * make sure that the /sbin/udevadm binary gets included,
 * and your scripts changed to use it,as it replaces the
 * old helper apps udevinfo, udevtrigger, ...
 *
 * mount options for directory /dev are no longer
 * set in /etc/udev/udev.conf, but in /etc/fstab
 * as for other directories.
 *
 * This version of udev no longer has devfs-compat enabled
 * If you use /dev/md/*, /dev/loop/* or /dev/rd/*,
 * then please migrate over to using the device names
 * /dev/md*, /dev/loop* and /dev/ram*.
 * The devfs-compat rules will be removed on the next udev update.
 * For reference see Bug #269359.
 *
 * This version of udev no longer has use flag old-hd-rules enabled
 * So all special rules for /dev/hd* devices are missing
 * Please migrate to the new libata if you need these rules.
 * They will be completely removed on the next udev update.
 *
 * For more information on udev on Gentoo, writing udev rules, and
 *          fixing known issues visit:
 *          http://www.gentoo.org/doc/en/udev-guide.xml
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Je crois que mon sushi est içi :

* CONFIG_SYSFS_DEPRECATED: should not be set. But it is.
* CONFIG_SYSFS_DEPRECATED_V2: should not be set. But it is.
* CONFIG_IDE: should not be set. But it is.


Ce qui expliquerai pourquoi je ne retrouve pas mes entrées /dev/md[1234] depuis busybox, toujours sans certitude !
J'ai beaucoup de mal à trouver ces options dans la config kernel , je continue mes investigations... j'ai bien du mal à y voir clair 8O !

Pour info, j'utilise Genkernel, 'genkernel --mdadm --menuconfig all' && device-mapper n'est pas activé au boot.
_________________
:-) Gentoo Linux Rullez !


Last edited by jaypeche on Mon Jan 03, 2011 4:16 pm; edited 2 times in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Mon Jan 03, 2011 3:44 pm    Post subject: Reply with quote

Bon, allez, je suis charitable, je ne vais pas me moquer (enfin pas trop ;)):
Code:
 * udev-151 does not support Linux kernel before version 2.6.25!
 * For a reliable udev, use at least kernel 2.6.27
 *
 * udev cannot be restarted after emerging,
 * as your running kernel version (2.6.24-gentoo-r5) is too old.
 * You really need to use a newer kernel after a reboot!


Tout est écrit...
Le problème n'est pas udev mais ton noyau, I win!! :wink:

--
edit: un peu d'aide pour configurer ton noyau "fait main": http://kernel-seeds.org/settings-01.html
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
jaypeche
Apprentice
Apprentice


Joined: 13 Jun 2007
Posts: 161
Location: France

PostPosted: Mon Jan 03, 2011 4:00 pm    Post subject: Reply with quote

On se moque pas ! hein ! noob !

Je suis navré, mais tu vas un peu vite en besogne, mon système étant cassé (cf impossible de démarrer mon système, ben oui j'ai un souçi au démarrage, cf plus haut...). Je tourne donc avec un live cd, avec mon système chrooté, d'où cette version de Kernel, la mienne est "Linux xxxxxx 2.6.28-hardened-r9", donc pas de souçi !

Perdu ! allez sans rancune ! 8)

Si j'ai un doute sur l'initrd, je tenterai un :

Code:
# cd /usr/src/linux
# make menuconfig
# make dep && make clean && make bzImage
# make modules && make modules_install


Et je modifierai Grub en circonstance...

Merçi de t'interesser à mon post... Je recompile mon kernel avec les options citées plus haut désactivées pour voir.. cf https://bugs.gentoo.org/show_bug.cgi?id=269359
_________________
:-) Gentoo Linux Rullez !


Last edited by jaypeche on Thu Jan 06, 2011 4:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Mon Jan 03, 2011 4:59 pm    Post subject: Reply with quote

Huhu oui c'est tout l'inverse de ce que je disais :lol: (pour ma défense, je m'en occupe rarement ... parce que moi ça marche :P )

A tout hasard, es-ce que ta partoche racine est sur lvm ?
Parce si c'est le cas il ne faut pas oublier de mettre lvm dans l'initrd pour que le noyal lance lvm manière qu'il trouve se petit quand il a fini de se décompresser =)
_________________
Ez.
Back to top
View user's profile Send private message
jaypeche
Apprentice
Apprentice


Joined: 13 Jun 2007
Posts: 161
Location: France

PostPosted: Mon Jan 03, 2011 5:05 pm    Post subject: Reply with quote

Pas de souçi Ezka !

Non ma partition système est une partoche RAID1, tout comme le Boot, /dev/md4 correspond à LVM, voiçi mon fstab :

Code:
/dev/md1                /boot           ext2            noauto,noatime  1 2
/dev/md2                /               ext3            noatime         0 1
/dev/md3                none            swap            sw              0 0

/dev/vg/usr             /usr            ext3            noatime         1 2
/dev/vg/portage         /usr/portage    ext3            noatime         1 2
/dev/vg/distfiles       /usr/portage/distfiles  ext3    noatime         1 2
/dev/vg/var             /var            ext3            noatime         1 2
/dev/vg/www             /var/www        ext3            noatime         1 2
/dev/vg/tmp             /tmp            ext3            noatime         1 2
/dev/vg/home            /home           ext3            noatime         1 2
/dev/vg/data            /data           ext3            noatime         1 2


PS: Je sais le swap en Raid c'est pas génial ! :(


++ :idea: Le serveur est de nouveau UP ! Il fallait désactiver les options ci-dessus de la config Kernel.
L'abstraction des disques IDE ne se fait plus par le Kernel mais par Udev avec cette nouvelle version, d'où mon souçi !
Les disques IDE sont maintenant attachés aux entrées /dev/sd[ab], comme les disques SCSI ou SATA. J'ai modifié mon fichier '/etc/mdadm.conf' en circonstance et recompiler mon initrd (Bien que cela ne semble pas nécessaire du fait).

J'ai donc fais un emerge -e system, pendant la nuit, masqué GCC v3 car je n'ai pas d'intérêt à l'updater, je crains trop des problèmes de dépendances sur les services qui tournent sur le serveur (genre libstd c++). Tout est maintenant OK ou presque (J'ai quelques souçis au chargement de LVM sans conséquence sur le fonctionnement, cela fera l'objet d'un autre post : https://forums.gentoo.org/viewtopic-p-6534019.html#6534019 ).

De plus j'ai noté une notable amélioration sur les performances de mes disques IDE, cf :

Code:

# hdparm -tT /dev/md[124]

/dev/md1:
 Timing cached reads:   220 MB in  2.01 seconds = 109.38 MB/sec
 Timing buffered disk reads:   94 MB in  2.78 seconds =  33.78 MB/sec

/dev/md2:
 Timing cached reads:   216 MB in  2.00 seconds = 107.74 MB/sec
 Timing buffered disk reads:  104 MB in  3.00 seconds =  34.62 MB/sec

/dev/md4:
 Timing cached reads:   218 MB in  2.00 seconds = 108.98 MB/sec
 Timing buffered disk reads:  102 MB in  3.01 seconds =  33.92 MB/sec


Code:
# hdparm -I /dev/sd[ab]

/dev/sda:

ATA device, with non-removable media
   Model Number:       ST380021A                               
   Serial Number:      3HV3XLRV           
   Firmware Revision:  3.19   
Standards:
   Supported: 5 4 3
   Likely used: 6
Configuration:
   Logical      max   current
   cylinders   16383   16383
   heads      16   16
   sectors/track   63   63
   --
   CHS current addressable sectors:   16514064
   LBA    user addressable sectors:  156301488
   Logical/Physical Sector size:           512 bytes
   device size with M = 1024*1024:       76319 MBytes
   device size with M = 1000*1000:       80026 MBytes (80 GB)
   cache/buffer size  = 2048 KBytes
Capabilities:
   LBA, IORDY(can be disabled)
   bytes avail on r/w long: 4
   Standby timer values: spec'd by Standard
   R/W multiple sector transfer: Max = 16   Current = 8
   Recommended acoustic management value: 128, current value: 128
   DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 *udma4 udma5
        Cycle time: min=120ns recommended=120ns
   PIO: pio0 pio1 pio2 pio3 pio4
        Cycle time: no flow control=240ns  IORDY flow control=120ns
Commands/features:
   Enabled   Supported:
      *   SMART feature set
          Security Mode feature set
      *   Power Management feature set
      *   Write cache
      *   Look-ahead
      *   Host Protected Area feature set
      *   WRITE_BUFFER command
      *   READ_BUFFER command
      *   DOWNLOAD_MICROCODE
          SET_MAX security extension
      *   Automatic Acoustic Management feature set
          Device Configuration Overlay feature set
Security:
   Master password revision code = 65534
      supported
   not   enabled
   not   locked
   not   frozen
   not   expired: security count
   not   supported: enhanced erase
HW reset results:
   CBLID- above Vih
   Device num = 1
Checksum: correct

/dev/sdb:

ATA device, with non-removable media
   Model Number:       ST380011A                               
   Serial Number:      4JV4RP0J           
   Firmware Revision:  8.01   
Standards:
   Used: ATA/ATAPI-6 T13 1410D revision 2
   Supported: 6 5 4
Configuration:
   Logical      max   current
   cylinders   16383   16383
   heads      16   16
   sectors/track   63   63
   --
   CHS current addressable sectors:   16514064
   LBA    user addressable sectors:  156301488
   LBA48  user addressable sectors:  156301488
   Logical/Physical Sector size:           512 bytes
   device size with M = 1024*1024:       76319 MBytes
   device size with M = 1000*1000:       80026 MBytes (80 GB)
   cache/buffer size  = 2048 KBytes
Capabilities:
   LBA, IORDY(can be disabled)
   Standby timer values: spec'd by Standard, no device specific minimum
   R/W multiple sector transfer: Max = 16   Current = 8
   Recommended acoustic management value: 128, current value: 0
   DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 *udma4 udma5
        Cycle time: min=120ns recommended=120ns
   PIO: pio0 pio1 pio2 pio3 pio4
        Cycle time: no flow control=240ns  IORDY flow control=120ns
Commands/features:
   Enabled   Supported:
      *   SMART feature set
          Security Mode feature set
      *   Power Management feature set
      *   Write cache
      *   Look-ahead
      *   Host Protected Area feature set
      *   WRITE_BUFFER command
      *   READ_BUFFER command
      *   DOWNLOAD_MICROCODE
          SET_MAX security extension
      *   48-bit Address feature set
      *   Device Configuration Overlay feature set
      *   Mandatory FLUSH_CACHE
      *   FLUSH_CACHE_EXT
      *   SMART error logging
      *   SMART self-test
      *   General Purpose Logging feature set
          Time Limited Commands (TLC) feature set
          Command Completion Time Limit (CCTL)
Security:
   Master password revision code = 65534
      supported
   not   enabled
   not   locked
   not   frozen
   not   expired: security count
   not   supported: enhanced erase
HW reset results:
   CBLID- above Vih
   Device num = 0 determined by the jumper
Checksum: correct



Merçi à ceux qui m'accompagnent dans ce périble qu'est un update sur un serveur en production (Résolu !).
_________________
:-) Gentoo Linux Rullez !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum