Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ATI] Installation sur 2.6.36 x86_64 ( Résolu )
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
syphering
n00b
n00b


Joined: 13 Feb 2007
Posts: 53
Location: France

PostPosted: Sun Jan 16, 2011 6:44 pm    Post subject: [ATI] Installation sur 2.6.36 x86_64 ( Résolu ) Reply with quote

Salut à tous !

Voila mon petit souci avec ma Gentoo x86_64, j'ai changé ma carte graphique par une ATI HD5750. Mais voila, je suis passé sous le noyau 2.6.36, et la impossible de ré-installer les pilotes.

Avec le pilotes officiels "ati-driver-installer-10-12-x86.x86_64.run" l'installation se fait, mais pas la génération de "fglrx". Ci dessous la log de l'installeur :

Code:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
make -C /lib/modules/2.6.36-gentoo-r5/build SUBDIRS=/lib64/modules/fglrx/build_mod/2.6.x modules
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.36-gentoo-r5 »
  CC [M]  /lib64/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib64/modules/fglrx/build_mod/2.6.x/firegl_public.c:410: erreur: unknown field 'ioctl' specified in initializer
/lib64/modules/fglrx/build_mod/2.6.x/firegl_public.c:410: attention : initialization from incompatible pointer type
make[2]: *** [/lib64/modules/fglrx/build_mod/2.6.x/firegl_public.o] Erreur 1
make[1]: *** [_module_/lib64/modules/fglrx/build_mod/2.6.x] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-2.6.36-gentoo-r5 »
make: *** [kmod_build] Erreur 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.


Une recherche sur la système ne permet pas trouver le module.

L'installation de pilote "x11-drivers/ati-drivers" par Gentoo est idem

Code:

/usr/include/GL/glext.h:1661:1: attention : ceci est la localisation d'une précédente définition
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lGL
collect2: ld a retourné 1 code d'état d'exécution
 * ERROR: x11-drivers/ati-drivers-10.11 failed:
 *   fgl_glxgears build failed
 *
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 3833:  Called die
 * The specific snippet of code:
 *       "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU -I"${S}"/${FOLDER_PREFIX}usr/include fgl_glxgears.c -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed";
 *
 * If you need support, post the output of 'emerge --info =x11-drivers/ati-drivers-10.11',
 * the complete build log and the output of 'emerge -pqv =x11-drivers/ati-drivers-10.11'.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-10.11/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-10.11/temp/environment'.
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-10.11/work'

>>> Failed to emerge x11-drivers/ati-drivers-10.11, Log file:

>>>  '/var/tmp/portage/x11-drivers/ati-drivers-10.11/temp/build.log'

 * Messages for package x11-drivers/ati-drivers-10.11:

 *
 * Please note that this driver supports only graphic cards based on
 * r600 chipset and newer.
 * This represent the ATI Radeon HD series at this moment.
 *
 * If your card is older then usage of x11-drivers/xf86-video-ati
 * as replacement is highly recommended. Rather than staying with
 * old versions of this driver.
 * For migration informations please reffer to:
 * http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 * ERROR: x11-drivers/ati-drivers-10.11 failed:
 *   fgl_glxgears build failed
 *
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 3833:  Called die
 * The specific snippet of code:
 *       "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU -I"${S}"/${FOLDER_PREFIX}usr/include fgl_glxgears.c -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed";
 *
 * If you need support, post the output of 'emerge --info =x11-drivers/ati-drivers-10.11',
 * the complete build log and the output of 'emerge -pqv =x11-drivers/ati-drivers-10.11'.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-10.11/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-10.11/temp/environment'.
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-10.11/work'


Là c'est 'cannot find -lGL', le truc, c'est que je ne sais pas à quelle librairie cela correspond, et un 'emerge --search' retourne pas mal de choix possible, à mon avis ça doit être des librairies graphiques.

Si vous avez une idée je suis preneur, merci ;)
_________________

Core 2 Quad Q9550 - 8 Go DDR2 Corsair - WD Caviar Black 500 Go - ATI HD5750 1 Go DDR5
Zotac Fusion-itx Wifi - 8 Go DDR3 G.Skill - Seagate 320 Go - WD Caviar Green 2 To - 1080P - 5.1


Last edited by syphering on Mon Jan 31, 2011 8:25 pm; edited 2 times in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3088
Location: Paris

PostPosted: Sun Jan 16, 2011 9:46 pm    Post subject: Reply with quote

Il supporte le noyau 2.6.36 le fglrx 10.12? Tu as vérifié (changelog, notice d'AMD)?
La plupart du temps, c'est ce genre de problème qui se pose lors d'une mise à jour.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
syphering
n00b
n00b


Joined: 13 Feb 2007
Posts: 53
Location: France

PostPosted: Wed Jan 19, 2011 9:59 pm    Post subject: Reply with quote

Peut être, quoi qu'il en soit j'ai regardé dans l'installer ATI, en faisant un extract, rien de bien spécifique relatif à un quelconque kernel. Rien aussi coté site web ATI.

J'ai essayé d'installer les binaires a partir d'une version antérieure mais rien n'y fait.

Y a t il moyen de contourner cette erreur sans attendre les prochains binaires ATI qui se font désespérément attendre ?
_________________

Core 2 Quad Q9550 - 8 Go DDR2 Corsair - WD Caviar Black 500 Go - ATI HD5750 1 Go DDR5
Zotac Fusion-itx Wifi - 8 Go DDR3 G.Skill - Seagate 320 Go - WD Caviar Green 2 To - 1080P - 5.1
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3088
Location: Paris

PostPosted: Wed Jan 19, 2011 10:28 pm    Post subject: Reply with quote

Repasser en 2.6.35 en attendant?
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed Jan 19, 2011 11:47 pm    Post subject: Reply with quote

'alute

-lGL c'est la libGL non ? alors ce qui me vient aussitôt à l'esprit c'est : mesa est-il installé correctement ?

Edit: tant qu'on y est, on peut avoir la sortie de #eselect opengl list ?
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
syphering
n00b
n00b


Joined: 13 Feb 2007
Posts: 53
Location: France

PostPosted: Sat Jan 22, 2011 2:44 pm    Post subject: Reply with quote

J'ai réintsallé mesa et essayé à nouveau d'installer les pilotes ATI et ceux fourmis par portage, idem, même problème.

Voici le résultat :
Code:

Available OpenGL implementations:
  [1]   xorg-x11 *


Passer sous un noyau inférieur j'ai les mêmes problème alors qu'avant ça fonctionné nickel :O J'ai l'impression que mon dernier 'emerge --deep --newuse --update world' a fait quelque chose de bizarre, ce qui expliquerai mon problème actuel, mais quoi :O
_________________

Core 2 Quad Q9550 - 8 Go DDR2 Corsair - WD Caviar Black 500 Go - ATI HD5750 1 Go DDR5
Zotac Fusion-itx Wifi - 8 Go DDR3 G.Skill - Seagate 320 Go - WD Caviar Green 2 To - 1080P - 5.1
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sat Jan 22, 2011 8:26 pm    Post subject: Reply with quote

bon ok

essaie de regarder si les liens libGL.so sont corrects i.e. selon les cas :
#ls -al /usr/lib64/libGL.so /* ls -al /usr/lib32/libGL.so */
#ls -al /usr/lib64/xorg/modules/extensions/libglx.so

D'ailleurs, tu peux même te fendre d'un suppression desdits liens et d'une recompilation de tout le batcalan (mesa ; mesa-progs ; ...)

Au fait, le symlink linux pointe vers ton nouveau kernel au moins ?
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
syphering
n00b
n00b


Joined: 13 Feb 2007
Posts: 53
Location: France

PostPosted: Sun Jan 23, 2011 10:24 am    Post subject: Reply with quote

Le symlink pointe sur le bon kernel car j'ai supprimé l'ancien.

Code:
lrwxrwxrwx  1 root root   22  9 janv. 12:32 linux -> linux-2.6.36-gentoo-r5
drwxr-xr-x 24 root root 4096 12 janv. 11:43 linux-2.6.36-gentoo-r5


Mes libs me semblent correctes :

Code:
lrwxrwxrwx 1 root root 21 22 janv. 15:39 /usr/lib32/libGL.so -> /usr/lib32/libGL.so.1
lrwxrwxrwx 1 root root 12 22 janv. 15:39 /usr/lib32/libGL.so.1 -> libGL.so.1.2
-rw-r--r-- 1 root root 779324 20 nov.  09:03 /usr/lib32/libGL.so.1.2

lrwxrwxrwx 1 root root 12 22 janv. 15:39 /usr/lib64/libGL.so.1 -> libGL.so.1.2
-rw-r--r-- 1 root root 859792 20 nov.  17:41 /usr/lib64/libGL.so.1.2

lrwxrwxrwx 1 root root 45 22 janv. 15:36 /usr/lib64/xorg/modules/extensions/libglx.so -> ../../../opengl/xorg-x11/extensions/libglx.so
-rwxr-xr-x 1 root root 417880 24 déc.  11:09 /usr/lib64/opengl/xorg-x11/extensions/libglx.so


J'ai relancé les commandes suivantes afin de réparer toute installations bancales, et là problème :(

Code:
emerge --update --deep --newuse world
emerge --depclean
revdep-rebuild


Code:
 * IMPORTANT: 6 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
 *
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 *
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr
 * Found some broken files that weren't associated with known packages
 * The broken files are:
 *   /usr/lib32/libGL.so.1.2
 *   /usr/lib64/libGL.so.1.2


Il y a bien un problème sur libGL.

Je vais regarder ça en détail et vous tiens au courrant
_________________

Core 2 Quad Q9550 - 8 Go DDR2 Corsair - WD Caviar Black 500 Go - ATI HD5750 1 Go DDR5
Zotac Fusion-itx Wifi - 8 Go DDR3 G.Skill - Seagate 320 Go - WD Caviar Green 2 To - 1080P - 5.1
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Sun Jan 23, 2011 2:20 pm    Post subject: Reply with quote

Ah ben voilà ! Je le supposais un peu :)

A priori, tu supprimes juste tes libs et leurs liens et reconstruit tout le bataclan via emerge -1v et ça devrait coller - Je te mets un lien vers un vieux tracker à ce sujet si besoin - :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
syphering
n00b
n00b


Joined: 13 Feb 2007
Posts: 53
Location: France

PostPosted: Sun Jan 23, 2011 8:29 pm    Post subject: Reply with quote

Effectivement, en supprimant les liens :

Code:
lrwxrwxrwx 1 root root     12 23 janv. 12:14 /usr/lib/libGL.so.1 -> libGL.so.1.2
-rw-r--r-- 1 root root 859792 20 nov.  17:41 /usr/lib/libGL.so.1.2
lrwxrwxrwx 1 root root     21 23 janv. 12:14 /usr/lib32/libGL.so -> /usr/lib32/libGL.so.1
lrwxrwxrwx 1 root root     12 23 janv. 12:14 /usr/lib32/libGL.so.1 -> libGL.so.1.2
-rw-r--r-- 1 root root 779324 20 nov.  09:03 /usr/lib32/libGL.so.1.2
lrwxrwxrwx 1 root root     12 23 janv. 12:14 /usr/lib64/libGL.so.1 -> libGL.so.1.2
-rw-r--r-- 1 root root 859792 20 nov.  17:41 /usr/lib64/libGL.so.1.2


Et en recheckant les paquets :

Code:
emerge --depclean && revdep-rebuild


Et en ré-installant les paquets suivants :

Code:
mesa
xorg-server
eselect
eselect-opengl


Les drivers ATI (ceux fournis par ATI pas par portage) s'installent, le X démarre, mais pas ça saccade, et petit message d'erreur dans les logs :

Code:
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
make -C /lib/modules/2.6.36-gentoo-r5/build SUBDIRS=/lib64/modules/fglrx/build_mod/2.6.x modules
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.36-gentoo-r5 »
  CC [M]  /lib64/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib64/modules/fglrx/build_mod/2.6.x/firegl_public.c:410: erreur: unknown field 'ioctl' specified in initializer
/lib64/modules/fglrx/build_mod/2.6.x/firegl_public.c:410: attention : initialization from incompatible pointer type
make[2]: *** [/lib64/modules/fglrx/build_mod/2.6.x/firegl_public.o] Erreur 1
make[1]: *** [_module_/lib64/modules/fglrx/build_mod/2.6.x] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-2.6.36-gentoo-r5 »
make: *** [kmod_build] Erreur 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.


Le module est chargé, mais j'ai un doute sur sa fiabilité :

Code:
Module                  Size  Used by
xt_mark                 1125  0
scsi_wait_scan           711  0
test_nx                 1595  0
fglrx                2490304  3


Vais voir si le problème est identique avec celui fournit par portage.
_________________

Core 2 Quad Q9550 - 8 Go DDR2 Corsair - WD Caviar Black 500 Go - ATI HD5750 1 Go DDR5
Zotac Fusion-itx Wifi - 8 Go DDR3 G.Skill - Seagate 320 Go - WD Caviar Green 2 To - 1080P - 5.1
Back to top
View user's profile Send private message
syphering
n00b
n00b


Joined: 13 Feb 2007
Posts: 53
Location: France

PostPosted: Mon Jan 31, 2011 8:23 pm    Post subject: Reply with quote

Bon, beh en installant les derniers drives fournis par ATI, les 11.1 tout fonctionne à merveille.

Merci à tous pour votre aide

@++ sur le forum ;)
_________________

Core 2 Quad Q9550 - 8 Go DDR2 Corsair - WD Caviar Black 500 Go - ATI HD5750 1 Go DDR5
Zotac Fusion-itx Wifi - 8 Go DDR3 G.Skill - Seagate 320 Go - WD Caviar Green 2 To - 1080P - 5.1
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum