Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[pambase] Temps de compilation ? (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sunseb7
n00b
n00b


Joined: 06 Feb 2011
Posts: 15

PostPosted: Mon Mar 21, 2011 12:47 pm    Post subject: [pambase] Temps de compilation ? (résolu) Reply with quote

Bonjour,

J'installe actuellement une nouvelle machine sous Gentoo. J'ai lancé la migration vers "~arch64" hier soir. Un paquet nommé "pambase" était alors en cours de compilation. Ce matin, je me lève et je remarque que mon PC est toujours en train de compiler ce même paquet.

KDE s'est compilé en 2 heures (Intel Core i5 750 à 4 coeurs) et "pambase" n'a toujours pas fini après une nuit... Bref, il est évident qu'il y a un problème. J'ai essayé d'arrêter et de relancer la compilation, mais le paquet semble à nouveau se compiler indéfiniment et sans afficher de messages d'erreurs.

C'est quoi au juste "pambase" ? Est-ce que ce paquet se compile correctement chez vous (et en combien de temps) ? Et que faire dans cette situation ? Je précise enfin que tous les autres paquets se compilent normalement.

Merci pour votre aide !

:)
_________________
sunse8


Last edited by sunseb7 on Tue Mar 22, 2011 2:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8073
Location: ~Brussels - Belgique

PostPosted: Mon Mar 21, 2011 1:13 pm    Post subject: Reply with quote

Etrange... pambase est un petit paquets, contenant la base du système de gestion de droits PAM (Pluggable Authentification Modules ou un truc du genre).
Arrête-le et reprend ta compilation avec
Code:
emerge --resume

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
sunseb7
n00b
n00b


Joined: 06 Feb 2011
Posts: 15

PostPosted: Mon Mar 21, 2011 4:53 pm    Post subject: Reply with quote

Merci pour ces informations !

Mais rien à faire, ce paquet se bloque à la compilation...

Tout mon système fonctionne parfaitement sinon. Vraiment étrange ?
_________________
sunse8
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Mon Mar 21, 2011 5:35 pm    Post subject: Reply with quote

Salut,

Donne ton emerge --info. Quand tu dis que çà compile indéfiniment, tu veux dire que çà bloque, ou que çà tourne en boucle ?
Quand tu dis :
Quote:

J'ai lancé la migration vers "~arch64" hier soir.

Je suppose que tu veux dire : ~amd64
Et tu es parti de quoi pour lancer ta migration ?
Sinon, pour répondre à :
Quote:

et en combien de temps ?

environ 13 secondes :lol:
Back to top
View user's profile Send private message
sunseb7
n00b
n00b


Joined: 06 Feb 2011
Posts: 15

PostPosted: Mon Mar 21, 2011 6:25 pm    Post subject: Reply with quote

LOL ! 13 secondes ? Ca fait mal...

Avec emerge --keep-going, je pensais avoir un système prêt et opérationnel ce matin. Qui aurait crû que le paquet le plus insignifiant du monde allait mettre à mal ma mise à jour ?

:lol:

emerge --info wrote:
!!! CONFIG_PROTECT is empty
Portage 2.1.9.44 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_750_@_2.67GHz-with-gentoo-2.0.2
Timestamp of tree: Mon, 21 Mar 2011 17:00:01 +0000
app-shells/bash: 4.2_p8
dev-lang/python: 2.7.1-r1, 3.1.3-r1
dev-util/cmake: 2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc: 0.7.0
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.68
sys-devel/automake: 1.11.1
sys-devel/binutils: 2.21
sys-devel/gcc: 4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82
virtual/os-headers: 2.6.38 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT=""
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gpm iconv ipv6 jpeg kde lcms ldap libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 readline sdl semantic-desktop session spell sse sse2 sse3 sse4 ssl ssse3 startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


build.log wrote:
>>> Unpacking source...
>>> Unpacking pambase-20101024.tar.bz2 to /var/tmp/portage/sys-auth/pambase-20101024/work
>>> Source unpacked in /var/tmp/portage/sys-auth/pambase-20101024/work
>>> Preparing source in /var/tmp/portage/sys-auth/pambase-20101024/work/pambase-20101024 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-auth/pambase-20101024/work/pambase-20101024 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/sys-auth/pambase-20101024/work/pambase-20101024 ...


- La compilation fait chauffer à 100% un des processeurs, mais rien ne se passe... Une boucle infinie quelque part ?
- Oui, désolé, je voulais dire ~amd64.
- J'ai fait un emerge @world -e depuis le LiveCD (chroot). Mais ce problème de compilation se pose encore, alors que Gentoo est installé et fonctionnel sous KDE.
_________________
sunse8
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8073
Location: ~Brussels - Belgique

PostPosted: Mon Mar 21, 2011 8:25 pm    Post subject: Reply with quote

Essaie de resynchroniser l'arbre et faire un "emerge -DuNav world"
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
sunseb7
n00b
n00b


Joined: 06 Feb 2011
Posts: 15

PostPosted: Mon Mar 21, 2011 8:47 pm    Post subject: Reply with quote

Quote:
Calculating dependencies... done!
[ebuild R ] sys-auth/pambase-20101024 USE="consolekit* cracklib sha512 -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-auth/pambase-20101024
* pambase-20101024.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* Package: sys-auth/pambase-20101024
* Repository: gentoo
* Maintainer: pam-bugs@gentoo.org
* USE: amd64 consolekit cracklib elibc_glibc kernel_linux multilib sha512 userland_GNU
* FEATURES: sandbox
>>> Unpacking source...
>>> Unpacking pambase-20101024.tar.bz2 to /var/tmp/portage/sys-auth/pambase-20101024/work
>>> Source unpacked in /var/tmp/portage/sys-auth/pambase-20101024/work
>>> Preparing source in /var/tmp/portage/sys-auth/pambase-20101024/work/pambase-20101024 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-auth/pambase-20101024/work/pambase-20101024 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/sys-auth/pambase-20101024/work/pambase-20101024 ...


Et à nouveau une compilation infinie...

:lol:
_________________
sunse8
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8073
Location: ~Brussels - Belgique

PostPosted: Tue Mar 22, 2011 7:03 am    Post subject: Reply with quote

Peux-tu voir dans le log où ça cycle ?

Je vois que c'est un rebuild, à cause de l'ajout d'un flag. As-tu fait un "emerge --deep --update --newuse" (= emerge -DuN) ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Tue Mar 22, 2011 10:54 am    Post subject: Reply with quote

Ajoute --debug à ta commande emerge, pour voir ce que çà dit.
Back to top
View user's profile Send private message
sunseb7
n00b
n00b


Joined: 06 Feb 2011
Posts: 15

PostPosted: Tue Mar 22, 2011 12:03 pm    Post subject: Reply with quote

Alors...

Quote:
>>> Compiling source in /var/tmp/portage/sys-auth/pambase-20101024/work/pambase-20101024 ...
+ ebuild_phase src_compile
+ declare -F src_compile
+ qa_call src_compile
++ shopt
+ local 'shopts=autocd off
cdable_vars off
cdspell off
checkhash off
checkjobs off
checkwinsize off
cmdhist on
compat31 off
compat32 off
compat40 off
compat41 off
dirspell off
dotglob off
execfail off
expand_aliases on
extdebug on
extglob off
extquote on
failglob off
force_fignore on
globstar off
gnu_errfmt off
histappend off
histreedit off
histverify off
hostcomplete on
huponexit off
interactive_comments on
lastpipe off
lithist off
login_shell off
mailwarn off
no_empty_cmd_completion off
nocaseglob off
nocasematch off
nullglob off
progcomp on
promptvars on
restricted_shell off
shift_verbose off
sourcepath on
xpg_echo off' 'OLDIFS=
'
+ local retval
+ src_compile
+ local implementation=
+ local linux_pam_version=
+ has_version sys-libs/pam
+ '[' compile == depend ']'
+ [[ -n 1 ]]
+ /usr/lib64/portage/bin/ebuild-ipc has_version / sys-libs/pam
+ local retval=0
+ case "${retval}" in
+ return 0
+ implementation=linux-pam
++ cut -d ' ' -f 3
+++ best_version sys-libs/pam
+++ '[' compile == depend ']'
+++ [[ -n 1 ]]
+++ /usr/lib64/portage/bin/ebuild-ipc best_version / sys-libs/pam
+++ local retval=0
+++ case "${retval}" in
+++ return 0
++ qatom sys-libs/pam-1.1.3


Et ensuite emerge reste bloqué ici... J'ai réinstallé sys-libs/pam, mais pambase se bloque encore et toujours... :roll:

Pour le build.log, voir quelques messages plus haut.
_________________
sunse8
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Tue Mar 22, 2011 12:25 pm    Post subject: Reply with quote

Si tu lances un :
Code:

# qatom sys-libs/pam-1.1.3

en root, çà bloque de la même manière ?
Back to top
View user's profile Send private message
sunseb7
n00b
n00b


Joined: 06 Feb 2011
Posts: 15

PostPosted: Tue Mar 22, 2011 12:27 pm    Post subject: Reply with quote

netfab wrote:
Si tu lances un :
Code:

# qatom sys-libs/pam-1.1.3

en root, çà bloque de la même manière ?


Exact ! Donc le problème concerne sys-libs/pam ?
_________________
sunse8
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Tue Mar 22, 2011 12:28 pm    Post subject: Reply with quote

Essaye :
Code:

# emerge -1 portage-utils

et réessaye le qatom.
Back to top
View user's profile Send private message
sunseb7
n00b
n00b


Joined: 06 Feb 2011
Posts: 15

PostPosted: Tue Mar 22, 2011 12:34 pm    Post subject: Reply with quote

netfab wrote:
Essaye :
Code:

# emerge -1 portage-utils

et réessaye le qatom.


Pourquoi cette option -1 ? Elle fait quoi ?

Mais ça ne change rien malheureusement...

:cry:
_________________
sunse8
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Tue Mar 22, 2011 12:42 pm    Post subject: Reply with quote

Le -1 (--oneshot) par habitude, pour ne pas inscrire ce paquet dans le fichier world, car c'est une dépendance.
En root, si tu lances un :
Code:

# /etc/portage/postsync.d/q-reinitialize

çà te sort quoi ?
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1698
Location: 127.0.0.1

PostPosted: Tue Mar 22, 2011 1:08 pm    Post subject: Reply with quote

Ok, laisse tomber le q-reinitialize : c'est le bug #359613, pour le moment tu dois downgrader portage-utils, certainement en version 0.4 :

Quote:

Same problem here, q / qatom hangs with 100% CPU.

Quote:

Worked around by downgrading portage-utils.

Quote:

Comfirmed that downgrading portage-utils fixes the problem...
Back to top
View user's profile Send private message
sunseb7
n00b
n00b


Joined: 06 Feb 2011
Posts: 15

PostPosted: Tue Mar 22, 2011 2:20 pm    Post subject: Reply with quote

BINGO ! Merci beaucoup pour ton aide, netfab !

:D

C'est pas un paquet très important, je ferai sans lui, en attendant un prochain correctif.

Et super le -1, je faisais chaque fois --deselect derrière et c'est vrai que c'était pas intuitif !
_________________
sunse8
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum