Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Samba] Configuration
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
jerep6
Apprentice
Apprentice


Joined: 02 Aug 2006
Posts: 215
Location: Landes

PostPosted: Tue Apr 05, 2011 6:06 pm    Post subject: [Samba] Configuration Reply with quote

Salut,
Je souhaite savoir quelle option de samba provoque le comportement suivant :
Lorsque je suis sous windows avec l'utilisateur "jerep6", je suis automatiquement connecté en temps qu'utilisateur "jerep6" sous samba.

Voici ma configuration :
Code:

[global]
## Browsing/Identification ###
   workgroup = MSHOME
   server string = %h
   dns proxy = no

#### Debugging/Accounting ####
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog only = no
   syslog = 4
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######
   security = user
   encrypt passwords = true
   passdb backend = tdbsam

############ Misc ############
   socket options = TCP_NODELAY
   domain master = auto
   usershare max shares = 0

#======================= Share Definitions =======================

[homes]
   comment = Home Directories
   browseable = no
   read only = no
   create mask = 0755
   directory mask = 0755


[Donnees]
    path = /mnt/donnees/
    comment = Donnees rsync de Jeremy
    browseable = yes
    public = no
    writable = yes
    hide dot files = yes
    preserve case = yes
    valid users=jerep6
    force user=utilisateurX
    force group=users


Voici la manière dont j'ai crée les utilisateurs
Code:

groupadd smb
# Création d’un utilisateur unix (nécessaire) qui ne pourra pas se connecter au système (shell = /bin/false)
useradd -g smb utilisateurX -s /bin/false
useradd -g smb jerep6 -s /bin/false
#Création de l’utilisateur samba (se base sur un utilisateur unix)
smbpasswd -a utilisateurX
smbpasswd -a jerep6
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Tue Apr 05, 2011 6:09 pm    Post subject: Reply with quote

J'aurais tendance à te suggérer de regarder du côté de windows, puisque c'est il me semble son comportement par défaut, que d'essayer de se connecter avec l'identifiant du système client.
RTFM$ ? :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum