Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel 2.6 with BootX on PowerBook 3400c [almost solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message

Joined: 29 Aug 2009
Posts: 5

PostPosted: Fri Mar 04, 2011 6:16 pm    Post subject: Kernel 2.6 with BootX on PowerBook 3400c [almost solved] Reply with quote

Original message
Hello all, I’m facing a really hard wall on trying to boot a linux kernel for the first time on a PowerBook 3400c, one of the last Old World Macs, with PCI bus and OpenFirmware 2.0.x. I got the computer for free because supposedly “broken” (all it needed was an OS reinstall, and I put Mac OS 9.1 on it, working regularly with TCP and Internet and all you could ask for :) ). Too bad I guess I got allergic to proprietary OSes, so I decided to make it dual boot with Linux as well. Now, being a regular Gentoo user, and knowing its shortcomings and benefits, I decided to install that.

My first step was to get some documentation, which I found at:My specific model has a 200 MHz PowerPC 603ev, 80 MiB RAM, 2 GiB disk.

Gentoo 20101212
What I then did is:

  • I reinstalled Mac OS 9 (plus the 9.1 upgrade) after repartitioning the disk, leaving some 1.5 GiB for Linux as first partition (temporarily “A/UX root”), and formatting the rest as HFS+;
  • I grabbed install-powerpc-minimal-20101212.iso on my regular computer, and burned it to a CD-R (the only kind of disk the PowerBook will read);
  • I downloaded BootX 1.2.2 on the Mac - the link on the Handbook is broken, but I found it nonetheless;
  • I installed BootX, and copied from the CD the file /boot/ppc32 (also incorrect in the Handbook) in Mac OS 9.1:System Folder:Linux Kernels, and /boot/ppc32.igz in Mac OS 9.1:System Folder;
  • I loaded BootX, told it to pick the ppc32 kernel and load its initrd, set the ramdisk size to 32000 as suggested, and copied the arguments literally from the instructions in the Handbook:
    cdroot root=/dev/ram0 init=linuxrc loop=image.squashfs looptype=squashfs console=tty0
  • then I started Linux.
At this point, all I got was a black screen with the text “Welcome to Linux” followed by the kernel version. The hard drive also spun down (it’s quite loud, so that was very noticeable), and I heard some humming from the CD drive, but no actual zeg-zeg reading sound. Then, nothing else, for many minutes, until I pressed Ctrl+Apple+Power. (Reminded me of Windows 98 - ugh.)

My first thought was “hey, maybe this very kernel needs some not-yet-documented adjustments”, since at least the file name was different than in the Handbook, so I tried varying the size of the ramdisk (8192, 16000, 32000, 64000), checking/unchecking every checkbox in BootX, adding a “video=ct65550:800x600” argument, adding the made-up arguments “debug”, “verbose” and “loglevel=9” (I later found out that debug is an actual option :) ). I tried most of the combinations of the above, but nothing changed: always stuck at the “Welcome to Linux”.

Debian 6.0.0
So I decided to try some other distribution, just as a bootstrap, to then overinstall Gentoo over it. After reading that Debian is one of the few distros still supporting PowerPC, I grabbed debian-6.0.0-powerpc-netinst.iso and repeated the same steps (put the kernel in System Folder:Linux Kernels, the initrd in System Folder), reconfigured BootX for the new kernel and initrd, with the very same result: nothing but “Welcome to Linux”. I also repeated some of the configuration attempts, but I gave up after noticing that nothing had changed at all.

Gentoo 2007.0
Since I noticed that all the success stories I could find, as well as the documentation, were all referring to at least some three years ago, I decided to get the oldest Gentoo I could get, install-ppc-minimal-2007.0.iso, and tried again with that, this time noticing that the kernel image name was the same as mentioned in the Handbook, giving me a feeling that this time was going to be the right one.
The illusion didn’t last long.

All in all, I still haven’t managed to boot Linux a single time on this PowerBook. Can somebody help me figure out what I’m doing wrong?
Just in case you think about it, no, it doesn’t boot from non-Mac OS CDs; been there.

Thanks everybody, even just for reading this.

See next message.

Last edited by fastijum on Sun Mar 06, 2011 2:45 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 29 Aug 2009
Posts: 5

PostPosted: Sat Mar 05, 2011 6:55 am    Post subject: Update Reply with quote

Turns out that Debian keeps an historical archive of earlier releases, so I managed to get my hands on their Debian 3, which included a 2.2 kernel.

Well, that did boot with BootX.

The only problems, though, are that it’s a 2.2 kernel, and that it’s not Gentoo :)
So, are there any reports of a 2.6 kernel working on an Old World Mac with BootX?

Or, is it feasible to:

  • install Debian 3,
  • install quik to avoid BootX,
  • try updating it to a more recent Debian 6,
  • see if a 2.6 kernel is able to boot, without BootX,
  • and then converting that to current stable Gentoo?

Does it sound too complicated to succeed? Comments or experiences are welcome.

I tried again with Debian 3.1, which included a 2.4 and a 2.6 kernel, and they both worked. So, 2.6.8 (ugh) worked properly. With help of really nice people on #gentoo-powerpc and #debianppc, I came up with the idea (with a supporting story from JoseJX) that kernel 2.6 was broken on some release.

From the Debian web site I picked the .config they used for that release, and compiled a custom 2.6.8, which didn’t get to the point where it would try accessing the root, but it did indeed initialize and output something. Since the Debian image had patches on (2.6.8-4), I tried with vanilla 2.6.9, assuming (hoping) that important patches had made it into the upstream tree. Coincidence or not, 2.6.9 booted completely up to being unable to read the root.

So I tried again, jumping to (last 2.6.15), and that worked too. Now I’ll find the first kernel that doesn’t boot, and (thanks Monkeh for the tip) I’ll have git bisect tell me which commit introduced the regression.

Again, comments very welcome.
Back to top
View user's profile Send private message

Joined: 01 Aug 2005
Posts: 52
Location: EN51vt

PostPosted: Sat Apr 16, 2011 3:49 pm    Post subject: Reply with quote

I remember the same headaches when I was trying to get my 3400 running Gentoo. I was just wondering if this got fixed in newer kernels.
It's been a while, but I remember having to get old release media (somewhere around 2.6.8-2.6.15 sounds right), boot that, then proceed with the install.
Looking through my drawer, I see I have a Gentoo 2006.0 ppc universal install CD- that's probably the one. Looks like 2.6.15.

The NIC in my 3400 is flaky (even under MacOS), so I got a G3 Wallstreet instead. I had the same issues with initially booting it, but it's been running reliably (with the exception of a hard drive dying, not the G3's fault) for I think 4 years now.

I've never got (though it's been at least a year since I tried) a kernel greater than 2.6.27 to work, nor have I ever got the new SATA/PATA subsystem (CONFIG_ATA) to work, so I'm still using the legacy CONFIG_IDE. However, last time I upgraded udev I got a big warning that the next version won't support hdX nodes anymore, so I have two options- get a recent kernel and hope CONFIG_ATA works, or lock udev to whatever it's at now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum