Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X.org: Segmentation fault.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
V10lator
Apprentice
Apprentice


Joined: 11 Jul 2004
Posts: 199

PostPosted: Sat May 07, 2011 11:11 am    Post subject: X.org: Segmentation fault. Reply with quote

Hi,
wie in einem anderen Thread angedeutet startet mein X-Server nicht mehr.

startx: http://paste.pocoo.org/show/384466
Xorg.0.log: http://paste.pocoo.org/show/384468
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Mon May 09, 2011 7:13 am    Post subject: Reply with quote

Probiere das mal aus:

Code:
"Section "InputClass"
        Identifier "disabling synaptic second mouse found"
        MatchProduct "SynPS/2 Synaptics TouchPad"
        MatchDevicePath "/dev/input/mouse0"
        Option "Ignore" "on"
EndSection"


/etc/X11/xorg.conf.d/10-synaptics.conf

Es würde helfen zu wissen welchen Laptop du hast. Auch könnte es bei einem Segmentation Fault das Problem nicht bei den Synaptics-Treibern und der Hardwareerkennung liegen.. und eigentlich sollte der Xserver mit einem solchen Problem auch starten, nur fehlt dir dann z.B. die Maus/Touchpad-Funktionalität.

Wie hast du denn bisher dein Touchpad eingerichtet gehabt, also was steht in deiner evdev.conf?
Back to top
View user's profile Send private message
V10lator
Apprentice
Apprentice


Joined: 11 Jul 2004
Posts: 199

PostPosted: Mon May 09, 2011 2:20 pm    Post subject: Reply with quote

ChrisJumper wrote:
Probiere das mal aus:

Das hat leider nicht geholfen.
Quote:
Es würde helfen zu wissen welchen Laptop du hast.

Ein Lenovo idepad S10

Ich denke auch nicht das es am synaptics Treiber liegt da es ja früher auch funktionierte.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Mon May 09, 2011 3:59 pm    Post subject: Reply with quote

Sehr seltsam, es macht auf mich den Eindruck das es wie hier (archlinux.org - forum) diskutiert - dazu führt das sich der evdev als auch der synaptics-Treiber um das selbe Gerät streiten. Aber niemand schreibt dort das der X-Server deswegen nicht mehr startet. Dennoch würde ich versuchen diese Fehlermeldung los zu werden.

Mit zwei weiteren ansätzen:

1. Versuchen den Xserver ohne eine Synaptics-Konfiguration zu starten. (Dafür die Synaptics-Datei aus dem xorg.conf.d Verzeichnis entfernen oder die entsprechenden Zeilen auskommentieren.).

2. Wie eben im archlinux-Forum beschrieben mit dieser Einstellung in /etc/X11/xorg.conf.d/10-synaptics.conf probieren:

Code:
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
        Option "VertEdgeScroll" "on"
        Option "HorizEdgeScroll" "on"
EndSection


Wichtig scheint die Zeile mit dem MatchDevicePath zu sein.

Gegebenfalls solltest du in deiner 10-evdev.conf den touchpad-Abschnitt auskommentieren

Code:
#Section "InputClass"
#        Identifier "evdev touchpad catchall"
#        MatchIsTouchpad "on"
#        MatchDevicePath "/dev/input/event*"
#        Driver "evdev"
#EndSectio


3. Sollte das nicht funktionieren, würde ich noch mal den X-Server und die x11-drivers Pakete neu bauen. Vielleicht auch mal ein revdep-rebuild durchlaufen lassen.
Back to top
View user's profile Send private message
V10lator
Apprentice
Apprentice


Joined: 11 Jul 2004
Posts: 199

PostPosted: Mon May 09, 2011 4:18 pm    Post subject: Reply with quote

Ich habe gerade alle Dateien aus /etc/x11/xorg.conf.d gelöscht. So startet der Server. :)

Also werde ich nun Datei für Datei gucken welche den Fehler verursacht.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum