Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] cups-pdf druckt nicht mehr
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri May 27, 2011 9:47 pm    Post subject: [solved] cups-pdf druckt nicht mehr Reply with quote

Guten Morgen,

heut ist mir aufgefallen, dass mein Cups-PDF, was monatelang zuverlässig funktionierte, gar nicht mehr will. Meine cupsd.conf
Code:
LogLevel warn

# Administrator user group...
SystemGroup lpadmin


# Only listen for connections from the local machine.
Listen *:631
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow all
BrowseLocalProtocols CUPS

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
<Location />
  Order allow,deny
  Allow localhost
  Allow From 192.168.*
</Location>

# Restrict access to the admin pages...
<Location /admin>
  Order allow,deny
</Location>


Die Logfiles:
/var/log/cups/access_log
Code:
localhost - - [27/May/2011:23:09:46 +0200] "POST /printers/Cups-PDF HTTP/1.1" 200 138875 Print-Job successful-ok
localhost - - [27/May/2011:23:11:12 +0200] "POST /printers/Cups-PDF HTTP/1.1" 200 138875 Print-Job successful-ok


/var/log/cups/error_log
Code:
 Address family not supported by protocol.
E [27/May/2011:23:10:44 +0200] Unable to open listen socket for address :::631 - Address family not supported by protocol.
E [27/May/2011:23:11:04 +0200] Unable to open listen socket for address :::631 - Address family not supported by protocol.


In /var/spool/cups bzw. /var/spool/cups-pdf befindet sich natürlich nichts. Ich vermute, dass cups mit Upgrade auf 1.4.6-r1 seinen Dienst eingestellt haben könnte. Zur Fehlermeldung hab ich bei Google 'ne ganze Menge gefunden. Nur leider war nichts dabei, was irgendwie mein Problem hätte lösen können. Ach ja: IPv6 ist bei mir sowohl im Kernel als auch in den Use-Flags deaktiviert. Hat jemand 'ne Idee, warum cups-pdf nicht mehr mag? Hab's auch mal zusätzlich auf meinem Notebook ausprobiert - selbes Problem.

Anmerkung:
Hab grad das hier gefunden. Scheint ein ähnliches Problem gehabt zu haben.


Last edited by musv on Sat May 28, 2011 7:52 am; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Fri May 27, 2011 10:46 pm    Post subject: Reply with quote

musv wrote:
.... Ich vermute, dass cups mit Upgrade auf 1.4.6-r1 seinen Dienst eingestellt haben könnte. ....

Hmm.., an der Version cups-1.4.6-r1 sollte es vermutlich nicht liegen. Hier auf enem ~x86 System funkt der PDF Druck damit einwandfrei.

Nur ein Schuss ins Blaue: sofern du kde mit nutzt teste doch mal ob ein reemerge der von "poppler" abhängigen Pakete etwas ändert. (das wird nach einem poppler Update eh empfohlen)
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Sat May 28, 2011 7:51 am    Post subject: Reply with quote

Hab was gefunden:

https://bugs.gentoo.org/show_bug.cgi?id=365875

Lösung:
Code:
chmod 700 /usr/libexec/cups/backend/cups-pdf


Frage an die Cups-Profis. Das Verzeichnis sieht bei mir so aus:
Code:
drwxr-xr-x 2 root root    15 28. Mai 09:37 .
drwxr-xr-x 9 root root     9 22. Jan 2009  ..
-rwxr-xr-x 1 root root  7254 23. Mai 11:39 beh
-rwxr-xr-x 1 root root 52512 22. Mai 19:50 bluetooth
-rwx------ 1 root root 26880 27. Mai 19:57 cups-pdf
lrwxrwxrwx 1 root root     3 28. Mai 09:37 http -> ipp
lrwxrwxrwx 1 root root     3 28. Mai 09:37 https -> ipp
-rwx------ 1 root root 48976 28. Mai 09:37 ipp
-rwx------ 1 root root 44744 28. Mai 09:37 lpd
-rwxr-xr-x 1 root root 31296 28. Mai 09:37 parallel
-rwxr-xr-x 1 root root 10352 28. Mai 09:37 scsi
-rwxr-xr-x 1 root root 31280 28. Mai 09:37 serial
-rwxr-xr-x 1 root root 27112 28. Mai 09:37 snmp
-rwxr-xr-x 1 root root 31264 28. Mai 09:37 socket
-rwxr-xr-x 1 root root 22864 28. Mai 09:37 usb

Parallel-Port, USB usw. nutz ich nicht zum Drucken. Müssten die Treiber/Schnittstellen/Wasauchimmer korrekterweise eigentlich alle auf 700 stehen?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum