Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] broken packages
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Tue May 24, 2011 5:51 pm    Post subject: [solved] broken packages Reply with quote

Hallo, habe leider ein Durcheinander und weiß nicht, wie ich das am besten auflösen kann. Ausgangspunkt war, dass ich xfce updaten wollte.

http://pastebin.com/g87ukYRA

mit dem Porthole Portage Frontend sieht die Ausgabe (beim upgrade; nach sync) so aus:

http://pastebin.com/5rEkG6jQ

Ich hätte zwar den angegebenen Link angesehen (mit broken packages), aber da kam ich (mit emerge --umerge...) leider nicht weiter.


Last edited by FrancisA on Sun May 29, 2011 3:49 pm; edited 2 times in total
Back to top
View user's profile Send private message
Necoro
Veteran
Veteran


Joined: 18 Dec 2005
Posts: 1912
Location: München (Germany)

PostPosted: Tue May 24, 2011 10:04 pm    Post subject: Reply with quote

Quote:
* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Sowas sollte man nicht ignorieren.

Ansonsten scheinst du gerade gleichzeitig KDE, Qt und Xfce upzugraden ... das sind zu viele große Sachen auf einmal würde ich sagen. Versuch die doch runterzubrechen und zB erst Qt, denn Xfce und denn KDE zu machen.

Für das Xfce-Update würde ich dir auch raten
Code:
gnome-base/gvfs -gdu
xfce-base/thunar -udev
xfce-base/xfce4-session -udev

zu nutzen. Das sollte dir an der Stelle das ganze PolicyKit-Geraffel sparen, so dass man das denn in Ruhe mit KDE upgraden kann. Wenn man das hat, kann man das oben ja wieder rückgängig machen und das Zeugs auch in Xfce einbauen, sofern man will.
_________________
Inter Deum Et Diabolum Semper Musica Est.
Back to top
View user's profile Send private message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Wed May 25, 2011 7:45 am    Post subject: Reply with quote

Necoro wrote:
Quote:
* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Sowas sollte man nicht ignorieren.

Danke für die Antwort, Ja, wissen sollte ich das eigentlich ;) wird nachgeholt
Necoro wrote:

Ansonsten scheinst du gerade gleichzeitig KDE, Qt und Xfce upzugraden ... das sind zu viele große Sachen auf einmal würde ich sagen. Versuch die doch runterzubrechen und zB erst Qt, denn Xfce und denn KDE zu machen.

Ja, habe mich auf xfce festgelegt. Aber auf Krusader und k3b, ... möchte ich nicht verzichten, darum habe ich es in Kauf genommen, das kde und qt zu emergen.
Necoro wrote:

Für das Xfce-Update würde ich dir auch raten
Code:
gnome-base/gvfs -gdu
xfce-base/thunar -udev
xfce-base/xfce4-session -udev

zu nutzen. Das sollte dir an der Stelle das ganze PolicyKit-Geraffel sparen, so dass man das denn in Ruhe mit KDE upgraden kann. Wenn man das hat, kann man das oben ja wieder rückgängig machen und das Zeugs auch in Xfce einbauen, sofern man will.

Ich probiere das einmal aus und melde mich dann wieder. ;)

Das gnome-base/gvfs -gdu habe ich jetzt hinbekommen, indem ich vorher blockierende Packages ungemergt habe.
Nun kommit bei sud emerge xfce-base/thunar -udev
Code:

[blocks B     ] >x11-libs/qt-test-4.6.3-r9999 (">x11-libs/qt-test-4.6.3-r9999" is blocking x11-libs/qt-svg-4.6.3, x11-libs/qt-multimedia-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-opengl-4.6.3)
[blocks B     ] <x11-libs/qt-qt3support-4.7.2 ("<x11-libs/qt-qt3support-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] <x11-libs/qt-script-4.7.2 ("<x11-libs/qt-script-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] <x11-libs/qt-sql-4.7.2 ("<x11-libs/qt-sql-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] >x11-libs/qt-script-4.6.3-r9999 (">x11-libs/qt-script-4.6.3-r9999" is blocking x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-multimedia-4.6.3)
[blocks B     ] >x11-libs/qt-core-4.6.3-r9999 (">x11-libs/qt-core-4.6.3-r9999" is blocking x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-multimedia-4.6.3)
[blocks B     ] <x11-libs/qt-dbus-4.7.2 ("<x11-libs/qt-dbus-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-script-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] sys-apps/hal ("sys-apps/hal" is blocking sys-power/upower-0.9.9)
[blocks B     ] >x11-libs/qt-xmlpatterns-4.6.3-r9999 (">x11-libs/qt-xmlpatterns-4.6.3-r9999" is blocking x11-libs/qt-svg-4.6.3, x11-libs/qt-multimedia-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3, x11-libs/qt-opengl-4.6.3)
[blocks B     ] >x11-libs/qt-sql-4.6.3-r9999 (">x11-libs/qt-sql-4.6.3-r9999" is blocking x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-multimedia-4.6.3)
[blocks B     ] >x11-libs/qt-opengl-4.6.3-r9999 (">x11-libs/qt-opengl-4.6.3-r9999" is blocking x11-libs/qt-multimedia-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3)
[blocks B     ] <xfce-base/xfdesktop-4.7.0 ("<xfce-base/xfdesktop-4.7.0" is blocking xfce-base/garcon-0.1.7)
[blocks B     ] >x11-libs/qt-gui-4.6.3-r9999 (">x11-libs/qt-gui-4.6.3-r9999" is blocking x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-multimedia-4.6.3)
[blocks B     ] <x11-libs/qt-gui-4.7.2 ("<x11-libs/qt-gui-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] >x11-libs/qt-webkit-4.6.3-r9999 (">x11-libs/qt-webkit-4.6.3-r9999" is blocking x11-libs/qt-svg-4.6.3, x11-libs/qt-multimedia-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-opengl-4.6.3)
[blocks B     ] <x11-libs/qt-multimedia-4.7.2 ("<x11-libs/qt-multimedia-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-core-4.7.2-r1, x11-libs/qt-sql-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)
[blocks B     ] >x11-libs/qt-svg-4.6.3-r9999 (">x11-libs/qt-svg-4.6.3-r9999" is blocking x11-libs/qt-multimedia-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-opengl-4.6.3)
[blocks B     ] >x11-libs/qt-qt3support-4.6.3-r9999 (">x11-libs/qt-qt3support-4.6.3-r9999" is blocking x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-multimedia-4.6.3)
[blocks B     ] >x11-libs/qt-dbus-4.6.3-r9999 (">x11-libs/qt-dbus-4.6.3-r9999" is blocking x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-multimedia-4.6.3)
[blocks B     ] <x11-libs/qt-core-4.7.2 ("<x11-libs/qt-core-4.7.2" is blocking x11-libs/qt-test-4.7.2, x11-libs/qt-svg-4.7.2, x11-libs/qt-gui-4.7.2, x11-libs/qt-qt3support-4.7.2, x11-libs/qt-sql-4.7.2, x11-libs/qt-webkit-4.7.2, x11-libs/qt-declarative-4.7.2-r1, x11-libs/qt-opengl-4.7.2, x11-libs/qt-dbus-4.7.2, x11-libs/qt-script-4.7.2, x11-libs/qt-xmlpatterns-4.7.2)


Wenn ich nun versuche:
Code:

franz@localhost:~$ sudo emerge --unmerge xfce-base/xfdesktop-4.7.0
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find '=xfce-base/xfdesktop-4.7.0' to unmerge.

>>> No packages selected for removal by unmerge
franz@localhost:~$
dann findet er das nicht.

Sorry, draufgekommen: sudo emerge --unmerge "<xfce-base/xfdesktop-4.7.0": so gehts
Trotzdem: zb x11-libs/qt-qt3support-4.7.2 bringe ich nicht weg, weils nicht gefunden wird.

Ich hätte sudo emerge --depclean aufgerufen, da sagt er dann:

Dependencies could not be completely resolved due to
* the following required packages not being installed:
....
* Have you forgotten to run `emerge --update --newuse --deep @world` prior
* to depclean?

Das habe ich nun aufgerufen und will 348(!) packages emergen. Irgendwie glaube ich, bin ich auf dem Holzweg.
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6292

PostPosted: Sat May 28, 2011 7:43 am    Post subject: Reply with quote

FrancisA wrote:
sudo emerge --unmerge xfce-base/xfdesktop-4.7.0

Atome spezifiziert man entweder ohne Versionsnummer (xfce-base/xfdesktop) oder mit "=" davor ("=xfce-base/xfdesktop-4.7.0").
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3668
Location: Germany

PostPosted: Sat May 28, 2011 12:50 pm    Post subject: Reply with quote

FrancisA wrote:
.....
* Have you forgotten to run `emerge --update --newuse --deep @world` prior
* to depclean?

Das habe ich nun aufgerufen und will 348(!) packages emergen. Irgendwie glaube ich, bin ich auf dem Holzweg.

Nein warum? Was spricht denn dagegen das System mal auf einen aktuellen gesunden Stand zu bringen?
Back to top
View user's profile Send private message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Sat May 28, 2011 9:03 pm    Post subject: Reply with quote

Josef.95 wrote:
FrancisA wrote:
.....

Das habe ich nun aufgerufen und will 348(!) packages emergen. Irgendwie glaube ich, bin ich auf dem Holzweg.

Nein warum? Was spricht denn dagegen das System mal auf einen aktuellen gesunden Stand zu bringen?


Es passt wieder alles, hat fast 24 stunden geemergt. ;)

@mv: danke für den Hinweis
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2050
Location: My own world! I and Gentoo!

PostPosted: Sat May 28, 2011 10:10 pm    Post subject: Reply with quote

Legst du bitte noch ein [solved] in den Threadtitel?
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
FrancisA
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2010
Posts: 111

PostPosted: Sun May 29, 2011 3:46 pm    Post subject: [solved] Reply with quote

Max Steel wrote:
Legst du bitte noch ein [solved] in den Threadtitel?


Wie geht das schnell? Hier solved eintragen? Ich probiers
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum