Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Verständnisfrage Luks Genkernel
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Yikity
n00b
n00b


Joined: 10 May 2011
Posts: 10

PostPosted: Sun Jun 26, 2011 8:19 pm    Post subject: Verständnisfrage Luks Genkernel Reply with quote

Hi Leute,

ich versuche immer noch mein System zu verschlüsseln, bin schon recht weit gekommen, nur ich verstehe da etwas absolut nicht.

Von der Fehlermeldung habe ich mal einen Screenshot gemacht: http://cr4ck.net/gentoo.jpg

Ich bin leider ein Kackn00b und kann nur meinen Kernel etc mit Genkernel stricken. Im Genkernel menuconfig habe ich alles was ich brauch mal als Modul, mal im Kernel getestet, aber er scheint es nicht zu übernehmen (AES, CBC, SHA256... Devicemapper...). Also habe ich im Initramfs mal shell eingegeben und geschaut was geladen ist, leider keine Spur von AES usw, auch bei cat /proc/crypto ... nichts von den Sachen die ich angeben habe.

Meine Zeile um Genkernel aufzurufen ist: genkernel --menuconfig --luks --install all

Er schreibt es dann auch ordentlich in boot.

Hab ich da irgend einen unglaublichen Denkfehler? Ich werde noch Wahnsinnig!

Mit der minimal LiveCD bekomm ich mein Root entschlüsselt und kann damit arbeiten, aber die nötigen Module kann ich damit auch nicht ausgeben :(

Vielen Dank schon mal im voraus!
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Jun 27, 2011 10:06 am    Post subject: Reply with quote

kompilier doch die essenzielle Module in den Kernel, dann ist es egal, ob diese dann geladen werden oder nicht

es läuft so oder so ;)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Yikity
n00b
n00b


Joined: 10 May 2011
Posts: 10

PostPosted: Mon Jun 27, 2011 11:23 am    Post subject: Reply with quote

Wie kann ich denn, wenn ich sie in den Kernel kompiliert habe, sehen was drin ist? So zur Überprüfung das es auch wirklich drin ist.
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Mon Jun 27, 2011 11:39 am    Post subject: Reply with quote

Yikity wrote:
Wie kann ich denn, wenn ich sie in den Kernel kompiliert habe, sehen was drin ist? So zur Überprüfung das es auch wirklich drin ist.


aktiviere im kernel:
general setup -> kernel .config support -> enable access to .config through /proc/config.gz

die konfiguration kannst du dann, für den laufenden kernel, einsehen indem du
Code:
zcat /proc/config.gz
machst
Back to top
View user's profile Send private message
Yikity
n00b
n00b


Joined: 10 May 2011
Posts: 10

PostPosted: Tue Jun 28, 2011 9:36 am    Post subject: Reply with quote

Ok hat geklappt, genkernel hat wirklich nicht das gemacht was ich ihm eingestellt habe, mit dem Anhang --oldconfig ging es dann, leider verschließt sich mir der Sinn davon :) aber OK, so klappt es!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3710
Location: Germany

PostPosted: Tue Jun 28, 2011 12:46 pm    Post subject: Reply with quote

Yikity wrote:
Ok hat geklappt, genkernel hat wirklich nicht das gemacht was ich ihm eingestellt habe, mit dem Anhang --oldconfig ging es dann, leider verschließt sich mir der Sinn davon :) aber OK, so klappt es!

Du hast vermutlich nicht mit den default Einstellungen in der /etc/genkernel.conf gerechnet ;)
Siehe zb auch hier
Back to top
View user's profile Send private message
Yikity
n00b
n00b


Joined: 10 May 2011
Posts: 10

PostPosted: Tue Jun 28, 2011 3:04 pm    Post subject: Reply with quote

Josef.95 wrote:
Yikity wrote:
Ok hat geklappt, genkernel hat wirklich nicht das gemacht was ich ihm eingestellt habe, mit dem Anhang --oldconfig ging es dann, leider verschließt sich mir der Sinn davon :) aber OK, so klappt es!

Du hast vermutlich nicht mit den default Einstellungen in der /etc/genkernel.conf gerechnet ;)
Siehe zb auch hier


Ganz genau! Aber jetzt hab ichs kapiert :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum