Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
deluge lässt sich nicht mehr starten - Python Fehler?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Mon Aug 08, 2011 7:50 am    Post subject: deluge lässt sich nicht mehr starten - Python Fehler? Reply with quote

Hallo,
ich wollte am Wochende nach 1-2 Monaten mal wieder "deluge" auf meinem Server starten und bekam nur folgende Fehlermeldung
Code:
server ~ # deluged -d
[ERROR   ] 09:37:27 main:226 /usr/lib/libboost_python-mt-1_46.so.1.46.1: undefined symbol: PyBytes_Size
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/deluge/main.py", line 219, in start_daemon
    Daemon(options, args)
  File "/usr/lib/python2.6/site-packages/deluge/core/daemon.py", line 136, in __init__
    from deluge.core.core import Core
  File "/usr/lib/python2.6/site-packages/deluge/core/core.py", line 36, in <module>
    from deluge._libtorrent import lt
  File "/usr/lib/python2.6/site-packages/deluge/_libtorrent.py", line 59, in <module>
    import libtorrent as lt
ImportError: /usr/lib/libboost_python-mt-1_46.so.1.46.1: undefined symbol: PyBytes_Size


Ich habe jetzt zwar mal versucht diverse Pakete zu "maskieren", aber geholfen hat alles was ich bei google gefunden habe leider nicht.

Hat jemand eine Idee?
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Mon Aug 08, 2011 2:00 pm    Post subject: Reply with quote

python-updater
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Tue Aug 09, 2011 8:10 am    Post subject: Reply with quote

das war bereits mein aller erster Gedanken - leider ohne Erfolg.
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Wed Sep 07, 2011 7:18 am    Post subject: Reply with quote

Leider geht deluge immernoch nicht, beim starten bekomme ich folgenden Fehler
Code:
[ERROR   ] 09:16:39 main:226 /usr/lib/libboost_python-mt-1_42.so.1.42.0: undefined symbol: PyBytes_Size
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/deluge/main.py", line 219, in start_daemon
    Daemon(options, args)
  File "/usr/lib/python2.6/site-packages/deluge/core/daemon.py", line 136, in __init__
    from deluge.core.core import Core
  File "/usr/lib/python2.6/site-packages/deluge/core/core.py", line 36, in <module>
    from deluge._libtorrent import lt
  File "/usr/lib/python2.6/site-packages/deluge/_libtorrent.py", line 59, in <module>
    import libtorrent as lt
ImportError: /usr/lib/libboost_python-mt-1_42.so.1.42.0: undefined symbol: PyBytes_Size


Weiß wirklich keiner Rat?
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4484

PostPosted: Wed Sep 07, 2011 7:33 am    Post subject: Reply with quote

mach mal ein Revdep-rebuild oder resinstalliere boost
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4410

PostPosted: Wed Sep 07, 2011 7:37 am    Post subject: Reply with quote

Hier hat google was ähnliches gefunden:
Quote:
Vielen Dank für die Ratschläge! Nachdem grundlegende Version 2.7 und den Wiederaufbau der notwendigen Pakete, begann delyug und nahm meine Hand!

Welche python-Version ist bei dir gesetzt?
Also:
Code:
eselect python set python2.7

Danach python-updater. Vllt. gehts ja dann.
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Wed Sep 07, 2011 7:42 am    Post subject: Reply with quote

Quote:
mach mal ein Revdep-rebuild oder resinstalliere boost
Hatte ich beides schon vor Wochen versucht, und beides hat leider gar nichts gebracht.

Quote:
Welche python-Version ist bei dir gesetzt?

Code:
server ~ # eselect python show
python3.1


Versuche es jetzt mal mit Python 2.7
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Wed Sep 07, 2011 7:57 am    Post subject: Reply with quote

Hmm, nachdem umstellen auf 2.7 und dem ausführen von python-updater will er auf einmal ne ganze Menge Pakete re-emergen, und ich frage mich ob das so richtig ist??

Code:
Calculating dependencies... done!
[ebuild   R    ] dev-libs/libxml2-2.7.8-r1  USE="python readline -debug -doc -examples -icu -ipv6 -test" 4,768 kB
[ebuild   R    ] dev-libs/gobject-introspection-0.10.8  USE="-doc -test" 1,001 kB
[ebuild   R    ] media-libs/alsa-lib-1.0.23  USE="python -alisp -debug -doc" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" 790 kB
[ebuild   R    ] dev-libs/libgamin-0.1.10-r2  USE="python -debug -static-libs" 643 kB
[ebuild   R    ] dev-python/dbus-python-0.83.2  USE="-doc -examples -test" 528 kB
[ebuild   R    ] media-libs/lcms-1.19  USE="jpeg python tiff zlib -static-libs" 907 kB
[ebuild   R    ] app-admin/webapp-config-1.50.16-r1  102 kB
[ebuild   R    ] app-backup/bacula-5.0.3-r1  USE="X bacula-clientonly mysql python readline sqlite3 ssl tcpd -bacula-nodir -bacula-nosd -ipv6 -logwatch -postgres -qt4 -static -vim-syntax" 0 kB
[ebuild   R    ] dev-python/pycurl-7.19.0  USE="-examples" 70 kB
[ebuild   R    ] x11-proto/xcb-proto-1.6-r1  91 kB
[ebuild   R    ] dev-libs/libxslt-1.1.26-r1  USE="crypt python -debug" 3,322 kB
[ebuild   R    ] sys-libs/tdb-1.2.7-r1  USE="python -static-libs -tdbtest -tools" 443 kB
[ebuild   R    ] dev-python/imaging-1.1.7  USE="X -doc -examples -scanner -tk" 488 kB
[ebuild   R    ] dev-python/setuptools-0.6.19  0 kB
[ebuild   R    ] sys-apps/file-5.07-r3  USE="python zlib -static-libs" 0 kB
[ebuild   R    ] dev-python/pyopenssl-0.12  USE="-doc" 0 kB
[ebuild   R    ] dev-python/chardet-2.0.1  0 kB
[ebuild     U  ] dev-python/cython-0.14.1 [0.13] USE="-doc -examples" 1,285 kB
[ebuild   R    ] dev-python/pyxdg-0.19  0 kB
[ebuild   R    ] dev-python/numpy-1.6.0  USE="-doc -lapack -test" 2,572 kB
[ebuild   R    ] sys-libs/cracklib-2.8.16  USE="nls python" 604 kB
[ebuild   R    ] dev-python/argparse-1.2.1  68 kB
[ebuild   R    ] dev-python/beaker-1.5.4-r1  USE="-test" 0 kB
[ebuild   R    ] dev-python/markupsafe-0.12  0 kB
[ebuild   R    ] dev-python/mysql-python-1.2.3  69 kB
[ebuild   R    ] net-zope/zope-fixers-1.0  0 kB
[ebuild   R    ] dev-python/imdbpy-4.7  299 kB
[ebuild   R    ] dev-python/mako-0.4.1  USE="-doc -test" 0 kB
[ebuild   R    ] net-zope/zope-interface-3.6.2  0 kB
[ebuild   R    ] dev-java/java-config-2.1.11-r3  60 kB
[ebuild   R    ] dev-lang/yasm-1.1.0-r1  USE="nls python" 1,377 kB
[ebuild   R    ] app-text/gnome-doc-utils-0.20.6  700 kB
[ebuild     UD~] dev-libs/boost-1.42.0-r1 [1.42.0-r2] USE="eselect python -debug -doc -icu -mpi -static-libs -test -tools" 32,644 kB
[ebuild   R    ] app-portage/gentoolkit-0.3.0.4  177 kB
[ebuild   R    ] dev-libs/boost-1.41.0-r3  USE="eselect python -debug -doc -expat -icu -mpi -test -tools" 0 kB
[ebuild   R    ] net-libs/rb_libtorrent-0.15.6  USE="python ssl -debug -doc -examples" 0 kB
[ebuild   R    ] dev-python/pycairo-1.8.10  USE="svg -doc -examples -test" 575 kB
[ebuild   R    ] dev-python/pygobject-2.28.6  USE="cairo introspection -doc -examples -libffi -test" 0 kB
[ebuild   R    ] dev-python/pygame-1.9.2_pre3082  USE="X -doc -examples -test" 0 kB
[ebuild   R    ] media-gfx/graphviz-2.26.3-r3  USE="cairo gtk java nls perl python -doc -examples -lasi -ruby -static-libs -tcl" 16,692 kB
[ebuild   R    ] net-analyzer/rrdtool-1.3.8  USE="nls perl python -doc -rrdcgi -ruby -tcl" 0 kB
[ebuild   R    ] dev-python/pygtk-2.24.0-r1  USE="-doc -examples -test" 2,306 kB
[ebuild   R    ] dev-python/pygtksourceview-2.10.1  USE="-debug -doc" 284 kB
[ebuild   R    ] dev-python/twisted-11.0.0  USE="crypt gtk -serial" 0 kB
[ebuild   R    ] dev-python/notify-python-0.1.1-r2  USE="-examples" 0 kB
[ebuild   R    ] gnome-base/gnome-menus-2.30.5  USE="python -debug (-introspection)" 461 kB
[ebuild   R    ] x11-libs/vte-0.28.1-r200  USE="introspection python -debug -doc -glade" 941 kB
[ebuild   R    ] dev-vcs/git-1.7.3.4-r1  USE="blksha1 curl gtk iconv perl threads webdav -bash-completion -cgi -cvs -doc -emacs (-ppcsha1) -subversion -tk -xinetd" 2,862 kB
[ebuild   R    ] dev-python/twisted-web-11.0.0  USE="-soap" 0 kB
[ebuild   R    ] media-tv/mythtv-0.23.1_p27077  USE="alsa css dbus faad fftw lirc mmx perl python tiff vdpau xvmc (-altivec) -autostart -debug -directv -dvb -ieee1394 -jack -lcd -pulseaudio" VIDEO_CARDS="nvidia -via" 31,519 kB
[ebuild   R   ~] net-p2p/deluge-1.3.3  USE="gtk libnotify webinterface" 0 kB
[ebuild   R    ] net-dns/avahi-0.6.28-r1  USE="dbus gdbm gtk howl-compat mdnsresponder-compat python -autoipd -bookmarks -doc -ipv6 -mono -qt4 -test" 1,210 kB
[ebuild   R    ] net-libs/libproxy-0.4.6-r3  USE="gnome perl python -kde -mono -networkmanager -test" 81 kB
[ebuild   R    ] app-editors/gedit-2.30.4  USE="python spell -doc" 4,596 kB
[ebuild   R    ] dev-vcs/subversion-1.6.17  USE="apache2 berkdb dso gnome-keyring java nls perl python webdav-neon -bash-completion -ctypes-python -debug -doc -emacs -extras -kde -ruby -sasl -test -vim-syntax -webdav-serf" 0 kB
[ebuild   R    ] dev-libs/libgweather-2.30.3  USE="python -doc" 7,275 kB

_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4484

PostPosted: Wed Sep 07, 2011 8:26 am    Post subject: Reply with quote

ja das ist korrekt, da diese pakete vorher gegen python 3.1 gebaut wurden. Und jetzt müssen diese Pakete auch gegen python 2.7 gebaut werden, weil python 3.1 nicht mit python 2.7 kompatible ist
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.


Last edited by firefly on Wed Sep 07, 2011 8:50 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4410

PostPosted: Wed Sep 07, 2011 8:32 am    Post subject: Reply with quote

firefly wrote:
weil python 3.1 nicht mit python 3.1 kompatible ist

Aha :D
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4484

PostPosted: Wed Sep 07, 2011 8:51 am    Post subject: Reply with quote

franzf wrote:
firefly wrote:
weil python 3.1 nicht mit python 3.1 kompatible ist

Aha :D

Ups :oops: schon korrigiert *g*
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Wed Sep 07, 2011 9:12 am    Post subject: Reply with quote

Gut, dann habe ich nur noch eine Frage. Wie bekomme ich die ganzen Programme re-emerget? Er spuckt mir zwar bei einem python-update diese Liste aus, aber das wars dann auch schon. Es kommt keine Abfrage ob ich diese Programm jetzt neuinstallieren will sondern hört einfach auf.
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4410

PostPosted: Wed Sep 07, 2011 9:15 am    Post subject: Reply with quote

Ich hab jetzt ins ebuild geschaut, und da steht für die rb_libtorrent definitiv python2 als Abhängigkeit (0.14 besteht sogar auf python:2.6).
Also sollte das Setzen von python2.7 + python-updater die Lösung sein.
Man kann aber vllt. mal mit dem deluge-Entwickler reden, dass der im Executable ein "#!/bin/env python2" reinnimmt, da deluge ja hart von rb_libtorrent abhängt, und das nur mit python2 funktioniert. Ein Gentoo-Bugreport wäre auch nicht schlecht.
Back to top
View user's profile Send private message
grim
n00b
n00b


Joined: 26 Jul 2007
Posts: 34

PostPosted: Wed Sep 07, 2011 1:54 pm    Post subject: Reply with quote

Hallo,

delug neu bauen. Das Problem hatte ich bei einigen Paketen, nach einem kompletten Systemupdate.

Gruß

grim
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum