Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Abspielen von Audio CDs nicht möglich / Rippen funktioniert
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2034
Location: Heidelberg - Germany

PostPosted: Wed Aug 31, 2011 11:48 am    Post subject: Abspielen von Audio CDs nicht möglich / Rippen funktioniert Reply with quote

Hi,

ich habe festgestellt, dass sowohl KSCD als auch Audacity oder smplayer keine AudioCDs abspielen. Nachschauen in /dev/* ergibt, es sind die nötigen Symlinks /dev/cdrom auf /dev/sr0 vorhanden. Warum auch nicht, denn sonst wüde das Rippen mittels Kioslave "audiocd:/" ja nicht funktionieren. Aber es funktioniert im Konqueror!

Erstaunlicherweise bringt das KDE4 Device Plasmoid auch kein Popup wenn eine Audiocd eingelegt wird, dagegen wird das Einlegen eines leeren CD Rohlings mit der Auforderung, diese zu brennen, freudig begrüßt.

Ich frage mich jetzt, was hier jetzt schief liegt. Ich nutze das selten, kann aber sagen, dass es vor einiger Zeit definitiv funktioniert hat. Es gab mal Udev Symlink Probleme damals. Daran liegt es diesmal nicht.

Grüße
Erdie
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2047
Location: My own world! I and Gentoo!

PostPosted: Wed Aug 31, 2011 11:54 am    Post subject: Reply with quote

hmm evtl weil für dvd-roms das Symlink dvd und für DVD Brenner der Symlink dvdr bzw. dvdrw angelegt wird.
und cdrom eig nur für CD-ROMs-
Möglicherweiße fehlen auch nur erweiterte Udev-Regeln für dem cdrom-symlink.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2034
Location: Heidelberg - Germany

PostPosted: Wed Aug 31, 2011 12:56 pm    Post subject: Reply with quote

Leider nein .. es handelt sich um eine Notebook mit, wie gewöhnlich, einem DVD Brenner. Alle Symlinks: cdrom, dvd, dvdrw etc. zeigen auf ein und dasselbe Device --> den DVD Brenner /dev/sr0.
Die alten Tücken von udev kenne ich, weil ich sie schon erlebt habe. Damals ging aber auch das Rippen nicht und ich mußte eine zusätzlichen link cdrom anlegen, da udev nur cdrom1 angelegt hatte. Das ist es diesesmal leider nicht.

:roll: Erdie
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Wed Aug 31, 2011 2:10 pm    Post subject: Reply with quote

Hmm.., wenn selbst mplayer sie nicht abspielen kann scheint ja irgendwas grundsätzliches nicht zu passen. Ist die AudioCD eventuell defekt, überaltert?
Hast du es schon mal mit einer anderen AudioCD getestet?

Poste doch bitte mal die Ausgabe von
Code:
ls -l /dev/ | grep -e cdr -e dvd

Und auch die Ausgabe von mplayer beim versuch eine AudioCD abzuspielen
Code:
mplayer cdda://
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2034
Location: Heidelberg - Germany

PostPosted: Wed Aug 31, 2011 2:41 pm    Post subject: Reply with quote

Bin noch im Büro, aber wollte schon mitteilen, dass ich es mit mehreren CDs probiert hatte. Die URLs unten probiere ich dann heute abend, danke für den Tipp ..
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2034
Location: Heidelberg - Germany

PostPosted: Wed Aug 31, 2011 4:48 pm    Post subject: Reply with quote

Da kommen wir der Sache schon näher:

ls -l /dev/ | grep -e cdr -e dvd
Code:

lrwxrwxrwx 1 root root         3 Aug 31 18:39 cdrom -> sr0
lrwxrwxrwx 1 root root         3 Aug 31 18:39 cdrw -> sr0
lrwxrwxrwx 1 root root         3 Aug 31 18:39 dvd -> sr0
lrwxrwxrwx 1 root root         3 Aug 31 18:39 dvdrw -> sr0
crw-rw---- 1 root cdrom  21,   1 Aug 29 08:20 sg1
brw-rw---- 1 root cdrom  11,   0 Aug 31 18:39 sr0


Mplayer auf der console funktioniert !
Code:

mplayer cdda://
MPlayer SVN-r32624-4.4.5 (C) 2000-2010 MPlayer Team

Playing cdda://.
Found audio CD with 3 tracks.

Track 1
rawaudio file format detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 1411.2 kbit/100.00% (ratio: 176400->176400)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   7.4 (07.3) of 3356.5 (55:56.5)  1.9%


KSCD zeigt die Tracks an, aber bleibt stumm.

SMPlayer sucht nach cdrom2 und findet es nicht, warum sucht er cdrom2?

Code:

ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau, -lavdopts threads=2 -sub-fuzziness 1 -identify -slave -vo vdpau -ao alsa -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 71303585 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/martin/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -subpos 100 -volume 100 -cdrom-device /dev/cdrom2 -cache 1000 -osdlevel 0 -noslices -channels 2 -af scaletempo -softvol -softvol-max 100 cdda://1

MPlayer SVN-r32624-4.4.5 (C) 2000-2010 MPlayer Team

Playing cdda://1.
Failed to open /dev/cdrom2 device.
++ WARN: Can't get file status for /dev/cdrom2:
No such file or directory
++ WARN: could not retrieve file info for `/dev/cdrom2': No such file or directory
++ WARN: can't open nrg image file /dev/cdrom2 for reading
Can't open CDDA device.
Failed to open cdda://1.


Exiting... (End of file)
ID_EXIT=EOF


KSCD liefert auf der console folgendes:

Code:

kscd

(kscd:18048): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed


Fazit: KDE ist schuld. Ich schaue in der Konfig nach ..
Back to top
View user's profile Send private message
doedel
Guru
Guru


Joined: 05 Feb 2006
Posts: 579
Location: Denmark

PostPosted: Wed Aug 31, 2011 5:11 pm    Post subject: Reply with quote

Quote:
SMPlayer sucht nach cdrom2 und findet es nicht, warum sucht er cdrom2?

smplayer ist ja nur eine GUI, cdrom2 wird er suchen, weils so eingestellt ist ;)

Schau dir KSCD mal an, wie die Ausgabe aussieht, alsa, oss, ... Vielleicht fehlt ja ne Einstellung.
_________________
1 ha == 1 Hekto-Ar == 1 Hektar
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2034
Location: Heidelberg - Germany

PostPosted: Wed Aug 31, 2011 6:21 pm    Post subject: Reply with quote

smplayer spielt jetzt, oh peinlich, das hatte ich übersehen. Dafür kann mir jetzt den Veteran - Status aberkennen :oops:

Bei kscd finde ich keine Einstellung, die das Device betrifft. Auch nicht in der kscdrc - datei. Alles was er in der Standardausgabe ausgibt, steht oben.

Aber schon mal vielen Dank, mit smplayer kann ich gut leben, der kscd ist sowieso nicht das gelbe vom Ei.

Alles in allem muß ich zugeben, das hätte ich auch selbst herausfinden können. War keine Glanzleistung von mir :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum