Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge 11-libs/gtk+-3.2.2 failure
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1057
Location: Tri-Cities, WA USA

PostPosted: Wed Nov 16, 2011 1:57 am    Post subject: emerge 11-libs/gtk+-3.2.2 failure Reply with quote

I could find the source of the problem on this one:

Any ideas?


e.c gdkrgba.c gdkscreen.c gdkselection.c gdkvisual.c gdkwindow.c gdkwindowimpl.c gdkenumtypes.c gdkenumtypes.h libgdk-3.la Makefile --output Gdk-3.0.gir
make[4]: *** [Gdk-3.0.gir] Error 139
make[4]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-3.2.2/work/gtk+-3.2.2/gdk'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-3.2.2/work/gtk+-3.2.2/gdk'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-3.2.2/work/gtk+-3.2.2/gdk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-3.2.2/work/gtk+-3.2.2'
make: *** [all] Error 2
* ERROR: x11-libs/gtk+-3.2.2 failed (compile phase):
* emake failed
*


Code:


azzerare ~ # emerge --info =x11-libs/gtk+-3.2.2
Portage 2.1.10.11 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.12.2-r0, 3.0.6-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.0.6-gentoo-x86_64-AMD_Athlon-tm-_64_Processor_3400+-with-gentoo-2.0.3
Timestamp of tree: Tue, 15 Nov 2011 12:30:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.6-r2, 2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo floppym x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.osuosl.org/ "
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/floppym /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support readline sdl session spell sqlite sse sse2 ssl startup-notification svg sysfs tcpd threads tiff tk truetype udev unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11613

PostPosted: Wed Nov 16, 2011 3:22 am    Post subject: Reply with quote

It appears that the compilation failed due to an error building Gdk-3.0.gir, which caused a cascade of failures up the chain of recursive make invocations.
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1057
Location: Tri-Cities, WA USA

PostPosted: Wed Nov 16, 2011 4:27 am    Post subject: Reply with quote

Hu wrote:
It appears that the compilation failed due to an error building Gdk-3.0.gir, which caused a cascade of failures up the chain of recursive make invocations.


Hello Hu:)

The obvious is always pointed out to me :)

Now to solve the problem. I'll need to find what package Gdk-3.0.gir is in.
That is gnome? Isn't it?
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11613

PostPosted: Thu Nov 17, 2011 2:57 am    Post subject: Reply with quote

Based on the text in your top post, I think Gdk-3.0.gir is a target built by =x11-libs/gtk+-3.2.2. However, you have not provided enough output for us to understand why it failed to build. ;)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1057
Location: Tri-Cities, WA USA

PostPosted: Fri Nov 18, 2011 12:26 pm    Post subject: Reply with quote

Hu wrote:
Based on the text in your top post, I think Gdk-3.0.gir is a target built by =x11-libs/gtk+-3.2.2. However, you have not provided enough output for us to understand why it failed to build. ;)



I'm stuck here with an emerge world:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ~] x11-libs/gtk+-2.24.8-r1 [2.24.7] USE="cups introspection (-aqua) -debug -doc -examples -test -vim-syntax -xinerama" 0 kB
[ebuild U ~] x11-libs/vte-0.28.2-r202 [0.28.2-r200] USE="introspection -debug -doc -glade -python" 0 kB
[blocks b ] <x11-libs/vte-0.28.2-r201:0 ("<x11-libs/vte-0.28.2-r201:0" is blocking x11-libs/gtk+-2.24.8-r1)
[ebuild U ~] x11-libs/gtk+-3.2.2-r1 [3.2.1] USE="colord cups introspection (-aqua) -debug -doc -examples -packagekit -test -vim-syntax -xinerama" 0 kB

I set <x11-libs/vte-9999 introspection -debug -doc -glade -python in package.keywords

Both vte and gtk fail.

GTK ERROR:
libtool: link: ( cd ".libs" && rm -f "libgdk-x11-2.0.la" && ln -s "../libgdk-x11-2.0.la" "libgdk-x11-2.0.la" )
/usr/bin/g-ir-scanner --add-include-path=../gdk --namespace=Gdk --nsversion=2.0 --libtool="/bin/sh ../libtool" --include=Gio-2.0 --include=GdkPixbuf-2.0 --include=Pango-1.0 --include=cairo-1.0 --library=libgdk-x11-2.0.la --warn-all -DG_LOG_DOMAIN=\"Gdk\" -DGDK_COMPILATION -I.. -I../gdk -DG_DISABLE_CAST_CHECKS -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15 -I/usr/include/libdrm -I/usr/include/gio-unix-2.0/ -I/usr/include/gdk-pixbuf-2.0 gdk.h gdkapplaunchcontext.h gdkcairo.h gdkcolor.h gdkcursor.h gdkdisplay.h gdkdisplaymanager.h gdkdnd.h gdkdrawable.h gdkevents.h gdkfont.h gdkgc.h gdki18n.h gdkimage.h gdkinput.h gdkkeys.h gdkkeysyms.h gdkpango.h gdkpixbuf.h gdkpixmap.h gdkprivate.h gdkproperty.h gdkregion.h gdkrgb.h gdkscreen.h gdkselection.h gdkspawn.h gdktestutils.h gdktypes.h gdkvisual.h gdkwindow.h gdk.c gdkapplaunchcontext.c gdkcairo.c gdkcolor.c gdkcursor.c gdkdisplay.c gdkdisplaymanager.c gdkdnd.c gdkdraw.c gdkevents.c gdkfont.c gdkgc.c gdkglobals.c gdkimage.c gdkkeys.c gdkkeyuni.c gdkoffscreenwindow.c gdkpango.c gdkpixbuf-drawable.c gdkpixbuf-render.c gdkpixmap.c gdkpolyreg-generic.c gdkrectangle.c gdkregion-generic.c gdkrgb.c gdkscreen.c gdkselection.c gdkvisual.c gdkwindow.c gdkwindowimpl.c gdkkeynames.c gdkenumtypes.c gdkenumtypes.h x11/checksettings.c x11/gdkapplaunchcontext-x11.c x11/gdkasync.c x11/gdkcolor-x11.c x11/gdkcursor-x11.c x11/gdkdisplay-x11.c x11/gdkdnd-x11.c x11/gdkdrawable-x11.c x11/gdkgc-x11.c x11/gdkgeometry-x11.c x11/gdkglobals-x11.c x11/gdkimage-x11.c x11/gdkim-x11.c x11/gdkinput.c x11/gdkkeys-x11.c x11/gdkmain-x11.c x11/gdkpixmap-x11.c x11/gdkproperty-x11.c x11/gdkscreen-x11.c x11/gdkselection-x11.c x11/gdksettings.c x11/gdkspawn-x11.c x11/gdktestutils-x11.c x11/gdkvisual-x11.c x11/gdkwindow-x11.c x11/gdkxftdefaults.c x11/gdkxid.c x11/xsettings-client.c x11/xsettings-common.c libgdk-x11-2.0.la Makefile --output Gdk-2.0.gir
/usr/include/glib-2.0/glib/gthread.h:347: syntax error, unexpected '{' in ' if ((gpointer) (__extension__ ({ G_STATIC_ASSERT (sizeof *(value_location) == sizeof (gpointer)); __sync_synchronize (); (gpointer) *(value_location); })) != ((void *)0))' at '{'
make[4]: *** [Gdk-2.0.gir] Illegal instruction
make[4]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.24.8-r1/work/gtk+-2.24.8/gdk'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.24.8-r1/work/gtk+-2.24.8/gdk'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.24.8-r1/work/gtk+-2.24.8/gdk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.24.8-r1/work/gtk+-2.24.8'
make: *** [all] Error 2
* ERROR: x11-libs/gtk+-2.24.8-r1 failed (compile phase):
* emake failed
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1057
Location: Tri-Cities, WA USA

PostPosted: Fri Nov 18, 2011 12:44 pm    Post subject: Reply with quote

Hu wrote:
Based on the text in your top post, I think Gdk-3.0.gir is a target built by =x11-libs/gtk+-3.2.2. However, you have not provided enough output for us to understand why it failed to build. ;)


This is wild:

azzerare ~ # ./justemergeworld.sh

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ~] x11-libs/gtk+-2.24.8-r1 [2.24.7] USE="cups introspection (-aqua) -debug -doc -examples -test -vim-syntax -xinerama" 0 kB
[ebuild U ~] x11-libs/gtk+-3.2.2-r1 [3.2.1] USE="colord cups introspection (-aqua) -debug -doc -examples -packagekit -test -vim-syntax -xinerama" 0 kB
[blocks B ] <x11-libs/vte-0.28.2-r201:0 ("<x11-libs/vte-0.28.2-r201:0" is blocking x11-libs/gtk+-2.24.8-r1)

Total: 2 packages (2 upgrades), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(x11-libs/gtk+-2.24.8-r1::gentoo, ebuild scheduled for merge) pulled in by
>=x11-libs/gtk+-2.8:2 required by (dev-java/gnu-classpath-0.98-r3::gentoo, installed)
x11-libs/gtk+:2 required by (x11-misc/xdg-user-dirs-gtk-0.8-r1::gentoo, installed)
>=x11-libs/gtk+-2.11:2 required by (dev-libs/libgweather-2.30.3::gentoo, installed)
>=x11-libs/gtk+-2.19.7:2[introspection] required by (x11-libs/libwnck-2.30.7::gentoo, installed)
>=x11-libs/gtk+-2.24:2 required by (gnome-extra/evolution-data-server-2.32.3-r1::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (gnome-base/gnome-keyring-2.32.1-r1::gentoo, installed)
x11-libs/gtk+:2 required by (x11-libs/wxGTK-2.8.11.0::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (media-gfx/eog-2.32.1::gentoo, installed)
>=x11-libs/gtk+-2.21.2:2 required by (gnome-base/gnome-settings-daemon-2.32.1-r2::gentoo, installed)
x11-libs/gtk+:2 required by (app-crypt/pinentry-0.8.0::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (sys-apps/gnome-disk-utility-2.32.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.24:2 required by (dev-python/pygtk-2.24.0-r1::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (gnome-extra/swfdec-gnome-2.30.1::gentoo, installed)
>=x11-libs/gtk+-2.13:2[-aqua,introspection] required by (net-libs/webkit-gtk-1.4.3-r200::gentoo, installed)
>=x11-libs/gtk+-2.8.6:2 required by (net-libs/xulrunner-1.9.2.20::gentoo, installed)
>=x11-libs/gtk+-2.6:2 required by (net-analyzer/nmap-5.51::gentoo, installed)
>=x11-libs/gtk+-2.8.0:2 required by (media-libs/swfdec-0.8.4::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (gnome-base/gnome-applets-2.32.1.1::gentoo, installed)
>=x11-libs/gtk+-2.16:2 required by (gnome-base/librsvg-2.34.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.22:2[introspection] required by (gnome-base/gnome-panel-2.32.1-r3::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (gnome-extra/gconf-editor-2.32.0::gentoo, installed)
>=x11-libs/gtk+-2.21.8:2 required by (media-video/totem-2.32.0-r2::gentoo, installed)
x11-libs/gtk+:2 required by (www-client/opera-11.52.1100::gentoo, installed)
>=x11-libs/gtk+-2.12:2 required by (x11-libs/gtksourceview-2.10.5-r1::gentoo, installed)
>=x11-libs/gtk+-2.10.7:2 required by (media-gfx/inkscape-0.48.2::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (gnome-extra/gcalctool-5.32.2::gentoo, installed)
x11-libs/gtk+:2 required by (media-libs/gegl-0.1.6::gentoo, installed)
x11-libs/gtk+:2 required by (app-text/ghostscript-gpl-9.04-r4::gentoo, installed)
>=x11-libs/gtk+-2.4.0:2 required by (net-analyzer/wireshark-1.4.9::gentoo, installed)
>=x11-libs/gtk+-2.22.1-r1:2 required by (gnome-base/gnome-2.32.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.4.0:2 required by (dev-python/gnome-python-desktop-base-2.32.0::gentoo, installed)
>=x11-libs/gtk+-2.20.1:2 required by (app-text/poppler-0.16.7::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (net-misc/vino-2.32.2::gentoo, installed)
>=x11-libs/gtk+-2.8:2 required by (media-sound/alsaplayer-0.99.80-r1::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (gnome-base/libgnomeui-2.24.5::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (media-gfx/gthumb-2.12.3::gentoo, installed)
>=x11-libs/gtk+-2:2 required by (x11-libs/gtkglext-1.2.0::gentoo, installed)
>=x11-libs/gtk+-2.24:2 required by (dev-cpp/gtkmm-2.24.2::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (net-analyzer/gnome-netstatus-2.28.2::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (xfce-base/libxfce4ui-4.8.0::gentoo, installed)
x11-libs/gtk+:2 required by (x11-libs/gtk+extra-2.1.2-r1::gentoo, installed)
>=x11-libs/gtk+-2.20.0:2 required by (mail-client/evolution-2.32.3::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (x11-themes/gtk-engines-xfce-2.8.1::gentoo, installed)
>=x11-libs/gtk+-2.6:2 required by (gnome-base/libgnomeprintui-2.18.6::gentoo, installed)
>=x11-libs/gtk+-2.8.10:2 required by (gnome-base/libglade-2.6.4::gentoo, installed)
>=x11-libs/gtk+-2.8.6:2 required by (www-client/seamonkey-2.4.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.17.7:2 required by (gnome-extra/gnome-power-manager-2.32.0-r2::gentoo, installed)
>=x11-libs/gtk+-2.14 required by (www-client/seamonkey-2.4.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.17.1:2 required by (gnome-extra/polkit-gnome-0.101-r1::gentoo, installed)
>=x11-libs/gtk+-2.19.0:2 required by (app-editors/gedit-2.30.4::gentoo, installed)
>=x11-libs/gtk+-2.11:2[introspection] required by (dev-libs/libunique-1.1.6-r1::gentoo, installed)
x11-libs/gtk+:2 required by (dev-haskell/gtk-0.12.0::gentoo, installed)
>=x11-libs/gtk+-2.10:2 required by (xfce-base/xfce-utils-4.8.3::gentoo, installed)
>=x11-libs/gtk+-2.14.0:2 required by (gnome-extra/gnome-screensaver-2.30.2-r1::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (gnome-extra/evolution-webcal-2.32.0::gentoo, installed)
x11-libs/gtk+:2 required by (www-client/chromium-16.0.912.36::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (x11-wm/metacity-2.30.3::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (gnome-base/libgnomekbd-2.32.0-r1::gentoo, installed)
>=x11-libs/gtk+-2.6:2 required by (gnome-base/gdm-2.20.11-r1::gentoo, installed)
>=x11-libs/gtk+-2:2 required by (x11-themes/gnome-themes-2.32.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.21.9:2 required by (app-cdr/brasero-2.32.1::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (gnome-extra/gnome-system-monitor-2.28.2-r1::gentoo, installed)
>=x11-libs/gtk+-2.19.7:2 required by (net-analyzer/gnome-nettool-2.32.0::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (x11-terms/gnome-terminal-2.32.1::gentoo, installed)
x11-libs/gtk+:2 required by (dev-java/gnu-classpath-0.98-r3::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (net-libs/gtk-vnc-0.4.3-r1::gentoo, installed)
>=x11-libs/gtk+-2.19.5:2 required by (www-client/epiphany-2.30.6-r1::gentoo, installed)
>=x11-libs/gtk+-2.16:2 required by (gnome-extra/gnome-games-2.28.2::gentoo, installed)
>=x11-libs/gtk+-2.21.4:2 required by (app-arch/file-roller-2.32.2::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (gnome-extra/yelp-2.30.2-r5::gentoo, installed)
x11-libs/gtk+:2 required by (media-video/vlc-1.1.12::gentoo, installed)
>=x11-libs/gtk+-2.8.6:2 required by (www-client/firefox-7.0.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.22.0:2 required by (gnome-base/gnome-session-2.32.1-r3::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (gnome-base/gconf-2.32.4::gentoo, installed)
x11-libs/gtk+:2 required by (media-video/nvidia-settings-260.19.29::gentoo, installed)
>=x11-libs/gtk+-2.8.12:2 required by (gnome-base/libbonoboui-2.24.5::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (media-sound/sound-juicer-2.32.0-r1::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (gnome-base/gnome-control-center-2.32.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.12:2 required by (x11-themes/gtk-engines-2.20.2::gentoo, installed)
>=x11-libs/gtk+-2.4:2 required by (x11-libs/gksu-2.0.2::gentoo, installed)
>=x11-libs/gtk+-2.12:2 required by (gnome-extra/hamster-applet-2.32.1::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (xfce-base/xfce4-panel-4.8.6::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (xfce-base/thunar-1.2.3::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (xfce-base/exo-0.6.2::gentoo, installed)
x11-libs/gtk+:2 required by (www-plugins/adobe-flash-11.0.1.152::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (x11-misc/notification-daemon-0.5.0::gentoo, installed)
>=x11-libs/gtk+-2.21.5:2 required by (app-text/evince-2.32.0-r3::gentoo, installed)
>=x11-libs/gtk+-2.6:2 required by (media-gfx/gtkimageview-1.6.4::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (xfce-base/xfwm4-4.8.2::gentoo, installed)
x11-libs/gtk+:2 required by (app-text/gtkspell-2.0.16::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (gnome-extra/zenity-2.32.1::gentoo, installed)
>=x11-libs/gtk+-2.2:2 required by (www-client/firefox-bin-7.0.1::gentoo, installed)
>=x11-libs/gtk+-2:2 required by (www-plugins/nspluginwrapper-1.4.4-r1::gentoo, installed)
>=x11-libs/gtk+-2.6:2 required by (app-admin/sabayon-2.30.1::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (gnome-extra/bug-buddy-2.32.0-r2::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (gnome-extra/gnome-utils-2.32.0-r2::gentoo, installed)
>=x11-libs/gtk+-2.16:2 required by (net-misc/vinagre-2.30.3::gentoo, installed)
x11-libs/gtk+:2 required by (media-sound/alsa-tools-1.0.23::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (xfce-base/xfce4-settings-4.8.3::gentoo, installed)
>=x11-libs/gtk+-2.24:2 required by (x11-libs/gtk+-3.2.2-r1::gentoo, ebuild scheduled for merge)
>=x11-libs/gtk+-2.22:2 required by (gnome-base/nautilus-2.32.2.1-r1::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (gnome-extra/deskbar-applet-2.32.0::gentoo, installed)
>=x11-libs/gtk+-2.20.0:2 required by (media-libs/libcanberra-0.28-r5::gentoo, installed)
>=x11-libs/gtk+-2.6:2 required by (dev-python/gnome-python-base-2.28.1::gentoo, installed)
>=x11-libs/gtk+-2.21.6:2 required by (www-client/epiphany-extensions-2.32.0-r1::gentoo, installed)
>=x11-libs/gtk+-2.0:2 required by (dev-python/pygtkglext-1.1.0::gentoo, installed)
x11-libs/gtk+:2 required by (app-mobilephone/obex-data-server-0.4.5::gentoo, installed)
>=x11-libs/gtk+-2.18.0:2 required by (gnome-extra/gnome-media-2.32.0-r1::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (gnome-base/gnome-desktop-2.32.1::gentoo, installed)
>=x11-libs/gtk+-2.18:2 required by (app-crypt/seahorse-2.32.0::gentoo, installed)
>=x11-libs/gtk+-2.12:2 required by (x11-libs/libgksu-2.0.12-r1::gentoo, installed)
>=x11-libs/gtk+-2.19.1:2 required by (media-video/cheese-2.32.0::gentoo, installed)
>=x11-libs/gtk+-2.12.5:2 required by (media-gfx/gimp-2.6.11-r5::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (xfce-base/xfdesktop-4.8.1::gentoo, installed)
>=x11-libs/gtk+-2.8:2 required by (app-cdr/gnomebaker-0.6.4::gentoo, installed)
>=x11-libs/gtk+-2.14:2 required by (gnome-extra/gucharmap-2.32.1::gentoo, installed)
>=x11-libs/gtk+-2.13:2 required by (gnome-base/libgnomecanvas-2.30.3::gentoo, installed)
>=x11-libs/gtk+-2.20:2 required by (gnome-extra/gtkhtml-3.32.2::gentoo, installed)
>=x11-libs/gtk+-2.20:2[introspection] required by (x11-libs/vte-0.28.2-r200::gentoo, installed)

(x11-libs/vte-0.28.2-r200::gentoo, installed) pulled in by
>=x11-libs/vte-0.26.0:0 required by (x11-terms/gnome-terminal-2.32.1::gentoo, installed)
>=x11-libs/vte-0.20:0 required by (net-misc/vinagre-2.30.3::gentoo, installed)
>=x11-libs/vte-0.26.2:0 required by (gnome-base/gnome-2.32.1-r1::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum