Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gnome 3.2] Installationsanleitung für Anfänger gesucht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
germanikus83
n00b
n00b


Joined: 17 Jan 2012
Posts: 4

PostPosted: Tue Jan 17, 2012 10:14 pm    Post subject: [gnome 3.2] Installationsanleitung für Anfänger gesucht Reply with quote

Hallo Leute,

Ich habe mir vor kurzem Gentoo mit dem 3.0.6 Kernel installiert.
Meine aktuelle Gnome Version ist die 2.32.1
Ich habe eine NVidia Grafikkarte, die definitiv 3D kann.

Jetzt lese ich in der eselect news, dass man gnome 3.2 bekommen kann. Ich dachte, dass man das einfach mit
Code:
emerge -UDnav world
bekommt, aber außer Firefox 9 und Thunderbird 9 kam da nix nennenswertes mit.

Das bekomme ich, wenn ich gnome direkt emergen will.
Code:
# emerge -pv gnome

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] gnome-base/gnome-2.32.1-r1  USE="cdr cups dvdr ldap policykit -accessibility -mono" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB



Im Upgrade-Guide (die xml webseite von gentoo) steht auch nicht, wie man genau vorgehen kann/soll/muss.

Was muss ich denn jetzt tun, damit ich gnome 3.2 nutzen kann?

Gruß
Felix

Nachtrag:

Ich benutze die x86_x64 Architektur.
Back to top
View user's profile Send private message
SkaaliaN
Veteran
Veteran


Joined: 21 Apr 2005
Posts: 1345
Location: Tranquility

PostPosted: Wed Jan 18, 2012 8:04 am    Post subject: Reply with quote

Hallo,

aus dem engl. Forum: https://forums.gentoo.org/viewtopic-t-899016.html

LG

xlayre
_________________
-RHP- Respect Honor Passion
Back to top
View user's profile Send private message
germanikus83
n00b
n00b


Joined: 17 Jan 2012
Posts: 4

PostPosted: Wed Jan 18, 2012 8:24 pm    Post subject: Reply with quote

Ich danke dir für diesen tollen Link.
Scheint mir alles verständlich und gut erklärt, aber ... es geht nicht :(

Ich habe mir demnach layman installiert. Danach wollte ich das gnome overlay hinzufügen.

Es hängt schon hier:

Code:
# layman -a gnome
* Overlay "gnome" does not exist.


und damit auch hier:
Code:
# emerge -pvuDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB


Woran liegt das, dass ich kein Gnome overlay finden und ich kein Gnome 3.2 installieren kann?
Bzw. wie kann ich es ändern?

Gruß
Felix
Back to top
View user's profile Send private message
germanikus83
n00b
n00b


Joined: 17 Jan 2012
Posts: 4

PostPosted: Wed Jan 18, 2012 9:17 pm    Post subject: Reply with quote

ah ok.
Habe es jetzt herausgefunden...

Code:
#layman --fetch

Dann erst kann man das gnome overlay hinzufügen.

Update:
=====

Jetzt bin ich aber verwundert...
Wenn ich
Code:
emerge -pvUDn world
ausführe, dann kommt u.a. folgende Ausgabe:

Code:
* The GNOME overlay is switching to GNOME 3.3.x prerelease packages.
 * These are unstable, potentially incompatible with 3.2, and may well
 * break your system in intriguing ways.
 *
 * If you enabled the GNOME overlay to get GNOME 3.2, please disable
 * it now, since GNOME 3.2 is already in portage and unmasked.


Wenn Gnome 3.2 stable im Portage Tree ist, wieso wird es dann beim world update nicht automatisch aktualisiert?
Ist es überhaupt gut, wenn ich das gnome overlay nutze?
Bekomme ich Gnome 3.2 auf "offiziellen Gentoo Kanälen" ... also einfach via emerge oder muss noch ein spezielles Paket installiert werden?

...irgendwie kompliziert.

Felix
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3655
Location: Germany

PostPosted: Wed Jan 18, 2012 9:49 pm    Post subject: Reply with quote

Hm, ich denke das gnome Overlay sollte nicht mehr nötig sein, denn gnome-3.2.1 steht doch im normalen portage Tree als Test-Version bereit.
Code:
eix -e gnome
* gnome-base/gnome
     Available versions:  (2.0) 2.32.1-r1 (~)3.2.1
        {accessibility (+)cdr cups dvdr +extras +fallback ldap mono policykit}
     Homepage:            http://www.gnome.org/
     Description:         Meta package for GNOME 3, merge this package to install

Gebe emerge doch einfach die gewünschte Version mit
Code:
emerge -pv =gnome-base/gnome-3.2.1
Und schaue dann was demaskiert werden müsste.
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Thu Jan 19, 2012 12:47 pm    Post subject: Reply with quote

Mal ein Schuß ins Blaue:

Hast Du vorher ein
Code:
 emerge --sync 
gemacht?

Grüße
aleph
Back to top
View user's profile Send private message
germanikus83
n00b
n00b


Joined: 17 Jan 2012
Posts: 4

PostPosted: Thu Jan 19, 2012 6:20 pm    Post subject: Reply with quote

Hallo,

Danke an euch, dass ihr euch die Zeit genommen habt und über das Problem nachgedacht habt.
Ich habe jetzt eine Lösung gefunden und werde sie hier posten:

@aleph-muc:
Ja, ich habe vorher ein
Code:
emerge --sync
durchgeführt.

@Josef.95:
ich hatte es mit gnome-3.2 versucht, aber da kam nix zum installieren.

Jetzt zu meiner Lösung:

Ich bin einfach dieser Anleitung http://en.gentoo-wiki.com/wiki/Gnome_3 gefolgt.
Bis auf das optionale gnome-tweak-tool habe ich alles durchgeführt und es hat funktioniert.
Das Wiki war echt schwer zu finden (davon ausgegangen, dass ich nichts von dem Wiki wusste).

Jetzt muss ich nur noch Gnome Deutsch beibringen und dann ist alles toll.

Danke nochmal für eure Hilfe.

Gruß
Felix
Back to top
View user's profile Send private message
nowo
n00b
n00b


Joined: 02 Aug 2011
Posts: 15
Location: Potsdam

PostPosted: Thu Jan 19, 2012 11:54 pm    Post subject: Reply with quote

germanikus83 wrote:
Jetzt muss ich nur noch Gnome Deutsch beibringen und dann ist alles toll.

Hast du
Code:
LINGUAS="de"

in deiner /etc/make.conf?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3655
Location: Germany

PostPosted: Fri Jan 20, 2012 12:28 am    Post subject: Reply with quote

nowo wrote:
germanikus83 wrote:
Jetzt muss ich nur noch Gnome Deutsch beibringen und dann ist alles toll.

Hast du
Code:
LINGUAS="de"

in deiner /etc/make.conf?

Ja, und dann auch die locale bereitstellen.
Setze dazu in der
/etc/locale.gen
Code:
de_DE.UTF-8 UTF-8
und generiere sie dann mit einem
Code:
# locale-gen --update

Dann würde ich den Rat aus dem GNOME 3.2 Upgrade Guide beherzigen
Abschnitt:
1. Changes
Languages and encodings
...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum