Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg]HAL manquant => pas de souris mais clavier ok (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
rolie31
n00b
n00b


Joined: 09 Apr 2012
Posts: 38
Location: France toulouse

PostPosted: Sat May 05, 2012 11:43 am    Post subject: [Xorg]HAL manquant => pas de souris mais clavier ok (réso Reply with quote

Bonjour,

avant de débuter, je précise que ça fait un mois que je me suis lancé dans l'installation de gentoo après plusieurs années d'Ubuntu.

Ce petit mois m'a déjà appris pas mal de chose que j'ignorais sur linux et l'environnement gnome.

J'ai installé gentoo x64 à partir du live DVD. J'ai suivi les tutos un à un et j'ai créé 2 kernel 3.2.12: un avec genkernel et un moi meme.
J'en suis au tuto sur la configuration de X. Après pas mal de galère règlé à coup de google, surout par rapport au police, je peux enfin démarrer X sans gestionnaire de fenetre. Avant de passer à la configuration de gnome, j'aimerais résoudre mon problème de souris non detecté. Le reste semble ok, video et clavier.

Je pense que le problème de souris vient du fait que HAL n'est pas installé: je n'ai pas de /etc/init.d/hald ni de /usr/share/hal présent.

J'ai pourtant bien le use flag hal présent dans mon /etc/make.conf.

Voici le emerge --info:

Quote:

Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3, 2.6.38-8-generic x86_64)
=================================================================
System uname: Linux-2.6.38-8-generic-x86_64-AMD_Turion-tm-_X2_Ultra_Dual-Core_Mobile_ZM-82-with-gentoo-2.0.3
Timestamp of tree: Tue, 01 May 2012 12:45:01 +0000
app-shells/bash: 4.2_p20
dev-lang/python: 2.7.2-r3, 3.2.2
dev-util/cmake: 2.8.6-r4
dev-util/pkgconfig: 0.26
sys-apps/baselayout: 2.0.3
sys-apps/openrc: 0.9.8.4
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.11.1
sys-devel/binutils: 2.21.1-r1
sys-devel/gcc: 4.5.3-r2
sys-devel/gcc-config: 1.5-r2
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc: 2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=3 --load-average=5.0 --with-bdeps y"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ ftp://gentoo.imj.fr/pub/gentoo/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ ftp://mirrors.linuxant.fr/distfiles.gentoo.org/ http://gentoo.modulix.net/gentoo/ ftp://mirror.ovh.net/gentoo-distfiles/ http://mirror.ovh.net/gentoo-distfiles/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr_FR"
MAKEOPTS="-j3 -l3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit X a52 aac aacplus aacs ace acl acpi active-response additions adl alsa amd64 archive atahpt audio audiofile automount bash-completion berkdb bluetooth cairo cdda cdr chromium cli colord consolekit cpudetection crashreporter crypt css cups cxx daemon dbus device-mapper dga dirac dmx dts dvd dvdr eds encode ethernet evo exif extras fam fat fbcon ffmpeg firefox flac flash fortran fuse gconf gdbm gdu gif gnet gnome gnome-keyring gnome-online-accounts gnome-shell gnutls gpm gstreamer gtk gtk3 hal hpcups hpijs html htmlsingle http iconv id3 id3tag imagemagick introspection ipc jack java6 jpeg jpeg2k lcms libburn libnotify libv4l libv4l2 lightning live lm_sensors lzma mad matroska mmx mmxext mng modules mozdom mp3 mp4 mpeg mtp mudflap multilib nautilus ncurses network networkmanager nptl nptlonly nss nx ogg openexr opengl openmp pae pam pango pci pcre pdf pdf-writer pgo playlist png policykit posix ppds pppd pulseaudio python qt3support qt4 rar raw redeyes regex replaygain rhythmbox rss samba schroedinger sdk sdl session smp socialweb spell sqlite sse sse2 ssl startup-notification svg symlink sysfs system-sqlite tcpd theora threads tiff toolbar tools truetype udev unicode usb userlocales v4l vaapi vba vda vga vhost-net video virtualbox vlc vorbis web webcam webgl webkit webm wifi wiki wma wma-fixed wmf wxwidgets x264 xcb xcomposite xinerama xml xorg xpm xulrunner xv xvid" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr_FR" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


udev est dispo, je l'ai donc mis dans rc-update au niveau default mais ça n'aide pas.

Voici mon fichier xorg.conf:

Quote:

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
# FontPath "/usr/share/fonts/cyrillic/"
# FontPath "/usr/share/fonts/dejavu/"
# FontPath "/usr/share/fonts/encodings/"
# FontPath "/usr/share/fonts/freefonts/"
# FontPath "/usr/share/fonts/urw-fonts/"
# FontPath "/usr/share/fonts/util/"
EndSection

Section "Module"
Load "glx"
Load "extmod"
Load "record"
Load "dri2"
Load "dbe"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
# Option "XkbModel" "amilo"
Option "XkbLayout" "fr"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "synaptics"
Option "MatchIsTouchpad" "on"

Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
#DisplaySize 290 180 # mm
Identifier "Monitor0"
VendorName "LCD"
ModelName "307"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
### <percent>: "<f>%"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "Dac6Bit" # [<bool>]
#Option "Dac8Bit" # [<bool>]
#Option "BusType" # [<str>]
#Option "CPPIOMode" # [<bool>]
#Option "CPusecTimeout" # <i>
#Option "AGPMode" # <i>
#Option "AGPFastWrite" # [<bool>]
#Option "AGPSize" # <i>
#Option "GARTSize" # <i>
#Option "RingSize" # <i>
#Option "BufferSize" # <i>
#Option "EnableDepthMoves" # [<bool>]
#Option "EnablePageFlip" # [<bool>]
#Option "NoBackBuffer" # [<bool>]
#Option "DMAForXv" # [<bool>]
#Option "FBTexPercent" # <i>
#Option "DepthBits" # <i>
#Option "PCIAPERSize" # <i>
#Option "AccelDFS" # [<bool>]
#Option "IgnoreEDID" # [<bool>]
#Option "CustomEDID" # [<str>]
#Option "DisplayPriority" # [<str>]
#Option "PanelSize" # [<str>]
#Option "ForceMinDotClock" # <freq>
#Option "ColorTiling" # [<bool>]
#Option "VideoKey" # <i>
#Option "RageTheatreCrystal" # <i>
#Option "RageTheatreTunerPort" # <i>
#Option "RageTheatreCompositePort" # <i>
#Option "RageTheatreSVideoPort" # <i>
#Option "TunerType" # <i>
#Option "RageTheatreMicrocPath" # <str>
#Option "RageTheatreMicrocType" # <str>
#Option "ScalerWidth" # <i>
#Option "RenderAccel" # [<bool>]
#Option "SubPixelOrder" # [<str>]
#Option "ClockGating" # [<bool>]
#Option "VGAAccess" # [<bool>]
#Option "ReverseDDC" # [<bool>]
#Option "LVDSProbePLL" # [<bool>]
#Option "AccelMethod" # <str>
#Option "DRI" # [<bool>]
#Option "ConnectorTable" # <str>
#Option "DefaultConnectorTable" # [<bool>]
#Option "DefaultTMDSPLL" # [<bool>]
#Option "TVDACLoadDetect" # [<bool>]
#Option "ForceTVOut" # [<bool>]
#Option "TVStandard" # <str>
#Option "IgnoreLidStatus" # [<bool>]
#Option "DefaultTVDACAdj" # [<bool>]
#Option "Int10" # [<bool>]
#Option "EXAVSync" # [<bool>]
#Option "ATOMTVOut" # [<bool>]
#Option "R4xxATOM" # [<bool>]
#Option "ForceLowPowerMode" # [<bool>]
#Option "DynamicPM" # [<bool>]
#Option "NewPLL" # [<bool>]
#Option "ZaphodHeads" # <str>
Identifier "Card0"
Driver "radeon"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800"
EndSubSection
EndSection


Je précise que j'ai un ordinateur portable siemens amilo sa 3650 avec une souris intégré à l'ordinateur.

Autre précision, j'ai déjà lancé à plusieurs reprise (et c'est très long) des

Code:

emerge -e system


et des

Code:

emerge --update --newuse --deep world && emerge --depclean && revdep-rebuild


suite à la lecture de forum parlant de ce problème.

Merci d'avance pour votre aide

PS j'espere avoir respecté le format de titre, si ce n'est pas le cas, je le changerai rapidement.


Last edited by rolie31 on Mon May 07, 2012 8:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10342
Location: Somewhere over Atlanta, Georgia

PostPosted: Sat May 05, 2012 12:20 pm    Post subject: Reply with quote

Déplacé depuis "Desktop Environments" vers "French" où il sera, espérons-le plus d'attention.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Sat May 05, 2012 4:39 pm    Post subject: Reply with quote

Les USE c'est pas magique. Sur mon laptop dans les INPUT_DEVICES, j'ai mouse, tu peux peut-être essayé avec, et lancer un emerge -DNu world.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sat May 05, 2012 4:45 pm    Post subject: Reply with quote

Moi je tenterais avec juste evdev et aucun fichier de xorg.conf
HAL n'est plus utilisé, c'est normal, ça fait un bout de temps que ça a été abandonné
Back to top
View user's profile Send private message
rolie31
n00b
n00b


Joined: 09 Apr 2012
Posts: 38
Location: France toulouse

PostPosted: Sat May 05, 2012 5:53 pm    Post subject: Reply with quote

Quote:
Déplacé depuis "Desktop Environments" vers "French" où il sera, espérons-le plus d'attention.


Merci :)

Quote:

Les USE c'est pas magique. Sur mon laptop dans les INPUT_DEVICES, j'ai mouse, tu peux peut-être essayé avec, et lancer un emerge -DNu world.


J'avais bien vu que c'était pas magique, crois moi ;)
mais je n'avais pas vu qu'il fallait indiquer les périphériques dans le make.conf. Je vais essayer ça.

Quote:

Moi je tenterais avec juste evdev et aucun fichier de xorg.conf
HAL n'est plus utilisé, c'est normal, ça fait un bout de temps que ça a été abandonné


J'ai tenté sans fichier xorg.conf au tout début mais ça ne fonctionnait pas du tout. X plantait sur des problèmes de carte vidéo, puis une fois le fichier xorg créé, X plantait au démarrage car il ne savait pas où trouver les fonts fixed puis ISO8569

Merci pour l'info sur HAL, les tutos n'ont pas du être mis à jour, je vais voir si je peux le signaler.

Pour evdev, je l'ai bien mis dans mon noyau et j'imagine qu'il est mis automatiquement dans le noyau généré par genkernel.




Merci à vous 3, je reviens vers vous quand j'aurais tenté le flag INPUT_DEVICES
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Sat May 05, 2012 6:28 pm    Post subject: Reply with quote

INPUT_DEVICES n'est pas un flag, par contre. Pour la documentation, l'anglaise est plus à jour.

Aussi, en relisant le premier message, j'ai vu que tu parlais de lancer emerge -e world, et que tu trouvais ça long. Sais-tu au moins ce que ça fait ?
Back to top
View user's profile Send private message
rolie31
n00b
n00b


Joined: 09 Apr 2012
Posts: 38
Location: France toulouse

PostPosted: Sun May 06, 2012 10:20 am    Post subject: Reply with quote

Quote:
INPUT_DEVICES n'est pas un flag, par contre. Pour la documentation, l'anglaise est plus à jour.


Merci, pour INPUT_DEVICES, j'avais en réalité déjà la variable définit de cette manière dans le make.conf:
INPUT_DEVICES="evdev synaptics"

Je vais essayer de voir la doc anglaise, merci pour l'info.

J'ai aussi lu http://en.gentoo-wiki.com/wiki/X.Org/Input_drivers qu'il fallait que j'ajoute le USE udev (et j'ai enlevé hal, toujours d'apres ce même wiki)

J'attend la fin du emerge -e system pour refaire un test, en espérant que ça fonctionne grace à ce flah udev.

Quote:
Aussi, en relisant le premier message, j'ai vu que tu parlais de lancer emerge -e world, et que tu trouvais ça long. Sais-tu au moins ce que ça fait ?


d'après ce que j'ai compris, ça permet de recompiler tout les paquets systèmes. Quand je fais des emerge, je vois régulièrement que certain paquet sont ajouté à world, j'imagine que ce sont ces paquets qui sont recompilés mais je crois avoir lu que X n'en faisait pas partie. Merci de me donner l'explication si je me trompe.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8076
Location: ~Brussels - Belgique

PostPosted: Sun May 06, 2012 11:04 am    Post subject: Reply with quote

Bonjour,

Si tu changes les USE flags, il ne faut pas nécessairement tout recompiler. Il y a les options "new use" et "update" :
Code:
emerge -DuNav world
par exemple.

C'est normalement expliqué dans le manuel, que tout Gentooïste doit avoir lu 42 fois. S'il ne le fait pas, il sera puni en devant le traduire en Klingon, les voyelles en blanc et les consonnes en gris.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
rolie31
n00b
n00b


Joined: 09 Apr 2012
Posts: 38
Location: France toulouse

PostPosted: Sun May 06, 2012 1:09 pm    Post subject: Reply with quote

Merci pour l'info. J'utilisai emerge -e system suite à la lecture d'un sujet sur un forum.
Quelqu'un préconisait de le faire en dernier recours mais j'utilise également la commande suivante
Code:
emerge --update --newuse --deep world && emerge --depclean && revdep-rebuild

qui est similaire.

Après mise à jour, j'ai bien la souris active ... mais seulement avec le noyau genkernel :(

Voici le .config de mon noyau:

http://dl.dropbox.com/u/13486835/.config

Je ne pense pas que ce soit très lisible comme ça mais si l'un d'entre vous peut le charger et regarder ce qui cloche, ce serait d'une grande aide. Je précise que Event interface est coché dans Device drivers (ce qui d'après le wiki des input devices est suffisant)
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8076
Location: ~Brussels - Belgique

PostPosted: Sun May 06, 2012 4:10 pm    Post subject: Reply with quote

Bonjour,

Cela ne sert à rien de faire "emerge -e" comme ça. C'est une perte de temps inutile. S'il y a un problème de configuration, recompiler tout (ou juste le système) ne solutionnera rien.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
rolie31
n00b
n00b


Joined: 09 Apr 2012
Posts: 38
Location: France toulouse

PostPosted: Sun May 06, 2012 4:41 pm    Post subject: Reply with quote

Merci pour l'info sur emerge -e system. Ca m'évitera de perdre du temps les prochaines fois.

Voici le détail du log du chargement de X avec mon kernel (celui qui ne me permet pas d'avoir la souris active alors qu'avec le kernel genkernel, pas de soucis)

Code:

[   100.345] (II) Using input driver 'synaptics' for 'Mouse0'
[   100.345] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[   100.345] (**) Option "CorePointer"
[   100.345] (**) Mouse0: always reports core events
[   100.345] (**) Option "Device" "/dev/input/mice"
[   100.345] (--) Mouse0: invalid x-axis range.  defaulting to 1615 - 5685
[   100.345] (--) Mouse0: invalid y-axis range.  defaulting to 1729 - 4171
[   100.345] (--) Mouse0: invalid pressure range.  defaulting to 0 - 256
[   100.345] (--) Mouse0: invalid finger width range.  defaulting to 0 - 16
[b][   100.365] (EE) Query no Synaptics: 6003C8[/b]
[   100.365] (--) Mouse0: no supported touchpad found
[   100.365] (EE) Mouse0 Unable to query/initialize Synaptics hardware.
[   100.400] (EE) PreInit returned 11 for "Mouse0"
[   100.400] (II) UnloadModule: "synaptics"
[   100.400] (II) Unloading synaptics


Ca ressemble a ce qu'on trouve dans le wiki de config de X

http://en.gentoo-wiki.com/wiki/X.Org

Quote:

Query no Synaptics: 6003C8

Your /var/log/Xorg.0.log contain this strings:
(EE) Query no Synaptics: 6003C8
(EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
(EE) PreInit returned 11 for "SynPS/2 Synaptics TouchPad"

One of the possible reasons for occurrence of this error is double including same sections with "synaptics". It possible, if your Xorg double load same settings from any files.

If you see on tty:
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

Move files on one place (/etc/X11/xorg.conf.d) and delete repeates files or sections.


Seul problème, je ne comprend pas ce que je dois faire. Je ne vois pas trop pourquoi je dois modifier la config de X sachant que la souris foncitonne avec le kernel genkernel.

J'ai malgré tout tripoté mon fichier /etc/X11/xorg.conf pour ne pas déclarer les input, pensant que les scripts /usr/share/X11/xorg.conf.d/10-evdev.conf et 50-synaptics.conf ferait peut etre le boulot mais pas mieux (au contraire, je n'avais plus le clavier non plus)

Voici un résumé de mon fichier xorg.conf actuel:

Code:

Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "evdev touchpad catchall" "CorePointer"
   InputDevice    "evdev keyboard catchall" "CoreKeyboard"
EndSection

Section "InputDevice"
   Identifier  "evdev keyboard catchall"
   Driver      "kbd"
   Option       "XkbModel" "pc105"
        Option          "XkbModel" "amilo"
   Option      "XkbLayout" "fr"
EndSection

Section "InputDevice"
   Identifier  "evdev touchpad catchall"
        Driver      "synaptics"
        Option      "MatchIsTouchpad" "on"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
EndSection
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8076
Location: ~Brussels - Belgique

PostPosted: Sun May 06, 2012 8:16 pm    Post subject: Reply with quote

Bonjour,

Tant que ton kernel configuré avec genkernel fonctionne, continue avec celui-ci. Je te conseille d'attendre que tu sois à l'aise avec Gentoo avant de configurer toi-même ton kenel, tout en potassant le site de Pappy McFae : http://kernel-seeds.org/

Sans HAL, il n'est pas nécessaire d'avoir un xorg.conf, à part pour définir le clavier, et des options du touchpad. Enlève la partie qui ne concerne pas le clavier et la souris, pour voir...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
rolie31
n00b
n00b


Joined: 09 Apr 2012
Posts: 38
Location: France toulouse

PostPosted: Mon May 07, 2012 8:57 pm    Post subject: Reply with quote

merci pour votre aide. Je vais suivre le conseil de XavierMiller et continuer pour le moment sur le noyau configuré avec genkernel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum